© 2007 Attachmate Corporation. All rights reserved.

INTRODUCTION

This file contains late-breaking information about Verastream Transaction Integrator, including Transaction Designer, Runtime Service, and Web Builder components.

This file was last updated on October 11, 2007. For the latest version of this file see the Attachmate Support site.


INSTALLATION

Extracting the Verastream Transaction Integrator via Electronic Files

This information applies only if you are extracting files from an electronic delivery site, such as the Attachmate Product Download Library.

After downloading Verastream Transaction Integrator zip file (VTI_4-0.zip), extract the files to a location off the root, such as c:\VTI_4-0. This will avoid errors that may occur due to path length limitations.

Explanation:

Due to third party limitations on Microsoft Windows operating systems, the length of a file path cannot exceed 260 characters. It is very important that the location you choose to extract the Verastream Transaction Integrator to does not contain more than 20 characters. This usually excludes extracting the files to a Windows desktop location, for example.


Red Hat v5 Installation Requires Default Java Home Directory

This information applies to Red Hat 5 installations only.

The Transaction Integrator install program requires the Java home directory to be /usr/J2SE. If you have configured another directory as the Java home directory, you must copy your Java installation into a directory named /usr/J2SE.


Importing Legacy Synapta Files if Synapta is Installed To a Non-Default Location

Because the Import wizard searches for legacy Synapta files in the default Synapta installation location, (C:\Program Files\Attachmate\EAI), if you have installed Synapta to a different location, you must modify the config.ini file to match the installed location.

  1. Open <Verastream Installation Location>\TransactionIntegrator\Designer\configuration\config.ini.
  2. Find the ATM_DIR property and edit the value to match the installed location of your Synapta files.


Uninstall Legacy Synapta Services Builder for IMS or CICS before Installing Transaction Integrator

Serious problems may occur if you do not uninstall Synapta Services Builder for CICS (IMS) before you install Transaction Integrator. While the co-existence of these products on the same computer is not supported, uninstalling does not remove existing data files. Legacy Synapta task definitions, host program definitions, and copybooks will still be available to import.

To uninstall:


Installing Client Files when Generating .NET Web Services

If you plan to use Web Builder to generate .NET Web services, the necessary client files must be installed on the same computer where the designer is installed.

To install the client files:

  1. From the installation program, click the Feature Selection tab.
  2. Choose to install the appropriate client feature for your host to the same computer where the designer is installed.
  3. Click Install Now.


KNOWN ISSUES

Generating Java Beans in Web Builder using Repeating Records or Repeating Elements

All repeating records and elements within a project must be uniquely named to successfully generate Java beans in Web Builder.


JavaScript Error when Accessing Javadocs from Designer Help

If you have a development environment installed (such as Visual Studio) on the same computer where you have installed the designer, you may encounter the following error when attempting to access the frames version of the Javadocs for Attachmate Java Interfaces from the designer online help: "Object doesn't support this property or method".

To remedy this:

  1. In Internet Explorer, click Tools > Internet Options>Advanced
  2. From the Browsing section, select Disable script debugging (Other).


.NET Web Service Fails with SOAP fault System.UnauthorizedAccessException

The following SOAP fault may occur after generating and invoking a .NET Web service:

System.Web.Services.Protocols.SoapException: Server was unable to process request.
System.UnauthorizedAccessException: Retrieving the COM class factory for component 
with CLSID {CLSID message} failed due to the following error: 80070005.

To remedy this issue:

Verify that IIS has the necessary permissions to access the CICS(IMS)ConnectorProxyService COM server:

  1. Open the Windows Control Panel (START menu>Control Panel.)
  2. Double-click Administrative Tools, and then double-click Component Services.
  3. Expand Component Services, Computers, and then expand My Computer and double-click DCOM Config.
  4. In the right pane, locate the program CICS(IMS)ConnectorProxyService, right-click and select Properties.
  5. Click the Security tab and in the Launch and Activation Permissions group box, select Customize, and click Edit.
  6. Add the appropriate user and give the user Local Activation permissions.
  7. Restart the ProxyService and IIS.


Use ServiceLog.txt to Diagnose Runtime Failures

The ServiceLog.txt file, located in the CICSServer or IMSServer directory depending on your host type, provides valuable diagnostic information.

This information can be helpful in identifying runtime service errors. For example, if you start the runtime service for either CICS or IMS from the Windows Service dialog, it will continue to read "Started" even after the engine JVM has shut down due to any number of reasons. However, since all console output for the server, including both services, is written to the SeviceLog.txt file, this information is readily available to you.


Rebuilding a Task Beans Project in Web Builder Fails after Renaming a Client Operation

If you rename a client operation in the Transaction Designer and then try to rebuild an existing Task Beans project in Web Builder, the generation will fail with a compilation error. If you inspect the log file you will see that the project is still referring to the old name. To remedy this issue:

  1. Dismiss the build status dialog if you havenít already done so.
  2. In the main Web Builder dialog, right-click on the broken project and select Explore in the context menu.
  3. In the Windows Explorer, browse to the taskbeans\src subdirectory and remove the .java files you find there.
  4. Close the Explorer window and return to Web Builder.
  5. Rebuild the project. The build should now succeed.


Place Copies of Projects Outside the Workspace

You should always place copies of your projects in an external directory outside the workspace directory. This is important not only to avoid the confusion of seeing duplicate projects listed in the Transaction Designer and Web Builder, but operations on these copied projects can cause loss of data.

For example, never attempt to delete a project that has been copied in the file system. It is perfectly safe, however, to make project copies using the Save Project As dialog available from the File menu.


Renaming Your Host Transaction

Before you attempt to rename your host transaction, back up your project (outside of the workspace).

Renaming a host transaction is an advanced process that not only requires the manual manipulation of your project files, but requires considerable care to avoid loss of data or the corruption of your project.

The following example walks you through the steps needed to rename a host transaction from AMNU to AMNUHostTransaction.

  1. Close Transaction Designer and make a backup of your project outside of the workspace (in an external directory).

  2. Locate your project, in our example, AMNU. By default, your project is located in a workspace directory under your Documents folder. In Windows XP, the default workspace location is ...\My Documents\Attachmate\Verastream\TransactionIntegrator\Designer\workspace. In Windows Vista, the default workspace location is ...Documents\Attachmate\Verastream\TransactionIntegrator\Designer\workspace.

  3. Open the <my_project>/transactions directory and locate the subdirectory that matches your host transaction name (in our example, AMNU) and rename it.

    In this case, change the name of the directory from AMNU to AMNUHostTransaction.

  4. Locate transaction.xml in your renamed directory. Open the file in a text editor and edit the name attribute in the com.attachmate.eclipse.transaction.model.hosttransaction:HostTransaction root element. In this example, change the name of the host transaction to AMNUHostTransaction. Save your changes.

  5. To rename the client operations associated with the renamed host transactions, locate the maps directory within your project directory. Within that directory is a subdirectory for each client operation associated with your host transaction. You may not have associated client operations.

    Perform the following steps on each client operation associated with your renamed host transaction. In our example, maps\GetBalance.

  6. Open map.xml in a text editor. This is a complicated edit; be careful. Every path to the old transaction must be changed. In our example, anything that references transactions\AMNU needs to be changed to transactions\AMNUHostTransaction.

    There will be one change in the hostTransaction element, and probably many value element changes under the inputMap and outputMap elements. Save your changes. Remember these changes must be made in each map.xml file for each associated client operation.

  7. In the project directory, locate the file named project.xml and open it in a text editor. Update the href attribute of the hostTransactionList element that matches the old name of your host transaction. Save your changes.

    For example, we would change the line:

    <hostTransactionList href="transactions/AMNU/transaction.xml#/"/>
    to
    <hostTransactionList href="transactions/AMNUHostTransaction/transaction.xml#/"/>

  8. Open Transaction Designer and confirm that the name change took effect.

Please note that renaming a client operation in Transaction Designer does not change the name of the directory containing the operation.xml file. This is important for steps 5 and 6 above, as any renamed client operations will have directory names that match the first name you gave it. You can update the directory name of the client operation, as long you update the paths in the map files and the project.xml file (in a similar fashion to the steps above).

Copying a Client Operation or Host Transaction

Just as in renaming a host transaction, these are advanced procedures that require great care and you should always back up your project before you begin.

  Attachmate