Mise à niveau à partir d'une version antérieure

Reflection for the Web 4.x

Si la version 4.x de Reflection for the Web est installée sur votre ordinateur, supprimez-la après avoir installé Reflection for the Web version 9.6.

  1. Conservation des paramètres de la version antérieure
  2. Installation des composants de Reflection for the Web 9.6
  3. Mise à niveau des composants de Reflection for the Web 9.6
  4. Suppression de la version antérieure de Reflection for the Web

Etape 1 : Conservation des paramètres de la version antérieure

Serveur de gestion de Reflection
Conservez l'ensemble de l'installation précédente du serveur de gestion tant que vous n'avez pas installé la dernière version dans un nouveau répertoire, utilisé les outils de la station Web Administrative et de la nouvelle installation pour mettre à niveau les fichiers obsolètes, puis testé votre nouvelle installation.

Serveur proxy de sécurité
La mise à niveau du serveur proxy de sécurité depuis une version antérieure à la version 5.0 n'est plus prise en charge ; il est recommandé d'installer la dernière version et de créer de nouveaux paramètres pour tirer le meilleur parti des fonctionnalités de la version 9.6. Pour plus d'informations, consultez la section Configuration du serveur proxy de sécurité.

Composant serveur de comptage : Conservation des paramètres
Si vous disposez du serveur de comptage de la version 4.x sur votre ordinateur, suivez la procédure ci-dessous.

Avant d'installer la nouvelle version du composant Comptage, récupérez les paramètres de comptage dans le programme d'exécution de servlet actuellement installé. Dans Reflection for the Web version 4.5, par exemple, le servlet ServletExec était fourni avec le composant Comptage. Suivez les étapes ci-dessous pour récupérer les paramètres de comptage dans ServletExec :

  1. Démarrez ServletExec et ouvrez le site Web ServletExec Admin.

  2. Sous Servlets, cliquez sur Configure dans le panneau de navigation situé sur la gauche.

  3. Dans la page Configure Servlets, sous Servlet Name, cliquez sur EVmeter.

  4. Imprimez la page Edit Servlet qui répertorie tous les paramètres définis pour EVmeter.

  5. Effectuez les étapes 2 et 3 pour EVreport.

Composant serveur de comptage : Résolution des conflits de port IIS
Les sessions terminal mises à niveau utiliseront, dans la nouvelle version du serveur de comptage, le même port que celui utilisé dans la version antérieure. Dans les versions antérieures de Reflection for the Web, le serveur de comptage fonctionnait par défaut avec ServletExec dans IIS. Pour que toutes les sessions contrôlées que vous avez configurées dans la version antérieure continuent de fonctionner dans la nouvelle version, effectuez une des opérations suivantes :

Etape 2 : Installation des composants de Reflection for the Web 9.6

Installez maintenant les composants de Reflection for the Web 9.6. Le composant Serveur de gestion de Reflection est obligatoire ; le serveur proxy de sécurité et le serveur de comptage sont facultatifs. Lorsque vous procédez à la mise à niveau à partir d'une version antérieure :

Etape 3 : Mise à niveau des composants de Reflection for the Web 9.6

Serveur proxy de sécurité
La mise à niveau du serveur proxy de sécurité depuis une version antérieure à la version 5.0 n'est plus prise en charge ; il est recommandé d'installer la dernière version et de créer de nouveaux paramètres pour tirer le meilleur parti des fonctionnalités de la version 9.6. Pour plus d'informations, consultez la section Configuration du serveur proxy de sécurité.

Serveur de comptage
Si vous avez utilisé le serveur de comptage dans des versions 4.x de Reflection for the Web, configurez à présent la nouvelle version. Suivez la procédure décrite dans la section Configuration du serveur de comptage avant de désinstaller la version précédente du serveur de comptage. Utilisez les paramètres que vous avez récupérés à l'étape 1 pour configurer votre nouvelle installation.

Serveur de gestion de Reflection
Ouvrez la station Web Administrative et accédez à la section Mise à niveau. Ouvrez la page Mise à niveau à partir de Reflection for the Web 4.5, 4.1 ou 4.0 ou la page Mise à niveau à partir de la version japonaise de Reflection for the Web 4.1 et avancez jusqu'à la section Etape 3 : Mise à niveau des composants de Reflection for the Web. Utilisez les outils fournis et suivez les procédures décrites sur les pages de mise à niveau pour mettre à jour les fichiers. Les types de fichier et les paramètres suivants peuvent être mis à jour :

Si vous avez enregistré des sessions sans utiliser l'outil Session terminal ou si vous avez modifié manuellement le code HTML, mettez à jour les sessions en utilisant l'Assistant Migration de sessions statiques.

Etape 4 : Suppression de la version antérieure de Reflection for the Web

Une fois que vous avez installé Reflection for the Web 9.6, effectué la migration des paramètres obsolètes et testé votre installation, supprimez la version antérieure de Reflection for the Web sur votre serveur et sur les stations de travail des administrateurs.

Remarque : si vous avez effectué la mise à niveau de votre serveur proxy de sécurité et choisissez d'utiliser le fichier server.properties file d'origine, ne supprimez pas l'installation d'origine de ce serveur.

Pour supprimer une version antérieure de Reflection for the Web :

Que faire ensuite