System Requirements

Requirements for Attachmate Reflection 2014 can vary, depending on your hardware and other software components present. For complete information about deploying Reflection in virtualized environments and other supported platforms, see Technical Note 2698.

Processor

2 GHz, 32-bit or 64-bit (1.5 GHz or higher multi-core, 32-bit or 64-bit recommended)

System memory (RAM)

1 GB (2 GB recommended)

Operating system and platform

One of the following:

 

Microsoft Windows 8.1 Pro 32-bit and 64-bit

 

Microsoft Windows 7 Enterprise 32-bit and 64-bit

 

Microsoft Windows 7 Ultimate 32-bit and 64-bit

 

Microsoft Windows Vista Enterprise, SP1 32-bit and 64-bit

 

Microsoft Windows Vista Ultimate, SP1 32-bit and 64-bit

 

Microsoft Windows Server 2012 R1 or R2 with Remote Desktop Services (for multi-user environments)

 

Microsoft Windows Server 2008 R1 or R2 with Windows Terminal Server (for multi-user environments) 32-bit and 64-bit for R1 (64-bit only for R2)

 

Microsoft Windows Server 2003 R2 with Windows Terminal Server (for multi-user environments) 32-bit and 64-bit

Additional software requirements

To use the Office integration features in Reflection, Microsoft Office 2007 or later must be installed.

Prerequisite software — Microsoft .NET Framework

Reflection 2014 R1 requires.NET Framework 4.0 or later (4.5 is recommended). If the .NET Framework isn't installed, the Attachmate Setup Program will install version 4.0 on all systems except Microsoft Windows Server 2008 R1 and later.

Notes:

  • If you install Reflection directly with MSI and the product features you install do not require .NET 4, you may add the SKIPDOTNET=1 property to the command line to bypass this test condition.
  • If you install with an MSI directly on Windows XP clients, before you deploy make sure that these clients have the Microsoft Windows Installer 3.1. Although Windows Installer 3.1 is optional, you should update your version of Windows Installer to take full advantage of the features available in Windows Installer 3.1.

Microsoft Windows Installer 3.1

 

The Microsoft Windows Installer (MSI) version 3.1 is distributed with Reflection 2014. This is applicable to Windows XP only. If you run the Attachmate Setup Program on Windows XP, the wizard determines whether Windows Installer 3.1 is installed, and automatically updates it if necessary.

Microsoft Visual Basic for Applications (VBA)

 

Reflection 2014 supports Microsoft VBA 6.5. If you select to install this feature in the Attachmate Setup Program, it is automatically installed. If you install Reflection 2014 directly with MSI or with a deployment tool and you want to install this feature, you must install it directly, using the core VBA 6.5 MSI and an appropriate language specific MSI (these MSIs are in the Prerequisites folder, in the distribution media).