Mostra Sommario / Indice / Ricerca

Requisiti software

I requisiti software per l'installazione di Reflection 2011 sono elencati di seguito. In base al metodo di installazione prescelto (utilizzo del Programma di installazione Attachmate, installazione diretta con MSI o distribuzione da un punto di installazione amministrativa) e alla piattaforma su cui si desidera eseguire l'installazione, il software viene installato o aggiornato automaticamente oppure viene richiesto all'utente di installare o eseguire un aggiornamento.

Microsoft .NET Framework 4.0 Runtime

Per tutti i sistemi operativi supportati, ad eccezione di Microsoft Server 2008, se si utilizza il Programma di installazione Attachmate (setup.exe) per installare Reflection 2011, viene determinato se .NET Framework è presente nel sistema e se necessario viene installato automaticamente. (Si applica solo per le installazioni che utilizzano il Programma di installazione Attachmate. Non si applica quando Reflection 2011 viene installato direttamente con MSI.)

Nota: Se si utilizza Microsoft Windows Server 2008 R1 ed è richiesto .NET Framework 4.0, è necessario assicurarsi che sia installato sul server. Il Programma di installazione Attachmate non installa .NET su questo server.

Reflection 2011 è dotato di numerose funzionalità aggiuntive che richiedono Microsoft .NET Framework 4.0. Se queste funzionalità sono selezionate per l'installazione principale di Reflection 2011 e questo framework non è ancora installato, il Programma di installazione Attachmate lo installa automaticamente dopo che è stata completata l'installazione principale. Sia la versione a 32 bit che quella a 64 bit di questo software sono distribuite con Reflection 2011.

Nota: Versioni del Programma di installazione Attachmate precedenti a R3 installano automaticamente Microsoft .NET Framework indipendentemente dalle funzionalità installate. Queste versioni rilevano se .NET Framework è installato sul dispositivo (ad esempio, per impostazione predefinita Windows XP non comprende .NET Framework, mentre Windows 7 lo comprende) e lo installano (se non è ancora installato) prima di installare Reflection 2011.

Microsoft Windows Installer 3.1

Microsoft Windows Installer (MSI) versione 3.1 viene distribuito insieme a Reflection 2011. Questo vale solo per Windows XP (Windows Vista e Windows 7 contengono già una versione più recente).

Se si utilizza il Programma di installazione Attachmate in Windows XP, la procedura guidata determina se Windows Installer 3.1 è installato e, se necessario, lo aggiorna automaticamente.

Microsoft Visual Basic, Applications Edition (VBA)

Reflection 2011 Release 3 supporta Microsoft VBA 6.5. Se si sceglie di installare questa funzione nel Programma di installazione Attachmate, viene installata automaticamente. Se si installa Reflection 2011 direttamente con MSI o con uno strumento di distribuzione e si desidera installare questa funzione, è necessario installarla direttamente utilizzando il pacchetto MSI VBA 6.5 principale e un MSI appropriato specifico della lingua (Questi MSI si trovano nella cartella Prerequisites, sul supporto di distribuzione.)

Distribuzione diretta di file MSI

Se si installa Reflection 2011 direttamente con MSI o con uno strumento di distribuzione, è necessario determinare se eventuali funzionalità aggiuntive selezionate richiedono Microsoft .NET Framework 4.0. Se è richiesto questo framework, è necessario installarlo.

Se si installa Reflection 2011 direttamente con MSI o se si distribuisce Reflection 2011 da un'installazione amministrativa, Windows Installer 3.1 non viene installato automaticamente in Windows XP. Sebbene Windows Installer 3.1 sia opzionale, è comunque opportuno aggiornare la versione di Windows Installer utilizzata per sfruttare al massimo le funzionalità di Windows Installer 3.1.

Distribuire Windows Installer 3.1 come pacchetto indipendente sulle workstation Windows XP che non ne dispongono.

Argomenti correlati

Requisiti di sistema