Inhalt /Index /Suche anzeigen

Erstellen eines Makros im Visual Basic-Editor

Erstellen Sie Makros nach Möglichkeit in Modulen. Dies unterstützt die Integrität und Stabilität Ihres Programms. Eine Ausnahme bilden lediglich Ereignisprozeduren, die Reflection-Objekten direkt hinzugefügt werden.

So erstellen Sie ein Makro im Visual Basic-Editor

  1. Öffnen Sie in Reflection ein Sitzungsdokument.
  2. Den Visual Basic-Editor öffnen Sie folgendermaßen:

    Darstellung

    Schritte...

    Reflection-Schaltfläche

    Reflection-Multifunktionsleiste

    Klicken Sie auf der Registerkarte Extras der Multifunktionsleiste auf Visual Basic.

    Reflection-Browser

    Klicken Sie im Menü Reflection auf Extras, Makro und dann auf Visual Basic.

    Das Sitzungsdokument wird im Projekt-Explorer als Projekt angezeigt, zum Beispiel als "Project (Meine Sitzung.rd3x)".

  3. Wählen Sie im Projekt-Explorer das Projekt aus, in dem Sie das Makro speichern möchten, und wählen Sie dann Einfügen > Modul, um ein neues Modul zu erstellen.
  4. Doppelklicken Sie auf das erstellte Modul.

    Das Fenster Code wird geöffnet.

  5. Wählen Sie Einfügen > Prozedur, geben Sie im Feld Name einen Namen ein, und klicken Sie dann auf OK.

    Der Name muss den Visual Basic-Benennungskonventionen für Makros entsprechen. Weitere Informationen hinzu finden Sie unter Benennen von Makros.

  6. Geben Sie den Code für Ihr Makro zwischen den Anweisungen Sub (oder Public Sub) und End Sub ein.

    Zu den Visual Basic-Befehlen steht Ihnen eine kontextsensitive Hilfe zur Verfügung. Positionieren Sie die Einfügemarke in einem Befehl, und drücken Sie F1.