Attachmate EXTRA! X-treme
versione 9, Service Pack 2


Note di rilascio
Luglio 2008

Introduzione

Questo file include le informazioni più aggiornate relative alla versione corrente di Attachmate EXTRA! X-treme. EXTRA! X-treme fornisce l'accesso a mainframe IBM, AS/400, VAX/VMS, UNIX o ad altre applicazioni host asincrone. Utilizzando EXTRA! X-treme gli utenti sono in grado di eseguire applicazioni host, trasferire file e integrare i dati in altre applicazioni Windows.

Per ulteriori informazioni su EXTRA! X-treme v. 9.0, SP2, visitare il sito Web del supporto all'indirizzo http://support.attachmate.com.


Novità nel Service Pack 2

EXTRA X-treme v. 9.0 SP2 include i seguenti miglioramenti.

Piattaforme supportate

EXTRA! è stato testato su Windows Vista SP1, Windows XP SP3 e Windows Server 2008 e supporta tutti questi sistemi operativi.

Determinazione del livello della chiave crittografica

Se si utilizza la protezione SSL/TLS o FIPS con EXTRA! è ora possibile specificare il livello della chiave crittografica. L'utente può stabilire, ad esempio, che EXTRA! si connetta tramite SSL utilizzando algoritmi di crittografia con chiavi a 128 bit.

Di norma, la funzionalità di sicurezza Attachmate si connette con il livello massimo di sicurezza consentita da EXTRA! e dal server SSL. Si sconsiglia l'utilizzo di questa nuova impostazione senza una completa conoscenza delle sue implicazioni. Per ulteriori informazioni, consultare la Nota tecnica 2356.

Eliminazione della richiesta di conferma per la modalità standby

Se l'utente utilizza Microsoft XP e il computer in uso entra in modalità standby mentre EXTRA! è in esecuzione, sono disponibili maggiori possibilità di controllo. Per impostazione predefinita EXTRA! richiede conferma all'utente prima di consentire al computer di entrare in modalità standby. Se si preferisce, EXTRA! può essere configurato in modo tale che il computer entri in modalità standby senza conferma da parte dell'utente oppure che il computer non possa entrare in modalità standby mentre EXTRA! è in esecuzione.

Per modificare le impostazioni della modalità standby
  • Dalla finestra di dialogo Preferenze generali:

  • Per
    Procedura
    Consentire al computer di entrare in modalità standby senza richiesta di conferma Deselezionare la casella di controllo Impedisci sospensione del sistema.
    Impedire al computer di entrare in modalità standby Selezionare la casella di controllo Impedisci sospensione del sistema.

Se vengono selezionate le impostazioni predefinite, che prevedono la conferma dell'utente per l'entrata in modalità standby, nella casella di controllo verrà visualizzato un quadratino colorato.

Modifiche al controllo ortografico

La funzione di controllo ortografico di EXTRA! non necessita più dell'installazione di Microsoft Word. È ancora possibile utilizzare il motore del controllo ortografico di Word personalizzando l'installazione tramite Installazione guidata personalizzata. L'Installazione guidata personalizzata consente inoltre di configurare ulteriori opzioni di controllo ortografico.

Stampa a colori da sessioni 3270

EXTRA! supporta ora la stampa a colori e a toni di grigio degli schermi delle sessioni del terminale 3270.
Per attivare la stampa a colori o a toni di grigio
  • Dalla finestra di dialogo Stampa lo schermo, deselezionare la casella di controllo Stampa in bianco e nero.

Miglioramenti per le aree sensibili

La presenza di aree sensibili può ora essere indicata da un certo numero di delimitatori, tra i quali molti caratteri non alfanumerici della tastiera oltre agli spazi. In questo modo è assicurata la compatibilità con il comportamento delle aree sensibili di altri prodotti di emulazione.

Le aree sensibili di testo possono essere rappresentate come pulsanti 3D.

Scelta dell'host per client 5250 su reti IPv4 e IPv6

Se un client esiste contemporaneamente su una rete IPv4 e IPv6, il nome dell'host può essere risolto in più indirizzi IP. Nelle sessioni TN5250 questo problema può essere gestito selezionando l'indirizzo IP corretto nell'elenco a discesa disponibile nella finestra Impostazioni di collegamento quando si immette il nome di un host.

Supporto delle opzioni API a16 bit

EXTRA! X-treme non supporta più le API a 16 bit.

Per ulteriori informazioni, consultare la Nota tecnica 2319.


Novità nel Service Pack 1

EXTRA X-treme v. 9.0 SP1 include i seguenti miglioramenti.

Maggiore sicurezza per i collegamenti TN3270 e TN5250

Una nuova opzione di sicurezza è stata aggiunta per i collegamenti TN3270 e TN5250. Il modello di sicurezza di Attachmate utilizza cifratura convalidata dallo standard FIPS (Federal Information Processing Standard) 140-2 e dai protocolli standard del settore SSL e TLS per garantire l'integrità dei dati e la privacy.

Per attivare l'opzione Utilizza la sicurezza Attachmate
  1. Nella finestra di dialogo Configura collegamento, selezionare l'opzione Utilizza la sicurezza Attachmate.

  2. Selezionare il livello di cifratura desiderato.

    Il funzionamento del modulo di sicurezza di Attachmate in modalità FIPS limita gli algoritmi di cifratura a quelli che soddisfano i rigidi requisiti dello standard FIPS 140-2, pertanto è necessario che il server a cui si collega EXTRA! supporti lo stesso livello di cifratura.

    In caso di problemi nel collegamento con i trasporti TN3270 o TN5250 dopo la selezione dell'opzione Utilizza la sicurezza Attachmate, cambiare la configurazione di trasporto del client in FIPS 140-2 oppure eliminare la selezione dell'opzione Utilizza la sicurezza Attachmate e scegliere SSL v3.0.

Supporto di IPv6

Il modulo di sicurezza di Attachmate supporta ora la versione 6 del protocollo di Internet (IPv6).

Per attivare il supporto di IPv6
  1. Nella finestra di dialogo Configura collegamento, selezionare l'opzione Utilizza la sicurezza Attachmate.

    Nota Un collegamento in una rete IPv6 può essere effettuato con o senza SSL/TLS.
  2. Per collegarsi a un host su una rete IPv6 senza sicurezza, impostare il Livello di cifratura su Nessuno.

    Se il sistema rileva indirizzi IPv6 nel campo Indirizzo IP, la sicurezza per il collegamento viene automaticamente impostata con l'opzione Utilizza la sicurezza Attachmate.

Modifiche per la gestione dei certificati del client

Diversi miglioramenti sono stati effettuati nel modo in cui EXTRA! gestisce i certificati digitali per l'autenticazione del client.

Smart Card

Miglioramenti per le zone attive

Copia al momento della selezione per le sessioni TN3270

Le sessioni TN3270 possono essere configurate in modo da copiare testo negli Appunti non appena viene selezionato sullo schermo.
Per attivare questa funzione
  • Scegliere la finestra di dialogo Opzioni | Impostazioni - Modifica e poi selezionare Deseleziona dopo la copia oppure Mantieni dopo la copia.

    L'impostazione predefinita viene disattivata.

Aggiunte all'interfaccia COM di EXTRA!

Gli eventi ExtraGotFocus e ExtraLostFocus sono stati aggiunti all'interfaccia COM per EXTRA!. Questi eventi COM sono attivati se la visualizzazione della sessione di EXTRA! diventa sfocata oppure appare maggiormente a fuoco.

Applicazioni ActiveX

Le interfacce COM di EXTRA! sono state modificate per essere compatibili con la versione 8.0. Le applicazioni client ActiveX esistenti non richiedono di essere ricostruite se sono state progettate utilizzando EXTRA! v. 8.0 o v. 8.0 SP1. Le applicazioni client compilate con altre versioni di EXTRA! devono essere ricompilate utilizzando la nuova libreria dei tipi di EXTRA! disponibile con EXTRA! v. 9.0 SP1.

Controllo della schermata di caricamento

Un'impostazione intitolata ShowSplashScreen è stata aggiunta al registro in HKCU\Software\Attachmate\Extra!\WorkStationUser\Preferences.

Installazione in Windows Vista o Windows XP

Per l'installazione predefinita di EXTRA! X-treme v. 9, le directory \sessions, \macros e \schemes devono essere installate nelle directory \MyDocs o \All Users. Non devono essere installate nella directory \Program Files.

In Vista, se viene specificato \Program Files per queste directory, l'icona di schermatura UAC appare sopra l'icona di collegamento di EXTRA! (la grande E arancione) per segnalare la necessità di disporre di autorizzazioni elevate o speciali per eseguire EXTRA! da questa posizione.

Miglioramenti dell'opzione client 6530 di EXTRA!

EXTRA! 6530 Client Option fornisce ora maggiore sicurezza SSL e bilanciamento del carico Telnet per connessioni client TN6530 tra host separati, configurati in modo identico.


Novità nella Versione 9.0

EXTRA! X-treme v. 9.0 fornisce una vasta gamma di importanti miglioramenti, tra i quali:

Certificazione Microsoft Windows Vista

La certificazione Microsoft Windows Vista garantisce che EXTRA! X-treme fornisca maggiore sicurezza, compatibilità con le piattaforme di prossima generazione (comprese quelle a 64 bit), maggiore facilità di installazione e migliore stabilità dell'applicazione.

Client Reflection Secure FTP

Il modulo Crypto incluso nel client Reflection Secure FTP soddisfa i rigidi requisiti di sicurezza FIPS 140-2, consentendo di crittografare i trasferimenti dei file utilizzando lo standard di settore SSL/TLS o i protocolli SSH.

Autenticazione della tastiera Interattiva SSH

L'autenticazione della tastiera interattiva SSH consente all'amministratore di implementare i requisiti di sicurezza più rigidi per le sessioni host VT evitando che l'utente salvi le password sul computer e chiedendogli di immettere una password quando tenta di connettersi a un host UNIX.

Funzione di applicazione Telnet predefinita

Ora è possibile rendere EXTRA!. il browser predefinito per le applicazioni Telnet.

Opzione di ripristino automatico tastiera

Quando è selezionata questa opzione, se si digita inavvertitamente in un campo protetto, EXTRA! Consente di eseguire un ripristino automatico della tastiera, di passare a un campo non protetto, quindi di immettere il testo.

Attivazione del riquadro produttività

Utilizzare la tastiera per passare da una sessione EXTRA! al riquadro produttività.

Funzione A capo automatico

Per le sessioni 3270 è possibile scegliere di consentire la funzionalità di ritorno a capo automatico all'interno di un campo non protetto con più righe.

Funzioni EHLLAPI

Sono state implementate le seguenti funzioni EHLLAPI:

  80 Notifica di avvio delle comunicazioni
  81 Evento di comunicazione query
  82 Notifica di arresto delle comunicazioni
  Per ulteriori informazioni su EHLLAPI, fare riferimento alla documentazione IBM SDK.

Note sull'installazione

Per informazioni sui requisiti di sistema e sull'installazione, vedere la Guida introduttiva disponibile nel CD di EXTRA! X-treme.

Installazione e test

EXTRA! X-treme v. 9 può essere installato su myEXTRA! Enterprise v. 7.11 ed EXTRA! X-treme v. 8.0 e 8.0 con SP1. Sono stati eseguiti test minimi in ambiente EXTRA! X-treme v. 9 su installazioni delle versioni precedenti di EXTRA!

Sistemi operativi supportati

Attachmate fornisce il supporto per EXTRA! X-treme v. 9 nei seguenti sistemi operativi:

Attachmate non supporta sistemi operativi Microsoft non più supportati da Microsoft.

Installazione di Installazione guidata personalizzata

Per installare Installazione guidata personalizzata, è sufficiente copiare il file CustomInstallationWizard.exe dalla cartella Tools del CD di EXTRA! in un disco fisso dell'amministratore.

Opzione di installazione non supportata

Anche se è possibile selezionare l'opzione "La caratteristica specificata verrà installata quando richiesto" durante un'installazione personalizzata, l'opzione non è supportata in questa versione di EXTRA! X-treme.

Riavvio consigliato dopo la disinstallazione

Per eliminare i file in uso, Attachmate consiglia di riavviare il computer dopo aver disinstallato questo prodotto.

FAT16 non supportato

Prima di installare EXTRA! X-treme v. 9 in ambiente Windows 2000, assicurarsi che Windows utilizzi il file system FAT32 o NTFS in quanto FAT16 non è supportato per EXTRA! X-treme v. 9.

Tandem 6530 Client Option

In caso di utilizzo dei Criteri di gruppo per pubblicare EXTRA! X-treme per gli utenti, è necessario installare EXTRA! X-treme prima di installare EXTRA! 6530 Client Option.

Se viene installato EXTRA! X-treme v. 9 in ambiente myEXTRA! Enterprise v. 8 in cui è installato myEXTRA! 6530 Client Option v. 8, 6530 Client Option v. 8 verrà rimosso. Per abilitare la connettività Tandem, è necessario installare EXTRA! 6530 Client Option v. 9 dopo aver installato EXTRA! X-treme v. 9. Rivolgersi al rappresentante di commercio Attachmate di zona per ulteriori informazioni su EXTRA! 6530 Client Option v. 9.

Supporto FTP in Tandem

È necessario installare il protocollo FTP durante l'installazione di EXTRA! X-treme se si desidera disporre del supporto FTP in Tandem. Il protocollo FTP viene installato per impostazione predefinita.

Driver DLC per l'installazione di Windows XP

Anche se al driver DLC di Attachmate per Windows XP non può essere apposto il logo "Progettato per Windows XP", tale driver è stato sottoposto a svariati test nella piattaforma Windows e in tale ambiente funziona correttamente.

Nota Il driver DLC non può essere installato in Windows Vista.

Nei computer che eseguono Windows XP il driver DLC viene installato come parte di un'installazione tipica di EXTRA! X-treme. Se tuttavia si desidera installare questo driver manualmente in un computer in ambiente Windows XP, procedere nel seguente modo.

Per installare il driver DLC per la visualizzazione classica di Windows XP
  1. Dal menu Start selezionare Impostazioni e quindi Connessioni di rete.

  2. Fare clic con il pulsante destro del mouse sulla connessione alla rete locale a cui si desidera aggiungere il protocollo e quindi scegliere Proprietà.

  3. Fare clic su Installa.

  4. Selezionare Protocollo e quindi fare clic sul pulsante Aggiungi.

  5. Se il protocollo DLC di Attachmate è già stato installato, esso verrà visualizzato in una finestra di dialogo, dove sarà possibile selezionarlo per reinstallarlo.

    -oppure-

    Fare clic sul pulsante Disco driver, inserire il CD di EXTRA! X-treme e passare alla seguente directory:

    \EXTRA!\program files\Attachmate\EXTRA!\

    A questo punto, è possibile selezionare il protocollo DLC di Attachmate per l'installazione.

  6. Se viene richiesto di specificare la posizione del file ATMDLC.SYS, passare alla directory indicata nel passaggio 5 e selezionare il file.

    A questo punto, il driver DLC è installato, abilitato e pronto per l'uso.

Per installare il driver DLC per la visualizzazione normale di Windows XP
  1. Dal menu Start selezionare Pannello di controllo e quindi Connessioni di rete.

  2. Fare clic con il pulsante destro del mouse sulla connessione alla rete locale a cui si desidera aggiungere il protocollo e quindi scegliere Proprietà.

  3. Fare clic su Installa.

  4. Selezionare Protocollo e quindi fare clic sul pulsante Aggiungi.

  5. Se il protocollo DLC di Attachmate è già stato installato, esso verrà visualizzato in una finestra di dialogo, dove sarà possibile selezionarlo per reinstallarlo.

    -oppure-

    Fare clic sul pulsante Disco driver, inserire il CD di EXTRA! X-treme e passare alla seguente directory:

    \EXTRA!\program files\Attachmate\EXTRA!\

    A questo punto, è possibile selezionare il protocollo DLC di Attachmate per l'installazione.

  6. Se viene richiesto di specificare la posizione del file ATMDLC.SYS, passare alla directory indicata nel passaggio 5 e selezionare il file.

    A questo punto, il driver DLC è installato, abilitato e pronto per l'uso.


Problemi noti

Profili comuni

I profili comuni non sono supportati in tutti i sistemi operativi.

Recupero di flussi in AS/400 tramite 802.2

IBM ha disabilitato il supporto del recupero dei flussi in 802.2 su OS/400 V5R2 e successive, in quanto provoca la mancata esplorazione di AS/400 utilizzando il metodo di trasferimento di file 5250 tramite 802.2. Attachmate consiglia di modificare il metodo di trasferimento di file da 802.2 a TCP/IP. Se risulta impossibile modificare il metodo di trasferimento di file, visitare il sito Web del supporto all'indirizzo http://supportweb.attachmate.com.

SSL (128 bit)

La crittografia viene eseguita solo se anche il sistema remoto supporta SSL (Secure Sockets Layer) in TN3270 e TN5250. È necessario disporre di un host o un gateway protetto.

Risposta di ritorno (solo sessioni asincrone)

In Risposta di ritorno nella pagina Generale della finestra Schermo - Impostazioni è possibile includere una parentesi graffa di apertura ("{") nella stringa della risposta di ritorno.

Per utilizzare una parentesi graffa di apertura
  • Durante l'immissione della stringa nella finestra di dialogo, racchiudere la parentesi graffa di apertura tra virgolette per visualizzarla, nel seguente modo:

    "{"

    La stringa verrà visualizzata nel modo in cui è stata digitata. Tuttavia, solo la parentesi graffa di apertura verrà inviata all'host.

Collegamento TN3270 tramite un firewall

In caso di utilizzo di un collegamento TN3270 tramite un firewall, sarà necessario modificare la sezione [Connection] del file .EDP in modo che NoEcho=YES.

Per utilizzare un collegamento TN3270 tramite un firewall
  1. Utilizzando un editor di testo aprire il file SESSION.EDP, disponibile nella sottodirectory Sessions della directory di installazione del prodotto. Ad esempio:

    C:\DOCUMENTI\EXTRA!\HOSTA.EDP

  2. Dopo aver aperto il file, nella sezione [Connection] modificare l'impostazione di NoEcho da NO a YES.

Connessione all'host tramite Microsoft SNA Server

EXTRA! X-treme consente l'accesso host tramite Microsoft SNA Server a mainframe e applicazioni e risorse AS/400. Il software client di Microsoft SNA Server è disponibile nel CD di installazione di Microsoft SNA Server o Host Integration Server oppure è possibile richiederlo direttamente a Microsoft. È consigliabile che il software client corrisponda alla versione di SNA Server o Host Integration Server installata e che nei client sia disponibile e installata la copia più aggiornata.

Il software client di SNA Server non è richiesto per le connessioni TN3270 o TN5250 a Microsoft SNA Server. Rivolgersi a Microsoft per richiedere una "licenza di accesso client" per Microsoft SNA Server in modo da assicurarsi che il software client disponga della licenza corretta per accedere alle risorse tramite Microsoft SNA Server.

Nota
  • La versione per Windows NT del software client di Microsoft SNA Server non è supportata.

  • La versione per Windows 98 del software client è invece supportata e può essere installata in Windows NT 4.0, Windows 2000 e Windows XP.

  • Il client Microsoft HIS 2004 è supportato.

Limiti della connettività al nodo APPN AS/400

È consentito solo un tipo di connessione per un host specifico. È tuttavia possibile configurare più tipi di connessione, a condizione che il nome dell'host sia diverso. Ad esempio, viene stabilita una connessione 802.2 a XYZ400 e quindi viene stabilita una connessione MPTN a XYZ400. Verrà utilizzato l'ultimo tipo connesso a XYZ400, in questo caso MPTN.

Inoltre, la connessione a un host specifico può essere di tipo diretto oppure pass-through, ma non di entrambi i tipi. Ad esempio, viene stabilita una connessione 802.2 a XYZ400 e quindi una seconda connessione 802.2 a XYZ400 tramite UVW400. Verrà utilizzata l'ultima definizione configurata per XYZ400, in questo caso XYZ400 tramite UVW400.

Utilizzo della virgola come separatore nelle opzioni internazionali di Windows

Se nelle opzioni internazionali di Windows viene utilizzata la virgola come separatore, per garantire il corretto funzionamento della virgola, è necessario che la voce DisableCSVCommaDelimiters nella sezione [Edit Scheme] del file .EDP sia impostata su TRUE.

Per utilizzare la virgola come separatore nelle opzioni internazionali di Windows
  1. Utilizzando un editor di testo aprire il file SESSION.EDP, disponibile nella sottodirectory Sessions della directory di installazione del prodotto. Ad esempio:

    C:\DOCUMENTI\EXTRA!\HOSTA.EDP

  2. Dopo aver aperto il file, nella sezione [Edit Scheme] modificare l'impostazione della voce DisableCSVDelimiters da FALSE a TRUE.

Utilizzo di caratteri raster e driver video non Microsoft

L'utilizzo di caratteri raster con driver video non Microsoft può generare un errore GPF. Questo errore si verifica spesso quando viene utilizzato IntelliMouse per eseguire lo zoom avanti o lo zoom indietro di una sessione.

Autenticazione host per SSH

Per impostazione predefinita, l'autenticazione host per SSH funziona solo quando il server SSH è impostato per l'utilizzo delle chiavi DSA e quando si stabilisce una connessione al server con il client, nel PC client verrà automaticamente inserita un'impronta digitale DSA. Se il server SSH è impostato per utilizzare solo le chiavi RSA, la connessione avrà esito negativo e nel file registro dello stato verrà incluso il seguente errore:

"EXTRA!SSH: No Host Key Alg" (orithm) "

Per abilitare la generazione di chiavi RSA con SSH, è necessario aggiungere una stringa "use_SSH2_RSA" con il valore "Y" alla voce HKEY_CURRENT_USER\Software\Attachmate\EXTRA!\WorkStationUser\Preferences nel Registro di sistema.


Stampa

Configurazione dell'elaborazione delle nuove righe tramite l'opzione ByPassWinGDI

Se si seleziona l'opzione di sistema Bypass Windows GDI in modo tale che la stampa su file venga eseguita in modalità di output non elaborato, per rendere configurabile l'elaborazione delle nuove righe è necessario modificare il file .EPP.

Per rendere configurabile l'elaborazione delle nuove righe se è selezionata l'opzione ByPassWinGDI
  1. Utilizzando un editor di testo aprire il file SESSION.EPP.

  2. Nella sezione [Terminal] aggiungere il seguente testo in qualsiasi riga:

    Convert NLtoLF = 1

  3. Nota Questa impostazione funziona solo nella modalità Solo testo.

Invio di comandi specifici della stampante prima e dopo un processo di stampa

Per impostare i valori per AtStartDoc e AtEndDoc in modo da consentire l'invio dei comandi specifici della stampante prima e dopo il processo di stampa
  1. Creare una sessione di stampa e salvarla.

  2. Aprire il file di sessione .EPP salvato utilizzando Blocco note o WordPad.

  3. Modificare la sezione [Terminal] come riportato di seguito:

    [Terminal]

    AtStartDoc="\x1B(0N\x1B"k4S"

    AtEndDoc="\x1BE"

    GeneralBypassWinGDI=1

Nota
  • La sezione [Terminal] viene utilizzata sia nel profilo della sessione di visualizzazione che nel profilo della sessione della stampante.

  • Per i valori AtStartDoc e AtEndDoc, non inserire spazi tra le virgolette doppie per evitare che l'intero processo di stampa venga stampato una riga per pagina.

  • È necessario sostituire l'istruzione ByPassWinGDI=1 con GeneralBypassWinGDI=1.


Trasferimento di file

Visualizzazione del trasferimento di file

Per tabelle codici PC diverse da 1252, è necessario accertarsi che l'applicazione per visualizzare i file trasferiti sia configurata per il corretto sottoinsieme del carattere desiderato. Ad esempio, la tabella codici 1250, che rappresenta il ceco e il croato, deve utilizzare il carattere Attachmate (Central Europe). Lucida per Attachmate viene automaticamente impostato sul sottoinsieme Western.

Trasferimento di file con 5250

L'utilizzo del trasferimento di file su AS/400 con NetWare for SAA tramite TCP/IP potrebbe causare il blocco del PC in situazioni specifiche. Per risolvere questo problema, è necessario modificare le dimensioni del buffer nel Registro di sistema.

Per modificare la voce DBServer nel Registro di sistema
  1. Scegliere Esegui dal menu Start.

  2. Nella finestra di dialogo Esegui digitare il seguente comando e quindi fare clic su OK:

    regedit

    Viene visualizzato l'Editor del Registro di sistema.

  3. Nel riquadro a sinistra, come illustrato nella figura seguente, fare clic sul segno più (+) accanto alla voce HKEY_CURRENT_USER, quindi su Software, Attachmate, EXTRA, WorkstationUser, AS400 e infine selezionare DBServer.

  4. Nel riquadro a destra dell'Editor del Registro di sistema fare doppio clic sulla voce MaxDataBufferSize.

  5. Nella casella Dati valore digitare il seguente valore e quindi fare clic su OK.

    2000 (HEX)

  6. Chiudere l'Editor del Registro di sistema.

Problemi relativi al formato del trasferimento di file batch


HLLAPI e OLE

Condivisione dell'area di presentazione

Le specifiche IBM EHLLAPI e WOSA WinHLLAPI identificano un insieme di parametri di sessione che determinano come e se l'area di presentazione di un'applicazione HLLAPI collegata viene condivisa. La condivisione dell'area di presentazione non è stata ancora implementata nel trasporto avanzato HLLAPI. Pertanto, più applicazioni HLLAPI potranno connettersi contemporaneamente a un'unica sessione host. Con il trasporto standard HLLAPI, dove la condivisione dell'area di presentazione è stata effettivamente implementata, solo un'applicazione HLLAPI alla volta può connettersi a una sessione host, a meno che un parametro di sessione appropriato sia stato impostato nelle applicazioni HLLAPI utilizzando la funzione 9 (Set Session Parameters). Una seconda applicazione che tenti di connettersi a una sessione già utilizzata da un'altra applicazione HLLAPI riceverà il codice restituito 11 sulla chiamata a ConnectPS (funzione 1).

Funzione Reset System

I programmi HLLAPI devono utilizzare la funzione Reset System (21) nelle rispettive routine di scaricamento per consentire a EXTRA! X-treme di annullare correttamente la registrazione di HLLAPI e delle risorse OLE correlate durante lo scaricamento. Se la funzione Reset System non viene utilizzata, è possibile che alcune risorse permangano nella memoria dopo la chiusura di EXTRA! X-treme.

Sessioni aperte e visibili

In myEXTRA! Enterprise v. 7.11 e versioni precedenti una sessione host aperta mediante una chiamata di apertura dell'automazione OLE non è visibile all'apertura. In EXTRA! X-treme v. 8.0, la sessione è visibile se si utilizza il comando OLE Open. In EXTRA! X-treme v. 9.0, questo funzionamento è stato aggiornato in modo conforme alla versione 7.11, ovvero la chiamata del comando OLE Open non apre una sessione visibile.


Macro

Registrazione di macro in host asincroni

Il registratore macro inserisce automaticamente le istruzioni WaitHostQuiet dopo ogni operazione SendKeys. Per gli host asincroni, il tempo di attesa predefinito potrebbe essere eccessivo. Tale valore può tuttavia essere modificato in modo semplice e rapido. Ad esempio, per attendere solo due secondi, anziché i cinque secondi predefiniti, modificare tutte le istruzioni WaitHostQuiet in modo da impostare un'attesa del valore di timeout definito dall'utente e definire tale valore all'inizio della macro. Quando si desidera modificare il valore del tempo di attesa, sarà sufficiente apportare la modifica in un unico posto.

Ad esempio:

WaitValue = 2000 'definire questo valore una volta all'inizio della macro
...
...
WaitHostQuiet(WaitValue) 'modificare ogni istruzione WaitHostQuiet per impostare il tempo di attesa su un valore definito dall'utente.

Macro EXTRA! Basic

Tutte le macro EXTRA! Basic di tutti i client vengono eseguite su un thread singolo. Pertanto quando una macro del client visualizza una finestra di dialogo, tutte le altre macro vengono sospese temporaneamente.

Conversione di macro e sessioni KEA!

È possibile convertire macro e sessioni KEA! utilizzando Migrazione guidata come descritto nella procedura seguente.

Per convertire macro e sessioni KEA! in EXTRA!
  1. Dal menu Start di Windows selezionare Programmi.

  2. Dal menu Attachmate EXTRA! X-treme selezionare Migrazione guidata.

  3. Per convertire le sessioni, nella finestra Migrazione guidata selezionare KTC_Migrate.

    -oppure-

    Per convertire le macro, nella finestra Migrazione guidata selezionare KTM_Migrate.

    Il nuovo file viene inserito nella cartella appropriata per EXTRA!, nonché ridenominato utilizzando una nuova estensione di file.

Utilizzo dei pulsanti di riduzione a icona o ingrandimento con le macro

Quando un documento macro viene ingrandito all'interno dell'editor di macro, i controlli di riduzione a icona/ingrandimento/chiusura disponibili nella barra del titolo della macro scompaiono. Per annullare l'ingrandimento di un documento macro, è necessario scegliere di sovrapporre o affiancare il documento utilizzando il menu Finestra.


Microsoft

Trasferimento di file su computer che eseguono Windows XP Service Pack 2

Microsoft ha modificato le impostazioni predefinite relative alla protezione in Windows XP Service Pack 2 per aumentare il livello di protezione del desktop. Poiché Firewall connessione Internet (ICF) di Microsoft è abilitato per impostazione predefinita, se si utilizza il protocollo FTP in EXTRA! per trasferire un file in un computer remoto in cui è installato Windows XP SP2, è possibile che EXTRA! non sia in grado di stabilire una sessione Telnet con l'host remoto. Per risolvere questo problema, aprire manualmente la porta 23 del server Telnet nel computer remoto. Per ulteriori informazioni, visitare www.microsoft.com/security/protect/ports.asp.

Uso della Guida

In Microsoft Vista non è disponibile il software necessario per visualizzare la Guida dell'interfaccia utente di EXTRA!. Per utilizzare la Guida, è necessario scaricare il software per la Guida dal sito Web di Microsoft. La Guida continua a funzionare correttamente in Windows XP e Windows 2000.


Preferenze generali

Esecuzione di più sessioni in un portale

Se nelle preferenze generali vengono selezionate più istanze di una sessione, l'esecuzione di una sessione in un portale non è supportata.

Protezione delle password

Anche se l'opzione generale Imposta riquadro password macro è disponibile per tutti i tipi di host, essa viene applicata solo alle sessioni di IBM Mainframe e viene ignorata per le altre sessioni.


Grafica ed EXTRA! X-treme

Suggerimenti per l'utilizzo della grafica

Per visualizzare un elemento grafico negli Appunti
  • Dal menu Visualizza scegliere DIB.

Per stampare la grafica o il contenuto visualizzati nella sessione di EXTRA! X-treme corrente
  1. Dal menu Modifica scegliere Seleziona tutto oppure evidenziare l'area desiderata e quindi scegliere Copia o Taglia.

  2. Passare all'applicazione che supporta il formato DIB e dalla quale è possibile eseguire la stampa.

  3. Incollare la grafica nel programma e quindi stamparla.

Per tagliare o copiare una selezione grafica quando è visualizzato un cursore grafico
  1. Utilizzando un editor di testo aprire il file SESSION.EDP, disponibile nella sottodirectory Sessions della directory di installazione del prodotto. Ad esempio:

    C:\PROGRAMMI\Attachmate\EXTRA!\HOSTA.EDP

  2. Dopo aver aperto il file, nella sezione [Terminal] modificare l'impostazione della voce APAGCSelection da FALSE a TRUE.

Esecuzione di un programma grafico con TN3270

Quando si esegue un programma grafico con TN3270, è necessario modificare il file SESSION.EDP.

Per modificare il file SESSION.EDP per eseguire un programma grafico con TN3270
  1. Utilizzando un editor di testo aprire il file SESSION.EDP, disponibile nella sottodirectory Sessions della directory di installazione del prodotto. Ad esempio:

    C:\PROGRAMMI\Attachmate\EXTRA!\HOSTA.EDP

  2. Dopo aver aperto il file, nella sezione [Terminal] inserire la seguente riga di testo:

    WCCResetClock=TRUE

Utilizzo della grafica host SAS in una sessione di EXTRA! X-treme

Date le difficoltà relative alla visualizzazione della grafica host SAS in un ambiente grafico di Windows, potrebbe essere necessario utilizzare le opzioni grafiche disponibili in EXTRA! per ottimizzare i risultati della sessione di visualizzazione corrente di EXTRA!.

Per modificare le impostazioni in EXTRA! X-treme per SAS
  • Eseguire una delle seguenti operazioni:
    Per
    Procedura
    Rendere la sessione di visualizzazione grafica di EXTRA! X-treme il più simile possibile alla visualizzazione grafica host che si desidera emulare Nella pagina Generale della finestra Schermo - Impostazioni selezionare una delle impostazioni grafiche e assicurarsi che l'applicazione SAS host sia impostata sulla stessa visualizzazione grafica.
    Modificare gli oggetti che non sono visualizzati in modo proporzionato, ad esempio cerchi o quadrati. Nella pagina Generale della finestra Schermo - Impostazioni modificare il carattere dello schermo utilizzato.
    Nota I tre caratteri grafici ATM, ovvero ATM Graphics 1:1, ATM Graphics 2:5 e ATM Graphics 3:4, sono più adatti alla visualizzazione della grafica host rispetto ai caratteri di testo standard disponibili in EXTRA! X-treme 2000. La selezione del carattere ottimale dipende dal modello grafico utilizzato dalla sessione e dal tipo di schermo del PC.
    Utilizzare simboli del programma con una visualizzazione SAS Nella pagina Generale della finestra Schermo - Impostazioni selezionare Support Program Symbols.
    Nota In base al modello di visualizzazione utilizzato e alla modalità di utilizzo dei simboli del programma da parte di SAS, talvolta non è consigliabile utilizzare questa funzione.
    Utilizzare caratteri APL Nella pagina Generale della finestra Schermo - Impostazioni selezionare Support APL Characters.
    Impedire l'aggiornamento frequente della grafica SAS Abilitare l'opzione Graphics Cache modificando il file SESSION.EDP.

Per modificare il file SESSION.EDP per abilitare l'opzione Graphics Cache
  1. Utilizzando un editor di testo aprire il file SESSION.EDP, disponibile nella sottodirectory Sessions della directory di installazione del prodotto. Ad esempio:

    C:\PROGRAMMI\Attachmate\EXTRA!\HOSTA.EDP

  2. Dopo aver aperto il file, nella sezione [Terminal] modificare l'impostazione della voce APASASExtension da FALSE a TRUE.

Modifica delle immagini nelle sessioni asincrone

Anche se è possibile stampare immagini grafiche direttamente da EXTRA! in una sessione asincrona, per copiare e incollare immagini è necessario utilizzare il metodo Bitmap dell'area di registrazione.


Tastiere

Tastiere per PC con 101 tasti e supporto di Windows Terminal Server

Su una tastiera per PC con 101 tasti la funzione Clear per una sessione 3270 viene in genere mappata al tasto PAUSA. Tuttavia, le sessioni 3270 di EXTRA! X-treme 3270 eseguite in ambiente Windows Terminal Server non sono in grado di utilizzare il tasto PAUSA per richiamare la funzione Clear.

Per utilizzare la funzione Clear
  • Utilizzando EXTRA! X-treme Keyboard Remapper mappare la funzione Clear su un tasto diverso.

Rimappatura dei tasti per utenti Citrix AS/400

La mappatura predefinita della combinazione di tasti CTRL + SEGNO PIÙ (+) è in conflitto con la mappatura predefinita di Citrix. Sono tuttavia disponibili due soluzioni alternative possibili: gli utenti di Citrix possono rimappare il tasto in Citrix oppure possono rimapparlo utilizzando Attachmate Keyboard Remapper.


Controlli del mouse

In circostanze specifiche le impostazioni definite nel Pannello di controllo - Mouse sostituiscono le impostazioni della mappatura del mouse di EXTRA! X-treme per la rotellina o il pulsante centrale di un mouse.

Se il mouse in uso dispone di un pulsante centrale

Prima di procedere alla mappatura del pulsante centrale del mouse in EXTRA! X-treme, è innanzitutto necessario aprire il Pannello di controllo di Windows e impostare l'azione del pulsante centrale del mouse in uso su Pulsante centrale. Se il pulsante centrale è impostato su un'azione diversa, ad esempio Scorrimento automatico, nella finestra Mouse del Pannello di controllo, il pulsante centrale eseguirà tale azione anziché l'azione assegnata a esso in EXTRA! X-treme.

Se il mouse in uso dispone di una rotellina

Se la rotellina del mouse è impostata sul valore predefinito di sistema, in genere Scorrimento automatico, la rotellina eseguirà l'azione predefinita e l'azione EXTRA! X-treme assegnata alla rotellina. Se si utilizza il Pannello di controllo per impostare la rotellina su un valore diverso rispetto all'impostazione predefinita, l'azione EXTRA! X-treme assegnata alla rotellina verrà ignorata.


Navigazione

Segnalibri e pagine registrate

È possibile attivare e disattivare la funzione Resta visibile nella finestra Bookmarks and Recorded Pages premendo ALT + v. Questa sequenza di tasti eseguirà la stessa azione eseguita facendo clic sul pulsante a forma di "puntina da disegno" disponibile nella finestra Bookmarks and Recorded Pages. Quando la funzione Resta visibile è attiva, la finestra Bookmarks and Recorded Pages rimane visibile anche in seguito alla selezione di un segnalibro o una pagina.



  Attachmate