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About This Guide
This guide provides a step-by-step introduction to the Micro Focus Screen Designer.

The guide shows you how to:

• Create a history file
• Use the Screen Designer to customize a set of screens
• Use the customized screens in Plus mode.

A comprehensive How To section provides further information about customizing screens.

Note: You can only customize screens for 3270 mainframe and 5250 AS/400 (iSeries) sessions.

Who should read this guide
This guide is intended to be read by all those interested in customizing green screen applications to create
applications with a modern look and feel.

It is expected that readers would mostly be system administrators or other IT personnel with a similar level
of expertise.

Prerequisites
• Micro Focus Reflection Desktop 16
• Micro Focus Reflection Desktop Plus Add-On
• Micro Focus Rumba+ Server Build Tool 1.3 for export to Rumba+ Mobile and Rumba+ Web

Accompanying files
The package file containing this guide also contains the following files:

• MF_logo.png

• pie_chart.png

• WebFrame_URL.txt

• welcome.png

If you do not have these files, you will not be able to complete some of the exercises in this guide.

Conventions used in this guide
The following typographic conventions are used in this guide:

This typeface ... Is used for ...

Bold Windows user interface elements such as window titles, fields, and buttons.

Also used for keyboard keys.

Monospace Host user interface elements such as screen titles and labels.
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This typeface ... Is used for ...

Also used for file names as well as for text that you are asked to type.

Entering commands:

This instructon ... Means this...

Enter TSOA Type the TSOA command, then press the Enter key.
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Introduction
You use the Screen Designer to provide a modern look and feel to green screen applications and make
them easier to use. You do this without touching any application code.

When you have customized a set of screens in the Screen Designer, you create a file which you then link
to a host session. When you run the host session in Plus mode, you see modernized screens instead of
standard green screens.

This guide provides instructions for you to start using the Screen Designer to customize green screens.

Note: For the purposes of this guide, only 3270 mainframe screens are used. However, you can also
use the same principles to customize 5250 AS/400 (iSeries) screens.

Terminology
Screen Designer

The customization engine for Plus. It consists of two parts:
Screen Design view
Used to add static controls on specific screens.

Rule Manager window
Used to add dynamic or conditional controls on multiple screens.

Control
A modern visual element that interacts with a green screen. For example, a button.

Rule
A mechanism that automatically creates one or more conditional controls on one or several
screens, managed by rules.

Plus
The middleware used to run green screen applications with a modern interface using
projects created in the Screen Designer.

How it works
The figure below provides an overview of what you do to create and use customized screens:
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Architecture
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Using the Screen Designer
This section provides a step-by-step guide to creating a customization project. You add a number of
controls to various green screens to create a project, then see the results of the customization in Plus
mode.

Getting started
Before you start using the Screen Designer, you need to:

• Extract the files that came with this guide.
• Connect to the Demo Host.

Extracting the package files
Extract the following files from the package .ZIP file to your local machine:

• MF_Logo.png

• pie_chart.png

• WebFrame_URL.txt

• welcome.png

Make a note of where you save the files because you will need them later.

Connecting to the Demo Host
1. From the Windows Start menu, select: Start > All Programs > Micro Focus Reflection > Reflection

Workspace

Reflection starts, showing the Create New Document window:
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2. Select 3270 Terminal and click Create. 

The Create New 3270 Terminal Document window appears:

3. In the Host name / IP address field, type: demo:plus3270.sim
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4. Click OK. 

The Create New Document window closes and the host session starts automatically:

5. Click File > Save As. 

The Save As window appears.

6. In the File name field, type Demo Host, then click Save.

Creating a history file
Before you start customizing screens, you need to capture a set of screens in a history file. This section
describes how to record a sequence of screens to use in the Screen Designer.

Recording history
To create a history file:

1. Select Session tab > Screen History. 

The History pane appears.

2. Select Session tab > Screen History group > Screen History. 

The Screen History pane appears:
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3. At the ENTER SYSTEM ID : prompt, enter: 

TSOA

The screens start to be recorded.

4. At the ENTER LOGON ID: prompt, press Enter.

5. At the LAST SYSTEM ACCESS prompt, press Enter. 

The READY prompt appears.

6. Click the Manual Capture icon  on the History pane toolbar. 

This shows how you can capture individual screens. There are two reasons you might want to capture a
screen manually:

• You switched off screen history but need to capture a screen.
• You modified one or more unprotected fields on a screen and want to capture the screen with the

modifications.

7. Enter: 

TOYS

8. At the TOPCO TOYS, INC screen, press Enter.

9. Enter O.

10.At the CUSTOMER SCREEN, press PF8.

11.At the DETAIL LINE ENTRY SCREEN, press Enter.

12.At the READY prompt, enter: 

E

13.At the TOP OF DATA screen, press Enter.

14.At the READY prompt, enter: 

R

15.At the TOPCO TOYS, INC screen, press PF3.

16.At the READY prompt, enter: 
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A

17.At the EXTENDED ATTRIBUTE TEST screen, press PF3.

18.At the READY prompt, enter: 

C

The EUROPEAN CUSTOMER LIST screen appears.

19.Press PF1.

Each screen has been added, in sequence, to the History pane:

Saving the history to a file
To save the recorded history to a file:

1. Select Appearance group > Plus tab > Plus > Export History for Screen Designer. 

The Save As dialog box appears.

2. In the File name field, type DemoHistory.

3. Click Save. 

You now have a number of screens to use in your customization project.

4. Select Session tab > Screen History. 

The History pane closes.

5. Select Session tab > Host group > Disconnect.

Opening the Screen Designer
To open the Screen Designer, select Appearance tab > Plus group > Plus > Screen Designer.

The Screen Designer window appears:
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Screen Designer menu bar and toolbar.

History pane. Contains thumbnails of all the screens recorded in the imported history file,
together with a search box to search and filter screens.

Work area. Contains a full size version of the selected thumbnail. Shows the controls
associated with the screen.

Control panel. Contains a list of available controls that can be applied to the screen in the
work area.

Property grid. Contains a list of available properties for the selected control.

Property description. Provides a description of the selected property in the property grid.

Status bar. Displays the coordinates of the cursor. Useful when looking for coordinates of
fields.

Starting a new project

1. Select File > New Project 

The New Project dialog appears.

2. In the Name field, type a name for your project, such as DemoHost, then click OK.

Importing history

1. Select File > Import History. 

The History Import dialog box appears.

2. Choose your history file, then click Open. 
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Thumbnails of the recorded screens appear in the history pane. Each screen has a unique screen ID.
You can also create screen identifications instead of, or in addition to this default ID (see Identify
screens).

The first screen is selected by default and a larger version of it appears in the work area:

3. Select File > Save Project. 

Note: It is always good practice to save your project after you have made any changes to it.

Selecting a theme
A theme defines the layout of the screen and the look of each control across all screens in a customization
project.

It is best to choose a theme early in the customization project.

To select a theme:

1. Select Tools > Project Settings 

The Project Settings dialog box appears.

2. Click Themes in the left pane.

3. Click Change in the right pane. The Choose Theme dialog box appears.

4. In the left pane, select the Rumba Plus Windows Theme thumbnail.

5. Click OK.

6. Click OK in the Project Settings dialog box. 

The theme is applied to all the screens in your project.

For more information about themes, see Using themes.

Adding controls
You will now use the Screen Design view to add controls to your screens.
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You use the Screen Design view to add static controls to specific screens. To add dynamic controls,
controls that repeat on multiple screens or many times on a single screen, you use the Rule Manager. For
information about the Rule Manager, see Using the Rule Manager.

As you go through this section, you add controls to your captured screens progressively. We recommend
that you add the controls in the order they are described to build a completed project.

Note: It is important to remember that, while the Screen Designer is a very powerful tool, it is not
WYSIWYG. You should always adopt an approach of design and test to ensure that what you do in
the Screen Designer has the desired appearance in Plus mode.

Adding a Button control
Button triggers an action or a sequence of actions when clicked.

Note: In this section you use the MF_Logo.png file supplied with the package file.

1. Ensure the first thumbnail is selected.
2. Drag the Button control icon from the control panel on to the work area and drop it to the left of the

AVAILABLE SYSTEM IDS ARE row. 

Note: When you drop the control on the screen, the property grid is populated.

3. In the property grid, click in the Caption field and delete the text Button.

4. Type Micro Focus SupportLine. 

When you click elsewhere on the screen, the text changes on the control.
5. To make the text appear on two lines, click in the Caption field and place your cursor after Micro

Focus, then press Alt+Enter. This splits the line.
6. Use the control's handles to size the control to fit the text.
7. Click in the Tooltip field and type SupportLine Web Site. 
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8. Click the accelerator button  next to the Actions field. 

The Actions dialog box appears.

9. Under Select type, select WebSite from the drop-down list.

10.Click Add. 

A new action appears in the Actions frame and its properties appear in the Properties frame.

11.In the Properties frame, type http://www.microfocus.com/supportline in the ActionTarget
field: 

12.Click OK.

13.Use the handles on the control to size it for the text. 

Your screen should look like this:

14.You can also use an image for the button instead of text. To do this, select Image from the Mode list.

15.Click the accelerator button next to ImagePath. 

The Choose Image dialog box appears.

16.Click  next to Add to pool.

17.Navigate to where you saved the MF_Logo.png file, select the file, then click Open

18.Ensure the image is selected in the Choose Image dialog box and click OK. 

The image appears on the button.
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19.Use the handles on the button to resize the button to 6x1. 

Your screen should look like this:

Note: You can also provide a link to an image that is not on your machine. To do this, type the Web
address of the image in the ImagePath field.

20.Select File > Save Project.

Adding a Chooser control
Chooser appears on the screen like a drop-down list. Chooser is used to insert data into a field on the
screen by selecting an item from the list.

1. Drag the Chooser control icon from the control panel on to the work area and drop it on top of TSOA on
the ENTER SYSTEM ID: row: 

2. In the property grid, click the accelerator button  next to ChooserItems. 

The ChooserItems dialog box appears:
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3. Click the Add button .

4. In the Properties frame, type Select Host in the Caption field.

5. In the Tooltip field, type Select host system. 

This text will appear as you hover over the selection. Tooltip text can be used for tips and helpful
information on the selection.

6. Leave the Value to Insert field empty.

7. Click the Add button .

8. In the Properties frame, type WYLBUR in the Caption field.

9. In the Tooltip field, type Select WYLBUR.

10.In the Value to Insert field, type WYL. 

This is the text that will be placed in the entry field and must match the commands you would normally
manually type in the field.

The ChooserItems dialog box looks like this:

11.Repeat the above steps to add the following Chooser items: 

Caption Tooltip Value To Insert

TSO MVS/XA Select TSO MVS/XA TSOA

TSO MVS/XB Select TSO MVS/XB TSOQ

VM/370 Select VM/370 VM

When complete, the ChooserItems dialog box looks like this:

20 | Using the Screen Designer



12.When you have finished, click OK.

13.Use the handles on the control to size it so that the text shows correctly. 

Your screen should look like this:

14.In the property grid, click the accelerator button  next to TextInsertionLocation. 

The Select Screen Location window appears.

15.Select Location from the Select By list at the bottom of the window.

16.Click on the T of TSOA to the right of ENTER SYSTEM ID: at the location 12,29.

17.Click OK.

18.In the property grid, click the accelerator button  next to Actions. 

The Actions dialog box appears.

19.From the Select type list, select Emulation Command.

20.Click Add.

21.From the Action list, select Enter. 

This action sends an Enter command to the host after the Chooser sends the selected text to the
screen location specified by TextInsertionLocation.

22.Click OK.

23.Select File > Save Project.
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Adding a Tooltip control
Tooltip displays text when the mouse hovers over the screen area that Tooltip occupies.

1. Drag the Tooltip control icon from the control panel on to the work area and drop it on top of ENTER
SYSTEM ID:

2. Drag the handles on the control so the control covers the screen text: 

3. In the property grid, type the following in the Caption field: 

Click drop-down list to select system

4. Click in the Caption field and position your cursor just before to.

5. Press Alt+Enter. 

The line splits into two.

6. Select File > Save Project.

Adding an AutoExecution control
After you log into the Demo Host, you need to press Enter twice before the READY prompt appears. You
can use an AutoExecution control to automate this sequence. To do this:

1. In the left pane, select the second screen. 

A larger version of the screen appears in the work area.

2. Drag the AutoExecution control from the control panel and drop it to the right of the Plus icon: 
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3. In the property grid, click the accelerator button  next to the Actions field.

4. From the Select type list, select Emulation Command. 

5. Click Add.

6. From the Action list, select Enter:

7. Click OK.

8. Select the third screen in the left pane:

9. Add another AutoExecution control and give it the same properties: 
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10.Select File > Save Project.

Adding an Image control
Image masks an area of a screen with either a color or an image.

Note: In this section you use the welcome.png file supplied with the package file.

1. In the history pane, scroll down and select the fourth thumbnail. This shows the READY prompt. 

A larger version of the screen appears in the work area:

2. Drag the Image control icon from the control panel onto the work area, then use the handles of the
control to size it to 15x66: 
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3. In the property grid, select Image from the Type drop-down list. 

The ImagePath field appears.

4. Click the accelerator button  next to the ImagePath field. 

The Choose Image dialog box appears.

5. Click  next to Add to pool.

6. Navigate to where you saved the welcome.jpg file, select the file, then click Open.

7. Ensure the image is selected in the Choose Image dialog box and click OK. 

The selected image now fills the control on the screen:

Note: You can also provide a link to an image that is not on your machine. To do this, type the Web
address of the image in the ImagePath field.

8. Select File > Save Project.
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Adding a Label control
Label adds a text label to a green screen. You can use Label to either replace an existing screen label or
create a new label.

1. In the history pane, select the SALES ORDER ENTRY - CUSTOMER SCREEN. 

A larger version of the screen appears in the work area.

2. Drag the Label control icon from the control panel on to the work area and drop it on top of the
Contract field.

3. Size the control so it covers the field completely: 

4. In the property grid, uncheck HostText. 

The LabelText field appears.

5. In the LabelText field, delete the default text Label and type Date:

6. Select Right from the Alignment list.

7. Check OverrideColorsSettings. 

The control now uses the screen background and foreground colors for the label background and the
text. The label text is now visible in the control:
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8. Select File > Save Project.

Adding a Calendar control
Calendar inserts a selected date at a specified point on the screen.

1. Ensure the SALES ORDER ENTRY - CUSTOMER SCREEN screen is still displayed in the work area.

2. Drag the Calendar control icon from the control panel on to the work area and drop it to the left of the
(new) Date field: 

3. In the property grid, click the accelerator button  next to the InsertedDateFormat field. 

The Date Format dialog box appears:
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You can select from a variety of supplied date formats. Alternatively, you can specify a custom date
format.

4. Select MM-dd-yy from the list of dates, then click OK. 

The dialog box closes and the date format appears in the InsertedDateFormat field.

5. In the Tooltip field, type Select date

6. Click the accelerator button  next to the TextInsertionLocation field. 

The Select Screen Location window appears.

7. Select Location from the Select By list.

8. Click one space to the right of the Contract field at screen location (3,52).

9. Click OK. 

The window closes and the coordinates appear in the TextInsertionLocation field. In this case, 3,52.
The coordinates also appear in the status bar, below the property grid.

When complete, the property grid looks like this:

10.Select File > Save Project.

Adding a GridCollector control
GridCollector gathers information from a specific screen location and displays the information in a table.

1. In the left pane, scroll down and select the EUROPEAN CUSTOMER LIST screen.

2. Drag the GridCollector control from the control panel and drop it at the start of the first row: 

28 | Using the Screen Designer



3. In the property grid, in the Name field, delete GridCollector1 and type CustomerList.

4. Click the Edit icon  on the control. 

The GridCollector frame appears:

5. Move and size the GridCollector frame so that it overlays the screen data: 
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6. Click the accelerator button  next to the Columns field. 

The Columns dialog box appears:

7. In the Name field, delete GridCollectorColumn, and type Account.

8. Click the Add button . 

Another item appears in the Column Items frame.

9. In the Name field, type Sales Rep.

10.Click the Add button . 

Another item appears in the Column Items frame.

11.Continue to add columns for:

• Vol/Yr

• Cum Rev

• Country

The dialog box should look like this:
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12.Click OK. 

The GridCollector frame now contains a number of blue vertical lines. These represent column dividers.

13.Drag each column divider to the left of each column. 

The GridCollector should look like this:

Tip: In some cases, such as Web applications, system parameters do not look for leading spaces.
It is therefore best to start a column on the first character of data.

14.At the top right of the GridCollector, click the Save icon .

15.Select File > Save Project

Adding a Table control
This section describes how to add a Table control to display the data collected by the GridCollector control.

1. Drag the Table control from the property grid and drop it on the GridCollector control. 

The table automatically links to the GridCollector control and maps on to the area defined by the
GridCollector:
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Note: The LinkedGridCollectorName field in the property is completed automatically, and the
table header and columns properties are taken from the linked GridCollector properties.

2. Uncheck IsMoreButtonVisible.

3. Uncheck IsAutoNavigateOnLoad.

4. Check IsExportButtonVisible. 

Note: The More button no longer appears in the table and is replaced by the Export button.

5. Select File > Save Project.

Adding a Collector control
Collector controls gather screen data for use in other functions. In this case you will add a Collector control
to collect data to generate a pie chart for January.

1. In the history pane, select the TOPCO TOYS, INC Revenue Analysis By Region screen. 

2. Drag the Collector control icon from the control panel on to the work area and drop it on top of 305 in
the JAN column for region 1: 
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3. In the property grid, type R1Jtoy in the Name field. 

This is the name of the variable where the value will be stored.

4. Leave Trim Spaces checked.

5. Add Collector controls for the three other regions. Use R2Jtoy, R3Jtoy, and R4Jtoy as global
parameter names. 

The screen looks like this:

6. Select File > Save Project.

Adding a WebFrame control
In the previous section, you added four Collector controls to collect data for a pie chart. You will now add a
WebFrame control to use the variables of the Collector controls to generate the pie chart.

Note: In this section you use the WebFrame_URL.txt file and pie chart.png files supplied with
the package file.

Using the Screen Designer | 33



1. Drag the WebFrame control icon from the control panel on to the work area and drop it just underneath
JAN: 

2. Select Pop-up from the Mode list. 

Note: If you were to select Embedded, the resulting pie chart would appear as an embedded
window on the green screen.

3. Click the accelerator button  next to ImagePath. 

The Choose Image dialog box appears.

4. Click  next to Add to pool.

5. Navigate to where you saved the pie chart.png file, select the file, then click Open.

6. Ensure the image is selected in the Choose Image dialog box and click OK.

7. In the Tooltip field, type Pie chart.

8. Open the WebFrame_URL.txt file. 

The file contains the following URL:

http://chart.googleapis.com/chart?chs=300x150&cht=p3&chco=0000FF|00FF00|
FF0000|FFFF00&chds=0,1000&chd=t:%%R1Jtoy%%,%%R2Jtoy%%,%%R3Jtoy%%,%%R4Jtoy%
%&chdl=Region1|Region2|Region3|Region4&chtt=TOYS

9. Copy the content of the file and paste it in the URLSource field.

10.Select File > Save Project.

Adding a Tab control
Tab provides an area of the screen to which you can assign other controls. You can have multiple Tab
controls on a screen, with multiple tab items within a Tab control.

1. In the history pane, select the SALES ORDER ENTRY - DETAIL LINE ENTRY SCREEN. 

A larger version of the screen appears in the work area.

2. Drag the Tab control icon from the control panel to work area and drop it on the lower set of input fields,
then size the control to fit: 
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3. In the property grid, click the accelerator button  next to the TabItems field. 

The TabItems dialog box appears:

4. In the Caption field, delete Tab Item and type Order.

5. Click the Add button . 

Another item appears in the Properties frame.

6. In the Caption field, delete Tab Item and type Quantity.

7. Click the Add button . 

Another item appears in the Properties frame.

8. In the Caption field, delete Tab Item and type Approved. 

The dialog box looks like this:

Using the Screen Designer | 35



9. Click OK. 

The Tab control now as three tab items:

You can change the width of the tab item headers to fit the text you choose. For example, the default
width is eight characters. You can specify a different width by changing the value in the HeaderSize
field in the property grid.

10.Change the value in the HeaderSize field to 12. 

You can see the change in the width of the tab item headers.

Note: If you select Dynamic from the HeaderWidth list, the headers automatically size to fit the
length of text in each header.

11.In the property grid, click the down button  next to the Color field. 

The Available Colors palette appears.

12.Select RoyalBlue: 

The color fills the Tab control and its Tab items:

36 | Using the Screen Designer



13.Select File > Save Project.

Adding an InputField control
InputField provides a text input field in which you type text at a specific screen location.

1. Each input field requires a label. Drag the Label control icon from the control panel and drop it onto the
Tab control you have created: 

2. In the property grid, uncheck HostText. 

The LabelText field appears.
3. In the LabelText field, delete the default text Label and type Order Number:.

4. Add another Label control below the first and call it Status:.

5. Size both labels: 

6. Drag the InputField control icon from the control panel and drop it on the Order Number row: 

7. Click the accelerator button  next to the TextInsertionLocation field. 

The Select Screen Location window appears.
8. Select Location from the Select By drop-down list.
9. Click in the Order Number field, then click OK. 

The coordinates 3,16 appear in the TextInsertionLocation field.

10.Check OverrideColorsSettings. 

The Tab item currently looks like this:
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11.Click the Quantity tab.

12.Drag the Label control icon onto the tab item.

13.Uncheck HostText and call the label Product Number:.

14.Size the label.

15.Add another label below the first, call it Quantity:, then size it. 

The Tab item should look like this:

16.Add an InputField control on the Product Number row.

17.Click the accelerator button  next to the TextInsertionLocation field to open the Screen Location
window.

18.Select Location from the Select By drop-down list.

19.Click in the Product Number field, then click OK. 

The coordinates 6,18 appear in the TextInsertionLocation field.

20.Check OverrideColorsSettings.

21.Add an InputField control on the Quantity row.

22.Open the Screen Location window and click in the Order Qty field.

23.Click OK. 

The coordinates 8,18 appear in the TextInsertionLocation field.

24.Check OverrideColorsSettings. 

The Tab item should look like this:

25.Click the Approved tab.

26.Drag the Label control icon onto the tab item.

27.Uncheck HostText, call the label Approval:, then size the label: 

28.Select File > Save Project.

Adding a RadioButton control
RadioButton sends text to a specified screen location.

This section uses the Tab control you created previously.

1. Click the Order tab: 
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2. Drag the RadioButton control from the control panel and drop it on the Status row: 

3. In the property grid, delete RadioButton from the Caption field and type Open.

4. In the GroupName field, type OrderStatus.

5. Open the Screen Location window from the TextInsertionLocation accelerator button.

6. Select Location from the Select By drop-down list.

7. Click in the Status field on the top row of the green screen.

8. Click OK. 

The coordinates 3,33 appear in the TextInsertionLocation field.

9. In the SelectedState > TextToSend field, type Open. 

The property grid should look like this:

10.Drag the RadioButton control from the property grid and drop it below the Open radio button: 

11.In the property grid, delete RadioButton from the Caption field and type Shipped.

12.In the GroupName field, type OrderStatus.

13.Open the Screen Location window from the TextInsertionLocation accelerator button.

14.Select Location from the Select By drop-down list.

15.Click in the Status field on the top row of the green screen.

16.Click OK. 

The coordinates 3,33 appear in the TextInsertionLocation field.

17.In the SelectedState > TextToSend field, type Shipped.
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18.Click the accelerator button  next to the Actions field. 

The Actions window appears.

19.Select Email from the Select type list, then click Add.

20.In the ActionTarget field, type: customer@address.com

21.Click OK. 

The tab item should look like this:

22.Select File > Save Project.

Adding a CheckBox control
CheckBox acts like an on/off toggle in the same way as a typical check box.

This section uses the Tab control you created previously.

1. Click the Approved tab: 

2. Drag the CheckBox control from the control panel and drop it on the Approval row: 

3. In the property grid, delete CheckBox in the Caption field and type Approved.

4. Open the Screen Location window from the TextInsertionLocation accelerator button.

5. Select Location from the Select By drop-down list.

6. Click in the Status field on the Line Number row, then click OK. The coordinates 5,57 appear in the
TextInsertionLocation field.

7. In the CheckedState > TextToSend field, type Approved.

8. In the UnCheckedState > TextToSend field, type Pending in the TextToSend field. 

The property grid should look like this:
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The tab item should look like this:

9. Select File > Save Project.

Taking the project live
Now the customization project is complete, you need to:

• Generate a customization file.
• Associate the file with a mainframe session.
• Test the screens.

Generating a customization file
You must now generate all the controls and rules you have created to a customization file. You will then link
the file to a mainframe session.

To generate the customization file:

1. Select Generate > Customization File. 

The Save Designer Archive dialog appears.

2. In the File name field, type a name for the file, such as DemoHost.

3. Click Save.

4. Select File > Exit.

Associating a customization file with a host session
The final step is to associate the customization file with a host session. To do this:

1. On the Reflection desktop, select Appearance tab > Plus group > Plus > Select Plus Customization
File. The Open dialog box appears.

2. Choose the customization file you created, then click Open. 

Plus mode is enabled automatically.
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Testing the screens

1. Select Session tab > Connect. 

The mainframe screen appears in Plus mode, showing the controls you added to it:

2. Hover your mouse over the Micro Focus button. 

The tooltip text you created appears:

3. Hover your mouse over ENTER SYSTEM ID: 

The tooltip text you created appears:

4. Select TSO MVS/XA from the Chooser control. The AutoExecution action you specified in the Chooser
automatically sends an Enter command to execute the system selection. The additional AutoExecution
controls you created send Enter commands automatically at the ENTER LOGON ID: and LAST
SYSTEM ACCESS prompts, presenting you with the READY prompt screen and the image you added
with the Image control:
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5. At the READY prompt, enter: 

O

The SALES ORDER ENTRY CUSTOMER SCREEN appears:

This screen contains the Date label and Calendar control you created:

6. Hover your mouse over the Calendar control. 
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The tooltip text you entered appears:

7. Click the Calendar control. 

A calendar appears:

8. Select today's date. 

The date appears:

9. Press PF3.

10.At the READY prompt, enter C. 

The EUROPEAN CUSTOMER LIST screen appears, showing the table you created with the
GridCollector and Table controls:
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11.Click Export at the top right of the table. 

The Save As dialog appears.

12.Specify a name for the table and click Save. The contents of the table are saved in .CSV format.

13.Press PF1.

14.At the READY prompt, enter: 

TOYS

15.At the TOPCO TOYS, INC screen, click the WebFrame control under JAN. 

The pie chart you created appears in a separate window:

16.Close the pie chart window.

17.In the TOPCO TOYS, INC screen, press Enter.

18.At the READY prompt, enter: 

O

The SALES ORDER ENTRY CUSTOMER SCREEN appears.

19.Press PF8. 

The SALES ORDER ENTRY DETAIL LINE ENTRY SCREEN appears, showing the Tab control you
created:

20.On the Order tab item, in the Order Number field, type 12345. 
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The number appears in the Order Number field on the green screen.

21.Select the Open radio button. 

The text Open appears in the Status field next to the order number:

22.Select the Shipped radio button. 

The text Shipped replaces Open in the Status field:

Your default email client opens a new message window so you can advise the customer that the order
has shipped.

23.Click the Quantity tab.

24.In the Product Number field, type ABC77701. 

The text appears in the Product Number field.

25.In the Quantity field. type 25. 

The text appears in the Order Qty field:

26.Click the Approved tab.

27.Check Approved. 

The check box is unchecked and the text Pending appears in the second Status field.

28.Check Approved again. 

The check box is checked and the text Approved appears in the second Status field.

The screen looks like this:

29.Select Session tab > Host group > Disconnect.

46 | Using the Screen Designer



Using the Rule Manager
Use the Rule Manager to add dynamic controls that repeat on multiple screens or many times on a single
screen.

When to use the Rule Manager
The following basic scenarios describe when to use the Rule Manager instead of the Screen Design view.

• Adding Tooltip or Button controls to entire applications.

Fields with specialized Tooltip controls or assistance which remain consistent within the application.
Especially useful to explain account, customer, and status information that is abbreviated or appears in
abbreviated form on the screen.

Buttons such as Exit, Clear (screen), and Reset (keyboard).
• Adding controls to screens within subsystems.

Controls which are consistent with major subsystems such as accounts payable, help ticket systems, or
customer lookup. A subsystem might consist of five to ten screens, but operator functions are consistent
throughout.

Screen content can change, but header information needs to offer similar modernization control.
• Data scroll areas with modernizations that repeat on each line.

One Plus rule can generate multiple modernizations.

Tip: If you find that a control in the Screen Design view might be used better as a rule, right-click
the control and select Convert To Rule from the pop-up menu. The Screen Designer moves the
control to the Rule Manager.

The Rule Manager window
To open the Rule Manager window, select Tools > Rule Manager from the Screen Designer toolbar.

The Rule Manager window appears:
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Control panel. Contains a list of the following actions:

New Rule Opens the Rule Wizard to create a new rule.

Edit Rule Opens the selected rule in the Rule Wizard for editing.

Delete Rule Deletes the selected rule.

Enable Rule Enables the selected rule, if disabled.

Disable Rule Disables the selected rule.

Duplicate Rule Creates a copy of the selected rule.

The control panel also contains:

• Buttons to move a rule up, down, or to the top or bottom of a list.
• A search box to search rules.

List of rules pane. Contains a list of configured rules. Each rule consists of:

• A description.
•

An icon to use the rule to filter screens .
• An icon to show whether the rule is enabled 
•

An icon to show whether the rule is disabled 
•

An icon to edit the rule 
•

An icon to delete the rule 

Rule description pane. Displays a natural language version of the rule.

48 | Using the Rule Manager



The Rule Wizard
The Rule Wizard helps you to define rules and conditions that govern what actions occur on a screen and
when.

Steps pane. Contains the steps you need to go through to create a rule. The current step is
highlighted.

Options pane. Contains the options available for the selected step:

When this step is highlighted ... The options pane contains ...

Step 1 A list of templates that you can use to build
a rule.

Step 2 Conditions that identify the screen the rule
will apply to.

Step 3 The field, location, or text to look for on the
screen.

Step 4 The controls to create according to the rules.

Step 5 Exceptions to the rules that select screens.

Rule description pane. Contains a natural language version of the rule.

Examples
The following examples show different ways in which you can use the Rule Manager to design modernized
screens.
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Adding Button or Tooltip controls to entire applications
A simple system Clear button is designed with a rule that places it on every screen of the application in the
top right corner.

Button controls like this help users who are not used to the rules that apply to 3270 / 5250 applications.

Adding controls to screens within subsystems
In this example, the administrator wants to help users identify an account status. Anywhere in the
application where the string ACCOUNT STATUS : AB appears, a tooltip appears so that the operator
knows that the account status is active with credit approved.

The rule first finds the character string, then places a tooltip over the entire string. Moving the mouse over
the abbreviated field provides a more detailed description.
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Adding rules to be used on a set of screens
This example shows three screens in an application called Master Inquiry. The screens are similar, but
have different input prompts and different data headings. Each screen would be identified automatically as
a different screen.

The example creates a rule that puts a Create New Customer button near the first entry field.

The rule for this button is based on the Master Inquiry screen designation. If the screen identifies itself as
Master Inquiry and the string 5=display is found, the rule automatically puts a button by the
5=display field. On screens that do not match the criteria, no button is created. The button is
programmed with the keystrokes to create a customer record within the application.
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Adding controls to each line on a screen
This example uses screens containing tables of data and adds the same controls to each line on the
display. If you were to use the Screen Designer view, you would need to add a separate control for each
line of each table. Instead, you can use rules to replicate controls on each line.

To select a customer, the user types 1, then presses Enter. The example sets up a rule that replaces these
actions.

Note: The number of data entries per page varies. The rule creates 10 static selections per page. As
a result, the last page will only have three buttons because only three selections are valid.

The rule looks for the character strings Select Customer and 1 Select. It then replaces the single
character input field with a button labeled SEL. This button replaces the two actions of typing 1 in the data
field and pressing Enter with a simple point and click.
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Because the rule looks for the input field, if that input field is not found, the control is not added to the
screen.
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Types of control

AutoExecution
AutoExecution is used to trigger a sequence of actions when a green screen appears. The control is not
visible in a Plus session.

Properties:

Name Default value Description

Actions Empty list One or many actions are executed
sequentially from the top to the
bottom in the specified list.

Button
Button is used to trigger a sequence of actions when clicked. The control can include text or an image.

Properties:

Name Default value Description

Mode Text Specifies the type of content for the
control. Can be Text or Image.

Caption Button The text to be displayed on the
button.

ImagePath Empty string Click the accelerator button to open
the project image pool folder where
you can select an image file with a
format of JPG, GIF, or PNG. To
select a different image, click Add to
pool and browse to the image you
want to use. The image file is then
copied to the image pool and saved
with the project.

Alternatively, you can type the
location of an image in the form of its
full path or full Web address in the
ImagePath field.

Only available if Mode is Image.

ImagePosition Stretch Specifies the position of the image
inside the button:

Stretch (default)
Fill
Fit
Center

Tooltip The tool tip is displayed when the
mouse pointer hovers over the button.
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Name Default value Description

If empty, the button’s caption is
displayed.

Actions Empty list One or many actions which are
executed sequentially from the top to
the bottom in the specified list.

Style Default The button style.

OverrideColorsSettings Unchecked When checked, the background and
foreground color options are made
available, overriding the Style
property.

Background UseBackgroundFromHost A list box containing two options:

• UseBackgroundFromHost (the
host screen text color is used as
the background color)

• CustomColors

Available only if
OverrideStyleSettings is checked.

Foreground UseForegroundFromHost A list box containing two options:

• UseForegroundFromHost (the
host screen text color is used s
the foreground color)

• CustomColors

Available only if
OverrideStyleSettings is checked.

Calendar
Calendar is used to pick a date and is initially displayed on the screen as an icon. Calendar opens when
you click the icon. It closes on losing focus, or when you select a date.

When you select a date in the date picker, the date is inserted on the screen at the coordinates defined by
TextInsertionLocation. The format used is defined by InsertedDateFormat.

If the field occupied by Calendar contains date, the field is used by Calendar when it opens. Otherwise,
Calendar uses the current date.

Properties:

Name Default value Description

InsertedDateFormat Empty string Specifies the format of the text
representing the date format.

If empty, the default date format is
used:

dd/MM/yyyy

For example, 03/01/2015.

Tooltip Empty string If empty, no tool tip is displayed.
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Using the Date Format dialog box
Use the Date Format dialog box either to select a predefined date format or to create a customized date
format.

Selecting date formats
To select a date format other than the default:

1. Click the accelerator button  next to the InsertedDateFormat field in the property grid. 

The Date Format dialog box appears.

2. Select a date format from the list shown, then click OK. 

The dialog box closes and the chosen date format appears in the InsertedDateFormat field.

Using customized date formats
To use a customized date format:

1. Type the format you want in the field at the top of the Date Format dialog box. 

Note: Day and year must always be specified in lower case. Month must always be specified in
upper case.

2. Click Add. 

The custom format appears in the main list.

3. Click OK. 

The dialog box closes and the chosen date format appears in the InsertedDateFormat field.

4. To remove a custom format from the list, select the format, then click Remove. 

Note: You can only remove custom formats, not a supplied format.

Custom date format specification
The table below describes the date formats you can use with the Calendar control.

Format specifier Description Example Interpretation

j Represents the sequence
number of a day in the
calendar year.

j displays values between 1,
which represents January
1, and 366, which
represents December 31 in
a leap year.

j-yy

j-yyyy

The date 1/1/2015, j is
displayed as 1-15.

The date 12/31/2015,

j is displayed as 365-2015.

jjj Represents the sequence
number of a day in the
calendar year.

jjj displays values between
1, which represents
January 1, and 366, which
represents December 31 in
a leap year.

jjj-yy

jjj-yyyy

The date 1/1/2015, jjj is
displayed as 001-15.

The date 12/31/2015, jjj is
displayed as 365-2015.
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Format specifier Description Example Interpretation

For jjj, values less than 100
are padded with a leading
zero or zeros.

d The day of the month, from
1 through 31.

M/d/yyyy

M/d/yy

For the date 6/1/15, d is
interpreted as 1.

For the date 6/15/15, d is
interpreted as 15.

dd The day of the month, from
1 through 31.

M/dd/yyyy

M/dd/yy

For the date 6/1/2015

dd is interpreted as 01.

For the date: 6/15/15

dd interpreted as 15.

ddd The abbreviated name of
the day of the week.

M-ddd-yyyy

M-ddd-yy

For the date 6-Mon-2015,
ddd is interpreted as Mon
(for EN-US).

For the date 6-lun.-15, ddd
is interpreted as lun. (for
FR).

dddd The full name of the day of
the week.

M-dddd-yyyy

M-dddd-yy

For the date 6- Monday
-2015

dddd is interpreted as
Monday (for EN-US).

For the date 6- lundi -15,
dddd is interpreted as
lundi (for FR).

M The month, from 1 through
12.

M-dd-yyyy For the date 6/15/2015, M
is interpreted as 6.

For the date 12/15/2015, M
is interpreted as 12.

MM The month, from 01 through
12.

MM-dd-yyyy For the date 06/15/2015,
MM is interpreted as 06.

For the date 12/15/2015,
MM is interpreted as 12.

MMM The abbreviated name of
the month.

MMM-dd-yyyy For the date Jun-15-2015,
MMM is interpreted as Jun
(for EN-US).

For the date juin-15-2015,
MMM is interpreted as juin
(for FR).

MMMM The full name of the month. MMMM-dd-yyyy For the date
January-15-2015, MMMM
is interpreted as January
(for EN-US).

y Represents only the last
digit of the year.

M-dd-y For the date 2-03-15, y is
interpreted as 5.
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Format specifier Description Example Interpretation

When the Calendar control
is opened by the user, the
digit of the current decade
is added to the left. That is,
the year would be set to 15
(2015)

yy The year, from 00 to 99. M-dd-yy For the date 6-15-15, yy is
interpreted as 15.

yyyy The year, as a four-digit
number.

M-dd-yyyy For the date 6-15-2015,
yyyy is interpreted as 2015.

Any string Data separators. Examples:

M dd yyyy

M-dd-yyyy

M/dd/yyyy

M#dd#yyyy

CheckBox
The CheckBox control acts as an on/off toggle control in the same way as a typical check box.

CheckBox provides the user with the choice of one of two options, such as Yes and No.

Properties:

Name Default value Description

CheckedState Empty string The text to be used at the specified
screen location and any specified
actions to be performed if the check
box is checked.

UncheckedState Empty string The text to be used at the specified
screen location and any specified
actions to be performed if the check
box is unchecked.

Caption Check Box The label text that appears next to the
check box.

Tooltip Empty string The tool tip text that appears when
the mouse hovers over the control.

OverrideStyleSettings Unchecked When checked, the background and
foreground color options are made
available which, when selected,
override the Style property.

Background UseBackgroundFromHost A list box containing two options:

• UseBackgroundFromHost (the
host screen background color is
used as the background color)

• CustomColors

Available only if
OverrideStyleSettings is checked.
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Name Default value Description

Foreground UseForegroundFromHost A list box containing two options:

• UseForegroundFromHost (the
host screen text color is used as
the foreground color)

• CustomColors

Available only if
OverrideStyleSettings is checked.

BackgroundColor Black A color palette for choosing the
background color. Only available if
Background is set to
CustomColors.

ForegroundColor White A color palette for choosing the text
color. Only available if Foreground is
set to CustomColors.

Chooser
Chooser is displayed on the screen as a drop-down control. Chooser is used to insert data into a field on
the screen by selecting an item from the list.

Auto-complete is supported.

Properties:

Name Default value Description

ChooserItems Empty list The list of items displayed by the
drop-down list when clicking the down
arrow. The list of items can be
imported from a .csv file (see
below). Each item is specified by
Caption, Tooltip, and ValueToInsert.

Caption The text to be displayed on the drop-
down list item.

Tooltip The text to be displayed by ToolTip
when the mouse cursor hovers over
the drop-down list item.

ValueToInsert Specifies the text to be inserted when
selecting an item from the list.

IsAutoCompleteEnabled Checked When checked, Chooser
automatically offers a case-insensitive
matching item to be selected from the
list. If the user is not typing in the
screen field occupied by Chooser, no
suggestions are made.

IsEditable Checked When checked, data can be typed
into the field that Chooser is using. If
unchecked, data can only be selected
from the drop-down list.

Actions Empty list A collection of actions to be
performed when a Chooser item is
selected.
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Name Default value Description

OverrideStyleSettings Unchecked When checked, the background and
foreground color options are made
available, overriding the Style
property.

Background UseBackgroundFromHost A list box containing two options:

• UseBackgroundFromHost (the
host screen text color is used as
the background color)

• CustomColors

Available only if
OverrideStyleSettings is checked.

Foreground UseForegroundFromHost A list box containing two options:

• UseForegroundFromHost (the
host screen text color is used s
the foreground color)

• CustomColors

Available only if
OverrideStyleSettings is checked.

BackgroundColor Black A color palette for choosing the
background color. Only available if
Background is set to
CustomColors.

ForegroundColor White A color palette fro choosing the text
color. Only available if Foreground is
set to CustomColors.

Importing items from a .csv file

To use this feature successfully, the contents of the .csv file must be in the following format:

<CAP><DEL><TIP><DEL><VAL>

where:

This ... Denotes this ...

<CAP> Caption.

<DEL> Delimiter (;). This is the only supported delimiter.

<TIP> Tool tip.

<VAL> Value to insert.

For example:

#First block

AAA;BBB;CCC

AAA;BBB;CCC

DDD;EEE;ZZZ

GGG;HHH;III

JJJ;KKK;LLL

MMM;NNN;OOO

To import a .csv file:
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1. Click the accelerator button next to ChooserItems in the property grid.
2. In the ChooserItems dialog box, click the Import icon.
3. Select the .csv file.
4. Click OK.

Collector
Collector is not visible in a Plus session. It is used to copy text from the screen location of the Collector to
the session database. The screen location of the Collectoris defined by the two pairs (Row Offset,
Column Offset), (Row Span, Column Span).

The database lifetime is the whole session. Data is collected when host screen appears as a list of (key,
value) pairs of strings. The data can be used by other controls only from the current session. When the
screen location of the Collector spans screen rows, appropriate line breaks are inserted into the collected
data.

For example, a Button control looking like a small handset icon can be set up with an action
Run_Application to run Skype. Additional_Arguments of this action can use a phone number stored by
the Collector located in a phone number field on another screen of the session.

Properties:

Name Default value Description

Name Empty string A name of the Collector control.

Name also specifies a key to be used
by a Collector when copying data
from the Collector screen location to
the database.

Data stored with the same key more
than once is overwritten.

Data can be accessed later in the
session by using the syntax:

%%PhoneNumber%%

where PhoneNumber is the global
variable name.

TrimSpaces Checked When checked, whitespace
characters are not copied to the
database. When unchecked,
whitespace characters are included in
the data.

GridCollector
The GridCollector control is an extended version of the Collector control. Collector collects data as text
from a specific screen location. GridCollector collects data as a table (grid).

The control stores the collected information in a database for the lifetime of the current session. The
information can be used by any other control.

To configure GridCollector properties, click the Edit Mode button at the top right corner of the control.
When you have finished, click either the Save and Exit button or the Cancel Edit Mode button.

Properties:
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Name Default value Description

Name GridCollector The name for a GridCollector. Must
be unique.

Columns GridCollector Column Columns collection. Each column has
one property:

Name: Non-empty string.

IncludesHeader Checked When checked, the selection includes
the table header.

AvoidDuplications Checked When checked, duplicate rows are
not collected.

MultiPageNavigation Checked When checked, the following
properties are enabled:

MaxPages
AIDKey
EndCondition

MaxPagesToLookUp 1 Integer. The number of additional
pages that are fetched ahead each
time the fetch operation is triggered
by one of the controls that uses the
GridCollector data. The GridCollector
implements the fetching mechanism
(not the control that uses the
GridCollector) .

NavigationAidKey PF8 The AID key for fetching the next
page.

EndOfDataConditions Clicking the accelerator key opens
the EndOfDataConditions dialog
box (see below).

EndOfDataConditions properties
Name Default value Description

SameData When selected, data collection stops
if duplicate data is found. Default.

Note: If this is the only stop
condition that is defined,
SameData cannot be deleted.

EmptyLine When selected, data collection stops
if an empty line is found.

Text When selected, data collection stops
if either:

The specified non-empty string is
found at the specified screen location.

or:

The specified string is empty and
nothing is found at the specified
screen location.
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Name Default value Description

EndOfDataText The text to search. Available if Text is
selected.

EndOfDataTextLocation Location of the text. This is one of the
following:

• The whole screen, as specified by
the string Anywhere.

• A specific location on the screen,
specified in the Screen Location
dialog box. To open this dialog
box, click the accelerator button
next to the
EndOfDataTextLocation field.

EndOfDataTextRow The row of the text.

EndOfDataTextColumn The column of the text.

Note: GridCollector checks stop conditions from the top to the bottom of the list until any condition is
met, then stops collecting data. In this way, you can re-order conditions to collect different amounts of
data from the same screens.

Syntax
Any control that wants to use the data from the GridCollector can get the data by using the following
syntax:

%%GridCollector_Name[Row_Number,Column_Name]%%

Examples:

%%Customers[5,Address]%% Defines getting the address of the entry 5.

%%Customers[*,Address]%% Defines getting the address of all customers. This can be
useful for setting a list control's items source.

%%Customers[3,*]%% Defines getting all data for the customer at the third row.

%%Customers[*,*]%% Defines getting GridCollector data for all customers.

On a Plus screen, each time new data appears on the screen, the data is added to the GridCollector table.

Image
Image control is used to mask an area on the screen. The control appears in a Plus session without a
frame, and can be filled with one of the following:

Color If UseBackgroundFromHost is checked, Image is filled with the host background color. If
UseBackgroundFromHost is unchecked, you can select the fill color from the palette. The
default color is black. If you select a transparent fill, the Image control is invisible on the screen.

Image If you do not select a valid image, or provide a valid URL, the Image control is invisible on the
screen.

You can change the opacity of the Image control to show the contents of the screen behind the control. To
do this, select the control, then click the icon on the top right corner of the control's frame.

Properties:
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Name Default value Description

Type Color Can be either Color or Image.

UseBackgroundFromHost Checked Only available if Type is Color.

Color Black Fill color. Only available if Type is
Color and
UseBackgroundFromHost is
unchecked.

ImagePath Empty string Click the accelerator button to open
the project image pool folder where
you can select an image file with a
format of JPG, GIF, or PNG. To
select a different image, click Add to
pool and browse to the image you
want to use. The image file is then
copied to the image pool and saved
with the project.

Alternatively, you can type the
location of an image in the form of its
full path or full Web address in the
ImagePath field.

Only available if Mode is Image.

ImagePosition Stretch Position and size of the selected
image. Can be one of the following:

Stretch (default)
Fill
Fit
Tile
Center

InputField
The InputField control provides a text input field into which the user types text which is inserted at a
specified screen location.

For example, InputField can be used to modernize or rationalize the layout of a screen with a number of
input fields. InputField controls can be placed where they are most useful. The information the user types
into them is then inserted in the screen locations of the traditional editable areas.

Note: When the control is used in a Plus screen, the input field displays the value from the screen
location, at the specified length. However, if the screen location is a protected field, no data is read
and no typing is allowed in the InputField control..

In addition, if the length is 0 (the default value), data is read until the end of the green screen field the
control refers to, and the number of characters is limited by the length of the green screen.

Properties:

Name Default value Description

Length 0 The maximum number of characters
that the input field can contain. A
value of 0 means the number of
characters is limited by the length of
the green screen field.
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Name Default value Description

Tooltip Empty string A tool tip that describes the control.

IsNumeric False Specifies whether the input is
numeric or for all characters.

OverrideStyleSettings Unchecked When checked, the background and
foreground color options are made
available, overriding the Style
property.

Background UseBackgroundFromHost A list box containing two options:

• UseBackgroundFromHost (the
host screen text color is used as
the background color)

• CustomColors

Available only if
OverrideStyleSettings is checked.

Foreground UseForegroundFromHost A list box containing two options:

• UseForegroundFromHost (the
host screen text color is used s
the foreground color)

• CustomColors

Available only if
OverrideStyleSettings is checked.

BackgroundColor Black A color palette for choosing the
background color. Only available if
Background is set to
CustomColors.

ForegroundColor White A color palette for choosing the text
color. Only available if Foreground is
set to CustomColors.

IsPassword Unchecked When checked, an asterisk (*) is used
to masked the typed characters.

Label
The Label control is a single line control which is used to place any static text at a specified location on a
screen.

Properties:

Name Default value Description

HostText Checked When checked, the host text located
at (StartRow,StartColumn) is used
as the label text. When unchecked,
LabelText is made available.

LabelText Label If HostText is unchecked, this
specifies the custom text to be
displayed on the label.

TextLocation InPlace The (row,column) where the label text
on the screen should be taken.
InPlace means the label text should
be taken from the location of the
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Name Default value Description

control as specified on the Screen
Design page, or from the location of
the logical marker defined by the
SearchFor condition.

The screen location can also be
defined by using the Select Screen
Location window, opened by clicking
the accelerator button next to the
TextLocation field.

TextLength 0 Specifies the number of characters in
the label text.

Alignment Left Specifies the alignment of the label
text:

Left
Center
Right

OverrideColorsSettings Unchecked When checked, the background and
foreground color options are made
available, overriding the Style
property.

Background UseBackgroundFromHost A list box containing two options:

• UseBackgroundFromHost (the
host screen text color is used as
the background color)

• CustomColors

Available only if
OverrideStyleSettings is checked.

Foreground UseForegroundFromHost A list box containing two options:

• UseForegroundFromHost (the
host screen text color is used s
the foreground color)

• CustomColors

Available only if
OverrideStyleSettings is checked.

RadioButton
The RadioButton control is used to add text at a specified screen location.

Properties:

Name Default value Description

Caption RadioButton The text to be displayed on the
control.

Tooltip Empty string The tool tip text that appears when
the mouse hovers over the control.

GroupName Empty string The radio button group this radio
button belongs to.
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Name Default value Description

SelectedState Empty string The text to be used at the specified
screen location and any specified
actions to be performed if the check
box is checked.

UnselectedState Empty string The text to be used at the specified
screen location and any specified
actions to be performed if the check
box is not checked.

OverrideStyleSettings Unchecked The text to be used at the specified
screen location and any specified
actions to be performed if the check
box is checked.

Background UseBackgroundFromHost A list box containing two options:

• UseBackgroundFromHost (the
host screen background color is
used as the background color)

• CustomColors

Available only if
OverrideStyleSettings is checked.

Foreground UseForegroundFromHost A list box containing two options:

• UseForegroundFromHost (the
host screen text color is used as
the foreground color)

• CustomColors

Available only if
OverrideStyleSettings is checked.

BackgroundColor Black A color palette for choosing the
background color. Only available if
Background is set to
CustomColors.

ForegroundColor White A color palette for choosing the text
color. Only available if Foreground is
set to CustomColors.

Tab
Tab provides an area of the screen to which you can assign other controls. You can have multiple Tab
controls on a screen, with multiple tab items within a Tab control.

To assign a control to a tab item, drag the control on to the appropriate tab item.

When you select another tab item, that tab item is shown, together with its controls.

Notes:

• Deleting a tab item deletes all its assigned controls.
• Deleting a Tab control deletes all its tab items and their assigned controls.

Properties:
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Name Default value Description

TabItems Empty collection Lists all tab items and their controls.
Each tab item has a caption.

HostBackground Unchecked When checked, the Tab control uses
the background color of the host
screen. When unchecked, the control
uses the color defined by the Color
property.

Color White Smoke Specifies the background color of the
Tab control.

HeaderWidth Static Specifies the width of the tab item
headers. Static sets a fixed width
specified by HeaderSize. Dynamic
sets a variable width according to the
length of the header text.

HeaderSize 8 Specifies the fixed width of the tab
item headers.

Table
The Table control formats data from multiple screens as a scrollable table with filtering and sorting
capabilities.

The Table control uses a pre-defined GridCollector control as its data source. If there is already one, single
GridCollector on the screen, the Table control links to it automatically. If there is no GridCollector on the
screen, you must link to a GridCollector manually using the LinkedGridCollectorName property.

Properties:

Name Default value Description

LinkedGridCollectorName Name of the GridCollector control to
which the Table control is linked.

Columns Collection of columns.

Title Name of the linked
GridCollector column.

The visible column title.

IsVisible Checked When checked, the control is visible
on a Plus screen.

ColumnAliasInGridCollector Name of the GridCollector column
from where the data will be taken.

ColumnType String Can be one of:

String
Number
Date

ColumnDateFormat Format of dates in the selected
column.

ColumnAlignment Left Aligns the cell text. Can be one of:

Left
Center
Right
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Name Default value Description

IsHeaderVisible Unchecked When checked, the table shows the
column headers.

IsAutoNavigateOnLoad Checked When checked, the Table control
triggers the GridCollector to fetch the
next pages automatically when the
Table control is activated.

IsFilterable Checked When checked, adds a Filter field to
the table. The typed value filters out
all rows except those with strings or a
string prefix that match filter text in a
column.

IsMoreButtonVisible Checked When checked, adds a More button is
enabled to the table title bar. More
pages down the screen until there is
no more table data.

IsExportButtonVisible Unchecked When checked, adds an Export
button to the table title bar. This
allows the user to export the table
contents to a comma-delimited .csv
file for use in Microsoft Excel.

DefaultRowCommand Actions performed when the user
double-clicks a row. When creating
actions, the following syntax can be
used to take the text from any table
cell in a row that is double-clicked:

##ColumnAliasInGridCollec
tor##

The following syntax can also be used
to take text from any Collector control:

%% GlobalVariableName%%

Tooltip
The Tooltip control is activated when the mouse pointer hovers over the screen area that Tooltip occupies.

There are two modes for Tooltip:

Static mode Where the content of Tooltip is a free string. The string can include global parameters
set by Collectors.

Advanced mode Where Tooltip can read text from screen location and use it as the displayed text.

Properties:

Name Default value Description

Caption Empty string Specifies the text displayed by Tooltip.
Data stored by Collector controls can
be used.

Advanced Unchecked When checked, activates advanced
mode.

KeyTextLocation InPlace The (row,column) where the text
should be taken from the screen.
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Name Default value Description

InPlace means the location of the
control as specified in the Screen
Design view, or the location of the
logical marker defined by the
SearchFor condition.

The screen location can also be
defined by using the Select Screen
Location window, opened by clicking
the accelerator button next to the
KeyTextLocation field.

TooltipItems Advanced mode only.

Importing items from a .csv file

To use this feature successfully, the contents of the .csv file must be in the following format:

<KEY><DEL><TIP>

where:

This ... Denotes this ...

<KEY> Key representing on-screen emulation text.

<DEL> Delimiter (;). This is the only supported delimiter.

<TIP> Tooltip text.

For example:

#Tool Tip values

TSO;TSO log on

Password;Enter your password

Application required;Enter your CICS application name

Userid;Enter your user ID

To import a .csv file:

1. Click the accelerator button next to TooltipItems in the property grid.
2. In the TooltipItems dialog box, click the Import icon.
3. Select the .csv file.
4. Click OK.

WebFrame
WebFrame is a control, which can be displayed either as an icon or as an embedded window on the
screen. An icon looking like a small globe can be set to open a map based on the postal address displayed
in the host screen field. An embedded window displays content at a specified Web address when the
screen arrives.

Properties:

Name Default value Description

Mode Pop-up Specifies whether WebFrame is
displayed as an icon (Pop-up) or as
an embedded window (Embedded).
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Name Default value Description

URLSource Empty string Any valid Web address. The data
stored by Collector controls can be
used to specify the target.

ImagePath Empty string Click the accelerator button to open
the project image pool folder where
you can select an image file with a
format of JPG, GIF, or PNG. To
select a different image, click Add to
pool and browse to the image you
want to use. The image file is then
copied to the image pool and saved
with the project.

Alternatively, you can type the
location of an image in the form of its
full path or full Web address in the
ImagePath field.

Width 500 Window width in pixels.

Height 500 Window height in pixels.

Tooltip If empty, no tool tip is displayed.
Otherwise, specifies the text that
Tooltip displays when the mouse
hovers over the WebFrame icon.

Shared properties
Each of the following properties may be used by more than one type of control:

Name Default value Description

Name Specifies a custom name for one or
more controls.

Note: If a rule creates more
than one control of the same
type on the same screen, the
following naming convention is
used:

<name>,
<name>_1, ...
<name>_<name>

TextInsertionLocation InPlace The (row,column) where the text is
inserted on the screen.

• InPlace means the location of the
control as specified in the Screen
Design view, or the location of the
logical marker defined by the
SearchFor condition.

• None means that the control has
no specified location on the green
screen and that its function is
independent of the green screen.

The screen location can also be
defined by using the Select Screen
Location window, opened by clicking
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the accelerator button next to the
TextInsertionLocation field.

BoundVariable A data source that controls can use to
read from or to write to so that they
can interact with each other.

ControlTarget MainArea The control target is the region
specified in the currently selected
theme, where the control is placed.
MainArea is the region occupied by
the green screen.

Style Empty string Style defines the look of a control. Its
possible values are displayed in the
list of items taken from the currently
selected theme. If not specified, the
default style is used.

UseBackgroundFromHost Unchecked When checked, a control acquires its
background color coming from host.
When unchecked, the background
color defined by the control’s style is
used.

UseForegroundFromHost Unchecked When checked, a control acquires its
foreground color coming from host.
When unchecked, the foreground
color defined by the control’s style is
used.

RowOffset 0 Vertical offset relative to the row
where the logical marker is located.
Logical markers are defined by the
SearchFor condition. A positive or
negative value defines the screen
location as the number of rows down
or up the logical marker.

A wrong offset value can adversely
displace the control.

ColumnOffset 0 Horizontal offset relative to the
column where the logical marker is
located. Logical markers are defined
by the SearchFor condition. A positive
or negative value defines the screen
location as the number of columns
from the right or left of the logical
marker.

A wrong offset value can adversely
displace the control.

RowSpan 0 If not zero, overrides the height of a
logical marker defined by the
SearchFor condition.

ColumnSpan 0 If not zero, overrides the width of a
logical marker defined by the
SearchFor condition.

ZOrder The highest ZOrder value of all
controls on the current screen on the

Specifies the stacking order of a two
or more controls. Controls with higher
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Name Default value Description

Screen Design page except Topmost
+ 1

ZOrder values appear further up the
stack or closer to the foreground.

Actions
Action Description Values

SetText Inserts text into the
specified screen location of
an unprotected field.

If the specified location is
not in any unprotected field,
no action is performed.

TextInsertionLocation The (row,column) where the
control is inserted on the
screen. InPlace means the
location of the control as
specified in the Screen
Design view, or the location
of the logical marker defined
by the SearchFor condition.

The screen location can also
be defined by using the
Select Screen Location
window, opened by clicking
the accelerator button next to
the TextInsertionLocation
field.

ActionTarget The text to be inserted.

EmulationCommand Runs a specified emulation
command.

EmulationCommand Possible values are shown in a
list.

ClearField Clears the contents of a
specified field at s specified
screen location.

FieldLocation The (row,column) where the field is
located on the screen. InPlace means
the location of the control as specified
on the Screen Design page, or the
location of the logical marker defined
by the SearchFor condition.

The screen location can also be
defined by using the Select Screen
Location window, opened by clicking
the accelerator button next to the
FieldLocation field.

WebSite Runs the user’s default
browser to navigate to a
specified Web site.

ActionTarget Web site address. Data stored by
Collector controls can be used to
specify arguments.

RunApplication Run a specified application
on the user's machine.

ActionTarget

Command line to run. For example:

C:\Program Files (x86)\Skype\Phone
\Skype.exe

AdditionalArguments

Application arguments. For example:
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Action Description Values

/callto:+555555

Data stored by Collector controls can be used to specify
parameters for ActionTarget and AdditionalArguments.

RunMacro Runs a specified macro. ActionTarget Full path to the macro file to run, or the
path relative to the macros folder. Data
stored by Collector controls can be
used to specify arguments.

RunScript Runs a specified script. ActionTarget Full path to the script file to run, or the
path relative to the scripts folder. Data
stored by Collector controls can be
used to specify arguments.

SetCursor Places the cursor at the
specified screen location.

CursorLocation The (row,column) where the cursor
should be placed on the screen.
InPlace means the location of the
control as specified in the Screen
Design view, or the location of the
logical marker defined by the
SearchFor condition.

The screen location can also be
defined by using the Select Screen
Location window, opened by
clicking the accelerator button next
to the CursorLocation field.

SetValueToAVariable Creates a global variable
and sets its value. If the
global variable already
exists, its value is reset.

GlobalVariableName The name of the global variable.

Content The value of the global variable.

Expressions containing values of
other already existing global
variables may be used in the
form %
%<other_variable_name>
%%.

Email Sends an email to a
specified address.

ActionTarget The recipient’s email address.

The control context menu
When you right-click a control, a context menu appears with the following menu options:

Option Description

Convert to Rule Converts a static control in the Screen Design view to a
dynamic control managed by the Rule Manager.

Cut Cuts a control to the Screen Designer clipboard.

Copy Copies a control to the Screen Designer clipboard.
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Option Description

Paste Pastes a control from the Screen Designer clipboard to
the screen that is currently displayed in the working area
of the Screen Design view.

Delete Deletes a control.

Disable / Enable Disables a control so that it remains in your project, but is
not used in the customized screen. An exclamation mark
appears at the top right of the control to show that it is
disabled. To enable a control, right-click the control and
select Enable from the pop-up menu.

You can still edit disabled controls but they will not be
used on a customized screen until you enable them.

If you copy a disabled control or convert it to a rule, the
control remains disabled.

Send to Back If two or more controls appear over each other, this option
sends the selected control to the back of the stack of
controls.

Bring to Front If two or more controls appear over each other, this option
brings the selected control to the top of the stack of
controls.
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How To
This section contains additional information about the Screen Designer, controls, and rules.

Use themes
A theme defines the layout of the screen and the look of each control across all screens in a customization
project.

The screen layout is defined as having a rectangular main area in the center, which can be surrounded by
rectangular areas (margins). Margins are defined by the theme you use.

The main area of a screen can contain any type of control. However, margins can contain only buttons or
images.

Note: To add buttons to the margins of a theme, drag the control icon from the property grid in the
Screen Design view. To add images to the margins of a theme, use the Theme Editor.

In the example below, two images have been added to the project theme using the Theme Editor. The two
buttons in the left margin have been added from the property grid in the Screen Design view:

Important: If you change a theme, the margins of the previous theme disappear, together with their
contents. It is therefore best to choose a theme early in the customization project.

Three themes are included with the Screen Designer. Additionally, you can use the Theme Editor to design
your own theme.

Selecting a theme
1. Select Tools > Project Settings 

The Project Settings dialog box appears.

2. Click Themes in the left pane.
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3. Click Change in the right pane. The Choose Theme dialog box appears.

4. Select the thumbnail of the theme you want to use from the left pane.

5. Click OK.

6. Click OK in the Project Settings dialog box. 

The theme is applied to all the screens in your project.

Creating a Windows theme
1. Select Tools > Theme Editor. 

The Theme Editor window appears.

2. Select File > New. 

The Create Theme dialog box appears.

3. Type an appropriate name for the theme in the Theme Name field.

4. Click OK. 

The Theme Editor design screen appears.

5. Select a design from the Layouts pane. 

The layout appears in the center pane.

6. In the Skins pane, select BaseWindowsSkin from the drop-down list. 

Note: If you select a Windows theme, you cannot edit the skin of a control.

7. In the center pane, select a color from the Theme Preview Background list to display a background
color for the theme. 

Note: This only displays a preview of the color. To use a specific color, you must change the
background color in your emulator display.

8. To add a background or image to a pane of the theme, select the pane, then select the color or image
from the Background or Image list, as appropriate`.

9. When you have finished, select File > Close. 

The design screen closes.

10.In the Theme Editor window, select File > Exit.

Creating a green screen theme
1. Select Tools > Theme Editor. 

The Theme Editor window appears.

2. Select File > New. 

The Create Theme dialog box appears.

3. Type an appropriate name for the them in the Theme Name field.

4. Click OK. 

The Theme Editor design screen appears.

5. Select a design from the Layouts pane. 

The layout appears in the center pane.

6. In the Skins pane, select BaseGreenScreenSkin from the drop-down list.

7. Optional: Select a color from the Base color drop-down list. 

This determines the base foreground color used in the theme.
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8. In the center pane, select a color from the Theme Preview Background list to display a background
color for the theme. 

Note: This only displays a preview of the color. To use a specific color, you must change the
background color in your emulator display.

9. To add a background or image to a pane of the theme, select the pane, then select the color or image
from the Background or Image list, as appropriate`.

10.When you have finished, select File > Close. 

The design screen closes.

11.In the Theme Editor window, select File > Exit.

Search history screens
You can search the thumbnail screens in the history pane for text strings that appear either on a screen or
as part of a screen ID.

At the bottom of the history pane, type a search string in the search field. The thumbnails are filtered,
leaving only those screens that contain the search string.

Create modern screens with a screen canvas
Modern screens often require more space than the fixed green screen layout. You can free yourself from
the fixed screen defined by the terminal. To do this, you define settings for a screen canvas, then add
controls in the same way you would on a green screen.

As well as customized screen sizes, the screen canvas feature supports the following screen types:

• Model 2 (24x80)
• Model 3 (32x80)
• Model 5 (27x132)

Another advantage of using a screen canvas is being able to place a larger canvas over a smaller green
screen to maximize the space on the screen.

Defining default canvas settings
To define default settings for screen canvas, use the Project Settings dialog.

Note: You can specify different settings for selected screen by selecting Tools > Screen Canvas.

1. Select Tools > Project Settings. 

The Project Settings dialog box appears.

2. Click Screen Canvas in the left pane. 

The screen canvas settings appear in the right pane.

3. Specify the settings you want: 

Setting Description

Canvas Size Note: The canvas size cannot be smaller than the size of the selected
green screen.

Number of Rows Specifies the number of rows for the new screen. Default is the number of
rows on the green screen.
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Setting Description

Number of Columns Specifies the number of columns for the new screen. Default is the number of
columns on the green screen.

Canvas Font Size Defines the font size. Default is 26 pt.

Fixed Font Size When checked, the font size does not change if the window is resized.

Canvas Background

Color Defines the background color. Default is white. Can be used with Image.

Image Click the accelerator button to open the Choose Image dialog box to select
an image for the background. Can be used with Color.

Image Layout Select one of:

Stretch
Fill
Fit
Tile
Center

Apply settings automatically to
each new history screen

When checked, a screen canvas with the defined default settings is applied
automatically to each newly-imported history screen.

Note: This setting hides all green screen fields. We therefore
recommend using Auto-Generate Controls when you use this
setting.

Defining settings for a selected screen
1. Select a screen from the history pane.
2. Select Tools > Screen Canvas. 

The Screen Canvas dialog box appears.

Note: You can also right-click the screen in the work area and select Screen Canvas > Settings
from the pop-up menu.

3. Specify the settings you want: 

Setting Description

Canvas Size Note: The canvas size cannot be smaller than the size of the selected
green screen.

Number of Rows Specifies the number of rows for the new screen. Default is the number of
rows on the green screen.

Number of Columns Specifies the number of columns for the new screen. Default is the number of
columns on the green screen.

Canvas Font Size Defines the font size. Default is 26 pt.

Fixed Font Size When checked, the font size does not change if the window is resized.

Canvas Background

Color Defines the background color. Default is white. Can be used with Image.

Image Click the accelerator button to open the Choose Image dialog box to select
an image for the background. Can be used with Color.

Image Layout Select one of:

Stretch
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Setting Description

Fill
Fit
Tile
Center

4. Click OK.

Note: To override the default screen canvas settings with the settings you have just defined, click Set
As Default.

Copying and pasting a screen canvas
If a screen already has a screen canvas applied to it, you can copy the canvas and its settings, then apply
it to another screen. To do this:

1. Select a screen from the history pane.

2. Right-click the screen in the work area and select Copy Canvas from the pop-up menu.

3. Select another screen from the history pane.

4. Right-click the screen in the work area and select Paste Canvas from the pop-up menu. 

The copied screen canvas and its settings are applied to the screen.

Removing a screen canvas
To remove a screen canvas from a green screen, right-click the screen in the work area, then select
Remove Canvas from the pop-up menu. Any controls that you added to your customization project are not
affected.

Example
In the Adding controls section, we added controls to screens from the Demo Host to provide a modern look
and feel. This example shows you can modernize screens even more.

Using a screen canvas, we can give the welcome screen a clean, crisp modern look:
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Note the use of the Theme Editor to add a top banner and logo.

Selecting the host system takes you to the same screen as before, but with a fresher look:

Clicking Order Entry takes you to the SALES ORDER ENTRY - CUSTOMER screen:
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Note the use of auto-generated controls to completely replace the original green screen.

Identify screens

About screen identification
The Screen Designer supports the following ways of identifying screens:

Default An identification that is calculated from a screen's field data. Used by default.

To customize screens, a screen ID must be assigned to each screen. Unfortunately, this
default screen ID might not be sufficient. This occurs when several screens, which have to
be distinguished, get the same screen ID. It can also occur when several screens, which
have to be addressed as the same, get different screen IDs.

Selection
based

An identification based on the contents of one or more screen selections. When the default
screen ID is not sufficient, you can select the contents of a screen location to act as the
screen ID. If you make more than one selection, the contents of each selection are joined
together to form the screen ID. Each selection is limited to the height of one row on the
screen.

Note: Before you start to customize the screens in your project, you must choose either the default
screen ID type or a selection based screen ID type. You cannot change the screen ID type once you
have started to customize a screen.

Custom screen
identification

For each screen recorded during your session you can define a custom identification
algorithm. For custom screen identification, you define a set of selected areas on a
screen and specify a name for them. This defines screen data to distinguish a
particular screen from other screens in your project. The custom identification name is
assigned as a screen ID to each screen of your project that has exactly the same data
in exactly the same selected areas as your custom identification.
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You can choose either selection based selection screen identification, custom screen identification, or a
combination of both. In this way, you can either distinguish between screens which otherwise would have
had the same ID, or identify similar screens which otherwise would have had different IDs.

Specifying selection based screen identification
1. Select Tools > Project Settings. 

The Project Settings window appears.

2. On the Screen ID page, click Select next to Selection Based. 

The Selection window appears.

3. Select a screen thumbnail in the left pane.

4. In the work area, select a portion of text on the screen by drawing a rectangular border within a single
screen row with the mouse. 

The selected text is added as an ID to any screen in your project that has the same text in the same
location.

5. Optional: You can also add other screen selections to form the screen ID. The text in each selected
screen location is joined together to form the screen ID.

6. Click OK.

7. Click OK in the Project Settings window.

Removing a selection:

To remove a selection, right-click the selection and select Remove This Selection from the pop-up menu.

Specifying custom screen identification
1. Select Tools > Project Settings. 

The Project Settings window appears.

2. On the Screen ID page, click Manage Screen Identification. 

The Manage Screen Identification window appears.

3. Select a thumbnail from the left pane.

4. Click Add Custom Identification in the right pane.

5. Select text areas on the screen by drawing rectangular borders within single screen rows with the
mouse. 

The history pane on the left is filtered to show only those screens that have the same text areas at the
same locations that you selected.

6. Type a name in the Name field.

7. Optional: Check Use With Base ID. The base ID results from the screen ID type you chose before you
started customizing screens. When this option is checked, the base ID is used as an additional form of
screen identification. 

The name you specified is used as a custom screen ID of any screen in your project that:

• Has the same text areas at the same locations that you selected.
• Has the same base ID (if Use With Base ID is checked).

Note: The base ID is displayed on the top of each thumbnail in the left pane, while the screen ID is
displayed on the bottom of each thumbnail.

8. Click OK. 
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Note: Make only one custom identification a the screen before you click OK.

9. Click OK in the Project Settings window.

Removing custom screen identification:

To remove a selection, right-click the selection and select Remove This Selection from the pop-up menu.

Notes:

• You cannot define the same custom screen ID for two different screens if either one or both of
them are customized.

• A screen cannot have more than one custom screen ID. You cannot specify a custom screen ID if
the screen already has one.

• A screen ID ambiguity will be caused if you try to import an additional project where at least one
screen fits a custom ID of the base project but that screen already has a custom screen ID. The
affected screen will be marked as having a screen ID ambiguity in the Screen Designer view.

• You cannot import an additional project that has a screen with screen ID ambiguity. The project
must be reviewed first to fix the problem.

Manage controls

Auto-generating controls
In some cases, you might want to recreate the full screen. You can do this by generating Label and
InputField controls automatically for all protected and unprotected fields on a green screen. To do this:

1. Select Tools > Project Settings. 

The Project Settings dialog box appears.
2. Click Auto-Generate Controls in the left pane.
3. Specify the settings you want: 

Check this ... To do this ...

Exclude Labels created from empty fields When checked, filters out Label controls that are
created from protected fields that contain no text.
Checked by default.

Auto-generate controls on all new history screens When checked, auto-generates Label and InputField
controls on all newly-imported history screens.
Unchecked by default.

4. Click OK.
5. To auto-generate the controls on the current screen, select Tools > Auto-Generate Controls.

Changing the opacity level
You can use the slider on the toolbar to change the opacity of all controls on a screen from full opacity to
20% opacity.

Clicking the Opacity level icon displays the opacity slider and toggles the set opacity on and off.

Selecting multiple controls
You can select more than one control at any time so you can perform the same action once on the selected
controls, instead of once for each control.

You can select controls in one of the following ways:
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• Use your mouse to draw an area of the screen containing the controls you want to select.
• Press Ctrl+A to select all controls on the screen.
• Right-click the screen background and select Select All.
• Use Ctrl+Click to toggle whether a screen is selected.

You can perform the following actions on the selected controls:

• Move (using the mouse or arrow keys)
• Delete
• Cut
• Copy
• Paste
• Duplicate

Note: You cannot select Rule Manager controls as part of a multiple selection.

Working with rule controls
Rule controls are controls created using the Rule Manager.

About rule controls
When you create rule controls, they also appear in the Screen Design view. By default, this feature is
turned on. You can toggle between showing and hiding rule controls by selecting View > Rule Controls.

Rule controls are designed to be used on multiple screens. They are therefore shown in the Screen
Design view in a different style to single-screen controls so you can easily differentiate between them.

You can edit rule controls in the Screen Design view in the same way as in the Rule Manager. However,
you cannot resize, move, delete, copy, or duplicate these controls, as shown by a small padlock in the top
right corner of the control.

Editing rule controls
In the same way as a single-screen control, you can edit the control's properties using the property grid.

1. To edit a rule control in the Screen Design view, right-click the control and select Edit Rule from the
pop-up menu. 

The rule opens in the Rule Wizard.

Note: When you edit one rule control, it affects all the controls created by the source rule.

2. To view a rule control, right-click the control and select Show Rule from the pop-up menu. 

The rule opens in the Rule Manager window.

Using controls to set a variable
You can use the contents of an input control, such as an InputField control, to set a variable which can be
used, at any time and in any place, by the action of another control. To do this, you use the BoundVariable
action of the input control.

The following input controls use bound variables:

• Calendar
• CheckBox
• Chooser
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• InputField
• RadioButton

Use Web components in Plus
Plus can call both applications and Web components using one or more of the following controls:

Button A labeled UI control. It can call an application, script, URL, or Web page.

WebFrame Creates an icon using an image. You can set the size of the frame. Only valid for Web
browser URLs. No address bar is displayed.

Passing parameters to an application or Web page
You pass parameters to an application or Web page using the Collector control. Place a Collector control
over the data fields that Plus uses to capture data. When the application runs, there is nothing to show on
the screen that indicates this is a data collection field.

You add Collector controls in the Screen Design view:

Note: Collector controls should cover the entire data field to accommodate long strings.

When you configure a Collector control, you give it a name in the property grid. This name must be unique
in the customization file. You can refer to the data stored in the database as %%Name%%. In the figure
above, the Name of the first collector is MapCity and its global variable name is %%MapCity%%.

The TrimSpaces property resizes the length of the data string by removing trailing spaces. In most
applications, this option should be 1.

Creating Web objects and URLs
The first thing to do is to create a working URL using a known set of parameters for a known address. For
example, this Google Maps parameter is for an Office Park in Maryland:

http://maps.google.com/maps?q=700 King Farm,Rockville,MD
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Copy the working URL to an editor such as Notepad so you can edit it for use in the Screen Designer. For
example, the following string re-creates the address string:

%%MapAddr%%,%%MapCity%%,%%MapState%%

Note that the commas (,) used as delimiters in the Google command, are still in place in the Plus string.

Add a WebFrame control to receive the data from the Collector control:

The command to copy and paste into the WebFrame URLSource field is:

http://maps.google.com/maps?q=%%MapAddr%%,%%MapCity%%,%%MapState%%

In Plus mode, the Collector control captures the information you type. When clicked, the WebFrame control
takes that data and shows the location of the address on a map in a remote window.

As the character strings get more complex, testing becomes more important. For example, the following
string calls a Google charting facility for a pie chart. Notice that the original URL contains a section that
deals with both chart labels (AREA-A, etc) and chart data (T=:100,300,200,50). Other editable data
includes colors, format, and sizing:

http://chart.googleapis.com/chart?chs=300x150&cht=p3&chco=0000FF|00FF00|
FF0000|FFFF00&chds=0,1000&chd=t:100,300,200,50&chdl=AREA-A|AREA-B|AREA-C|AREA-
D&chtt=TOYS

As in the Google Maps example, we need to replace the data portion of this URL with variables collected
from the Plus screen. In this case, the data portion (specified by chd), becomes:

chd=t:%%R1Jtoy%%,%%R2Jtoy%%,%%R3Jtoy%%,%%R4Jtoy%%

The new URL to use with the WebFrame control becomes:

http://chart.googleapis.com/chart?chs=300x150&cht=p3&chco=0000FF|00FF00|
FF0000|FFFF00&chds=0,1000&chd=t:%%R1Jtoy%%,%%R2Jtoy%%,%%R3Jtoy%%,%%R4Jtoy%
%&chdl=Region1|Region2|Region3|Region4&chtt=TOYS

In a real application, you might also want to modify the label data dynamically as well. A label section might
therefore look like this:

chdl=%%Label1%%|%%Label2%%|%%Label3%%|%%Label4%%

You can experiment with the Google pie chart URL using the TOYS screen on the Demo Host.
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Generate output files for Rumba+ Web and Rumba+
Mobile

The Rumba+ Server Build Tool allows you to build Rumba+ Web and Rumba+ Mobile application
deployment packages.

The tool uses the customization file created by the Screen Designer to create a Web Application aRchive
(.war) file. The .war file contains a rules file and other resources, such as images, macros, and scripts.

The file is then deployed to an application server for implementation.

Note: The Rumba+ Server Build Tool is supplied with Micro Focus Rumba+ Web and Micro Focus
Rumba+ Mobile.

You can also generate customization files using the Screen Designer command line. See Use the Screen
Designer command line.

Exporting a customization file
For information about exporting a customization file, refer to the Rumba+ Server Build Tool 1.3: Help.

Deploying a .war file
For information about deploying a .war file to an application server, refer to the Rumba+ Server 1.3:
Administrator Guide.

Import additional projects
You can import additional customization projects to merge with a project that is currently open in the
Screen Designer.

To do this, select File > Import Project.

Notes:

• You cannot import a project if the base project is not open.
• The project name and theme will be the same as the currently open project.

The table below provides information about some circumstances where not all data might be included in an
import.

If this happens ... Then this happens ...

The screen ID configuration of the other project is
different from the one defined in the base project.

Following the import attempt, the operation halts with an
error message.

You import a project in which custom screen IDs are
defined.

If all the custom screen IDs are valid, they are added to
the custom screen IDs list of the base project.

You import a project in which custom screen IDs are
defined. However, one of the custom screen ID names
already exists in the base project, although the custom
screen IDs are not identical.

The custom screen ID is added to the project with a new
name: Origcustom screen ID - Copy,
Origcustom screen ID - Copy (2). Any
references to the renamed custom screen ID are
changed accordingly.

You import a project with a rule which is identical to one
of the rules in the base project.

Duplicated rules appear only once.
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If this happens ... Then this happens ...

You import a project in which custom screen IDs are
defined. One of the custom screen IDs is not valid
because it is assigned to a screen that has another
custom screen ID.

Not all of the new custom screen ID’s related rules are
merged into the project. Information is shown in the
results dialog box.

You import a project that includes a local resource. If the name of the resource already exists, you can select
one of:

• Copy and Replace

• Don’t Copy

• Copy, but keep both files

You can also import additional customization projects using the Screen Designer command line. See Use
the Screen Designer command line.

Use the Screen Designer command line
You can use the Screen Designer command line to:

• Generate one or more customization files from Screen Designer project files.
• Import multiple projects to a current Screen Designer project.

Syntax

<Install_Dir>\Plus\ScreenDesigner\RumbaScreenDesignerCLI.exe [/P
<project_file_path> | /L <project_file_list_path>] [/O <output_dir>][/S] | /I
<config_file> | /?

where:

<Install_Dir> is the folder where the Screen Designer is installed.

/P <project_file_path> is the fully qualified path to a single project file.

/L <project_file_list_path> is the fully qualified path to a file that contains a list of project files.

Each path and file name must be on a separate line. You can use
the pound sign (#) to comment out a line.

/O <output_dir> is the fully qualified path of where to export the customization files.
Optional. If not specified, the <Install_Dir>\Plus
\ScreenDesigner folder is used.

/S saves the project after the customization file is generated.

/I <config_file> is the fully qualified path of the configured list of projects to import.

/? shows this information on the screen.

Generating customization files

Syntax

<Install_Dir>\Plus\ScreenDesigner\RumbaScreenDesignerCLI.exe [/P
<project_file_path> | /L <project_file_list_path>] [/O <output_dir>][/S]
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Example: Generating a single customization file

RumbaScreenDesignerCLI.exe /P C:\Users\<user_name>\My Documents\Micro Focus
\Reflection\Plus\Projects\TableTest\TableTest.rsdp /O C:\Users\<user_name>\My
Documents\Micro Focus\Reflection\Plus\Rules /S

Example: Generating multiple customization files

RumbaScreenDesignerCLI.exe /L C:\Screen Designer\Projects\ProjectList.txt /O
C:\Users\<user_name>\My Documents\Micro Focus\Reflection\Plus\Rules /S

Example project file list contents:

C:\Users\<user_name>\My Documents\Micro Focus\Reflection\Plus\Projects
\u1\u1.rsdp
#C:\Users\<user_name>\My Documents\Micro Focus\Reflection\Plus\Projects\unique
\unique.rsdp
C:\Users\<user_name>\My Documents\Micro Focus\Reflection\Plus\Projects
\TableTest\TableTest.rsdp
C:\Users\<user_name>\My Documents\Micro Focus\Reflection\Plus\Projects
\longtable3\longtable3.rsdp
C:\work\mobile\TestApplications\TestPlanAppCSIMVS\TestAppCSIMVS
\TestAppCSIMVS.rsdp

Note: You can use the pound sign (#) to comment out a line.

Importing project files

Syntax

<Install_Dir>\Plus\ScreenDesigner\RumbaScreenDesignerCLI.exe /I <config_file>

Example

<Install_Dir>\Plus\ScreenDesigner\RumbaScreenDesignerCLI.exe /I C:\Screen
Designer\Projects\ImportFileList.txt

Example project file list contents:

duplicateresource=ckb
baseproject=C:\Users\<user_name>\My Documents\Micro Focus\Reflection\Plus
\Projects\MergeProjects1\MergeProjects1.rsdp
project=C:\Users\<user_name>\My Documents\Micro Focus\Reflection\Plus\Projects
\MergeProjects2\MergeProjects2.rsdp
project=C:\Users\<user_name>\My Documents\Micro Focus\Reflection\Plus\Projects
\MergeProjects3.rsdp
project=C:\Users\<user_name>\My Documents\Micro Focus\Reflection\Plus\Projects
\MergeProjects2\MergeProjects2.rsdp
project=C:\Users\<user_name>\My Documents\Micro Focus\Reflection\Plus\Projects
\a1\a1.rsdp
project=C:\Users\<user_name>\My Documents\Micro Focus\Reflection\Plus\Projects
\WYSIWYG\WYSIWYG\WYSIWYG.rsdp
saveto=C:\Users\<user_name>\My Documents\Micro Focus\Reflection\Plus\Projects
\MergeProjects20

where:

duplicateresource specifies copy options for duplicate resources:

cr Copy and replace.

dc Do not copy.
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ckb Copy, but keep both files.

baseproject is the base project that the projects will be imported to.

project is the absolute or relative path to the project file.

saveto is the path of the resulting merged project. If not specified, the base project is used.
If the project does not exist, a new project is created at that location with a name
matching the folder name. For example, if the path is:

C:\Users\<user_name>\My Documents\Micro Focus\Reflection\Plus
\Projects\MergeProjects20

the created project is called MergeProjects20.
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Contacting Micro Focus
Micro Focus is committed to providing world-class technical support and consulting services. Micro Focus
provides worldwide support, delivering timely, reliable service to ensure every customer's business
success.

All customers who are under a maintenance and support contract, as well as prospective customers who
are evaluating products are eligible for customer support. Our highly trained staff respond to your requests
as quickly and professionally as possible.

Visit http://supportline.microfocus.com/assistedservices.asp to communicate directly with Micro Focus
SupportLine to resolve your issues or e-mail supportline@microfocus.com.

Visit Micro Focus SupportLine at http://supportline.microfocus.com for up-to-date support news and access
to other support information. First time users may be required to register.

Information needed by Micro Focus SupportLine
When contacting Micro Focus SupportLine, please include the following information, if possible. The more
information you can give, the better Micro Focus SupportLine can help you.

• The name and version number of all products that you think might be causing an issue.
• Your computer make and model.
• System information such as operating system name and version, processors, and memory details.
• Any detailed description of the issue, including steps to reproduce the issue.
• Exact wording of any error messages involved.
• Your serial number. To find this number, look in the subject line and body of your Electronic Product

Delivery Notice e-mail that you received from Micro Focus.

Additional information needed by Micro Focus
SupportLine

If reporting a protection violation, you might be asked to provide a dump (.dmp) file. To produce a dump
file, use the Unexpected Error dialog box that is displayed when a protection violation occurs.

Unless requested by Micro Focus SupportLine, leave the dump setting as Normal (recommended), click
Dump, then specify a location and name for the dump file. Once the dump file has been written, you can e-
mail it to Micro Focus SupportLine.

You may also be asked to provide a log file created by the Consolidated Tracing Facility (CTF) - a tracing
infrastructure that enables you to quickly and easily produce diagnostic information detailing the operation
of a number of Micro Focus software components.
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Tell Us What You Think
We welcome your feedback regarding Micro Focus documentation.

Send feedback about this Help documentation.

Click the above link to email your comments to Micro Focus.
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