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This guide provides a quick overview of features in 
Reflection X.  

This evaluation guide includes:

• Getting Connected

– Establishing and saving your first connection in 
an X client file

– Starting an XDMCP Broadcast using a factory 
client template file

– Displaying and managing two or more X server 
instances

• Features to Evaluate

– Working with multiple X screen support

– Authenticating with the Secure Shell key agent

– Launching an executable resident on your local 
machine

– Resolving IP addresses assigned by a VPN 
using IPID

– Using the “RunRX” command line startup 
feature

• Troubleshooting Tools

• Secure Connections: Overview

• Reflection Administrator’s Toolkit

– Getting started with the toolkit

Each section points to a general procedure so that 
you can try the feature for yourself, and includes 
specific exercises that build on one another as you 
proceed with your evaluation.
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To launch Reflection X:

• On the Windows Start menu, point to Programs > 
Attachmate Reflection > Reflection X.

The first time you launch Reflection X you’ll see a 
dialog box with options to help you get started. By 
default this dialog box is configured to run the 
Reflection X Performance Tuner, which will optimize 
the X client drawing speed on your machine. This 
process is recommended and takes about two 
minutes. (You can also run the Performance tuner at 
a later time from the Reflection X Manager’s Tools 
menu.)

The startup dialog box also includes a choice of three 
options to help you get connected: XDMCP 
Broadcast, the Client Wizard,  or launching the 
Reflection X Manager. For this walkthrough, select 
the last item:

Go directly to the Reflection X Manager to start 
local or remote clients.

You will learn how to use  XDMCP Broadcast and the 
Client Wizard directly from the Reflection X 
Manager.
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The procedures in this document illustrate ways you 
can use the X Client Wizard, template files, and your 
own saved files to customize connections using the 
X Manager. For complete information, see the 
product Help.
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One way to get connected to your host is to use the 
Reflection X Client Wizard.

Try it now
Follow these steps to use the wizard to create and 
save a client file (.rxc) for a host of your choice:

1. Launch the X Client Wizard using either of the 
following techniques:

- In the Reflection X Manager, point to Tools > 
Client Wizard.

- On the Windows Start menu, point to 
Programs > Attachmate Reflection > 
Wizards > X Client Wizard.

2. Click Next and type the required values in Host 
and Type. Click Next.

3. Set Method to TELNET. 

4. Enter your user name and password as needed. 
Accept the default value for Command prompt 
and click Next.

Note: If you clear the Verify host clients check 
box, you will not have to confirm your connection 
information during this session.

5. Select a client from the list of X client 
applications, for example Clock or X Terminal. 
Click Next.

6. Note the descriptive name and file name given for 
this connection. You may also create a shortcut if 
you wish, and specify the location for the shortcut 
on your computer. Click Next.

7. Click Start Client. Doing this automatically starts 
the Reflection X Manager if it is not already 
running

8. Enter your password if you’re prompted to do so, 
and click OK. The client appears on your desktop. 

9. Return to the X Client Wizard and click Finish. 
Then, close the client to continue with your 
evaluation.

To see your new client file, open the Reflection X 
Manager and expand Client Files > Client Startup in 
the left pane of the application. If you accepted the 
default file name, you’ll see a file named “rxw0000.” 
Each new file increments by one (so, rxw0001, 
rxw0002, etc.). View the descriptive text you typed by 
hovering the cursor over the file to display the tooltip. 
If you want to give the client file a more descriptive 
name, right click the file in the Client Startup list 
and select Rename.

You can use any of the following techniques to make a 
connection using this client file:

• Double-click the client file icon.

• Right-click the client file icon and select 
Connect X Client.

• Select the client file icon, and, on the menu 
bar, click Action > Connect X Client.

pí~êíáåÖ=~å=uaj`m=_êç~ÇÅ~ëí=ìëáåÖ=~=Ñ~Åíçêó=
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The X Display Manager Control Protocol (XDMCP) 
is used to communicate with an X display manager 
(XDM) running on a particular host machine. This 
means that the host controls how the X environment 
is configured and which clients are run: if the host to 
which you connect supports XDMCP, this is the 
simplest type of connection to make. XDMCP is only 
available if you are using TCP/IP as a transport. 

Try it now
Use these steps to broadcast a request for available 
hosts using the Reflection X Manager’s XDMCP 
factory template client file. This template, and other 
templates provided by Reflection X, is located under 
Client Templates. Note that by right-clicking Client 
Templates you can access information about how to 
download additional client (and server) templates 
from the web.

bs^ir^qfkd=obcib`qflk=u
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To begin, start the Reflection X Manager if it is not 
already running and follow this procedure:

1. In the upper left pane, expand Client Templates > 
XDMCP and click xdmcpbrd. When you do this, 
connection information appears under XDMCP 
connection settings for configuration purposes.

2. Right-click the xdmcpbrd file and, in the context 
menu that appears, click Connect X Client. 

If you are not already running an X client, the 
Select XDMCP Host dialog box appears with a list 
of available hosts. If you are already running an X 
client, the Start XDM Session dialog box appears. 
Select the third radio button to start a new XDM 
session on a new X server instance.

3. Use the Select XDMCP Host dialog box to select a 
host, then click OK.

4. Enter your user name and password as requested 
by the host.

If you wish, use the Settings menu to customize X 
Manager settings such as fonts or display. To save this 
file, click File > Save As to open the Save As dialog 
box. Type a name for the file and click OK. To see 
your new client file, expand Client Files > XDMCP. 

aáëéä~óáåÖ=~åÇ=ã~å~ÖáåÖ=íïç=çê=ãçêÉ=u=ëÉêîÉê=
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In the steps below you will start two X server 
instances (displays), in addition to the default 
instance (“config”). You will first open a secure 
connection across Secure Shell using the supplied 
factory template that permits only this connection 
method. The second X server instance you run you 
will create yourself using a base set of settings from 
the default config server instance. 

Try it now
Before you begin, close any clients that are running 
and use View > X Server Management to be sure the 
server management panes appear at the bottom of 
the X Manager. Then, follow these steps:

1. Expand X Server Templates in the lower left 
pane. Select SECURESHELL_Only and right-
click the file name to display the context menu. 

2. Click Start. This X server instance appears in the 
right lower pane, under X server management 
and the name of the connection appears in the X 
Manager’s title bar along with a display number of 
“1”. 

Try this now: This server instance forces the user 
to log in with credentials before an SSH 
connection can be negotiated. To illustrate how 
this works, expand Client Templates > Client 
Startup, choose a client, and then choose the 
REXEC Method under Client connection 
settings. Now click Connect and note that an 
error message appears. The connection cannot be 
successfully completed because SECURE SHELL 
is not the selected Method. 

3. Under X server management, click config. Doing 
this makes this X server instance the currently 
managed server instance and thus the server 
instance that will provide the base settings for the 
server instance you will create next.

Note: The “config” server instance represents the 
base set of settings for an X server instance and 
cannot be deleted. It is provided for use as the 
basis for one or more X server instances you 
create from it, inheriting its settings and 
attributes (except for the Window mode setting).

4. Right-click X Server Instances and click New. 
Type a name for your new X server instance, then 
press Enter.

5. Right-click the new instance and, on the context 
menu that appears, click Start. Now, this server 
instance appears under X server management 
and the name of the instance is displayed in the 
title bar along with the display number (in this 
case “2”). 

You are now running three X server instances, 
including the config server instance, and can initiate 
as many more as you require. 

Each server instance can be configured by first 
switching to it. To do this, select the instance under X 
server management or, on the menu bar, click 
Action > Select/Start X Instances and select the 
instance you wish to manage.
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Try it now
Reflection's Multiple X Screen feature is a powerful 
tool for organizing your client applications as you 
work with them.  With it, you can assign up to nine 
screens to a single server instance. You can customize 
the size of each screen, direct them to the same 
monitor, or direct them to separate monitors. 

To explore this feature, start the X Manager and 
follow the steps below:

1. Click Settings > Window Manager. Under 
Window mode, select X terminal desktop and 
click OK. The Reflection X Root Window appears. 

2. In the X Manager, click Settings > X Screen. 
Under Number of X screens, enter the number 3 
(you can enter any number between 1 and 9). Click 
OK. 

3. For the change to take effect, the X server must be 
reset. Click OK in the dialog boxes that follow. 
Note that under X server management, Number 
of X Screens is now 3. 

4. Re-open the X Screen Settings panel by clicking 
the Settings button. 

5. Configure the size of each screen by selecting it 
from the Configure X Screen box and changing 
its Virtual size. For example, set X screen 0 to 
200 x 200 pixels, X screen 1 to 400 x 400 pixels, 
and X screen 2 to 700 x 300 pixels. 

If you have more than one monitor, use the Place 
it on monitor(s) list box to direct a screen to a 
different monitor. Click OK to apply your changes 
and exit the X Screen Settings panel.

6. Now, start a client application by expanding Client 
Templates > Client Startup and select a client 
template file (for example, unix). 

7. Under Client connection settings on the right, 
enter the  enter the host name and your user 
name.

8. In the Command text box, add the number 0 to 
the display parameter in the command string so 
that it reads as follows:

-display %IP#0% 

Click Connect.

9. In the next dialog box, enter your password and 
click OK. The client application window appears.

10. Repeat steps 6 through 9 for two more client 
applications on the same or different hosts,  
entering the numbers 1 and 2 to the display 
parameters. 

You should now have a single server instance 
running three different client applications. Each 
client application should appear on a different 
screen, and each screen should have a different 
size. Some screens may even appear on a different 
monitor (depending on your system 
configuration). 
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Try it now
The Reflection Key Agent allows you to quickly log in 
to Secure Shell servers using locally-stored private 
keys that authenticate your connection. The agent 
streamlines the user key management process and 
supports agent forwarding to additional Secure Shell 
servers.

To explore this feature, you will complete three main 
steps: 

• Creating a Key Pair

• Uploading the Public Key to the Server

• Authenticating using the Key Agent

Creating a Key Pair

One user authentication method supported by Secure 
Shell is based on a public key and a private key, also 
called a key pair. While the procedure below generates 
both keys, you won’t upload the public key to the host 
until the following procedure. 

1. Start the Key Agent from the Start menu by 
clicking Programs > Attachmate Reflection > 
Utilities > Key Agent.

2. When you use the Key Agent for the first time, 
you are prompted to initialize it with a passphrase. 
Enter a passphrase and click OK. 

If your Key Agent has already been initialized, 
click the Unlock button and enter the passphrase.

3. In the Key Agent dialog box, click the Generate 
Key button.

4. In the User Key Generation dialog box, specify a 
key name, type, and length, and click OK. 

Uploading the Public Key to the Server

In the following procedure, you will upload the public 
key to the host. This will allow you to securely 
authenticate to that host.

1. In the Reflection Key Agent, select the key you 
just created and click Upload.

2. In the Upload to Host dialog box, enter the name 
of the host to which you are uploading the key (a 
Secure Shell server must be running on the host). 
Leave SSH config scheme blank and click OK. 

3. Enter a valid user name for the host in the Secure 
Shell dialog box. Click OK.

4. If this is the first time you are establishing a 
connection to this host, you’ll see the Host Key 
Authenticity dialog box.  You can confirm the 
validity of the host key by contacting the system 
administrator for that host. Click Always to add 
the host key to your list of known hosts. 

5. Enter the password for this user and click OK.

6. After the secure connection to the host has been 
established, you will see a dialog box showing 
information about where on the host Reflection 
will upload this key. In most cases you do not need 
to change these settings. 

7. The Upload Public Key dialog box displays 
information about the transfer. Click OK to close 
this dialog box.

8. Close the Reflection Key Agent dialog box. 

^ìíÜÉåíáÅ~íáåÖ=ìëáåÖ=íÜÉ=hÉó=^ÖÉåí

In the following procedure you will log into the host 
and your authentication (password) will be handled 
for you by the Key Agent:

1. Open the X Manager by clicking its icon in the 
taskbar. 

2. Select a host type from the Client Startup list on 
the left.

2. Under the Client connection settings on the 
right, set Method to SECURE SHELL.

3. Enter the Host name. and User name. Leave SSH 
config scheme blank.

4. Click Advanced. 

5. In the Reflection Secure Shell Settings dialog box, 
confirm that on the General tab, Public Key is 
selected under User Authentication.

6. Click the User Keys tab and select the key you 
created by selecting its box in the Use column. 

3. Click OK to close the Secure Shell Settings dialog 
box.

4. In the X Manager, click Connect. 

A secure shell connection is established with the host. 
Note that you did not have to supply a password. The 
Secure Shell key agent handled that for you. 
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Try it now
The following steps show you how to use the Local 
Connection feature to start a Windows executable file 
(*.exe). Running a local executable file from 
Reflection X is a quick way to initiate sessions from a 
single application.

Use these steps to start the X Registry Utility from 
Reflection X:

1. Click X Manager on the task bar (or use the Start 
menu to launch Reflection X if it is not already 
running).

2. Expand Client Files and click Local Connection. 
Note that the connection information appears 
under Local client connection settings. 

3. Click Browse and find the file Regconv.exe using 
the Browse Local Connection Executable dialog 
box (this file is located in your Reflection program 
folder). Click Open.

4. Click Connect to start the Reflection X Registry 
Utility.

The Reflection X Registry Utility provides a filtered 
look into Windows registry, refining the keys to show 
only those applicable to Reflection X. For more 
information about this utility, see the product Help.

oÉëçäîáåÖ=fm=~ÇÇêÉëëÉë=~ëëáÖåÉÇ=Äó=~=smk=ìëáåÖ=
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The following information gives you an overview of 
how you can use Reflection X IPID server utility to 
resolve IP addresses between the host and the X 
Manager when a Virtual Private Network (VPN) is 
used at your site. While the process of setting up the 
IPID source code at the host is involved and thus 
cannot be detailed in this evaluation guide (please see 
the online help), you may find this information very 
useful if you must manually resolve IP addresses 
assigned by a VPN. 

Background: Running an X client across a 
VPN connection
If your site uses Virtual Private Network (VPN) 
client software for host connections you may find 
that you have to manually change the IP address 
using settings in the X Manager in order for an X 
client to “find” and run on your computer. This is 
because, on each VPN connection, the VPN assigns a 
different IP address to your computer which is not 
the same as the IP address Reflection X provides via 
your computer’s TCP/IP settings. You can resolve the 
differing addresses by:

• Clicking Settings > Network and clearing the 
Disable remote TCP/IP connections and 
Autodetect network interface check boxes. Now, 
type the IP address assigned to you by the VPN in 
the IP address box. Determining the IP address 
you have been assigned depends on the VPN 
software. If available, right-click the VPN client 
icon to see this value. For more information, see 
Technical Notes 1580 and 1632 at http://
support.attachmate.com/techdocs/1580.html and 
http://support.attachmate.com/techdocs/1632.html.

• Using the IPID server included in Reflection X to 
do this, explained next.

Discussion: Using IPID server to resolve an IP 
address assigned by a VPN
You will typically see error messages such as “Unable 
to resolve <hostname>” or “Connection time out” 
when your VPN client software is not letting the X 
Manager return the correct IP address to report to 
the X client you want to run. With some initial setup 
at your host, you can implement the IPID server at 
your site to resolve these IDs without manually 
entering IP addresses for every different VPN 
connection you make. This is done for you by the IPID 
server, which consists of a client and daemon. The 
daemon, as source code, is compiled on the UNIX 
host on which it will reside. The resolution of the IP 
address is performed by communications between 
Reflection X and the daemon via UDP datagrams.
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The following overview describes the process of setting 
up the IPID server (see the product Help, searching 
for IPID: about this utility for specific information or 
reference the technical notes listed above):

• First, download the daemon for IPID and compile 
this on the UNIX host. You might include the 
daemon in the startup script so that you do not 
have to run it manually. 

• Next, use the Network Settings panel (Settings > 
Network) to clear both Disable remote TCP/IP 
connections and Autodetect network interface. 
Then, select Use IPID host and enter the IP 
address of the host running the IPID server.

Now, when you connect, the IP address assigned to 
you is automatically resolved between the X Manager 
and the host via Windows registry, where the 
assigned IP address resides.

rëáåÖ=íÜÉ=“oìåouÒ=Åçãã~åÇ=äáåÉ=ëí~êíìé=ÑÉ~íìêÉ

Discussion: Running Reflection X from the command 
line
Reflection X Manager includes a utility called 
“RunRX” that enables you to start the X Manager 
from a command line. Typically this is done in order 
to pass host, password, method type, and scripts to 
the application for customized startup.

Here is an example of command line syntax being 
used to start the X Manager:

RUNRX  -m TELNET -h SYSTEM -u USER -p PASS -c  
/etc/bin/MONITOR -nm

This syntax will cause the X Manager to launch the 
client “monitor” from the host “system” via a Telnet 
connection without a splash screen (-nm). The user 
will be logged in as “user” and the password as “pass.” 

If you wish, a client (*.rxc) file can be referenced so 
that the host, method, user name, and password are 
included in the file rather than exposed directly on 
the command line. The syntax for this connection 
would look similar to this:

RUNRX default1.rxc -c /etc/bin/MONITOR -nm

For additional information about which parameters 
are supported by the RunRX command line utility, 
see the product Help. You can also reference a 
Technical Note on the subject at the following URL:

http://support.attachmate.com/techdocs/1530.html
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Reflection X Manager provides several tools that let  
you troubleshoot problems with the application. 

The View Settings command (Settings > View 
Settings) opens a dialog box that displays the current 
status of  X Manager settings, enabling the user to 
view all settings or filter the settings to show only 
those not currently set to the factory default state. 

Font use and substitutions can be recorded using the 
Log font activity check box (Settings > Fonts > 
Options group box). Use the information this option 
writes to the X Manager’s log file (“Logfile.txt”) to 
diagnose font problems in X Manager. This log file 
can also include display problems related to a video 
card’s capabilities or OpenGL compatibility. Click the  
Dump PFDs to logfile button (Settings > Server > 
Extensions > GLX > Advanced > Options) to write 
version, vendor, and renderer information to the file 
for analysis. 

The X Manager’s Trace program (Tools > Client 
Trace) captures X protocol information for diagnosis 
by the end user or WRQ Technical Support. Trace 
information is also useful for training users new to 
the X Manager by replaying the trace on any machine 
on which Reflection X is installed in order to observe 
the actions and results of server and client 
interaction.

You can decide to write the X protocol information to 
the X Manager’s log file in standard ASCII file text 
for review. Or, choose to create a binary file, 
Xscope.trc by default, that can be replayed by any 
Reflection X installation. If desired, you can also 
apply filters to the trace process that refine the 
information read to the file. WRQ Technical Support 
will typically request a trc file type when analyzing 
problems with the product. 

pÉÅìêÉ=`çååÉÅíáçåëW=lîÉêîáÉï

Reflection X Manager supports the following secure 
connection types:

• Secure Shell: You can configure the X Manager to 
use Secure Shell when you need secure, encrypted 
communications between a trusted host and your 
machine over an insecure network. When you 
configure Reflection to use Secure Shell, all 
connections between your machine and the remote 
host(s) are encrypted, protecting the data sent 
between these machines. Passwords are never sent 
over the network in a clear text format. 

• Kerberos: The Reflection Kerberos Manager is an 
optional utility available with the X Manager that 
you can use to create or modify principal profiles, 
add or modify realms, set ticket options, import 
and export Kerberos settings, or perform other 
Kerberos management tasks.

• XDM Authorization-1: Use this option to 
improve the security of connections made with the 
X Manager using XDMCP. By configuring XDM 
Authorization support, you can make XDMCP 
connections using XDM-AUTHORIZATION-1. 
This method is similar to MIT-MAGIC-COOKIE-
1, but provides added security by encrypting the 
authorization code using DES (Data Encryption 
Standard) encryption.

• Group Policies: The Reflection Administrator’s 
Toolkit (described on the next page) includes a 
policy that will not permit a user to connect over 
an unencrypted connection. This policy, Allow 
Unencrypted Connections, can be disabled to 
prevent unencrypted connections from a Windows 
2000 or Windows XP machine incorporating the 
Group Policy Editor.
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This guide walks you quickly through key Reflection® 
features. It covers:

• Getting Connected

• Customizing Your Terminal Session

– Working with toolbars

– Customizing your keyboard

– Customizing menus and commands

– Saving your customizations

– Viewing your customizations in HTML format

• Transferring Files and Data

• Automating Tasks

– Using macros

– Scheduling events

• Programming with VBA

• Administrative Tools: Reflection Administrator’s 
Toolkit

– Getting started with the toolkit

• Finding More Information About Deploying 
Reflection Products

• Conclusion

Each section covers a general procedure, so that you 
can try the feature for yourself, and includes hands-
on exercises that build on one another as you proceed 
with your evaluation. 

You can evaluate Reflection using a demonstration 
host (included) or your own host system. The 
procedures in this guide are geared toward using the 
demonstration host, which means you do not need 
network access to your host system to complete the 
procedures. You can, of course, repeat the steps on 
your own host system; notes are included throughout 
to get you headed in the right direction.

For information about new features in this release, 
launch Reflection and look up New features in the 
Reflection Help index.

dÉííáåÖ=`çååÉÅíÉÇ

Connecting to a host may be as simple as entering the 
name of the host, or it may involve changing other 
settings as well. Reflection includes a Connection 
Wizard that can walk you through the steps of 
connecting to your host system. Or, you may prefer to 
make a connection using the Connection Setup 
command on the Connection menu.

Try it now
The following steps show you how to make a 
connection to the Reflection demonstration host using 
the Connection menu. If you prefer, you can use these 
steps to connect to your own host system instead:

1. On the Connection menu, click Connection Setup. 

2. In the Connection Setup dialog box, click 
Network. In the text box that appears, scroll down 
and select DEMONSTRATION. Select a host 
type, and then click Connect. (To connect to an 
actual host, select Telnet or the appropriate 
protocol for your environment, and enter the host 
name or IP address.)

3. Log in to the demonstration host using any user 
name and password.

4. On the File menu, click Save to create a new 
settings file with your connection settings. You’ll 
use this settings file as you proceed with your 
Reflection evaluation.

`ìëíçãáòáåÖ=vçìê=qÉêãáå~ä=pÉëëáçå

Reflection provides powerful customization features 
that can make using your host application faster and 
easier. These include customizable menus, toolbars, 
and hotspots, the ability to assign keystrokes or 
mouse actions to terminal keys or functions, and the 
ability to change the color and appearance of your 
host application in Reflection. The following sections 
introduce you to just some of these features.
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Reflection supplies four predefined toolbars for quick 
access to frequently-used commands. You can display 
any or all of these toolbars, modify them, or create 
your own custom toolbars. To access this feature, 
click Toolbar on the Setup menu.

Try it now 
The following steps show you how to create a custom 
toolbar with a button for changing the host functions 
associated with specific keys on your PC keyboard:

1. On the Setup menu, click Toolbar.

2. On the Toolbars tab, click New. Specify a name 
for the toolbar, such as “Keyboard.” 

3. On the Settings tab, select an option for Location. 
As you change the Location setting, the position of 
the toolbar changes on your screen.

4. On the Predefined Buttons tab, select Setup under 
Categories, and then drag the Keyboard Map 
Setup icon to your new toolbar.  

5. Click Close to return to the terminal screen.

`ìëíçãáòáåÖ=óçìê=âÉóÄç~êÇ=

Reflection allows you to associate keystrokes with 
actions, a process known as keyboard mapping. You 
can customize your keyboard to match a familiar 
product, to improve interactions with your host 
application, or to speed up your work. To access this 
feature, click Keyboard Map on the Setup menu.

Try it now 
In this procedure, you’ll map a PC key to a terminal 
key. 

1. On the toolbar you created in the previous 
exercises, click the Keyboard Map Setup button. 
(You can also click Keyboard Map on the Setup 
menu.) 

2. The Keyboard Map Setup dialog box opens. Keys 
that are already mapped to host keys or functions 
appear green, while unmapped keys are gray. 

3. On the representation of the PC keyboard, click an 
unmapped (gray) key.

4. On the representation of the terminal keyboard, 
click any key. 

5. Click Map to map these keys together. 

6. To return to the terminal screen without saving 
your key mapping, click Cancel. Or, if you made a 
change you’d like to keep, click OK.
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You can customize the menus of Reflection by 
removing individual menu items, hiding the menu bar, 
adding menu items that perform standard Reflection 
tasks, or by creating menu items to run your own 
custom macros. To access this feature, click Menu on 
the Setup menu.

Try it now
In the following steps, we’ll remove the Keyboard 
Map command from the Setup menu. (You can still 
access the Keyboard Map Setup dialog box using the 
toolbar button you created in an earlier exercise.)

1. On the Setup menu, click Menu.

2. Click the plus sign (+) next to the “Setup” menu 
icon to expand the list of Setup menu commands. 

3. Select the “Keyboard Map” command, and then 
click Remove.

4. Click OK to return to the terminal screen. Click 
the Setup menu to verify that Keyboard Map no 
longer appears.

p~îáåÖ=óçìê=Åìëíçãáò~íáçåë

Customizations are saved with your current terminal 
session when you use the Save command on the File 
menu; however, you can also save a subset of 
customizations in a separate file for use with other 
terminal sessions. For example, you may want to save 
menu changes to a separate menu file for use with 
specific terminal sessions.

Try it now

In the following procedure, you’ll save menu changes 
to a separate menu settings file. 

1. On the File menu, click Save As. 

2. Set Save as type to Menus (*.rmu). 

3. Specify a name for your menu settings file.

4. Click Save. The custom menus are now saved in a 
menu settings file. 

Tip: To make your custom menus apply to a new 
terminal session, start a new session (click New 
Session on the File menu), and then open the menu 
settings file. (Click Open on the File menu, change 
Files of type to Menus in the Open dialog box, and 
then select your menu settings file.)

sáÉïáåÖ=óçìê=Åìëíçãáò~íáçåë=áå=eqji=Ñçêã~í

Customizations you have saved in a settings file can 
be viewed in a formatted, easy-to-navigate HTML 
page that Reflection generates when you use the 
Export and Transform XML feature. This feature lets 
you direct Reflection to make internal information, 
such as registry settings, mappings, display memory, 
terminal screen, and both saved and changed settings 
available in text, HTML, or Reflection for the Web 
report format. The output you decide to view is based 
on the XSL transform file you specify for the 
exported data you will have transformed. To start, try 
exporting all settings you have changed using this 
guide into an HTML page that will appear in your 
browser.

Try it now
In this procedure, you’ll create an HTML page that 
shows your changed settings. (If you have not changed 
any settings, you can simply view the current settings.)

1. On the File menu, go to  Import and Export > 
Export and Transform XML. 

2. Select the Changed settings option under Source 
XML.

3. Under Transform, click Browse to open the 
Select Transform dialog box. 

4. Select the Transform settings to HTML.xsl file.

5. Under Results file, type “Settings.htm” and ensure 
the Open results file check box is selected.

6. Click Transform. Reflection exports and 
transforms the changed settings into HTML 
format in your browser.
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You can use Reflection to transfer files and data to 
and from a host computer. Because Reflection 
automatically selects a file transfer configuration, you 
may find that you are ready to transfer files as soon 
as you make a host connection. 

Try it now

This procedure walks you through the process of 
transferring a file to or from the Reflection 
demonstration host. 

1. Make sure you are connected to the demonstration 
host. To quickly connect, open the settings file you 
created earlier, using the Open command on the 
File menu, and log in using any name and password. 

2. On the File menu, click Transfer. The File 
Transfer dialog box opens.

3. Click Show Host Files to view sample files on the 
demonstration host. (These files do not really exist.)

4. For If file exists, select Rename.

5. Select a file to transfer and click the appropriate 
Transfer icon in the Transfer dialog box. A 
progress indicator appears as Reflection simulates 
a file transfer. (No file is actually transferred 
when you use the demonstration host.) 

Tip: You can also transfer files by dragging and 
dropping them between panes in the Transfer 
dialog box.

6. Click Close to return to the terminal screen.

qê~åëÑÉêêáåÖ=ÑáäÉë=áå=óçìê=çïå=ÉåîáêçåãÉåí

You can follow the steps above to display and transfer 
files to and from your own host system, provided that 
file transfer is configured on your host. 

Reflection defaults to the WRQ/Reflecction 
proprietary protocol, which offers a more powerful 
range of file transfer options but needs to be 
configured on your host. To select a public protocol, 
such as FTP, click the Setup button in the File 
Transfer dialog box. If you aren’t sure which protocol 
to use, check with your host system administrator. 

For further information, search for Transferring files 
in the Reflection online help. 

^ìíçã~íáåÖ=q~ëâë=

Reflection provides you with powerful tools for 
automating your sessions. Tools like the event 
scheduler and the macro recorder require no 
programming knowledge. In addition to these tools, 
Microsoft Visual Basic® for Applications (VBA), 
which is included with Reflection, provides access to 
an industry-standard scripting language and a full-
featured development environment.
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Reflection includes fully integrated Visual Basic for 
Applications (VBA) for automating tasks and PC-to-
host interactions. VBA is used in many desktop 
applications, including Microsoft Office products. 

You can use VBA macros to increase your productivity 
and the usability of your host applications. For example, 
you may want to record a script that logs in to your 
host computer and navigates automatically to a 
particular screen in your host application. Or, you may 
want to automate a file transfer and schedule it to run 
during off-peak hours.

Macros you create in Reflection can be associated 
with a menu item, toolbar button, event, or keystroke. 
You can also customize VBA macros by editing them 
with the Microsoft Visual Basic Editor.

Try it now
In this procedure, you’ll record a file transfer to 
Reflection’s demonstration host.

1. Make sure you are connected to the demonstration 
host. (To quickly connect, open the settings file you 
created earlier, using the Open command on the 
File menu. You can log in to the demonstration 
host using any name and password.) 

2. On the Macro menu, click Start Recording. 

3. Repeat the steps for transferring a file in the 
“Transferring files and data” section above.

4. On the Macro menu, click Stop Recording. In the 
Stop Recording dialog box:

• Specify a macro name in the box. (Macro 
names cannot include spaces and must begin 
with a letter.)

• Select the Create a button check box, and click 
OK. A new toolbar button appears, labeled with 
the name of your macro. At this point, you can 
run and test your macro, but it has not yet been 
saved. 

5. On the File menu, click Save to save your macro. 
Your macro will be saved with the current settings 
file. 

6. To run your macro, click your macro’s toolbar 
button. The file transfer progress indicator 
appears, indicating that a file is being transferred. 
(You can also run a macro using the Macros 
command on the Macro menu.)

bs^ir^qfkd=obcib`qflk=clo=rkfu=^ka=lmbksjp=elpqp
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Today there are more than three million VB 
programmers. If you are familiar with Visual Basic 
for Applications, you can edit a recorded macro or 
create a new one using the Visual Basic Editor. To 
view this tool, click Visual Basic Editor on the 
Reflection Macro menu. Or, to edit the macro you 
just created, click Macros on the Macro menu, select 
your macro, and then click Edit to launch the Visual 
Basic Editor. The Reflection API is extensively 
documented in the online programming help. To 
view this help file, point to Advanced Topics on the 
Help menu, and then click Programming.
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Reflection’s Events feature enables you to associate 
events, such as “At a specific time of day,” with 
actions, such as transferring large amounts of data. 
The event is the trigger; the action is how Reflection 
responds. To access this feature, click Events on the 
Setup menu.

Try it now
In this procedure, we’ll associate the VBA macro 
created above with a specific time to illustrate how 
you could use this feature in your own environment to 
schedule events during off-peak hours.

1. On the Setup menu, click Events.

2. Click New. 

3. For Event type, select At a specific time of day. 

4. For Action, click Macro. Click Browse to select 
your macro.  

5. Select the file transfer macro you just recorded, 
and then click OK to return to the New Event 
Properties dialog box.

6. Set Time to a value one minute from now. Click OK.

7. Click OK to return to the terminal screen. 

8. Wait for the macro to run. The file transfer progress 
indicator appears while the macro is running.

This concludes the first part of the Reflection 
evaluation guide. We hope you have enjoyed using 
Reflection’s connection, file transfer, customization, 
and automation features. If you are evaluating 
Reflection for use at a large company, you may wish 
to read the next section to see how Reflection 
simplifies large-scale deployment and management 
tasks.
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This guide introduces you quickly to key features in  
Reflection for IBM. It covers:

• Getting Connected

• Customizing Your Session

– Working with toolbars

– Customizing your keyboard

– Customizing menus and commands

– Saving your customizations

• Transferring Files and Data

• Automating Tasks

– Using macros

– Scheduling events

• Programming with VBA

• Administrative Tools: Reflection Administrator’s 
Toolkit

– Getting started with the toolkit

• Finding More Information on Deploying 
Reflection Products

• Conclusion

Each section points you to a general command, so 
that you can try the feature for yourself, and includes 
hands-on exercises that build on one another as you 
proceed with your evaluation. 

You can evaluate Reflection using a demonstration 
host (included) or your own host system. The 
procedures in this guide are geared towards using the 
demonstration host, which means you do not have to 
have network access to your host system to complete 
the procedures. You can, of course, repeat the steps 
on your own host system; notes are included 
throughout to get you headed in the right direction.

For information about new features in this release, 
launch Reflection and look up New features in the 
Reflection Help index.

dÉííáåÖ=`çååÉÅíÉÇ

Connecting to a host may be as simple as entering the 
name of your host when you first launch Reflection, 
or you may need to configure your connection 
settings. To configure connection settings, cancel the 
initial host name prompt and use the Session Setup 
command on the Connection menu.

Try it now
The following steps show you how to make a 
connection to the demonstration host using the 
Connection menu. If you prefer, you can use these 
steps to connect to your own host system instead:

1. On the Connection menu, click Session Setup. 
The Session Setup dialog box opens.

2. Select a session type. Under Transport, set Type 
to Demonstration. For Simulation filename, 
select one of the listed simulation files. Click 
Connect. (To connect to an actual host, select 
Telnet or the appropriate protocol for your 
environment, and enter the host name or IP 
address.) 

3. Log in to the host. For demonstration hosts you can 
use any name or password.

4. On the File menu, click Save to create a new 
settings file with your connection settings. 

You’ll use this settings file as you proceed with your 
Reflection evaluation.

`ìëíçãáòáåÖ=vçìê=pÉëëáçå

Reflection provides powerful customization features 
that can make using your host application faster and 
easier. They include: customizable menus and 
toolbars, hotspots, the ability to assign keystrokes or 
mouse actions to terminal keys or functions, and the 
ability to change the color and appearance of your 
host application in Reflection. The following sections 
introduce you to just some of these features.
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Reflection supplies four predefined toolbars for quick 
access to frequently used commands. You can display 
any or all of these toolbars, modify them, or create 
your own custom toolbars. To access this feature, 
click Toolbar on the Setup menu.

Try it now 
The following steps show you how to create a custom 
toolbar with a button for changing the host functions 
associated with specific keys on your PC keyboard:

1. On the Setup menu, click Toolbar.

2. On the Toolbars tab, click New. Specify a toolbar 
name, such as Keyboard. 

3. On the Settings tab, select an option for Location. 
As you change the Location setting, the position 
of the toolbar changes on your screen.

4. Click the Predefined Buttons tab, and, under 
Categories, click Setup, and then drag the 
Keyboard Setup icon to your new toolbar. 

5. Click Close to return to the terminal screen.

6. On the File menu, click Save to save your changes.

`ìëíçãáòáåÖ=óçìê=âÉóÄç~êÇ

Reflection allows you to associate keystrokes with 
actions, a process known as keyboard mapping. You 
can customize your keyboard to match a familiar 
product, to improve interactions with your host 
application, or to speed up your work. To access this 
feature, click Keyboard on the Setup menu.

Try it now 
In this procedure, you’ll map a PC key to a terminal 
key. For example, you might want to map one of the 
Enter keys on the PC keyboard to the Return 
function on the host. This is useful in IBM 
environments where Return and Enter behave 
differently in the host application. 

1. On the Keyboard toolbar you created in the 
previous exercise, click the Keyboard Setup 
button you just created, or go to Setup > 
Keyboard. 

2. The Keyboard Setup dialog box opens. Keys that 
are already mapped to host keys or functions 
appear green, while unmapped keys are gray. 

3. On the representation of the PC keyboard, click 
a key.

4. On the representation of the terminal keyboard, 
click the host key you want to map to the PC key 
you just selected.

5. Click Map to map these keys together. 

6. To return to the terminal screen without saving 
your key mapping, click Cancel. (Or, if you made a 
change you’d like to keep, click OK.)

Tip: You can use the Reflection Terminal keyboard to 
see how your keys are currently mapped. On the 
Window menu, click Terminal Keyboard. Move the 
mouse pointer over any of the host keys to see how 
this key is mapped to your PC keyboard.

bs^ir^qfkd=obcib`qflk=clo=f_j=elpqp
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You can customize the Reflection menus—remove 
individual menu items, hide the menu bar, add menu 
items that perform standard Reflection tasks, or 
create menu items to run your own custom macros. 
To access this feature, click Menu on the Setup menu.

Try it now
In the following steps, we’ll remove the Keyboard 
command on the Setup menu. (You can still access 
the Keyboard Setup dialog box using the toolbar 
button you created in an earlier exercise.)

1. On the Setup menu, click Menu.

2. Click the plus sign (+) next to the Setup menu 
icon to expand the list of Setup menu commands. 

3. Select the Keyboard command, and then click 
Remove.

4. Click OK to return to the terminal screen. Click 
the Setup menu to verify that Keyboard no longer 
appears. (This change affects the current session 
only. New Reflection sessions will continue to use 
the default menus.)

p~îáåÖ=óçìê=Åìëíçãáò~íáçåë

Customizations are saved with your current terminal 
session when you use the Save command on the File 
menu; however, you can also save a subset of 
customizations in a separate file for use with other 
terminal sessions. You may want to save menu 
changes to a separate menu file, for example, for use 
with other terminal sessions.

Try it now
In this procedure, you’ll save menu changes to a 
separate menu settings file. 

1. On the File menu, Click Save As. 

2. Set Save as type to Menus (*.mnu).

3. Specify a name for your menu settings file.

4. Click Save. The custom menus are now saved in a 
menu settings file. 

Tip: To import your custom menus to a new terminal 
session, start a new session. (On the File menu, click 
New Session, and select the session type you want. 
You can enter the name of a host or cancel the 
opening dialog box.) To open the menu settings file go 
to File > Open, change Files of Type to Menus, and 
then select your menu settings file.) 

qê~åëÑÉêêáåÖ=cáäÉë=~åÇ=a~í~

You can use Reflection to transfer files and data to 
and from a host computer. Because Reflection 
automatically selects a file transfer configuration, you 
may find that you are ready to transfer files as soon 
as you make a host connection. 

Try it now
This procedure walks you through the process of 
transferring a file to or from the Reflection 
demonstration host.

1. Connect to the demonstration host. (To quickly 
connect, open the settings file you created earlier, 
using the Open command on the File menu, and log 
in using any name and password.)

2. On the File menu, click Transfer. The Transfer 
dialog box opens.

3. Click Show Host Files to view sample files on the 
demonstration host. (These files do not really 
exist.)

4. Select a file to transfer and click the appropriate 
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Transfer icon at the top of the Transfer dialog 
box. A progress indicator appears as Reflection 
simulates a file transfer. (No file is actually 
transferred when you use the demonstration 
host.)

Tip: You can also transfer files by dragging and 
dropping them between panes in the Transfer 
dialog box.

qê~åëÑÉêêáåÖ=ÑáäÉë=áå=óçìê=çïå=ÉåîáêçåãÉåí

You can follow the steps above to display and transfer 
files to and from your own host system. To change the 
Transport and/or protocol Reflection uses, Click 
Setup in the File Transfer dialog box, or open the 
Setup menu and click File Transfer. Reflection 
supports Mainframe (IND$FILE and APVUFILE), 
AS/400 (LIPI and EHNTFW), and FTP transfers. 
Use the Help button on each tab to learn more about 
configuring file transfer. 

Tip: If you frequently repeat the same file transfer, 
you can use the Save button in the Transfer dialog 
box to save your file transfer information. Or, use the 
Batch tab if you want to include more than one 
transfer operation in a saved batch. If you are 
transferring data from an AS/400, Reflection 
provides an interface to help simplify the creation of 
complex queries. Open the Transfer dialog box (On 
the File menu, click Transfer), click Setup, then 
click the SQL tab. 

^ìíçã~íáåÖ=q~ëâë=

Reflection provides you with powerful tools for 
automating your sessions. Tools like the event 
scheduler and the macro recorder require no 
programming knowledge. In addition to these tools, 
Microsoft Visual Basic® for Applications (VBA), 
which is shipped with Reflection, provides access to 
an industry-standard scripting language and a full-
featured development environment.

rëáåÖ=ã~Åêçë

Reflection includes fully integrated Visual Basic for 
Applications (VBA) for automating tasks and PC-to-
host interactions. VBA is used in many desktop 
applications, including Microsoft Office products. 

You can use VBA macros to increase your 
productivity and the usability of your host 
applications. For example, you may want to record a 
macro that logs in to your host computer and 
navigates automatically to a particular screen in your 
host application. Or, you may want to automate a file 
transfer and schedule it to run during off-peak hours.

Macros you create in Reflection can be associated 
with a menu item, toolbar button, event, or keystroke. 
You can also customize VBA macros by editing them 
with the Microsoft Visual Basic Editor.
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Today there are more than three million VB 
programmers. If you are familiar with Visual Basic 
for Applications, you can edit a recorded macro or 
create a new one using the Visual Basic Editor. To 
view this tool, click Visual Basic Editor on the 
Reflection Macro menu. Or, to edit the macro you 
just created, click Macros on the Macro menu, select 
your macro, and then click Edit to launch the Visual 
Basic Editor. The Reflection API is extensively 
documented in the application programming help 
file. To view this help, point to Advanced Topics on 
the Help menu, and then click Programming.
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Try it now
In this procedure, you’ll record a file transfer to the 
Reflection demonstration host.

1. Make sure you are connected to the demonstration 
host. (To quickly connect, open the settings file you 
created earlier, using the Open command on the 
File menu. You can log in to the demonstration host 
using any name and password.) 

2. On the Macro menu, click Start Recording. 

3. Repeat the steps for transferring a file in the 
“Transferring files and data” section above.

4. On the Macro menu, click Stop Recording. In the 
Stop Recording dialog box:

• Specify macro name in the box. (Macro names 
cannot include spaces and must begin with a 
letter.)

• Select the Create a button check box, and click 
OK. A new toolbar button appears, labeled with 
the name of your macro. At this point, you can 
run and test your macro, but it has not yet been 
saved. 

5. On the File menu, click Save to save your macro. 
Your macro will be saved with the current settings 
file. 

6. To run your macro, click your macro’s toolbar 
button. The file transfer progress indicator 
appears, indicating that a file is being transferred. 
(You can also run a macro using the Macros 
command on the Macro menu.)

pÅÜÉÇìäáåÖ=ÉîÉåíë

Reflection’s Events feature enables you to associate 
events, such as “At a specific time of day,” with actions, 
such as transferring large amounts of data. The event is 
the trigger; the action is how Reflection responds. To 
access this feature, click Events on the Setup menu.

Try it now
In this procedure, we’ll associate the VBA macro 
created above with a specific time to illustrate how 
you could use this feature in your own environment to 
schedule events during off-peak hours:

1. On the Setup menu, click Events.

2. Click New. 

3. For Event type, select At a specific time of day. 

4. Click Macros. Select the file transfer macro you 
just recorded, and then click OK to return to the 
Event Properties dialog box.

5. Set Time of Day to a value a minute from now. 
(For example, enter 12:05:00 to run the macro at 
five minutes past noon.) Click OK.

6. Click OK to return to the terminal screen. 

7. At the scheduled time, the macro will run and the 
file transfer progress indicator will appear.
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To install the Reflection administrative tools, choose 
“Reflection Administrator’s Toolkit” from the list of 
Reflection products you can install using the 
Reflection installation program. 

Reflection administrative tools include the 
Customization Manager, Group Policy support, and a 
Profiler for each Reflection product you install. These 
tools enable a system administrator to quickly 
customize and deploy Reflection applications. 

Using these tools the system administrator can:

• Perform an administrative installation to a file or 
web server

• Create settings files for users

• Open a Reflection installation and create a 
transform that will contain the customizations

• Select the feature set the user will install (and 
hide features, as needed)

• Add files to the installation or to a separate, 
“companion” database with its own Add/Remove 
programs entry

• Profile a Reflection product, including limiting 
user access to features and commands

• Use the Microsoft Group Policy editor to lock 
down Reflection features for individuals or groups 
of users

• Configure product shortcuts for location, 
parameters, and descriptions, and create a single 
shortcut that installs the customized Reflection 
installation

For a complete overview of Reflection’s 
administrative tools, see the Reflection System 
Administrator Guide, which is available online. See:
http://support.attachmate.com/manuals/
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To begin using the Reflection administrative tools, 
first install the “Reflection Administrator’s Toolkit” 
as you would any Reflection product, making sure to 
install the toolkit to a folder separate from your 
Reflection installation folder. To start the 
Customization Manager or Profiler, click Start, point 
to the folder containing your Reflection installation 
(Attachmate Reflection, by default), then 
Administrative Tools, clicking the tool you want to 
evaluate. 

Tip: To fully evaluate Customization Manager you 
will need an administrative installation of Reflection 
available to you. You can perform an administrative 
installation using options on Customization 
Manager’s Prepare Installation panel. 
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For more information about these tools, open the 
online Help for the product. To view a comprehensive 
overview, with procedures, on preparing and deploying 
Reflection, visit the Deployment Guide at 
http://docs.attachmate.com/reflection/14.1/deploy.pdf.

`çåÅäìëáçå

We hope you have enjoyed evaluating Reflection in 
your own environment. To learn more about 
Reflection products, visit our web site at 
www.attachmate.com.

* The Administrative Toolkit is available only on the Evaluator 
DVD or shipping product. This toolkit is not included in 
evaluation copies of Reflection downloaded from the  
Reflection product web site. Contact us to request a free 
Evaluator DVD.
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