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This guide introduces you quickly to key features in
Reflection for IBM. It covers:
•

Getting Connected

•

Customizing Your Session
– Working with toolbars
– Customizing your keyboard
– Customizing menus and commands
– Saving your customizations

•

Transferring Files and Data

•

Automating Tasks
– Using macros
– Scheduling events

•

Programming with VBA

•

Administrative Tools: Reflection Administrator’s
Toolkit

– Getting started with the toolkit
•

Finding More Information on Deploying
Reflection Products

•

Conclusion

Each section points you to a general command, so
that you can try the feature for yourself, and includes
hands-on exercises that build on one another as you
proceed with your evaluation.
You can evaluate Reflection using a demonstration
host (included) or your own host system. The
procedures in this guide are geared towards using the
demonstration host, which means you do not have to
have network access to your host system to complete
the procedures. You can, of course, repeat the steps
on your own host system; notes are included
throughout to get you headed in the right direction.
For information about new features in this release,
launch Reflection and look up New features in the
Reflection Help index.

dÉííáåÖ=`çååÉÅíÉÇ
Connecting to a host may be as simple as entering the
name of your host when you first launch Reflection,
or you may need to configure your connection
settings. To configure connection settings, cancel the
initial host name prompt and use the Session Setup
command on the Connection menu.

Try it now
The following steps show you how to make a
connection to the demonstration host using the
Connection menu. If you prefer, you can use these
steps to connect to your own host system instead:
1. On the Connection menu, click Session Setup.
The Session Setup dialog box opens.
2. Select a session type. Under Transport, set Type
to Demonstration. For Simulation filename,
select one of the listed simulation files. Click
Connect. (To connect to an actual host, select
Telnet or the appropriate protocol for your
environment, and enter the host name or IP
address.)
3. Log in to the host. For demonstration hosts you can
use any name or password.
4. On the File menu, click Save to create a new
settings file with your connection settings.
You’ll use this settings file as you proceed with your
Reflection evaluation.
`ìëíçãáòáåÖ=vçìê=pÉëëáçå
Reflection provides powerful customization features
that can make using your host application faster and
easier. They include: customizable menus and
toolbars, hotspots, the ability to assign keystrokes or
mouse actions to terminal keys or functions, and the
ability to change the color and appearance of your
host application in Reflection. The following sections
introduce you to just some of these features.

O
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Try it now

Reflection supplies four predefined toolbars for quick
access to frequently used commands. You can display
any or all of these toolbars, modify them, or create
your own custom toolbars. To access this feature,
click Toolbar on the Setup menu.

In this procedure, you’ll map a PC key to a terminal
key. For example, you might want to map one of the
Enter keys on the PC keyboard to the Return
function on the host. This is useful in IBM
environments where Return and Enter behave
differently in the host application.

Try it now
The following steps show you how to create a custom
toolbar with a button for changing the host functions
associated with specific keys on your PC keyboard:
1. On the Setup menu, click Toolbar.
2. On the Toolbars tab, click New. Specify a toolbar
name, such as Keyboard.

1. On the Keyboard toolbar you created in the
previous exercise, click the Keyboard Setup
button you just created, or go to Setup >
Keyboard.
2. The Keyboard Setup dialog box opens. Keys that
are already mapped to host keys or functions
appear green, while unmapped keys are gray.

3. On the Settings tab, select an option for Location.
As you change the Location setting, the position
of the toolbar changes on your screen.
4. Click the Predefined Buttons tab, and, under
Categories, click Setup, and then drag the
Keyboard Setup icon to your new toolbar.
5. Click Close to return to the terminal screen.
6. On the File menu, click Save to save your changes.

3. On the representation of the PC keyboard, click
a key.
4. On the representation of the terminal keyboard,
click the host key you want to map to the PC key
you just selected.
5. Click Map to map these keys together.
`ìëíçãáòáåÖ=óçìê=âÉóÄç~êÇ
Reflection allows you to associate keystrokes with
actions, a process known as keyboard mapping. You
can customize your keyboard to match a familiar
product, to improve interactions with your host
application, or to speed up your work. To access this
feature, click Keyboard on the Setup menu.

6. To return to the terminal screen without saving
your key mapping, click Cancel. (Or, if you made a
change you’d like to keep, click OK.)
Tip: You can use the Reflection Terminal keyboard to
see how your keys are currently mapped. On the
Window menu, click Terminal Keyboard. Move the
mouse pointer over any of the host keys to see how
this key is mapped to your PC keyboard.

P
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You can customize the Reflection menus—remove
individual menu items, hide the menu bar, add menu
items that perform standard Reflection tasks, or
create menu items to run your own custom macros.
To access this feature, click Menu on the Setup menu.

Tip: To import your custom menus to a new terminal
session, start a new session. (On the File menu, click
New Session, and select the session type you want.
You can enter the name of a host or cancel the
opening dialog box.) To open the menu settings file go
to File > Open, change Files of Type to Menus, and
then select your menu settings file.)

Try it now
In the following steps, we’ll remove the Keyboard
command on the Setup menu. (You can still access
the Keyboard Setup dialog box using the toolbar
button you created in an earlier exercise.)
1. On the Setup menu, click Menu.
2. Click the plus sign (+) next to the Setup menu
icon to expand the list of Setup menu commands.
3. Select the Keyboard command, and then click
Remove.
4. Click OK to return to the terminal screen. Click
the Setup menu to verify that Keyboard no longer
appears. (This change affects the current session
only. New Reflection sessions will continue to use
the default menus.)
p~îáåÖ=óçìê=Åìëíçãáò~íáçåë
Customizations are saved with your current terminal
session when you use the Save command on the File
menu; however, you can also save a subset of
customizations in a separate file for use with other
terminal sessions. You may want to save menu
changes to a separate menu file, for example, for use
with other terminal sessions.

qê~åëÑÉêêáåÖ=cáäÉë=~åÇ=a~í~
You can use Reflection to transfer files and data to
and from a host computer. Because Reflection
automatically selects a file transfer configuration, you
may find that you are ready to transfer files as soon
as you make a host connection.

Try it now
This procedure walks you through the process of
transferring a file to or from the Reflection
demonstration host.
1. Connect to the demonstration host. (To quickly
connect, open the settings file you created earlier,
using the Open command on the File menu, and log
in using any name and password.)
2. On the File menu, click Transfer. The Transfer
dialog box opens.

Try it now
In this procedure, you’ll save menu changes to a
separate menu settings file.
1. On the File menu, Click Save As.
2. Set Save as type to Menus (*.mnu).
3. Specify a name for your menu settings file.
4. Click Save. The custom menus are now saved in a
menu settings file.

3. Click Show Host Files to view sample files on the
demonstration host. (These files do not really
exist.)

Q
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4. Select a file to transfer and click the appropriate
Transfer icon at the top of the Transfer dialog
box. A progress indicator appears as Reflection
simulates a file transfer. (No file is actually
transferred when you use the demonstration
host.)
Tip: You can also transfer files by dragging and
dropping them between panes in the Transfer
dialog box.

^ìíçã~íáåÖ=q~ëâë=
Reflection provides you with powerful tools for
automating your sessions. Tools like the event
scheduler and the macro recorder require no
programming knowledge. In addition to these tools,
Microsoft Visual Basic for Applications (VBA),
which is shipped with Reflection, provides access to
an industry-standard scripting language and a fullfeatured development environment.
®
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You can follow the steps above to display and transfer
files to and from your own host system. To change the
Transport and/or protocol Reflection uses, Click
Setup in the File Transfer dialog box, or open the
Setup menu and click File Transfer. Reflection
supports Mainframe (IND$FILE and APVUFILE),
AS/400 (LIPI and EHNTFW), and FTP transfers.
Use the Help button on each tab to learn more about
configuring file transfer.

Reflection includes fully integrated Visual Basic for
Applications (VBA) for automating tasks and PC-tohost interactions. VBA is used in many desktop
applications, including Microsoft Office products.

Tip: If you frequently repeat the same file transfer,
you can use the Save button in the Transfer dialog
box to save your file transfer information. Or, use the
Batch tab if you want to include more than one
transfer operation in a saved batch. If you are
transferring data from an AS/400, Reflection
provides an interface to help simplify the creation of
complex queries. Open the Transfer dialog box (On
the File menu, click Transfer), click Setup, then
click the SQL tab.

You can use VBA macros to increase your
productivity and the usability of your host
applications. For example, you may want to record a
macro that logs in to your host computer and
navigates automatically to a particular screen in your
host application. Or, you may want to automate a file
transfer and schedule it to run during off-peak hours.
Macros you create in Reflection can be associated
with a menu item, toolbar button, event, or keystroke.
You can also customize VBA macros by editing them
with the Microsoft Visual Basic Editor.

mêçÖê~ããáåÖ=ïáíÜ=s_^
Today there are more than three million VB
programmers. If you are familiar with Visual Basic for
Applications, you can edit a recorded macro or create
a new one using the Visual Basic Editor. To view this
tool, click Visual Basic Editor on the Reflection
Macro menu. Or, to edit the macro you just created,
click Macros on the Macro menu, select your macro,
and then click Edit to launch the Visual Basic Editor.
The Reflection API is extensively documented in the
online programming help. To
view this help file, point to Advanced Topics on the
Help menu, and then click Programming.

R
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In this procedure, you’ll record a file transfer to the
Reflection demonstration host.

Reflection’s Events feature enables you to associate
events, such as “At a specific time of day,” with actions,
such as transferring large amounts of data. The event is
the trigger; the action is how Reflection responds. To
access this feature, click Events on the Setup menu.

1. Make sure you are connected to the demonstration
host. (To quickly connect, open the settings file you
created earlier, using the Open command on the
File menu. You can log in to the demonstration host
using any name and password.)
2. On the Macro menu, click Start Recording.
3. Repeat the steps for transferring a file in the
“Transferring files and data” section above.
4. On the Macro menu, click Stop Recording. In the
Stop Recording dialog box:
• Specify macro name in the box. (Macro names
cannot include spaces and must begin with a
letter.)
• Select the Create a button check box, and click
OK. A new toolbar button appears, labeled with
the name of your macro. At this point, you can
run and test your macro, but it has not yet been
saved.
5. On the File menu, click Save to save your macro.
Your macro will be saved with the current settings
file.

Try it now
In this procedure, we’ll associate the VBA macro
created above with a specific time to illustrate how
you could use this feature in your own environment to
schedule events during off-peak hours:
1. On the Setup menu, click Events.
2. Click New.
3. For Event type, select At a specific time of day.
4. Click Macros. Select the file transfer macro you
just recorded, and then click OK to return to the
Event Properties dialog box.
5. Set Time of Day to a value a minute from now.
(For example, enter 12:05:00 to run the macro at
five minutes past noon.) Click OK.
6. Click OK to return to the terminal screen.
7. At the scheduled time, the macro will run and the
file transfer progress indicator will appear.

6. To run your macro, click your macro’s toolbar
button. The file transfer progress indicator
appears, indicating that a file is being transferred.
(You can also run a macro using the Macros
command on the Macro menu.)

S
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This guide walks you quickly through key Reflection
features. It covers:
•

Getting Connected

•

Customizing Your Terminal Session

®

– Working with toolbars
– Customizing your keyboard
– Customizing menus and commands

dÉííáåÖ=`çååÉÅíÉÇ
Connecting to a host may be as simple as entering the
name of the host, or it may involve changing other
settings as well. Reflection includes a Connection
Wizard that can walk you through the steps of
connecting to your host system. Or, you may prefer to
make a connection using the Connection Setup
command on the Connection menu.

– Saving your customizations

Try it now

– Viewing your customizations in HTML format

The following steps show you how to make a
connection to the Reflection demonstration host using
the Connection menu. If you prefer, you can use these
steps to connect to your own host system instead:

•

Transferring Files and Data

•

Automating Tasks
– Using macros
– Scheduling events

•

Programming with VBA

•

Administrative Tools: Reflection Administrator’s
Toolkit

•

Finding More Information About Deploying
Reflection Products

•

Conclusion

– Getting started with the toolkit

Each section covers a general procedure, so that you
can try the feature for yourself, and includes handson exercises that build on one another as you proceed
with your evaluation.
You can evaluate Reflection using a demonstration
host (included) or your own host system. The
procedures in this guide are geared toward using the
demonstration host, which means you do not need
network access to your host system to complete the
procedures. You can, of course, repeat the steps on
your own host system; notes are included throughout
to get you headed in the right direction.
For information about new features in this release,
launch Reflection and look up New features in the
Reflection Help index.

1. On the Connection menu, click Connection Setup.
2. In the Connection Setup dialog box, click
Network. In the text box that appears, scroll down
and select DEMONSTRATION. Select a host
type, and then click Connect. (To connect to an
actual host, select Telnet or the appropriate
protocol for your environment, and enter the host
name or IP address.)
3. Log in to the demonstration host using any user
name and password.
4. On the File menu, click Save to create a new
settings file with your connection settings. You’ll
use this settings file as you proceed with your
Reflection evaluation.
`ìëíçãáòáåÖ=vçìê=qÉêãáå~ä=pÉëëáçå
Reflection provides powerful customization features
that can make using your host application faster and
easier. These include customizable menus, toolbars,
and hotspots, the ability to assign keystrokes or
mouse actions to terminal keys or functions, and the
ability to change the color and appearance of your
host application in Reflection. The following sections
introduce you to just some of these features.

T
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Reflection supplies four predefined toolbars for quick
access to frequently-used commands. You can display
any or all of these toolbars, modify them, or create
your own custom toolbars. To access this feature,
click Toolbar on the Setup menu.

Reflection allows you to associate keystrokes with
actions, a process known as keyboard mapping. You
can customize your keyboard to match a familiar
product, to improve interactions with your host
application, or to speed up your work. To access this
feature, click Keyboard Map on the Setup menu.

Try it now
The following steps show you how to create a custom
toolbar with a button for changing the host functions
associated with specific keys on your PC keyboard:

Try it now

1. On the Setup menu, click Toolbar.

1. On the toolbar you created in the previous
exercises, click the Keyboard Map Setup button.
(You can also click Keyboard Map on the Setup
menu.)

2. On the Toolbars tab, click New. Specify a name
for the toolbar, such as “Keyboard.”
3. On the Settings tab, select an option for Location.
As you change the Location setting, the position of
the toolbar changes on your screen.
4. On the Predefined Buttons tab, select Setup under
Categories, and then drag the Keyboard Map
Setup icon to your new toolbar.

In this procedure, you’ll map a PC key to a terminal
key.

2. The Keyboard Map Setup dialog box opens. Keys
that are already mapped to host keys or functions
appear green, while unmapped keys are gray.

5. Click Close to return to the terminal screen.

3. On the representation of the PC keyboard, click an
unmapped (gray) key.
4. On the representation of the terminal keyboard,
click any key.
5. Click Map to map these keys together.
6. To return to the terminal screen without saving
your key mapping, click Cancel. Or, if you made a
change you’d like to keep, click OK.

U

bs^ir^qfkd=obcib`qflk=clo=rkfu=^ka=lmbksjp=elpqp

`ìëíçãáòáåÖ=ãÉåìë=~åÇ=Åçãã~åÇë
You can customize the menus of Reflection by
removing individual menu items, hiding the menu bar,
adding menu items that perform standard Reflection
tasks, or by creating menu items to run your own
custom macros. To access this feature, click Menu on
the Setup menu.

Try it now
In the following steps, we’ll remove the Keyboard
Map command from the Setup menu. (You can still
access the Keyboard Map Setup dialog box using the
toolbar button you created in an earlier exercise.)
1. On the Setup menu, click Menu.
2. Click the plus sign (+) next to the “Setup” menu
icon to expand the list of Setup menu commands.
3. Select the “Keyboard Map” command, and then
click Remove.
4. Click OK to return to the terminal screen. Click
the Setup menu to verify that Keyboard Map no
longer appears.
p~îáåÖ=óçìê=Åìëíçãáò~íáçåë
Customizations are saved with your current terminal
session when you use the Save command on the File
menu; however, you can also save a subset of
customizations in a separate file for use with other
terminal sessions. For example, you may want to save
menu changes to a separate menu file for use with
specific terminal sessions.

Try it now
In the following procedure, you’ll save menu changes
to a separate menu settings file.

then select your menu settings file.)
sáÉïáåÖ=óçìê=Åìëíçãáò~íáçåë=áå=eqji=Ñçêã~í
Customizations you have saved in a settings file can
be viewed in a formatted, easy-to-navigate HTML
page that Reflection generates when you use the
Export and Transform XML feature. This feature lets
you direct Reflection to make internal information,
such as registry settings, mappings, display memory,
terminal screen, and both saved and changed settings
available in text, HTML, or Reflection for the Web
report format. The output you decide to view is based
on the XSL transform file you specify for the
exported data you will have transformed. To start, try
exporting all settings you have changed using this
guide into an HTML page that will appear in your
browser.

Try it now
In this procedure, you’ll create an HTML page that
shows your changed settings. (If you have not changed
any settings, you can simply view the current settings.)
1. On the File menu, go to Import and Export >
Export and Transform XML.
2. Select the Changed settings option under Source
XML.
3. Under Transform, click Browse to open the
Select Transform dialog box.
4. Select the Transform settings to HTML.xsl file.
5. Under Results file, type “Settings.htm” and ensure
the Open results file check box is selected.
6. Click Transform. Reflection exports and
transforms the changed settings into HTML
format in your browser.

1. On the File menu, click Save As.
2. Set Save as type to Menus (*.rmu).
3. Specify a name for your menu settings file.
4. Click Save. The custom menus are now saved in a
menu settings file.
Tip: To make your custom menus apply to a new
terminal session, start a new session (click New
Session on the File menu), and then open the menu
settings file. (Click Open on the File menu, change
Files of type to Menus in the Open dialog box, and

V
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You can use Reflection to transfer files and data to
and from a host computer. Because Reflection
automatically selects a file transfer configuration, you
may find that you are ready to transfer files as soon
as you make a host connection.

You can follow the steps above to display and transfer
files to and from your own host system, provided that
file transfer is configured on your host.

Try it now
This procedure walks you through the process of
transferring a file to or from the Reflection
demonstration host.
1. Make sure you are connected to the demonstration
host. To quickly connect, open the settings file you
created earlier, using the Open command on the
File menu, and log in using any name and password.
2. On the File menu, click Transfer. The File
Transfer dialog box opens.

Reflection defaults to the WRQ/Reflecction
proprietary protocol, which offers a more powerful
range of file transfer options but needs to be
configured on your host. To select a public protocol,
such as FTP, click the Setup button in the File
Transfer dialog box. If you aren’t sure which protocol
to use, check with your host system administrator.
For further information, search for Transferring files
in the Reflection online help.
^ìíçã~íáåÖ=q~ëâë=
Reflection provides you with powerful tools for
automating your sessions. Tools like the event
scheduler and the macro recorder require no
programming knowledge. In addition to these tools,
Microsoft Visual Basic for Applications (VBA),
which is included with Reflection, provides access to
an industry-standard scripting language and a fullfeatured development environment.
®

3. Click Show Host Files to view sample files on the
demonstration host. (These files do not really exist.)
4. For If file exists, select Rename.
5. Select a file to transfer and click the appropriate
Transfer icon in the Transfer dialog box. A
progress indicator appears as Reflection simulates
a file transfer. (No file is actually transferred
when you use the demonstration host.)
Tip: You can also transfer files by dragging and
dropping them between panes in the Transfer
dialog box.
6. Click Close to return to the terminal screen.

NM
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Reflection includes fully integrated Visual Basic for
Applications (VBA) for automating tasks and PC-tohost interactions. VBA is used in many desktop
applications, including Microsoft Office products.
You can use VBA macros to increase your productivity
and the usability of your host applications. For example,
you may want to record a script that logs in to your
host computer and navigates automatically to a
particular screen in your host application. Or, you may
want to automate a file transfer and schedule it to run
during off-peak hours.
Macros you create in Reflection can be associated
with a menu item, toolbar button, event, or keystroke.
You can also customize VBA macros by editing them
with the Microsoft Visual Basic Editor.

Try it now
In this procedure, you’ll record a file transfer to
Reflection’s demonstration host.

3. Repeat the steps for transferring a file in the
“Transferring files and data” section above.
4. On the Macro menu, click Stop Recording. In the
Stop Recording dialog box:
• Specify a macro name in the box. (Macro
names cannot include spaces and must begin
with a letter.)
• Select the Create a button check box, and click
OK. A new toolbar button appears, labeled with
the name of your macro. At this point, you can
run and test your macro, but it has not yet been
saved.
5. On the File menu, click Save to save your macro.
Your macro will be saved with the current settings
file.
6. To run your macro, click your macro’s toolbar
button. The file transfer progress indicator
appears, indicating that a file is being transferred.
(You can also run a macro using the Macros
command on the Macro menu.)

1. Make sure you are connected to the demonstration
host. (To quickly connect, open the settings file you
created earlier, using the Open command on the
File menu. You can log in to the demonstration
host using any name and password.)
2. On the Macro menu, click Start Recording.

mêçÖê~ããáåÖ=ïáíÜ=s_^
Today there are more than three million VB
programmers. If you are familiar with Visual Basic for
Applications, you can edit a recorded macro or create
a new one using the Visual Basic Editor. To view this
tool, click Visual Basic Editor on the Reflection Macro
menu. Or, to edit the macro you just created, click
Macros on the Macro menu, select your macro, and
then click Edit to launch the Visual Basic Editor. The
Reflection API is extensively documented in the online
programming help. To view this help file, point to
Advanced Topics on the Help menu, and then click
Programming.

NN
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Reflection’s Events feature enables you to associate
events, such as “At a specific time of day,” with
actions, such as transferring large amounts of data.
The event is the trigger; the action is how Reflection
responds. To access this feature, click Events on the
Setup menu.

Try it now
In this procedure, we’ll associate the VBA macro
created above with a specific time to illustrate how
you could use this feature in your own environment to
schedule events during off-peak hours.
1. On the Setup menu, click Events.
2. Click New.
3. For Event type, select At a specific time of day.
4. For Action, click Macro. Click Browse to select
your macro.
5. Select the file transfer macro you just recorded,
and then click OK to return to the New Event
Properties dialog box.
6. Set Time to a value one minute from now. Click OK.
7. Click OK to return to the terminal screen.
8. Wait for the macro to run. The file transfer progress
indicator appears while the macro is running.

This concludes the first part of the Reflection
evaluation guide. We hope you have enjoyed using
Reflection’s connection, file transfer, customization,
and automation features. If you are evaluating
Reflection for use at a large company, you may wish
to read the next section to see how Reflection
simplifies large-scale deployment and management
tasks.
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To install the Reflection administrative tools, choose
“Reflection Administrator’s Toolkit” from the list of
Reflection products you can install using the
Reflection installation program.
Reflection administrative tools include the
Customization Manager, Group Policy support, and a
Profiler for each Reflection product you install. These
tools enable a system administrator to quickly
customize and deploy Reflection applications.
Using these tools the system administrator can:
•

Perform an administrative installation to a file or
web server

•

Create settings files for users

•

Open a Reflection installation and create a
transform that will contain the customizations

•

Select the feature set the user will install (and
hide features, as needed)

•

Add files to the installation or to a separate,
“companion” database with its own Add/Remove
programs entry

•

Profile a Reflection product, including limiting
user access to features and commands

•

Use the Microsoft Group Policy editor to lock
down Reflection features for individuals or groups
of users

•

Configure product shortcuts for location,
parameters, and descriptions, and create a single
shortcut that installs the customized Reflection
installation

For a complete overview of Reflection’s
administrative tools, see the Reflection System
Administrator Guide, which is available online. See:

To begin using the Reflection administrative tools,
first install the “Reflection Administrator’s Toolkit”
as you would any Reflection product, making sure to
install the toolkit to a folder separate from your
Reflection installation folder. To start the
Customization Manager or Profiler, click Start, point
to the folder containing your Reflection installation
(Attachmate Reflection, by default), then
Administrative Tools, clicking the tool you want to
evaluate.
Tip: To fully evaluate Customization Manager you
will need an administrative installation of Reflection
available to you. You can perform an administrative
installation using options on Customization
Manager’s Prepare Installation panel.
cáåÇáåÖ=jçêÉ=fåÑçêã~íáçå=çå=aÉéäçóáåÖ=
oÉÑäÉÅíáçå=mêçÇìÅíë
For more information about these tools, open the
online Help for the product. To view a comprehensive
overview, with procedures, on preparing and deploying
Reflection, visit the Deployment Guide at
http://docs.attachmate.com/reflection/14.1/deploy.pdf.
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We hope you have enjoyed evaluating Reflection in
your own environment. To learn more about
Reflection products, visit our web site at
www.attachmate.com.
*

The Administrative Toolkit is available only on the Evaluator
DVD or shipping product. This toolkit is not included in
evaluation copies of Reflection downloaded from the
Reflection product web site. Contact us to request a free
Evaluator DVD.
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