SYSTEM ADMINISTRATOR GUIDE

Reflection for IBM
Reflection for HP
Reflection for UNIX and OpenVMS
Reflection for ReGIS Graphics
Reflection for Secure IT
Reflection X
Reflection NFS Client
Reflection FTP Client

WINDOWS® XP
WINDOWS 2000
WINDOWS SERVER 2003
WINDOWS 2000 SERVER
WINDOWS TERMINAL SERVER
CITRIX® MEXAFRAME™
CITRIX MEXAFRAME XP

ENGLISH

VERSION 14.0
**TABLE OF CONTENTS**

**SECTION 1**
Administering Reflection - All Products

<table>
<thead>
<tr>
<th>CHAPTER 1</th>
<th>Overview</th>
<th>Reflection Product Overview</th>
<th>3</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>About This Manual</td>
<td>Frequently Asked Questions</td>
<td>5</td>
</tr>
<tr>
<td></td>
<td>Other Resources</td>
<td>Application Help</td>
<td>8</td>
</tr>
<tr>
<td></td>
<td>Electronic Manuals</td>
<td>AttachmateWRQ Technical Note Library</td>
<td>8</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>CHAPTER 2</th>
<th>Administrator Tools</th>
<th>Reflection Administrator’s Toolkit</th>
<th>9</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Installing the Reflection Administrator’s Toolkit</td>
<td>Additional Help</td>
<td>10</td>
</tr>
<tr>
<td></td>
<td>Reflection Administrator</td>
<td>11</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>CHAPTER 3</th>
<th>Installing Reflection to Multiple Workstations</th>
<th>Overview of Reflection Customization Manager Utility</th>
<th>13</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Installing and Starting Customization Manager</td>
<td>Using the Buttons to Navigate the Panels</td>
<td>15</td>
</tr>
<tr>
<td></td>
<td>Other Features in Customization Manager</td>
<td>Additional Help</td>
<td>18</td>
</tr>
<tr>
<td></td>
<td>19</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
CHAPTER 4  •  Locking Down Reflection Features: Profilers and Group Policies ............................................. 21
  Should I use the Reflection Profilers or Group Policies? ................................................................. 22
  Reflection Profilers .......................................................................................................................... 24
    Running the Profiler ....................................................................................................................... 25
    Installing Profiled Copies of Reflection to User Workstations ................................................. 26
    IBM Profiles .................................................................................................................................. 27
    VT and HP Profiles ...................................................................................................................... 28
    X Profiles .......................................................................................................................................... 29
  Group Policy Settings ..................................................................................................................... 30
    How To Install and Use Group Policies .......................................................................................... 31
    List of Available Group Policy Settings ...................................................................................... 32

CHAPTER 5  •  Making Secure Connections: Authentication and Data Encryption .............................................. 35
  SSL / TLS Encryption .................................................................................................................. 37
    Authentication in SSL/TLS sessions ............................................................................................. 38
    Deploying SSL/TLS Settings to Other Users ............................................................................... 39
    Reflection Proxy Server ................................................................................................................ 40
    Reflection Secure Shell Support .................................................................................................. 42
    Port Forwarding ............................................................................................................................ 46
    Deploying Secure Shell Settings to Other Users ........................................................................ 46
    Reflection Key Agent .................................................................................................................. 47
    Secure Shell Command Line Utilities ......................................................................................... 48
    PKI Support in Reflection ............................................................................................................ 49
    Reflection Certificate Manager .................................................................................................. 50
    Kerberos support .......................................................................................................................... 52
    The Reflection Kerberos Manager ............................................................................................... 54
    Deploying Kerberos Settings to Other Users ............................................................................... 55
    XDM Authorization ...................................................................................................................... 56

CHAPTER 6  •  Using Web Pages to Install Reflection Software and Launch Reflection Sessions ................. 57
  Using Reflection Customization Manager for Web-based Installations ......................................... 58
  Working with the Reflection Administrative WebStation .............................................................. 59
# TABLE OF CONTENTS

<table>
<thead>
<tr>
<th>CHAPTER 7</th>
<th>Metering Reflection Products</th>
<th>61</th>
</tr>
</thead>
<tbody>
<tr>
<td>Configuring Metering</td>
<td>61</td>
<td></td>
</tr>
<tr>
<td>Installing the Reflection Metering Server</td>
<td>61</td>
<td></td>
</tr>
<tr>
<td>Configuring Reflection Workstations to Report to the Metering Server</td>
<td>64</td>
<td></td>
</tr>
<tr>
<td>Adding and Configuring Reflection License Pools</td>
<td>68</td>
<td></td>
</tr>
<tr>
<td>Viewing Metering Reports</td>
<td>70</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>CHAPTER 8</th>
<th>Supporting Reflection on Windows Terminal Servers</th>
<th>71</th>
</tr>
</thead>
<tbody>
<tr>
<td>Product Requirements</td>
<td>71</td>
<td></td>
</tr>
<tr>
<td>Citrix Metaframe Support</td>
<td>71</td>
<td></td>
</tr>
<tr>
<td>Which Reflection Products Run on Terminal Servers?</td>
<td>72</td>
<td></td>
</tr>
<tr>
<td>Installing Reflection: General Notes</td>
<td>73</td>
<td></td>
</tr>
<tr>
<td>Additional Help</td>
<td>74</td>
<td></td>
</tr>
<tr>
<td>AttachmateWRQ Technical Note Library</td>
<td>74</td>
<td></td>
</tr>
</tbody>
</table>

## SECTION 2

## Administering Reflection for IBM

<table>
<thead>
<tr>
<th>CHAPTER 9</th>
<th>Files Used by Reflection for IBM</th>
<th>77</th>
</tr>
</thead>
<tbody>
<tr>
<td>Settings Files</td>
<td>77</td>
<td></td>
</tr>
<tr>
<td>Complete (Default) Settings Files</td>
<td>77</td>
<td></td>
</tr>
<tr>
<td>Partial Settings Files</td>
<td>78</td>
<td></td>
</tr>
<tr>
<td>Settings Update Files</td>
<td>78</td>
<td></td>
</tr>
<tr>
<td>Settings Files that Include Macros</td>
<td>80</td>
<td></td>
</tr>
<tr>
<td>Layouts</td>
<td>80</td>
<td></td>
</tr>
<tr>
<td>Converting Reflection Settings to Other Formats</td>
<td>81</td>
<td></td>
</tr>
<tr>
<td>Migrating Settings to and from Reflection for the Web</td>
<td>81</td>
<td></td>
</tr>
<tr>
<td>Saving Settings in XML Format</td>
<td>81</td>
<td></td>
</tr>
<tr>
<td>Transfer Request and Batch Transfer Files</td>
<td>82</td>
<td></td>
</tr>
<tr>
<td>Batch File Transfer</td>
<td>82</td>
<td></td>
</tr>
<tr>
<td>The SNA Configuration File</td>
<td>83</td>
<td></td>
</tr>
</tbody>
</table>
### TABLE OF CONTENTS

**CHAPTER 10**  
- Reflection for IBM Utilities ................................................................. 85  
  - Reflection for IBM Conversion Tool ......................................................... 85  
  - Translation Table Editors ........................................................................ 86  

**SECTION 3**  
Administering Reflection for HP and Reflection for OpenVMS

**CHAPTER 11**  
- Files Used by Reflection for HP, UNIX and OpenVMS, and ReGIS Graphics ......................... 89  
  - Settings Files ......................................................................................... 89  
  - Complete (Default) Settings Files ............................................................... 90  
  - Partial Settings Files ............................................................................... 90  
  - Settings Update Files ............................................................................... 91  
  - Linking Settings Files ............................................................................... 93  
  - Layouts .................................................................................................... 94  
  - Converting Reflection Settings to Other Formats ........................................... 94  
  - Migrating Settings to and from Reflection for the Web .................................. 95  
  - Importing and Exporting Settings Using XML ............................................. 96  

**CHAPTER 12**  
- Configuring Your Host to Support WRQ/Reflection File Transfer Protocol ....................... 97  
  - Locating the Upload Scripts ....................................................................... 97  
  - Basic Steps for Uploading the Host Program ............................................... 98  
  - Specifics on Uploading the HP Host Program ............................................... 99  
    - HP Custom Upload Options .................................................................... 101  
    - Canceling an Upload ............................................................................. 103  
  - Specifics on Uploading the OpenVMS Host Program .................................... 104  
    - OpenVMS Custom Upload Options ......................................................... 105  
  - Specifics on Uploading the UNIX Host Program ......................................... 106  
    - UNIX Custom Upload Options .............................................................. 107
SECTION 4
Administering Reflection for Secure IT

<table>
<thead>
<tr>
<th>CHAPTER 13</th>
<th>Files Used by Reflection for Secure IT</th>
<th>111</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Secure Shell Configuration Files</td>
<td>111</td>
</tr>
<tr>
<td></td>
<td>Saving Settings Host-by-Host vs. Using the Same Settings for Multiple Hosts</td>
<td>112</td>
</tr>
<tr>
<td></td>
<td>Configuring Global Secure Shell Settings</td>
<td>112</td>
</tr>
<tr>
<td></td>
<td>Understanding Secure Shell Configuration Files and Reflection Settings Files</td>
<td>113</td>
</tr>
<tr>
<td></td>
<td>SSH Client Settings Files</td>
<td>114</td>
</tr>
<tr>
<td></td>
<td>Settings Update Files</td>
<td>114</td>
</tr>
<tr>
<td></td>
<td>SFTP Client Settings Files</td>
<td>114</td>
</tr>
<tr>
<td></td>
<td>SFTP Client Script Files</td>
<td>115</td>
</tr>
<tr>
<td></td>
<td>Layouts</td>
<td>116</td>
</tr>
<tr>
<td></td>
<td>Secure Shell File Reference</td>
<td>117</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>CHAPTER 14</th>
<th>Secure Shell Authentication Overview</th>
<th>121</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Secure Shell Host Authentication</td>
<td>122</td>
</tr>
<tr>
<td></td>
<td>Public key host authentication</td>
<td>122</td>
</tr>
<tr>
<td></td>
<td>Certificate host authentication</td>
<td>123</td>
</tr>
<tr>
<td></td>
<td>Secure Shell User Authentication</td>
<td>124</td>
</tr>
<tr>
<td></td>
<td>GSSAPI/Kerberos</td>
<td>124</td>
</tr>
<tr>
<td></td>
<td>Public Key</td>
<td>124</td>
</tr>
<tr>
<td></td>
<td>Keyboard Interactive</td>
<td>125</td>
</tr>
<tr>
<td></td>
<td>Password</td>
<td>125</td>
</tr>
</tbody>
</table>
# SECTION 5
Administering Reflection X

## CHAPTER 15 • Files Used by Reflection X

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Working with Client and Server Files in the X Manager</td>
<td>129</td>
</tr>
<tr>
<td>Client Files</td>
<td>130</td>
</tr>
<tr>
<td>Client Files for UNIX and OpenVMS Hosts</td>
<td>130</td>
</tr>
<tr>
<td>XDMCP Client Files for Indirect, Direct, and Broadcast</td>
<td>131</td>
</tr>
<tr>
<td>The Reflection X Client Wizard</td>
<td>132</td>
</tr>
<tr>
<td>X Server Instance Files</td>
<td>133</td>
</tr>
<tr>
<td>Managing X Server Instances</td>
<td>133</td>
</tr>
<tr>
<td>Keyboard Mapping Files</td>
<td>134</td>
</tr>
<tr>
<td>Toolbar Files</td>
<td>134</td>
</tr>
<tr>
<td>Additional Help</td>
<td>135</td>
</tr>
</tbody>
</table>

## CHAPTER 16 • Managing Fonts in Reflection X

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Overview of Fonts in Reflection X Manager</td>
<td>137</td>
</tr>
<tr>
<td>Fonts Installed in a Typical Installation</td>
<td>138</td>
</tr>
<tr>
<td>Other Fonts Installed Using a Custom Installation</td>
<td>139</td>
</tr>
<tr>
<td>How Font Requests Work</td>
<td>139</td>
</tr>
<tr>
<td>The Font Settings Panel: Overview of Options</td>
<td>140</td>
</tr>
<tr>
<td>Font Formats</td>
<td>141</td>
</tr>
<tr>
<td>Retrieving Fonts from a Server</td>
<td>142</td>
</tr>
<tr>
<td>Additional Help</td>
<td>143</td>
</tr>
<tr>
<td>AttachmateWRQ Technical Note Library</td>
<td>143</td>
</tr>
<tr>
<td>CHAPTER 17</td>
<td>Managing Multiple Displays in Reflection X</td>
</tr>
<tr>
<td>------------</td>
<td>------------------------------------------</td>
</tr>
<tr>
<td>CHAPTER 17</td>
<td>What is “Managing” One or More X Server Instances?</td>
</tr>
<tr>
<td>CHAPTER 17</td>
<td>Viewing Server Instances in the X Manager</td>
</tr>
<tr>
<td>CHAPTER 17</td>
<td>Creating an X Server Instance</td>
</tr>
<tr>
<td>CHAPTER 17</td>
<td>Using the X Manager to Manage X Server Instances</td>
</tr>
<tr>
<td>CHAPTER 17</td>
<td>Exporting X Server Instances for Deployment to Users</td>
</tr>
<tr>
<td>CHAPTER 17</td>
<td>Additional Help</td>
</tr>
<tr>
<td>CHAPTER 17</td>
<td>AttachmateWRQ Technical Note Library</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>CHAPTER 18</th>
<th>Reflection X Utilities</th>
<th>151</th>
</tr>
</thead>
<tbody>
<tr>
<td>CHAPTER 18</td>
<td>View Settings</td>
<td>151</td>
</tr>
<tr>
<td>CHAPTER 18</td>
<td>The Performance Tuner Utility</td>
<td>152</td>
</tr>
<tr>
<td>CHAPTER 18</td>
<td>The RunRX Command Line Utility</td>
<td>154</td>
</tr>
<tr>
<td>CHAPTER 18</td>
<td>The Font Retrieval Utility</td>
<td>154</td>
</tr>
<tr>
<td>CHAPTER 18</td>
<td>The Reflection X Client Wizard</td>
<td>155</td>
</tr>
<tr>
<td>CHAPTER 18</td>
<td>The Reflection X Resource Database (XRDB) Utility</td>
<td>155</td>
</tr>
<tr>
<td>CHAPTER 18</td>
<td>The Reflection X Trace Utility</td>
<td>157</td>
</tr>
</tbody>
</table>

SECTION 6
Administering Reflection FTP Client

<table>
<thead>
<tr>
<th>CHAPTER 19</th>
<th>Files Used by Reflection FTP Client</th>
<th>161</th>
</tr>
</thead>
<tbody>
<tr>
<td>CHAPTER 19</td>
<td>Settings Files</td>
<td>161</td>
</tr>
<tr>
<td>CHAPTER 19</td>
<td>Script Files</td>
<td>162</td>
</tr>
<tr>
<td>CHAPTER 19</td>
<td>Layouts</td>
<td>162</td>
</tr>
<tr>
<td>CHAPTER 19</td>
<td>Deploying FTP Client Settings to Other Users</td>
<td>163</td>
</tr>
</tbody>
</table>

SECTION 7
Administering Reflection NFS Client

<table>
<thead>
<tr>
<th>CHAPTER 20</th>
<th>Files Used by Reflection NFS Client</th>
<th>167</th>
</tr>
</thead>
<tbody>
<tr>
<td>CHAPTER 20</td>
<td>Deploying NFS Settings to Other Users</td>
<td>168</td>
</tr>
</tbody>
</table>
SECTION 1

Administering Reflection - All Products
Overview

Reflection products enable you to access diverse host systems, and provide tools to simplify management and to control costs. This guide provides information useful to system administrators and covers the complete line of Windows-based Reflection applications, including:

- Reflection for HP
- Reflection for UNIX and Digital
- Reflection for Secure IT
- Reflection for ReGIS Graphics
- Reflection for IBM
- Reflection X
- Reflection FTP
- Reflection SFTP Clients
- Reflection NFS Client

Reflection Product Overview

AttachmateWRQ offers many Windows-based Reflection products. Each product includes one or more Reflection applications as well as a number of useful utilities. Use the table on page 4 to determine which Reflection applications are included on your product CD.

All Reflection products include the Reflection Administrator's Toolkit, which is described in Chapter 2.

The following utilities are also available when you install Reflection:

- Reflection Connection Wizard\(^1\)\(^2\)
- Reflection Kerberos Manager\(^1\)
- Reflection TimeSync\(^2\)
- Reflection Virtual Desktop\(^1\)\(^2\)\(^3\)
- Reflection Ping\(^2\)

---

1 Not included with Reflection NFS Client.
2 Not included with Reflection for Secure IT.
3 Reflection Virtual Desktop is not available for Windows XP.
## Overview

### Included Reflection Applications

<table>
<thead>
<tr>
<th>Reflection Product Name</th>
<th>Reflection for IBM</th>
<th>Reflection for HP</th>
<th>Reflection for UNIX and OpenVMS</th>
<th>Reflection for Secure IT</th>
<th>Reflection X</th>
<th>Reflection FTP Client</th>
<th>Reflection SFTP Client</th>
<th>Reflection NFS Client</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reflection for the Multi-Host Enterprise, Professional Edition</td>
<td>•</td>
<td>•</td>
<td>•</td>
<td>•</td>
<td>•</td>
<td>•</td>
<td>•</td>
<td>•</td>
</tr>
<tr>
<td>Reflection for the Multi-Host Enterprise, Standard Edition</td>
<td>•</td>
<td>•</td>
<td>•</td>
<td>•</td>
<td>•</td>
<td>•</td>
<td>•</td>
<td>•</td>
</tr>
<tr>
<td>Reflection Suite for X</td>
<td>•</td>
<td>•</td>
<td>•</td>
<td>•</td>
<td>•</td>
<td>•</td>
<td>•</td>
<td>•</td>
</tr>
<tr>
<td>Reflection for IBM</td>
<td>•</td>
<td>•</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>•</td>
<td>•</td>
</tr>
<tr>
<td>Reflection for HP, with NS/VT</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>•</td>
<td>•</td>
</tr>
<tr>
<td>Reflection for UNIX and OpenVMS</td>
<td>•</td>
<td>•</td>
<td>•</td>
<td></td>
<td></td>
<td></td>
<td>•</td>
<td>•</td>
</tr>
<tr>
<td>Reflection for Secure IT</td>
<td></td>
<td></td>
<td></td>
<td>•</td>
<td></td>
<td></td>
<td>•</td>
<td>•</td>
</tr>
<tr>
<td>Reflection X</td>
<td>•</td>
<td>•</td>
<td>•</td>
<td>•</td>
<td></td>
<td></td>
<td>•</td>
<td>•</td>
</tr>
<tr>
<td>Reflection NFS Client (full product)</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>•</td>
<td>•</td>
</tr>
</tbody>
</table>
About This Manual
Reflection products include a powerful array of tools for system administrators. This manual is designed to give you a broad overview of these tools. Detailed information about all Reflection applications and administrative tools—including more in-depth discussions, step-by-step procedures, and context-sensitive help—is handled by the application Help.

Section 1 describes information and tools that apply to the entire Reflection product line. The remaining sections provide information useful to administrators of specific Reflection applications.

Frequently Asked Questions
Reflection administrative tools cover a broad range of tools designed to help you save time, secure sensitive data, and simplify the end-user experience. The following questions and answers may help you in your planning.

I want Reflection installation to be a simple one-step process. Can I customize the installation so that users get the features they need (and don't get features they don't need)?

Use Reflection Customization Manager (described in Chapter 3). This utility includes options that let you decide how Reflection will look and operate at the end user’s desktop. For example, you can decide what features to install, in what folder Reflection should be installed, if additional files should be installed, and if the installation should proceed with user interaction or silently, without intervention.

Can I preconfigure Reflection settings for connecting to our host systems so that users are ready to connect as soon as Reflection is installed?

The Reflection Customization Manager's Define Profiles and Default Settings feature provides this functionality. Review Chapter 3 and Chapter 4 for more information.

After I’ve configured our Reflection sessions, is there a way to prevent users from changing these settings? This would cut down on unnecessary calls to our help desk.

Reflection provides two ways of locking down settings—you can use the Reflection Profilers and/or configure Reflection Group Policy settings. See Chapter 4 for a comparison of these two strategies.
I want to use a web page for managing Reflection sessions. How can I configure Reflection to install and run from a web page?

For preparing a web-based installation, use the Customization Manager. To create and maintain Reflection sessions that users can launch from a web page, use the Reflection Administrative WebStation. See Chapter 6 for more information.

Can I create and maintain different web pages for different user groups?

You can—using the Reflection Administrative WebStation. The Reflection management server provides access control and LDAP integration that you can use to determine which Reflection sessions are available to particular users or groups of users.

Security is critical in our enterprise. Can I configure Reflection for secure authentication and data encryption?

Reflection applications can be configured for secure authentication and data encryption using a number of protocols, including Kerberos, Secure Shell, SSL/TLS, and XDM-Authorization. See Chapter 5 for more information.

I am currently using Reflection for Secure IT, which does not support some of the customization features available in other Reflection applications (including macros, event management, toolbar customization, and use of Reflection profilers to lock down features). Is there a Secure Shell client available that does include these features?

Reflection for UNIX and OpenVMS includes all of the Secure Shell client features available in Reflection for Secure IT, and also provides a full range of tools for customization and administration. When you first install Reflection for UNIX and OpenVMS you’ll see that Reflection for UNIX and OpenVMS is configured to make connections using Telnet by default, however, you can easily configure it to make Secure Shell connections and also customize it to make only Secure Shell connections, if needed.

How can I lock down Reflection so that only encrypted connections are allowed?

You can use either the Reflection Profilers, or Group Policy Settings to configure Reflection so that only encrypted connections are allowed. These tools are described in Chapter 4.
Can I install and run Reflection on a Citrix server?

Yes. Reflection products and components are designed to run in Windows Terminal Server environments. See Chapter 8 for more information.

We purchased a number of licenses. How can I monitor Reflection use so I know how many licenses we need?

This functionality is provided by the Reflection for the Web metering server. You will need to install the server and configure your Reflection workstations. See Chapter 7 for more information.

When our network configuration changes, I sometimes need to update user settings. Is there a way to make changes centrally and "push" these changes out to user workstations?

You can use settings update files to provide updates for end-user settings. This feature is available with Reflection for IBM, Reflection for HP, Reflection for UNIX and OpenVMS, Reflection for ReGIS Graphics, and Reflection for Secure IT. For more information, see pages 78, 91, and 114.

We frequently need to run several Reflection sessions at a time. Is there a one-step way to launch a configuration that involves multiple sessions?

If you frequently run two or more Reflection sessions simultaneously, you can use layout files to streamline your work. Layout files save your Reflection window arrangement. See pages 80 and 94 for more information. (This feature is available with Reflection for IBM, Reflection for HP, Reflection for UNIX and OpenVMS, Reflection for ReGIS Graphics, and Reflection for Secure IT.)
Other Resources

For information not covered in this guide, refer to the following resources.

Application Help

The Help installed with your Reflection products is generally your most complete source of information. Some Reflection applications include a separate system administrator help, which is not included as part of a Typical installation. Other applications (including Reflection for IBM, Reflection FTP Client, and Reflection NFS Client) incorporate administrative topics into the main application Help.

This icon is used throughout this guide to indicate where you should turn to the application Help for comprehensive information about the topics being covered.

Electronic Manuals

The following product manuals in Adobe Portable Document Format (PDF) are viewable during Reflection Setup and are also available on the web at http://support.wrq.com/manuals:

- Reflection System Administrator Guide (this manual)
- Programming with Reflection: Visual Basic User Guide
- HP Terminal Reference Manual
- VT Terminal Reference Manual

AttachmateWRQ Technical Note Library

The Technical Note Library provides easy-to-use documents about common technical issues or topics. The technical note library is available online at http://support.wrq.com/techdocs/.
Administrator Tools

The Reflection Administrator's Toolkit is available on the Reflection CD. Additional tools for managing Reflection applications are available in Reflection Administrator, an add-on product available from AttachmateWRQ.

Reflection Administrator's Toolkit

The Reflection Administrator's Toolkit is available on the Reflection product CD. The toolkit is designed for use by administrators and must be installed separately from Reflection.

The following utilities are available in the toolkit:

- **Reflection Customization Manager**: Enables an administrator to copy Reflection files quickly from the product CD to a file server in preparation for customizing and distributing the product to end users. Distribution options let you make Reflection available to the end user via a Windows shortcut or using any Microsoft Installer-compatible deployment tool (such as SMS or Active Directory). More information about the Customization Manager is available in Chapter 3, “Installing Reflection to Multiple Workstations,” page 13.

- **Reflection Profiler(s)**: Use the Profiler to limit an end user's access to Reflection features, commands, and settings, and to specify a site-wide settings file. More information about the Reflection Profilers is available in Chapter 4, “Locking Down Reflection Features: Profilers and Group Policies,” page 21.

  Note: The Reflection Profiler is not available in Reflection for Secure IT.

- **Group Policy Template**: Use Reflection Group Policy settings to change the behavior of the application at the user's desktop. For example, you might limit the user to encrypted connections or prevent file transfer at the user desktop. When you apply a setting, it acts to supersede Reflection behavior. More information about Reflection Group Policy settings is available in Chapter 4, “Locking Down Reflection Features: Profilers and Group Policies,” page 21.
Installing the Reflection Administrator's Toolkit

Before you install the toolkit, install the Reflection product on the administrative workstation. The toolkit installer detects your Reflection installation and automatically selects the features that support your Reflection applications.

Note: The toolkit is installed to a different system folder than the Reflection product by design—do not attempt to install the toolkit to the same folder as your Reflection product.

To install Reflection Administrator's Toolkit, follow these steps:

1. Put the Reflection CD in the CD-ROM drive. If enabled, the Autoplay feature of Windows causes the Reflection setup program (Install.exe) to start automatically and display the Welcome To Reflection screen.

2. Click Install Reflection.

3. In the Install Reflection panel, click Reflection Administrator's Toolkit, then click Workstation install.

4. The installation begins. When you are asked to specify your installation folder, accept the default folder of C:\Program Files\Attachmate\RToolkit or enter another folder of your choosing.

Starting Reflection Administrator's Toolkit Utilities

Each of the Toolkit's utilities are available from Windows Start button. To find and start a utility, click Start, then point to Programs > Attachmate Reflection > Administrative Tools and click the utility you want to start.

Additional Help

Each utility in the Reflection Administrator's Toolkit features application Help that can be viewed using any Help button. Application Help can also be opened directly from the C:\Program Files\Attachmate\RToolkit\<lang>\Help folder using Windows Explorer.

The Deployment Guide

To assist you in deploying Reflection, review the guide available on AttachmateWRQ's web site at http://support.wrq.com/tutorials/. Click Preparing to Deploy Reflection 14.0 Guide to open a PDF file that you can print for reference purposes.
Reflection Administrator

Reflection Administrator is an add-on product that provides tools for centrally managing Reflection in your organization. Reflection Administrator is not included with your Reflection software. Contact AttachmateWRQ if you are interested in these tools, which provide additional functionality that is not included with the Reflection Administrator's Toolkit.

Reflection Administrator includes:

- **Reflection Administrative WebStation and Management Server**
  Use the Administrative WebStation to simplify session management. You can deploy and configure all Reflection sessions from a single console. Optional LDAP support allows you to determine which Reflection sessions are available to particular users or groups of users. See page 59 for more information.

- **Reflection security proxy**
  Configure secure connections using the security proxy. The security proxy provides secure connections to any host through the Reflection security proxy server using SSL v3.0 or TLS v1.0 protocols. You can use this technique to configure secure connections even if your host is not running an SSL/TLS Telnet server. See page 40 for more information.

- **Reflection metering server**
  Use the metering server to audit Reflection usage at your site. See page 40 for more information.

Contact AttachmateWRQ for information about how to acquire Reflection Administrator.
Installing Reflection to Multiple Workstations

If you are an administrator responsible for preparing, customizing, and distributing Reflection to a group of Reflection users you can take advantage of administrative tools included in the Reflection Administrator's Toolkit to make these tasks easier. Explained in Chapter 2, the Reflection Administrator's Toolkit includes Reflection Profilers, a Group Policy template, and Customization Manager, a Microsoft Installer-compatible utility specifically designed to help the administrator with preparing and customizing Reflection.

This chapter describes how to install and start Customization Manager, and provides an overview of Customization Manager's panels, describing which options are available on each panel.

For information about Reflection Profilers and Group Policy support, see Chapter 4, “Locking Down Reflection Features on User Workstations.”
Overview of Reflection Customization Manager Utility

Reflection Customization Manager is a powerful software tool that guides the administrator through the preparation and customization of Reflection in anticipation of distribution. This utility enables administrators to:

- **Place Reflection on a server**: Quickly perform the installation of Reflection to a file server from the administrator's machine. Doing this enables the administrator to profile or otherwise customize the product prior to distribution to the end users.

- **Customize Reflection**: Customization Manager includes options that let the administrator decide how Reflection will look and operate at the end user's desktop.
  
  For example, the administrator can decide what features to install at the end user's machine, in what folder Reflection should be installed, if installation properties should be included, if site-specific files should be installed with Reflection, and if the installation should proceed with user interaction or silently, without intervention.

- **Prepare to Distribute Reflection to end users**: Make Reflection available to Reflection users using options in Customization Manager or using other deployment tools. Since Customization Manager works with Microsoft Installer (MSI), you can choose any Microsoft Installer-compatible deployment tool. Or, Customization Manager can create either a Windows shortcut or web link that, when distributed, provide one-click installation for the end user.
Installing and Starting Customization Manager

Reflection Customization Manager is installed as part of the toolset included in the Reflection Administrator’s Toolkit. To install this toolkit, refer to the instructions on page 10. When you do this, be sure to install the Reflection product prior to installing the toolkit. Doing this lets the Administrator’s Toolkit automatically detect what Profiler(s) to install on the administrator’s machine.

To start Customization Manager, click **Start**, then point to **Programs > Attachmate Reflection > Administrative Tools** and click **Customization Manager**.

When Customization Manager opens for the first time, it looks like this:
Using the Buttons to Navigate the Panels

Customization Manager is divided into panels, each opened by clicking a button on the left pane of the application. Each button opens a panel containing options that enable an administrator to perform the tasks of preparing, customizing, and distributing Reflection to the end user.

Introduction
Use this panel to familiarize yourself with Customization Manager’s function and features. On this panel you will find a description of the tasks you can perform with each panel.

Prepare
Click the Prepare button to view this panel. Use options on this panel to move Reflection from the product CD to a file server, also known as creating an administrative installation point. An administrative installation is essentially identical to the CD image, but is based on the file server. From the server, Reflection can be customized and either run directly from the server or installed to the end user’s machine.

Once Reflection is installed to a file server, you have the option of making the installation available to the end user without customizations, or customizing the product prior to installation at the end user’s desktop. To do this you use options available in the Customize panel.

Customize
Click the Customize button to view this panel. Use this panel to open your Reflection installation package and perform customizations, such as locking down settings, features, or commands using a Profiler. When you do this, Customization Manager creates a transform (*.mst) file which contains the customization information.
Customizing Reflection means deciding how you would like Reflection to install, look, and act at the end user's machine. For example, you may decide to specify which features are installed, if additional files should be installed, which installation properties should be included, and if the application should run on the end user's machine without access to file transfer. Or, you may decide to include a client or settings file using Reflection's Connection Wizard (described on page 18). The installation can also be customized to include modified Windows shortcuts.
Customization Manager stores these customizations in a transform file that is created in the same folder as the Reflection package file. The transform file is referenced during installation by the Reflection package in order to install the customizations as specified by the administrator. Since multiple transforms can be created for a given Reflection package file, the administrator can create customized installations for separate departments or groups of users, each represented in a transform file. In addition, since the package file and generated transform adheres to MSI standards, these files can be used in conjunction with Active Directory, SMS, or any other Microsoft Installer-compatible deployment tool.

Reflection Customization Manager can also create a simple Windows shortcut that will install the product. This is done using options on the Deployment Utilities panel.

**Deployment Utilities**
Click the Deployment Utilities button to view this panel. Use this panel to create a Windows shortcut that, when clicked, begins the installation of Reflection. The product is then installed to the end user's machine on a per-machine basis. For per-user installations it is best to use Active Directory, SMS, or any other Microsoft Installer-compatible deployment tool.

**Other Features in Customization Manager**
Customization Manager's Windows Installer Utilities panel (click Installer Utilities to see this) provides access to Connection Wizard, a utility used to create settings and client files. These files contain all of the information the applications need to connect the end user's machine to the host with all settings configured as desired. These files can be added to a customized Reflection installation using the Add Files button on the Customize Reflection Installations panel, described on page 16. For more information about adding files through Customization Manager, see the application Help.
Additional Help

More information about Customization Manager can be found in the application Help which can be viewed using any Help button in Customization Manager. Or open the file Rdep2.hlp in your Reflection \Help folder using Windows Explorer.

The Deployment Guide

To assist you in deploying Reflection, review the guide available on AttachmateWRQ's web site at http://support.wrq.com/tutorials/. Click Preparing to Deploy Reflection 14.0 Guide to open a PDF file that you can print for reference purposes.
Locking Down Reflection Features: Profilers and Group Policies

You can streamline your administrative tasks by preconfiguring Reflection sessions and controlling access to Reflection features on user workstations. Reflection products provide two ways of doing this:

- Reflection Profilers
- Reflection Group Policy support

Profiler support is not available for Reflection for Secure IT.

Reflection Group Policy support provides administrators with an added tool for customizing and securing Reflection applications. Examples of customizations that can be made using Group Policies include: enabling only secure, encrypted connections; disabling macros; disabling password saving; and disabling file transfers to and/or from host computers. Windows Group Policy editor support is available for Windows 2000 and Windows XP workstations.
Should I use the Reflection Profilers or Group Policies?

Both Reflection Profilers and the Windows Group Policy editor enable you to lock down Reflection features.

Although Active Directory is not a requirement, the administrator will gain the greatest benefits of Group Policy settings when implemented using Active Directory. If you want to take advantage of Active Directory, and the features you want to lock down are available through Reflection's Group Policy settings, using Group Policies is easier and more flexible than using the Profilers.

If you are not using Active Directory and/or the features you want to configure are not included in Reflection's Group Policy support, the Reflection Profilers offer a feature-rich alternative. Profiles can be configured for individual users or for all users of a computer.

Advantages of using Group Policies include:

- Group Policy settings can be applied to an organizational unit, individual, or security group using Active Directory.
- Group Policy settings can be administered centrally or remotely.
- Customizations made using the Windows Group Policy editor are easily deployed using the Microsoft Management Console. This means that Group Policy settings can be easily changed after deployment. Customizations made with the Profilers are not easy to change after installing the products. Profiled changes are saved to profile files, which must be present on user workstations. Typically, deploying profile files means creating these files before Reflection is installed on user workstations, and including the profile files as part of a custom installation.
- Group Policy settings apply to whatever workstation the user logs in to.
- Reflection settings are easily located and configured using Windows Group Policy editor. The Reflection policies are deployed exactly like Windows and Office policies. Learning to configure settings using the Profiler may take more time because Reflection Profilers are product-specific and cover a much broader range of features.
• Reflection Group Policy settings apply across the Reflection product line. By changing one Group Policy setting, you ensure consistent behavior across each Reflection application. Settings configured with the Profilers are specific to individual Reflection applications.

• If you have configured Windows to prevent user tampering of Windows policies, Reflection policies are also protected.

• Group Policies apply to all Reflection applications.

Advantages of using the Reflection Profilers include:

• Profilers enable you a much greater degree of control over Reflection applications. You can use the Profilers to configure and restrict access to hundreds of features, commands, and settings. Reflection Group Policies configure a much smaller number of features.

• You can use Reflection Customization Manager to create a customized Reflection installation that includes profiled changes. If you are not using Active Directory, making modifications to settings using Group Policies may require running the Windows Group Policy editor on individual workstations.

Note: It is possible to use both Profiles and Group Policies. Group Policy settings take precedence over Profiler settings.
Reflection Profilers

The Reflection Profilers are powerful administrative tools that allow you to customize single- and multi-user versions of Reflection. All Reflection Profilers allow you to:

- Create site defaults that affect all new Reflection sessions.
- Limit access to Reflection functionality.

For example, this sample screen shows the VT and HP Profiler configured to disable file transfer to the host:

Explore the Profiler Help to learn about the full range of features available with each Reflection Profiler.
Reflection Profilers are installed as part of the Reflection Administrator's Toolkit. The installer will automatically install the Profiler(s) that support the Reflection applications you have installed on your workstation. There are three Profilers:

<table>
<thead>
<tr>
<th>Profiler</th>
<th>Supported Reflection Application(s)</th>
</tr>
</thead>
<tbody>
<tr>
<td>IBM Profiler</td>
<td>Reflection for IBM</td>
</tr>
<tr>
<td>VT and HP Profiler</td>
<td>Reflection for HP&lt;br&gt;Reflection for UNIX and OpenVMS&lt;br&gt;Reflection for ReGIS Graphics</td>
</tr>
<tr>
<td>X Profiler</td>
<td>Reflection X</td>
</tr>
</tbody>
</table>

**Note:** Reflection for Secure IT does not include a Profiler.

Each profiler creates one or more profile files that must be present on user workstations. Refer to the product-specific sections that follow for details about working with these files.

**Running the Profiler**

You can run the Profiler directly from the Windows Start menu, or use the Reflection Customization Manager when you want to distribute profiled copies of Reflection to multiple users.

To run the profiler from the Windows **Start** menu, point to **Programs > Attachmate Reflection > Administrative Tools**.

If you are launching the VT and HP Profiler, you need to identify the name of the executable you want to profile. The applications supported by this profiler are:

- Reflection for HP (R1win.exe)
- Reflection for UNIX and OpenVMS (R2win.exe)
- Reflection for ReGIS Graphics (R4win.exe)

The default installation folder for these files is:

```
C:\Program Files\Attachmate\Reflection
```

Reflection Profilers provide a number of ways to customize the supported Reflection product(s). For complete information, refer to the Profiler Help.
Installing Profiled Copies of Reflection to User Workstations

Launch the Profiler using the Reflection Customization Manager when you want to install profiled copies of Reflection to multiple users. (See Chapter 3 for more information about this utility.) The Customization Manager automatically configures a custom installation that will install the profile(s) you create to the correct location(s) on user workstations. The installer transform files created by the Customization Manager support both per-user and per-machine installations.

To launch the Profilers from Reflection Customization Manager, you need to prepare an administrative installation, then:

1. On the Windows Start menu, point to Programs > Attachmate Reflection > Administrative Tools > Customization Manager.

2. Click Customize in the left panel, then click Open Installation and locate the installation package (*.msi) you want to modify. When you’ve completed this step, the other buttons on this panel will become available.

3. Click Define Profiles and Default Settings.

You can now work with existing profiles, or create new profiles to add to the custom installation.
IBM Profiles

The Reflection for IBM Profiler saves profile information in a file called Profile8.rpf. Reflection looks for this file in the following locations:

- A Reflection subfolder located in the personal Application Data folder.	For Windows 2000 and XP, the default location for this hidden folder is:
  C:\Documents and Settings\<user>\Application Data\Attachmate\Reflection

- A Reflection subfolder located in the common Application Data folder.	For Windows 2000 and XP, the default location for this hidden folder is:
  C:\Documents and Settings\All Users\Application Data\Attachmate\Reflection

- The Reflection folder. The default path is:
  C:\Program Files\Attachmate\Reflection

If Profile8.rpf is found in any of these locations, Reflection for IBM sessions use the profiled settings.

Note: When you launch the Reflection for IBM Profiler from the Windows Start menu, profiles are saved by default to the Toolkit folder. The default location for this folder is:

  C:\Program Files\Attachmate\RToolkit

Profiler changes saved to this location have no effect on subsequent Reflection for IBM sessions. To test your changes on your workstation, copy the profile file to one of the supported locations listed above.

You can also use the Reflection Profiler to profile the SNA Engine settings. (The SNA Engine is used for 802.2, Coax DFT, and SDLC connections.) The profile file for SNA Engine settings is Snassc.dll. See SNA profiling in the Profiler Help for more information.
VT and HP Profiles

Use the Reflection VT and HP Profiler to profile the following Reflection applications. Profile information is saved to the profile file given in the table:

<table>
<thead>
<tr>
<th>Reflection Application</th>
<th>Profile File</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reflection for HP</td>
<td>Profile1.rpf</td>
</tr>
<tr>
<td>Reflection for UNIX and OpenVMS</td>
<td>Profile2.rpf</td>
</tr>
<tr>
<td>Reflection for ReGIS Graphics</td>
<td>Profile4.rpf</td>
</tr>
</tbody>
</table>

Reflection looks for the profile file in the following locations:

- A Reflection subfolder located in the personal Application Data folder. For Windows 2000 and XP, the default location for this hidden folder is:
  
  C:\Documents and Settings\<user>\Application Data\Attachmate\Reflection

- A Reflection subfolder located in the common Application Data folder. For Windows 2000 and XP, the default location for this hidden folder is:

  C:\Documents and Settings\All Users\Application Data\Attachmate\Reflection

- The Reflection folder. The default path is:

  C:\Program Files\Attachmate\Reflection

If Profile<n>.rpf is found in any of these locations, the associated Reflection sessions use the profiled settings.

When you launch the Reflection VT and HP Profiler from the Windows Start menu, profiled changes are saved to the Reflection folder and affect all subsequent Reflection sessions on your workstation.
X Profiles

The Reflection X Profiler saves profile information in a file called Rx.ini. Reflection looks for this file in the following locations, and in the following order:

- A Reflection\X subfolder located in the common Application Data folder. For Windows 2000 and XP, the default location for this hidden folder is:
  C:\Documents and Settings\All Users\Application Data\Attachmate\Reflection\X

- A Reflection\X subfolder located in the personal Application Data folder. For Windows 2000 and XP, the default location for this hidden folder is:
  C:\Documents and Settings\<user>\Application Data\Attachmate\Reflection\X

- The Reflection folder. The default path is:
  C:\Program Files\Attachmate\Reflection

If Rx.ini is found in any of these locations, Reflection X sessions use the profiled settings.

Note: When you launch the Reflection X Profiler from the Windows Start menu, profiles are saved by default to the Toolkit folder. The default location for this folder is:

  C:\Program Files\Attachmate\RToolkit

Profiler changes saved to this location have no effect on subsequent Reflection X sessions. To test your changes on your workstation, copy the profile file to one of the supported locations listed above.
Group Policy Settings

Reflection’s Group Policy support provides administrators with an added tool for customizing and securing Reflection applications. Examples of customizations that can be made using Windows Group Policies include: allowing only secure, encrypted connections; disabling macros; disabling password saving; and disabling file transfers to and/or from host computers.
How To Install and Use Group Policies

To use policies, the Reflection policy template must first be added to your Windows Group Policy editor by installing the Reflection Administrator’s Toolkit and adding the file ReflectionPolicy.adm to the editor. Each setting includes a description of what it can do.

Follow these steps to add the Reflection policy template to the Group Policy Editor:

1. Run Gpedit.msc from the command line, or open the properties for an Organizational Unit in the Active Directory Users and Computers console, click the Group Policy tab, and edit or create a new policy object.
2. Expand the User Configuration tree.
3. Right-click the Administrative Templates container and select Add/Remove Templates.
4. In the Add/Remove Templates dialog box, click Add and browse to the \%systemroot\%inf folder (for example, “C:\Windows\inf”).
5. Select the file ReflectionPolicy.adm. Open the template, and then close the Add/Remove Templates dialog box.

Once you have added the template, use it to configure one or more policies. In the procedure below, a policy is applied that disables unencrypted connections:

1. Click the Reflection Settings tree and, in the right pane, double-click Allow Unencrypted Connections.
2. On the Policy tab, select Disabled, and then click OK.

Browse through the other available Reflection policies, or refer to page 32 for a list of policies available in the Reflection policy template.
List of Available Group Policy Settings

The tables below provide a complete list of Reflection Group Policies and identify which Reflection applications support each policy.

For more information about each policy setting, click the Explain tab for that setting in the Windows Group Policy Editor.

Application abbreviation key:

<table>
<thead>
<tr>
<th>RIBM</th>
<th>Reflection for IBM</th>
<th>RRG</th>
<th>Reflection for ReGIS Graphics</th>
</tr>
</thead>
<tbody>
<tr>
<td>RHP</td>
<td>Reflection for HP</td>
<td>RX</td>
<td>Reflection X</td>
</tr>
<tr>
<td>RUO</td>
<td>Reflection for UNIX and OpenVMS</td>
<td>RFTP</td>
<td>Reflection FTP</td>
</tr>
<tr>
<td>RSIT</td>
<td>Reflection for Secure IT</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

View and edit the following settings under Local Computer Policy > User Configuration > Administrative Templates > Reflection Settings:

<table>
<thead>
<tr>
<th>Setting name:</th>
<th>RIBM</th>
<th>RHP</th>
<th>RUO</th>
<th>RSIT</th>
<th>RRG</th>
<th>RX</th>
<th>RFTP</th>
</tr>
</thead>
<tbody>
<tr>
<td>Allow Start Screen</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
</tr>
<tr>
<td>Allow Reflection to save passwords</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
</tr>
<tr>
<td>Allow files to be sent to host computers</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
</tr>
<tr>
<td>Allow files to be received from host computers</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
</tr>
<tr>
<td>Allow Sessions without Settings Files</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
</tr>
<tr>
<td>Language Override</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
</tr>
<tr>
<td>Allow tracing for troubleshooting</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
</tr>
<tr>
<td>Migration of settings from F-Secure to Reflection</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
</tr>
<tr>
<td>Allow Unencrypted Connections</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
</tr>
<tr>
<td>Allow non-FIPS mode</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
</tr>
<tr>
<td>Folder for the default Auto Update file</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
</tr>
<tr>
<td>Folder for the Shared Macros Settings File</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
</tr>
<tr>
<td>Settings only in these Folders</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
</tr>
</tbody>
</table>
View and edit these settings under **Local Computer Policy > User Configuration > Administrative Templates > Reflection Settings > When Reflection Exits:**

<table>
<thead>
<tr>
<th>Setting name</th>
<th>RIBM</th>
<th>RHP</th>
<th>RUO</th>
<th>RSIT</th>
<th>RRG</th>
<th>RX</th>
<th>RFTP</th>
</tr>
</thead>
<tbody>
<tr>
<td>Prompt if connected when user exits Reflection</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
</tr>
<tr>
<td>Prompt when exiting all Reflection sessions</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td></td>
<td>●</td>
</tr>
<tr>
<td>If there are unsaved changes</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
</tr>
</tbody>
</table>

View and edit these settings under **Local Computer Policy > User Configuration > Administrative Templates > Reflection Settings > Application Programming Interfaces:**

<table>
<thead>
<tr>
<th>Setting name</th>
<th>RIBM</th>
<th>RHP</th>
<th>RUO</th>
<th>RSIT</th>
<th>RRG</th>
<th>RX</th>
<th>RFTP</th>
</tr>
</thead>
<tbody>
<tr>
<td>Allow Reflection to run Visual Basic for Applications macros</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td></td>
<td></td>
<td></td>
<td>●</td>
</tr>
<tr>
<td>Allow scripts and macros on the startup command line</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td></td>
<td>●</td>
</tr>
<tr>
<td>Allow Reflection to process DDE requests</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td></td>
<td></td>
<td></td>
<td>●</td>
</tr>
<tr>
<td>Allow other applications to use Reflection’s DLL API</td>
<td>●</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Allow other applications to use Reflection’s HLLAPI interface</td>
<td>●</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Allow other applications to use Reflection’s OLE Automation interface</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td></td>
<td></td>
<td></td>
<td>●</td>
</tr>
<tr>
<td>Allow Reflection to run Reflection Basic scripts</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td></td>
<td></td>
<td></td>
<td>●</td>
</tr>
<tr>
<td>Allow Reflection to run RCL scripts</td>
<td></td>
<td></td>
<td>●</td>
<td></td>
<td></td>
<td></td>
<td>●</td>
</tr>
<tr>
<td>Allow Reflection FTP Client Scripting</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>●</td>
</tr>
</tbody>
</table>
View and edit the following setting under Local Computer Policy > Computer Configuration > Administrative Templates > Reflection Settings > Client Metering:

<table>
<thead>
<tr>
<th>Setting name:</th>
<th>RIBM</th>
<th>RHP</th>
<th>RUO</th>
<th>RSIT</th>
<th>RRG</th>
<th>RX</th>
<th>RFTP</th>
</tr>
</thead>
<tbody>
<tr>
<td>Configure Client Metering</td>
<td>•</td>
<td>•</td>
<td>•</td>
<td>•</td>
<td>•</td>
<td>•</td>
<td>•</td>
</tr>
</tbody>
</table>

**Note:** Unlike most Reflection settings, Reflection client metering is configured per computer (not per user). The client metering setting is located under **Computer Configuration** not **User Configuration**.
Making Secure Connections: Authentication and Data Encryption

Reflection products provide fully integrated support for secure authentication and data encryption.

Authentication is the process of reliably determining the identity of a communicating party. This can be done a number of ways, including passwords, credentials, or certificates.

Encryption refers to the process of scrambling data by use of a secret code or cipher so it is unreadable except by authorized users. Encrypted data is far more secure than unencrypted data.

Reflection applications support the following security protocols.

- SSL/TLS (pages 37-41)
- Secure Shell (pages 42-48)
- Kerberos (pages 52-55)
- XDM authorization (page 56)

To see which security protocols are supported by the Reflection application(s) you are using, refer to the table on page 36.

This chapter also describes the following utilities, which are available for configuring secure connections.

- Reflection Key Agent (page 47)
- Reflection Certificate Manager (page 50)
- Reflection Kerberos Manager (page 54)
The security protocols available to you depend on the Reflection application you are running. Refer to the table for details:

<table>
<thead>
<tr>
<th>Reflection Application</th>
<th>Supported Protocols</th>
<th>Authentication</th>
<th>Encryption</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reflection for IBM</td>
<td>Kerberos, SSL/TLS</td>
<td>•</td>
<td>•</td>
</tr>
<tr>
<td>Reflection for HP</td>
<td>Kerberos, SSL/TLS, Secure Shell</td>
<td>•</td>
<td>•</td>
</tr>
<tr>
<td>Reflection for UNIX and OpenVMS</td>
<td>Kerberos, SSL/TLS, Secure Shell</td>
<td>•</td>
<td>•</td>
</tr>
<tr>
<td>Reflection for Secure IT</td>
<td>Secure Shell</td>
<td>•</td>
<td>•</td>
</tr>
<tr>
<td>Reflection for ReGIS Graphics</td>
<td>Kerberos, SSL/TLS, Secure Shell</td>
<td>•</td>
<td>•</td>
</tr>
<tr>
<td>Reflection X</td>
<td>Kerberos, Secure Shell, XDM Authorization 1</td>
<td>•</td>
<td>•</td>
</tr>
<tr>
<td>Reflection FTP Client</td>
<td>Kerberos, SSL/TLS, Secure Shell</td>
<td>•</td>
<td>•</td>
</tr>
<tr>
<td>Reflection SFTP Client</td>
<td>Secure Shell</td>
<td>•</td>
<td>•</td>
</tr>
</tbody>
</table>

a. You can configure Reflection for IBM 5250 terminal to sign onto IBM hosts using your Windows credentials. This authentication method uses iSeries Kerberos, which works in conjunction with IBM’s Enterprise Identity Mapping (EIM). Reflection for IBM does not support the full range of Reflection Kerberos features.
b. Reflection X supports 56-bit DES encrypted XDM-Authorization-1 protocol. This does not encrypt the login data sent using X-11 protocol.
c. Only the Telnet connection is encrypted, the X-11 protocol data stream is not encrypted.
This legend explains symbols used in security diagrams in this chapter:

### LEGEND
- 🗝️ Secure Authentication
- 🗠️ Encrypted
- 🔒 Unencrypted
- 📜 Data

**Note:** Prior to version 11.0, security support was provided by an add-on product called Reflection Security Components. This add-on product is no longer needed. Support for secure protocols is now fully integrated into Reflection applications, and installed by default.

### SSL / TLS Encryption

The Secure Sockets Layer protocol (SSL) and its compatible successor, the Transport Layer Security protocol (TLS), provide an industry standard for making secure connections. SSL and TLS protocols allow a client and server to establish a secure, encrypted connection over a public network. When you connect using SSL/TLS, Reflection authenticates the server before making a connection, and all data passed between Reflection and the server is encrypted.
Use the SSL/TLS tab of the Security Properties dialog box to configure SSL/TLS encrypted connections. For a step-by-step procedure, see SSL/TLS encryption, how to configure in the Reflection application Help index.

Authentication in SSL/TLS sessions

Before making an SSL/TLS connection, Reflection must authenticate the host (server). In addition, some servers may also require the user (client) to present a certificate for user authentication. When Reflection is configured to use SSL/TLS security, authentication is handled with digital certificates. These certificates are part of the same Public Key Infrastructure (PKI) that is used to secure internet transactions.

Your computer must be configured to recognize the digital certificate presented by your host and, if necessary, to provide a certificate for client authentication. If your computer is not properly configured, or if the certificates presented for authentication are not valid, you will not be able to make SSL/TLS connections.
Depending on how your digital certificates are issued, you may need to install certificates on your computer before you can connect using SSL/TLS security.

- If your host certificates were acquired from a well-known certification authority (CA), such as VeriSign or Thawte, and you have configured Reflection to support host authentication using the Windows system certificate store, you do not need to install any host certificates on your computer. A certificate identifying the issuer as a trusted CA should already be included in the Trusted Root Certification Authorities list on your system.

- If you have configured Reflection to require authentication using the Reflection store, each client computer must import required CA certificate(s) into the Reflection store.

- If your enterprise has created its own certification authority, each client computer must import the root certificate for your CA. Depending on your configuration, import it into either the Windows or Reflection certificate store.

- If the host creates its own self-signed certificates, each client computer must install any needed certificates. Depending on your configuration, import them into either the Windows or Reflection certificate store.

- If the host requires a client certificate for user authentication, you need to import the personal certificate. You can use either the Reflection or the Windows personal certificate store.

For more information about the Reflection PKI support, see page 49 in this manual and in Reflection on

For information about Reflection PKI support, see page 49 in this manual and also see PKI in the Reflection Help index.

**Deploying SSL/TLS Settings to Other Users**

SSL/TLS settings are saved to your Reflection settings files. Administrators can use Reflection Customization Manager to distribute settings files to end users. Certificate management must be handled individually on each user computer.
Reflection Proxy Server

An additional option for configuring secure SSL connections is to use the Reflection security proxy, which is available with Reflection Administrator. (See page 11 for information about this add-on Reflection product.) You can use the security proxy to configure secure connections even if your host is not running an SSL/TLS Telnet server. For example, you can use the proxy server if you are connecting to a host using VT-MGR and you want to configure secure SSL/TLS connections. Data transmitted between Reflection and the proxy server is encrypted; data sent from the proxy server to the destination host is unencrypted.

To support such connections, you must install and configure the proxy server, provide a server certificate on all workstations that will be connecting through the server, and create a Reflection settings file configured to connect through the proxy server.
If you are using the Reflection security proxy server, you can take advantage of the Reflection for the Web Administrative WebStation for creating and distributing your settings files. When you launch Reflection in Administrative WebStation mode (see page 60), the SSL/TLS tab of Security Properties dialog box includes additional list boxes that make it easy to create sessions that connect to hosts you have configured on the proxy:
Reflection Secure Shell Support

You can configure Reflection to use Secure Shell when you need secure, encrypted communications between a trusted host and your computer over an insecure network. When you configure Reflection to use Secure Shell, all connections between your computer and the remote host(s) are encrypted, protecting the data sent between these computers. Passwords are never sent over the network in a clear text format as they are when you use Telnet, FTP, rlogin, or rsh.
Reflection Secure Shell support includes:

- Secure connections to both ssh1 and ssh2 protocol servers.
- Standard Secure Shell features including: TCP port forwarding (including X-11),
data stream compression and encryption, authentication (password, keyboard
interactive, public key, or Kerberos/GSSAPI), and logging.
- A user key generation tool that enables you to create RSA, RSA1, and DSA keys.
- Tools for uploading public keys to your Secure Shell server. Reflection automati-
cally detects the server type, exports the correct key type, and installs it in the
correct location on the server.
- Tools to view and manage trusted host keys.
- A Key Agent utility that enables you to manage multiple keys and certificates
with a single passphrase, and forward authentication to additional servers. (For
more information about the Reflection Key Agent, see page 47.)
- PKI support, including a certificate manager that enables you to manage certifi-
cates in a Reflection-specific certificate store. You can also configure Reflection
to use certificates in the Windows store, or on smart cards or other PKCS #11-
compliant hardware devices. (For more information about the Reflection Certi-
ficat Manager, see page 50.)
- Secure SFTP file transfer.
- Standalone DOS command-line utilities for ssh, ssh-keygen, sftp, and scp.
When Secure Shell is the selected connection method, you can open the Reflection Secure Shell Settings dialog box to customize your Secure Shell settings.
The Secure Shell dialog box also includes tools for managing user and host keys.

For detailed information about configuring Secure Shell connections use the Help buttons in the Secure Shell Settings dialog box, or see Secure Shell in the Reflection application Help index.
Port Forwarding

Port Forwarding, also known as tunneling, provides a way to redirect commonly insecure TCP communications through the secure SSH tunnel. After you have configured port forwarding in Reflection, you can configure a client application to exchange data securely with a server by configuring the client to connect to the redirected port instead of directly to the computer running the associated server. The client and server applications are otherwise unaffected by the Secure Shell tunnel.

For detailed information about configuring port forwarding in Reflection, see Port forwarding (Secure Shell) in the Reflection application Help index.

Deploying Secure Shell Settings to Other Users

The settings you configure using the Reflection Secure Shell Client Settings dialog box are saved to a Secure Shell configuration file (called config). Within this file, Reflection uses SSH config schemes to identify groups of Secure Shell settings. When you make a Secure Shell connection, Reflection uses the current SSH config scheme to determine how the connection should be made. These schemes apply to any Reflection application that supports Secure Shell. (For information about additional Secure Shell files, see Chapter 13.)

Administrators can use Reflection Customization Manager to distribute the Secure Shell configuration file to end users.

For details, install the Administrator Help feature, and see Secure Shell, deploying settings to other users in the Reflection Help index.
Reflection Key Agent

The Reflection Key Agent is a tool for creating and managing Secure Shell user keys and/or certificates.

The Key Agent:

- Stores keys securely in encrypted form.
- Enables you to access all stored keys and certificates with a single passphrase. Because keys are decrypted and stored in memory, only your initial passphrase is required. The agent handles all subsequent authentication using your stored keys and certificates.
- Supports agent forwarding to additional Secure Shell servers. This enables public key authentication to be used for additional Secure Shell connections without transporting the private key.
- Provides tools for key and certificate management including: creating new keys, importing existing keys, importing certificates from the Windows and Reflection certificate stores, deleting keys, and uploading the public key file to a specified server in the appropriate format.
- Maintains a log file to aid in troubleshooting.

For complete information about working with the Reflection Key Agent, see the Key Agent application Help.
Secure Shell Command Line Utilities

The Reflection Secure Shell Client includes the following DOS command-line utilities. The executable files that support these utilities are installed to your PC in the same location as your Reflection program files.

- ssh
- ssh-keygen
- sftp
- scp

For a list of available command line options use the -h switch on the command line. For example:

```
ssh -h
```

For detailed information about the command line utilities listed above, see the command line topics in the Reflection application Help.

The following additional utilities are provided for customers who are migrating from F-Secure and need to maintain scripts written for the F-Secure command line utilities. These utilities support the same switch set as their F-Secure equivalents. (Note: If you do not have scripts written for F-Secure command line utilities, we recommend that you use the utilities listed above.)

- ssh2
- sftp2
- scp2

For a quick summary of command line options use the -h switch on the command line. For details about these utilities, refer to F-Secure product documentation.
PKI Support in Reflection

A Public Key Infrastructure (PKI) is a system that helps facilitate secure communications through the use of digital certificates. Reflection supports the use of a PKI for host and user authentication during Secure Shell and SSL/TLS sessions.

Digital certificates are maintained on your computer in certificate stores. A certificate store contains the certificates you use to confirm the identity of remote parties, and may also contain personal certificates, which you use to identify yourself to remote parties. Personal certificates are associated with a private key on your computer.

Reflection can be configured to use digital certificates located in either or both of the following stores:

- **The Windows certificate store**
  This store can be used by a number of applications, including Reflection, web browsers, and mail clients. Some certificates in this store are included when you install the Windows operating system. Others may be added when you connect to internet sites and establish trust, when you install software, or when you receive an encrypted or digitally signed email. You can also import certificates manually into your Windows store. Manage the certificates in this store using the Windows Certificate Manager.

- **The Reflection certificate store**
  This store is used only by Reflection applications. To add certificates to this store, you must import them manually. You can import certificates from files and also use certificates on hardware tokens such as smart cards. Manage the certificates in this store using the Reflection Certificate Manager.

Reflection applications can be configured to authenticate using only those certificates located in Reflection store, or using both the Windows and the Reflection store. Enabling host authentication using the Windows certificate store means that you may not need to import certificates, because authentication may be accomplished using certificates that are already available. Disabling authentication using the Windows certificate store enables you to have greater control over which certificates are used for authentication.

For information about configuring PKI in Reflection, see *PKI* in the Reflection Help index.
Reflection Certificate Manager

Use the Reflection Certificate manager to manage the digital certificates in the Reflection certificate store and to configure other aspects of Reflection PKI support. The following tabs are available:

Personal
Use this tab to manage your personal certificates, which are used for user (client) authentication.

Trusted Certification Authorities
Use this tab to manage your trusted root certificates, which are used for host (server) authentication.

LDAP
Use this tab to configure Reflection to use an LDAP server for external CRL (Certificate Revocation List) checking and/or to store intermediate certificates.

PKCS #11
Use this tab to configure Reflection for user authentication using smart cards and other hardware tokens that conform to PKCS #11 specifications.

Note: Files created by the Reflection Certificate Manager are described on page 119. These files are used by both Reflection SSL/TLS and Reflection Secure Shell sessions.
To open the Reflection Certificate manager
You can open the Reflection Certificate Manager from either the Secure Shell Settings dialog box or the Security Properties dialog box.

From the Secure Shell Settings dialog box
1. Open the Secure Shell Settings dialog box.
2. On the PKI tab, click Reflection Certificate Manager.

Note: The Secure Shell Settings dialog box is not available in Reflection for IBM.

From the Security Properties dialog box
1. Open the Security Properties dialog box.
2. On the SSL/TLS tab, select Use SSL/TLS Security.
3. Click Configure PKI.
4. Click Reflection Certificate Manager.

Note: The Security Properties dialog box is not available in Reflection X or Reflection for Secure IT.

For complete information about working with the Reflection Certificate Manager, see Certificate management in the Reflection Help index.
Kerberos support

Kerberos is a secret-key-based security service that prevents unauthorized access to network services. When Reflection Kerberos support is enabled, Reflection communicates with a security server, exchanging a series of encrypted messages with the server to prove the user’s identity. The authentication process does not involve sending passwords across the network, so an attacker cannot intercept this information and use it to breach network security. Depending on the Reflection application you are using, you may also choose to encrypt the data stream.
Use the Kerberos tab of the Security Properties dialog box to configure Kerberos connections. For a step-by-step procedure, see *Kerberos, how to configure* in the Reflection application Help.
The Reflection Kerberos Manager

The Reflection Kerberos Manager is an optional utility available with Reflection that you can use to create or modify principal profiles, add or modify realms, set ticket options, import and export Kerberos settings, or perform other Kerberos management tasks.

Use either of the following procedures to launch the Reflection Kerberos Manager:

- Click the **Kerberos Manager** button on the Kerberos tab of the Security Properties dialog box.
- On the Windows **Start** menu, point to **Attachmate Reflection > Utilities > Kerberos Manager**.
Deploying Kerberos Settings to Other Users

The settings you configure using the Kerberos tab of the Security Properties dialog box are saved to your Reflection settings or client file. Administrators can use Reflection Customization Manager to distribute these files to end users.

Information that you configure about Kerberos principals, realms, and tickets using either the Kerberos Manager or the Reflection Kerberos Initial Configuration dialog box is saved in your Windows registry and this information applies to all installed Reflection applications that support Kerberos. You can import and export these settings using the Kerberos Manager’s **Export Settings** and **Import Settings** commands. Settings are saved to a file called Rsckrb5.xml. If this file is present in either the common application data folder or the user-specific application data folder the first time you use Reflection Kerberos, you do not need to use the **Import Settings** command; settings are imported automatically. System administrators can use the Reflection Customization Manager (available in the Reflection Administrator’s Toolkit) to add the configuration file to user installations.

For details, see the Kerberos Manager Help. On the Contents tab, open *How To > Import and Export Kerberos Realm Settings*. 
XDM Authorization

XDM Authorization is an option for improving the security of connections made with Reflection X using XDMCP. When XDM Authorization support is not configured, Reflection makes XDMCP connections using MIT-MAGIC-COOKIE-1 authorization. With magic cookie authorization, the authorization code is not encrypted. By installing and configuring Reflection XDM Authorization support, you can make XDMCP connections using XDM-AUTHORIZATION-1. This method is similar to MIT-MAGIC-COOKIE-1, but provides added security by encrypting the authorization code using DES (Data Encryption Standard) encryption. Although XDM-AUTHORIZATION-1 improves the security of the authorization process, it does not encrypt subsequent data sent over the connection, including the username and password entered in the XDMCP login window.

**XDM-AUTHORIZATION-1 (FOR AUTHENTICATION ONLY)**

For information about how to configure XDM Authorization on both the PC and the host, see *XMD Authorization* in the Reflection X application Help.
Using Web Pages to Install Reflection Software and Launch Reflection Sessions

Web pages can help simplify the distribution of Reflection software and make it easy to launch Reflection sessions. The tools discussed in this chapter can help you create web pages with links that:

- Install customized Reflection software on user workstations.
- Launch pre-configured Reflection sessions.

To create web pages to install Reflection software on user workstations, use the Reflection Customization Manager. For more information, see page 58.

To create web pages that launch Reflection sessions on systems that already have Reflection software installed, you can use the Reflection Administrative WebStation. Use can use the WebStation to:

- Create web pages that securely copy Reflection session files to user workstations and launch Reflection sessions using these files.
- Choose between maintaining session files centrally on a web server, or allowing users to maintain their session files locally after the initial download.
- Manage Web-based Reflection sessions (which don’t require users to install Reflection software) and Windows-based Reflection sessions (which offer a greater range of features).
- Use the WebStation’s access control and LDAP integration to determine which Reflection sessions are available to particular users or groups of users.
- Easily configure Windows-based Reflection sessions that use the Reflection for the Web security proxy.

The Reflection Administrative WebStation is available with Reflection Administrator, an add-on product described on page 11. For more information about using the WebStation, see page 59.
Using Reflection Customization Manager for Web-based Installations

The Reflection Customization Manager is installed when you install the Reflection Administrator Toolkit. Customization Manager can help you create a web deployment package file that can install, remove, repair, or redeploy Reflection at the user's workstation.

The Customization Manager Help includes a detailed procedure describing how to deploy Reflection from a web page. To launch the Customization Manager and view this procedure:

1. On the Windows Start menu, point to Programs > Attachmate Reflection > Administrative Tools > Customization Manager.

2. Click Help. On the Contents tab, select How to > Deploy Reflection > Using a link in a web page.
Working with the Reflection Administrative WebStation

Administrators who have installed and configured Reflection Administrator (see page 11) can use the Reflection Administrative WebStation to administer Web- and Windows-based Reflection sessions. Use this administrative tool to:

- Administer all of your Reflection sessions from a single console.
- Use the WebStation's access control and LDAP integration to determine which Reflection sessions are available to particular users or groups of users.
- Use the Reflection security proxy to provide secure connections for Windows-based Reflection sessions as well as Reflection for the Web sessions.

Session Manager
Add New Reflection Session

<table>
<thead>
<tr>
<th>Session type</th>
<th>Web-Based</th>
<th>Windows-Based</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>FTP</td>
<td>FTP</td>
</tr>
<tr>
<td></td>
<td>HP</td>
<td>HP</td>
</tr>
<tr>
<td></td>
<td>IBM 3270</td>
<td>IBM 3270</td>
</tr>
<tr>
<td></td>
<td>IBM 3270 Printer</td>
<td>IBM 3270 Printer</td>
</tr>
<tr>
<td></td>
<td>IBM 5250</td>
<td>IBM 5250</td>
</tr>
<tr>
<td></td>
<td>IBM 5250 Printer</td>
<td>IBM 5250 Printer</td>
</tr>
<tr>
<td></td>
<td>IBM AS/400 Data Transfer</td>
<td>VT UNIX and OpenUMS</td>
</tr>
<tr>
<td></td>
<td>VT</td>
<td>VT RegIS</td>
</tr>
<tr>
<td></td>
<td></td>
<td>X</td>
</tr>
<tr>
<td></td>
<td></td>
<td>SFTP - Reflection for Secure IT</td>
</tr>
<tr>
<td></td>
<td></td>
<td>SSH - Reflection for Secure IT</td>
</tr>
</tbody>
</table>

Session name

The name identifies the session to Reflection users.

Continue
Begin configuring the session.
When you create or edit Windows-based Reflection sessions from the Administrative WebStation, Reflection runs in Administrative WebStation mode. In this mode, your sessions are saved automatically to the web server, and the Reflection Management server automatically creates web pages with links that can be used to launch your sessions.

The following steps outline how to use the Reflection Administrative WebStation to configure Windows-based Reflection sessions.

1. Install your Windows-based Reflection product on the administrative and end-user workstations.

2. Install the Reflection management server on the web server.

3. Launch the Administrative WebStation, open the Session Manager, and click **Create New Session**.

4. Click **Add**.

5. In the Add New Reflection Session page, select a session type, enter a session name, and click **Continue**.

6. Specify your preferences for how files will be copied to user workstations, then click **Launch**. This launches a Reflection session on your workstation in Administrative WebStation mode.

7. Configure the Reflection session.

   **Tip:** You can use the **File > Open** command to import settings from an existing settings or client file.

8. Save your settings. Files saved when you launch from the Administrative WebStation are automatically saved to your web server. The Windows-based Reflection session exits and you are returned to the Administrative WebStation.

9. Use the Access Mapper to determine which sessions will be available to which users.

10. Point users to the Reflection URL (for example http://myserver/rweb) to access Reflection sessions.

   **Note:** You can configure secure connections using the built-in Reflection security support or you can use the Reflection proxy server. If you have configured the proxy server, Reflection sessions you launch from the Administrative WebStation include additional options for configuring SSL/TLS sessions using the proxy server. See page 40 for more information.
Metering Reflection Products

Administrators who have installed and configured Reflection Administrator (see page 11) can use the Reflection metering server to audit both Windows- and Web-based Reflection sessions. Metering options include:

- Reports detailing when and how Reflection is being used.
- Tools for monitoring license compliance. You can configure the server to notify you via email when the number of users exceeds your specified number of licenses; and/or you can enforce a license limit, preventing Reflection from launching on additional desktops once the license limit is reached.

Configuring Metering

To monitor Windows-based Reflection products using the Reflection metering server:

1. Install the metering server. You can use the default metering server configuration or, optionally, configure your own metering server preferences.
2. Configure Reflection workstations to report to the server.

Installing the Reflection Metering Server

The Reflection metering server is installed by default when you use the automated Reflection Administrator installer. If you want to use the default metering configuration options, the server is ready to use when the automatic installation is complete. No further configuration is necessary.
Reflection Administrator installation notes:

- In addition to installing the Reflection metering server, a default automatic installation includes the Reflection management server, which you can use to manage both Windows- and Web-based Reflection sessions (see Chapter 6) and the Reflection security proxy (see Chapter 5).

- If you want to use a servlet runner other than the one automatically installed with Reflection (Tomcat), or if you are installing on a platform for which an automatic installer is not provided, you can perform a manual installation.

In most cases you can use the default metering server configuration. Use the Configure Metering Server page only if you want to view and/or change the default configuration. To do this:

1. Use either of the following techniques to open your browser to the metering server logon page:

   If you installed to a server running Windows:
   
   Go to **Start > Programs > Attachmate Reflection Administrator > Metering Configuration**.
   
   Or,

   Open a browser and go to the metering configuration URL, which will be in this form:

   http://[host name]:[port number]/[metering server context name]/AdminStart.html

   If you used the default port, you can omit the port number.

   For example:

   http://Myserver.com/rwebmeter/AdminStart.html
2. Enter your password. (If you used an automated installer, you entered a password during installation. If you have not specified a password, the default is admin.)

3. Next to **Change metering options**, click Configure.

![Metering Reflection Products](image)

<table>
<thead>
<tr>
<th><strong>Password</strong></th>
<th><strong>User name</strong></th>
<th><strong>Default address</strong></th>
<th><strong>Default port</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Admin password</td>
<td>admin</td>
<td>192.168.1.10</td>
<td>8080</td>
</tr>
</tbody>
</table>

**Notification**
- **Time log file for** (in hours): Set the time log file for notification.
- **Notify if the network is down** (in minutes): Set the time log file for notification.

**Default mail notification options**
- **Mail notification options** (in minutes): Set the time log file for notification.
- **Mail notification options** (in minutes): Set the time log file for notification.

**Submit** | **Cancel** | **Help**
Configuring Reflection Workstations to Report to the Metering Server

To configure Reflection workstations to report to the metering server, you can use either or both of the following strategies:

- Use the Reflection Customization Manager to create a customized Reflection installation that includes metering configuration information.
- Use Reflection's Group Policy settings to configure metering information.

Configuring Metering using the Customization Manager

You can use the Reflection Customization Manager (described in Chapter 3) to create a customized Reflection installation that will automatically configure Reflection workstations for metering. To do this:

1. Open the Reflection Customization Manager (Start > Programs > Attachmate Reflection > Administrative Tools > Customization Manager).
2. If you have not already created an administrative installation of Reflection, use the Prepare button to do this.
3. Click Customize in the left pane, then click Open Installation. Select Customize a Reflection installation and locate the Reflection installation package (*.msi) in your administrative installation point. You will be asked to specify a transform file name (*.mst). This file will contain your customization information.
4. Click Metering Options.
5. In the Set Metering Options dialog box:
   - Select **Enable metering**.
   - Enter the URL of your metering server. The metering server URL will be in this form:
     
     ```
     http://[host name]:[port number]/[metering server context name]/meter.do
     ```

     If you used the default port, you can omit the port number.

     For example:
     
     ```
     http://Myserver.com/rwebmeter/meter.do
     ```

   - Specifying a VPA number to identify the metered product is optional. The VPA number is required only if you want to monitor multiple Reflection products and these products use different VPA numbers. If you omit this value, the metering server uses zero.

   - Do not select **Require metering server** unless you want to prevent users from launching Reflection when the metering server is not available. (Enabling this setting can be useful when you are creating a trial installation and want to test to see if the metering server is running and available.)
6. Click **OK** to return to the Customization Manager. You can create additional customizations, or use the Deployment Utilities option to create a shortcut to your customized installation.

![Reflection Customization Manager](image)

**Note:** Because the metering web server URL that you specify becomes a permanent part of the Reflection installation, you should always test your customized Reflection installation carefully on a test workstation to ensure that the server is successfully monitoring Reflection activity on that workstation. The Customization Manager can only configure settings at installation time; it cannot be used to update the URL after your customized installation is complete. (If you use Group Policy at your site, you will probably prefer to use the that approach to configuring metering, as described below. Group Policy settings are easily updated.)

**Configuring Metering using Group Policy**

An alternative way to configure metering is to use Reflection's Group Policy support (described in Chapter 4). This technique is convenient if you use Active Directory. To configure client metering using Group Policy:

1. If you have not already done so, install the Reflection policy template. (See page 31.)

2. Open the Group Policy editor (**Start** > **Run** > **gpedit.msc**).

3. Go to **Computer Configuration** > **Administrative templates** > **Attachmate Reflection Settings** > **Client Metering**.
4. Open the Configure Client Metering Properties dialog box and configure metering as follows:

- Select **Enabled**.

- Enter the URL of your metering server. The metering server URL will be in this form:

  http://[host name]:[port number]/[metering server context name]/meter.do

  If you used the default port, you can omit the port number.

  For example:

  http://Myserver.com/rwebmeter/meter.do

- Do not select **Require connection to metering server** unless you want to prevent users from launching Reflection when the metering server is not available. (Enabling this setting can be useful when you want to test to see if the metering server is running and available.)
Adding and Configuring Reflection License Pools

A license pool comprises the licenses for a given Reflection product name, type, and VPA number. Although it is possible to manually add licenses to the license pool list, you don’t need to do this; license pools are added automatically the first time a Reflection client requests a license. If you want to use the default license pool settings, no further action is necessary. (If you want to enforce concurrent license limits, you will need to edit the license pool configuration as described below.)

<table>
<thead>
<tr>
<th>License Pool Settings</th>
</tr>
</thead>
<tbody>
<tr>
<td>The metering server adds a license pool automatically the first time a metered client is run.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Product Type</th>
<th>VPA Number</th>
<th>License Limit</th>
<th>License Type</th>
<th>Enforcement</th>
<th>Notify</th>
</tr>
</thead>
<tbody>
<tr>
<td>Predix Reflection</td>
<td>12345</td>
<td>1000</td>
<td>Concurrent</td>
<td>No</td>
<td></td>
</tr>
</tbody>
</table>

If you want to view and/or edit the current list of license pools:

1. Use either of the following techniques to open your browser to the metering server logon page:

   - If you installed to a server running Windows:
     
     Go to **Start > Programs > Attachmate Reflection Administrator > Metering Configuration**.

   - Or,

     Open a browser and go to the metering configuration URL, which will be in this form:

     http://[host name]:[port number]/[metering server context name]/AdminStart.html

     If you used the default port, you can omit the port number.

     For example:

     http://Myserver.com/rwebmeter/AdminStart.html

2. Enter your password. (If you used an automated installer, you entered a password during installation. If you have not specified a password, the default is admin.)
3. Click on any product listed to view and/or edit the current settings for that product.
Viewing Metering Reports

To view the metering reports, open the metering request report page:

1. Use either of the following techniques to open your browser to the metering report logon page:

   If you installed to a server running Windows:
   
   Go to **Start > Programs > Attachmate Reflection Administrator > Metering Reports**.
   
   Or,
   
   Open a browser and go to the metering reports URL, which will be in this form:
   
   `http://[host name]:[port number]/[metering server context name]/ReportsLogin.do`
   
   If you used the default port, you can omit the port number.
   
   For example:
   
   `http://Myserver.com/rwebmeter/ReportsLogin.do`

   It is also possible to view Reports using the Reflection Administrative WebStation. Configure the WebStation to look for reports provided by your metering server using **Tools > Reports > Usage Metering**.

   A variety of report options are available for both Reflection product usage and host connections. Use the Help on the metering reports page for information about configuring and viewing reports.
Supporting Reflection on Windows Terminal Servers

Reflection products and components are designed to run in Windows Terminal Server environments where a site is implementing terminal services for access to their Windows applications. This chapter provides a brief overview of the installation requirements as well as where to go for more information about running Reflection in this environment.

Product Requirements

Reflection is supported under the NT family of Windows servers, with or without Citrix MetaFrame XP 1.0 and MetaFrame 1.8. Support is provided in the Windows 2000 Server and Windows Server 2003 family of servers by installing the Terminal Services component. Some additional configuration may be required to suit the specific site environment.

The workstation can be either Windows 2000, or Windows XP. In all cases, the Remote Desktop Connection client software must be installed.

Citrix Metaframe Support

Citrix MetaFrame XP 1.0 and MetaFrame 1.8 are application server software packages that give the administrator greater command over networked applications in an enterprise environment. As a MetaFrame administrator, you have the ability to control the way your users run networked applications. A typical user will see only the applications that are “published” to the Citrix Program Neighborhood. In the MetaFrame environment, a published application is one whose icon can be seen on the client workstation inside the Citrix Program Neighborhood.

For more information about Citrix and Reflection, see Technical Note 1097 at http://support.wrq.com/techdocs/1097.html.
## Which Reflection Products Run on Terminal Servers?

Use the following table to determine which Reflection products run under Windows Terminal Server (WTS):

<table>
<thead>
<tr>
<th>Product Name</th>
<th>Works in WTS Environment?</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reflection for UNIX and OpenVMS</td>
<td>Yes.</td>
</tr>
<tr>
<td>Reflection for HP with NS/VT</td>
<td>Yes.</td>
</tr>
<tr>
<td>Reflection for IBM</td>
<td>Yes, with exceptions. This product includes transport types that run in the WTS environment only with restrictions. The SNA engine was designed to run on individual PC workstations. Modifications have been made to enable the SNA engine to function in a Terminal Server environment, but it can handle only a limited number of simultaneous connections (10 or less). For this reason, using Telnet is strongly recommended in the IBM environment. Telnet and Telnet Extended connections do work in this environment. DLC is a network protocol that is not designed for, and does not work in this environment.</td>
</tr>
<tr>
<td>Reflection X</td>
<td>Yes.</td>
</tr>
<tr>
<td>Reflection NFS Client</td>
<td>Yes. Reflection NFS is a network protocol and will run in this environment.</td>
</tr>
<tr>
<td>Reflection for Secure IT</td>
<td>Yes.</td>
</tr>
<tr>
<td>Security in Reflection products</td>
<td>Yes. Reflection Security can be used to encrypt data between the Windows Terminal Server and the destination proxy server or host. To protect the data from the server to the client, users must configure WTS to enable encryption between these points.</td>
</tr>
</tbody>
</table>
Use this list to determine which Reflection components work under Windows Terminal Server:

<table>
<thead>
<tr>
<th>Component Name</th>
<th>Works in WTS Environment?</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reflection FTP Client</td>
<td>Yes.</td>
</tr>
<tr>
<td>Reflection LPD Server</td>
<td>No. LPD is a network service and cannot run in this environment.</td>
</tr>
<tr>
<td>Reflection Ping</td>
<td>Yes. When using the Find Route feature, keep in mind that the ping is being initialized from the WTS, not the client PC.</td>
</tr>
<tr>
<td>Reflection TimeSync</td>
<td>No. TimeSync is a network service and cannot run in this environment.</td>
</tr>
<tr>
<td>Reflection Virtual Desktop (not supported under Windows XP)</td>
<td>This component has not been developed for the WTS environment. It adds unnecessary overhead and so should not be installed in the WRS environment.</td>
</tr>
</tbody>
</table>

**Installing Reflection: General Notes**

Technical Note 1606 (http://support.wrq.com/techdocs/1606.html) provides information on installing Reflection under Windows 2000 Terminal Server. Please note the following exceptions and guidelines before and during the installation of Reflection to WTS:

- Perform the installation after normal working hours so that rebooting the server will cause the least disruption.
- Be sure the Windows server is using the very latest Service Packs.
- Be sure that Windows Terminal Services is installed on the server.
- Log in as administrator or with elevated privileges.
- Do not install Reflection Virtual Desktop, TimeSync, or LPD.
Additional Help

More information about installing Reflection products under Windows Terminal Server can be found in the application Help. Open Help using any Help button in the Reflection product you are using and search the index for "Windows Terminal Server" and "Citrix MetaFrame support."

AttachmateWRQ Technical Note Library

The Technical Note Library provides easy-to-use documents about installing Reflection products under Windows Terminal Server. The library is available online at http://support.wrq.com/techdocs/.

Of special interest to WTS users is Technical Note 1097, which is an overview of topics relating to WTS. See this note at http://support.wrq.com/techdocs/1097.html.
Administering Reflection for IBM
Files Used by Reflection for IBM

This chapter describes files that store Reflection for IBM configuration information.

Settings Files

Reflection settings files generally contain information your users need for connecting to your host. They can also include any customizations you’ve made to the display, toolbars, hotlists, hotspots, menus, macros, keyboard, or mouse setup. By default, Reflection saves settings to a complete settings file. Double-clicking a complete settings file Launches Reflection with the configurations specified in that file.

Administrators can make settings files available to users in a number of ways, including:

• Use the Reflection Customization Manager (described in Chapter 3) to add settings files to a customized Reflection installation.

• Create web pages with links that download and launch settings files. See Chapter 6 for details.

• Copy settings files to a shared network location and provide users with shortcuts that point to these files.

Complete (Default) Settings Files

When you save a settings file using the default values in either the Save As or Save dialog box, Reflection creates a complete settings file. Opening a complete settings file configures all of your Reflection settings.

Settings files are specific to individual Reflection applications. Reflection for IBM settings files use an *.rsf file extension.
Partial Settings Files

By default, settings files contain information about every aspect of your Reflection configuration. To save or load a settings file that contains information about only a specific aspect of Reflection's configuration, you can use a partial settings file.

When you save or open a partial settings file, you save or update only the relevant part of your configuration. To copy the contents of a partial settings file into your regular settings file, open the regular settings file, open the partial settings file, and then save the regular settings file.

Reflection for IBM uses the following partial settings file types:

<table>
<thead>
<tr>
<th>Type of Partial Settings</th>
<th>File Extension</th>
</tr>
</thead>
<tbody>
<tr>
<td>Key/Mouse map</td>
<td>.map</td>
</tr>
<tr>
<td>Toolbar</td>
<td>.btp</td>
</tr>
<tr>
<td>Colors</td>
<td>.clr</td>
</tr>
<tr>
<td>Hotspot/Hotlist</td>
<td>.hsp</td>
</tr>
<tr>
<td>Menus</td>
<td>.mnu</td>
</tr>
</tbody>
</table>

Settings Update Files

Settings update files contain information about specific settings only. When you open a settings update file, only those settings are changed. Settings update files allow you to share one or more settings with other Reflection users without changing their other settings. For example, you could create an update file that specifies a new printer destination. When other users open this file, the printer name is updated without affecting any other settings. Users who open this file can open the File menu and click Save to incorporate this change into their existing settings file.

Settings update files are similar to partial settings files, as both update a subset of Reflection settings. However, partial settings files save every setting in a related group of settings, while settings update files include only those settings that are changed from the default when you create the update file. Use settings update files when you want to share only specific settings without overwriting others.

To create a settings update file, use the Save or Save As command on the File menu, and change **Save as type** to **Settings Update (*.rsu)**.

Reflection for IBM settings update files use an *.rsu file extension.
Configuring Automatic Updates of User Settings Files

You can use settings update files to configure ongoing, automatic updates of end-user settings. To do this, maintain a settings update file on a shared network server, and create end-user settings files that specify the location of the update file using the **Auto Update File** setting (Setup > View Settings > Auto Update File). Reflection checks for new settings in the update file each time the end user opens this settings file. You can use UNC path names or URLs to specify an update file located on a network server, as shown in these examples.

Sample UNC path:

`\MyServer\Reflection\Update Demo.rsu`

Sample URL:

`HTTP://Myserver.com/Update Demo.rsu`

**Note:** By default, Reflection looks for a settings update file called *Settings.rsu* in the Reflection user folder. This means that you can place a settings update file in this default location and the updates will be applied automatically even if you have not explicitly specified a value for **Auto Update File**. For example, if you are running a default configuration of Windows XP or Windows 2000 and installed Reflection for IBM using default values, Reflection will automatically check for updates in the following location:

`C:\Documents and Settings\<user>\My Documents\Reflection\Settings.rsu`

You can change the default value of the **Auto Update Setting** using the “Folder for the default Auto Update file” Group Policy setting. See Chapter 4 for more information.

For more information about working with settings update files, including step-by-step procedures, see *Settings update files* in the Reflection Help index.
Settings Files that Include Macros

When you first create a macro, you can run it and edit it, but it is not yet saved to a file. Either of the following actions saves both your macros and your current settings. By default, macros are saved to the current settings file.

• In Reflection, click **Save** or **Save As** on the File menu.
• In the Visual Basic Editor, click **Save <current settings file>** on the File menu.

**Note:** Prior to version 12.0 of Reflection for IBM, macros were not stored directly in your settings files. Macros (and other Visual Basic project information) were saved in files had the same base name as your settings file and used an *.rvx extension. This information is now saved directly in your complete (*.rsf) settings files; *.rvx files are no longer needed. When you open a pre-12.0 settings file, Reflection automatically updates the settings file format. The first time you save the file using a newer Reflection version, the *.rvx file is removed and the *.rsf file is saved in binary file format.

Layouts

If you frequently run two or more Reflection sessions simultaneously, you can use layout files to streamline your work. Layout files save your Reflection window arrangement. For example, if you regularly work with both a display and a printer session, you can create a layout to launch both sessions using your preferred arrangement. Layouts include all the saved Reflection sessions that are running when you create the layout. Layouts can include any of the following applications:

- Reflection for IBM
- Reflection for HP
- Reflection for UNIX and OpenVMS
- Reflection for Secure IT
- Reflection for ReGIS Graphics
- Reflection FTP Client

To create a layout, use **File > Layout > Save Layout As**. Click the **Shortcut** button if you want to create a shortcut to open your layout. You can open layouts using shortcuts, or from a Reflection session using **File > Layout > Open Layout**.

Layout files use an *.rlo file extension.
Converting Reflection Settings to Other Formats

You can convert Reflection settings to the following formats:

- Reflection for the Web (*.config) files
- XML Settings (*.xml)

Migrating Settings to and from Reflection for the Web

Reflection for the Web provides easy and secure access to host applications from within a web browser. If you are currently using Windows-based Reflection applications, you may find that you can reduce the cost of deploying and maintaining host access to some users by using Reflection for the Web. If you are currently using Reflection for the Web, you may want to install Windows-based Reflection on some workstations to take advantage of its full range of features. You can use the Reflection for the Web Administrative WebStation (described on page 59) to administer all of your Reflection sessions.

Converting Reflection settings that are supported in both Windows and Web-based Reflection products is a simple, one-step process. To import Reflection for the Web files, use File > Open, then set Files of type to Reflection for the Web (*.config). Reflection for the Web settings that can be converted are imported into your current session. To export supported settings to Reflection for the Web format, use File > Save As, then set Save as type to Reflection for the Web (*.config).

Saving Settings in XML Format

Extensible Markup Language (XML) is an industry standard markup language for identifying and displaying structured information retrieved from a wide variety of applications. Reflection settings can be exported to XML format.

To export your current Reflection settings to XML format, use File > Save As, then set Save as type to XML Settings (*.xml).

You can view XML documents in any text editor. Or, to see a formatted document with settings information, open the converted XML file in Internet Explorer. (The display you see in Internet Explorer is controlled by the value of the Transform Settings To HTML setting. By default, this setting identifies a transform file that displays the XML file as formatted HTML when you open it in Internet Explorer.)

Transform files that are installed with Reflection can be used in combination with the TransformXML method to convert XML settings to a number of other formats. See TransformXML method in the Reflection Help index for details.
Transfer Request and Batch Transfer Files

File transfer settings can be saved to a transfer request file. Transfer request files enable you to perform the same transfer (or transfers) again later, without having to specify files and options each time.

To create and use transfer request files, use the Save and Open buttons on the File Transfer dialog box.

Tip: You don’t need to launch Reflection to run 5250 session transfer requests. When you save a transfer request file, you can create a shortcut that you can use to run the transfer in a single step.

Transfer request file extensions depend on your session type:

<table>
<thead>
<tr>
<th>Session Type</th>
<th>Transfer Request File Extension</th>
</tr>
</thead>
<tbody>
<tr>
<td>5250</td>
<td>.xto</td>
</tr>
<tr>
<td>3270</td>
<td>.mto</td>
</tr>
</tbody>
</table>

For more information, see Transfer request files in the Reflection Help index.

Batch File Transfer

If you routinely need to perform a group of transfer operations, you can create transfer request files that perform batch transfers in a single operation. Use the Batch tab in the Transfer dialog box to save and manage batch transfers. When you perform a series of transfers, successful transfers are automatically added to a list of transfers on the Batch tab. You can use this tab to modify individual transfers, to add or delete items, and to change the order in which transfers will happen when you run the saved file.

For more information, see Batch transfer in the Reflection application Help index.
The SNA Configuration File

Before you can connect over 802.2 DLC, Coax DFT, SDLC, or MPTN, you must configure your links to the host. Connections made using these transports use the Reflection SNA Engine. Link information for connections made with the Reflection SNA Engine is stored in the SNA Engine configuration file, not in Reflection settings files. The SNA Engine configuration file is created automatically when you configure your link. Settings saved to this file affect all SNA transports. The default name and path to this file is:

C:\Documents and Settings\All Users\Application Data\Wrqsna.rlf

Whenever you make changes to your links configuration, the Wrqsna.rlf file is automatically updated.

You can use the Reflection Customization Manager to include a correctly configured SNA Engine configuration file in user installations.

For more information about configuring links, see Links in the Reflection Help index.
Reflection for IBM Utilities

This chapter describes the following utilities for use with Reflection for IBM:

- Reflection for IBM Conversion Tool—Use this tool to convert files created with other terminal emulation software.
- Reflection for IBM translation table editors—Use these utilities to customize character translation between the PC and the host.

Reflection for IBM Conversion Tool

If you are moving to Reflection from EXTRA! Personal Client, ViewNow, or Rumba, you can use the Reflection for IBM Conversion Tool to convert your existing files to Reflection for IBM format. The converter creates Reflection files that let you get up and running as quickly as possible without altering your original files.

The following files run and support the converter:

- Ribmconvert.exe (the converter)
- Msvcp70.dll (supporting file)
- Msvcr70.dll (supporting file)
- HowToConvert.html (help file)

The converter is installed when you install the Reflection for IBM component of the Reflection Administrator's Toolkit. The converter files are installed to the Toolkit folder (by default C:\Program Files\Attachmate\RToolkit).

Refer to the conversion tool file, HowToConvert.html, for complete information about using this tool.

**Tip:** Another option for users migrating to Reflection is to use a set of specialized templates that give Reflection a familiar look and feel. See Templates, using competitive product templates in the Reflection Help index for more information.
Translation Table Editors

The translation table editors enable you to customize how Reflection translates characters during data exchange between your Windows computer and the IBM host. Use the editors to customize Reflection for unique host system environments. Four translation table editors are available:

<table>
<thead>
<tr>
<th>Executable File Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit3270.exe</td>
<td>Customize character translation for 3270 sessions</td>
</tr>
<tr>
<td>Edit5250.exe</td>
<td>Customize character translation for 5250 sessions</td>
</tr>
<tr>
<td>Ed3270db.exe</td>
<td>Customize double-byte character translation for 3270 sessions</td>
</tr>
<tr>
<td>Ed5250db.exe</td>
<td>Customize double-byte character translation for 5250 sessions</td>
</tr>
</tbody>
</table>

To run one of the table editors, locate the executable file in the Reflection product folder (by default C:\Program Files\Reflection) and double-click the file. Each editor includes built-in Help which explains how to make changes to your character translation.

The changes you make using the translation table editors are written directly to the application file, R8nes.dll. The table editors also support import and export of edited data.
Administering Reflection for HP and Reflection for OpenVMS
Files Used by Reflection for HP, UNIX and OpenVMS, and ReGIS Graphics

This chapter describes files that store information for these Reflection applications:

- Reflection for HP
- Reflection for UNIX and OpenVMS
- Reflection for ReGIS Graphics

Settings Files

Reflection settings files generally contain information your users need for connecting to your host. They can also include any customizations you’ve made to the display, toolbars, menus, macros, keyboard, or mouse setup. By default, Reflection saves settings to a complete settings file. Double-clicking a complete settings file launches Reflection with the configurations specified in that file.

Administrators can make settings files available to users in a number of ways, including:

- Using the Reflection Customization Manager (described in Chapter 3) to add settings files to a customized Reflection installation.
- Creating web pages with links that download and launch settings files. See Chapter 6 for details.
- Copying settings files to a shared network location and providing users with shortcuts that point to these files.
Complete (Default) Settings Files

When you save a settings file using the default values in either the Save As or Save dialog box, Reflection creates a complete settings file. Opening a complete settings file configures all of your Reflection settings.

Settings files are specific to individual Reflection applications. The Reflection applications covered in this chapter use the following file extensions:

<table>
<thead>
<tr>
<th>Reflection Application</th>
<th>Settings File Extension</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reflection for HP</td>
<td>.r1w</td>
</tr>
<tr>
<td>Reflection for UNIX and OpenVMS</td>
<td>.r2w</td>
</tr>
<tr>
<td>Reflection for ReGIS Graphics</td>
<td>.r4w</td>
</tr>
</tbody>
</table>

Partial Settings Files

By default, settings files contain information about every aspect of your Reflection configuration. To save or load a settings file that contains information about only a specific aspect of Reflection’s configuration, you can use a partial settings file. When you save or open a partial settings file, you save or update only the relevant part of your configuration.

Partial settings files are not supported in Reflection for Secure IT. Partial settings files can be shared among Reflection for HP, Reflection for UNIX and OpenVMS, and Reflection for ReGIS Graphics. These products use the following file extensions:

<table>
<thead>
<tr>
<th>Type of Partial Settings</th>
<th>File Extension</th>
</tr>
</thead>
<tbody>
<tr>
<td>Key/Mouse map</td>
<td>.rkm</td>
</tr>
<tr>
<td>Toolbar</td>
<td>.rtb</td>
</tr>
<tr>
<td>Colors</td>
<td>.rcr</td>
</tr>
<tr>
<td>Menus</td>
<td>.rmu</td>
</tr>
<tr>
<td>Hotspots</td>
<td>.rhs</td>
</tr>
<tr>
<td>Connection</td>
<td>.rco</td>
</tr>
</tbody>
</table>
Settings Update Files

Settings update files contain information about specific settings only. When you open a settings update file, only those settings are changed. Settings update files allow you to share one or more settings with other Reflection users without changing their other settings. For example, you could create an update file that specifies a new printer destination. When other users open this file, the printer name is updated without affecting any other settings. Users who open this file can open the File menu and click Save to incorporate this change into their existing settings file.

Settings update files are similar to partial settings files, as both update a subset of Reflection settings. However, partial settings files save every setting in a related group of settings, while settings update files include only those settings that are changed from the default when you create the update file. Use settings update files when you want to share only specific settings without overwriting others.

To create a settings update file, use the Save or Save As command on the File menu, and change Save as type to Settings Update. Reflection applications covered in this chapter use the following file extensions for update files.

<table>
<thead>
<tr>
<th>Reflection Application</th>
<th>Settings Update File Extension</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reflection for HP</td>
<td>.r1u</td>
</tr>
<tr>
<td>Reflection for UNIX and OpenVMS</td>
<td>.r2u</td>
</tr>
<tr>
<td>Reflection for ReGIS Graphics</td>
<td>.r4u</td>
</tr>
</tbody>
</table>
Configuring Automatic Updates of User Settings Files

You can use settings update files to configure ongoing, automatic updates of end-user settings. To do this, maintain a settings update file on a shared network server, and create end-user settings files that specify the location of the update file using the Auto Update File setting (Setup > View Settings > Auto Update File). Reflection checks for new settings in the update file each time the end user opens this settings file. You can use UNC path names or URLs to specify an update file located on a network server, as shown in these examples.

Sample UNC path:

```
\MyServer\Reflection\Update Demo.rsu
```

Sample URL:

```
HTTP://Myserver.com/Update Demo.rsu
```

**Note:** By default, Reflection looks for a settings update file called Settings.rsu in the Reflection user folder. This means that you can place a settings update file in this default location and the updates will be applied automatically even if you have not explicitly specified a value for Auto Update File. For example, if you are running a default configuration of Windows XP or Windows 2000 and installed Reflection for HP using default values, Reflection will automatically check for updates in the following location:

```
C:\Documents and Settings\<user>\My Documents\Reflection\Settings.rsu
```

You can change the default value of the Auto Update Setting using the “Folder for the default Auto Update file” Group Policy setting. See Chapter 4 for more information.

For more information about working with settings update files, including step-by-step procedures, see Settings update files, using in the Reflection Help index.
Linking Settings Files

Reflection for HP, Reflection for UNIX and OpenVMS, and Reflection for ReGIS Graphics support an advanced feature that lets you link partial settings files to complete settings files. This is useful if you want to:

- Share a partial settings file, such as a toolbar, among users of a variety of complete settings files. This way when you update the toolbar, the changes are automatically distributed to the linked complete settings files.

- Distribute some special settings, such as customized colors or mouse mappings, to a group of users.

- Keep partial settings files on a shared network drive so that users can link to them from their complete settings files stored on their local drives. Again, changes made to the partial settings file are automatically updated and distributed via the link.

Because linking is an option typically reserved for advanced users, the Link to file check box is hidden for convenience. To show this option, in the View Settings dialog box (Setup > View Settings), select the setting Show Link to File Check Box and change the value in the Setting details box to Yes. Now, when you use the Open Settings dialog box to load a partial settings file, you’ll see the Link to file check box.

For more information about working with linked settings files, see Linked settings files in the Reflection Help index.
Layouts

If you frequently run two or more Reflection sessions simultaneously, you can use layout files to streamline your work. Layout files save your Reflection window arrangement. For example, if you regularly work with both an IBM and an HP host, you can create a layout to launch both sessions using your preferred arrangement. Layouts include all the saved Reflection sessions that are running when you create the layout. Layouts can include any combination of the following applications:

- Reflection for HP
- Reflection for UNIX and OpenVMS
- Reflection for ReGIS Graphics
- Reflection FTP Client
- Reflection for IBM
- Reflection for Secure IT
- Reflection SFTP Client

To create a layout use File > Layout > Save Layout As.

Click the Shortcut button if you want to create a shortcut to open your layout. You can open layouts using shortcuts, or from a Reflection session using File > Layout > Open Layout.

Layout files use an *.rlo file extension.

Converting Reflection Settings to Other Formats

You can convert Reflection settings to the following formats:

- Reflection for the Web (*.config) files
- XML Settings (*.xml)

Note: This feature is not available in Reflection for Secure IT.
Migrating Settings to and from Reflection for the Web

Reflection for the Web provides easy and secure access to host applications from within a web browser. If you are currently using Windows-based Reflection applications, you may find that you can reduce the cost of deploying and maintaining host access to some users by using Reflection for the Web. If you are currently using Reflection for the Web, you may want to install Windows-based Reflection on some workstations to take advantage of its full range of features. You can use the Reflection for the Web Administrative WebStation (described on page 59) to administer all of your Reflection sessions.

Converting Reflection settings that are supported in both Windows and Web-based Reflection products is a simple, one-step process. To import Reflection for the Web files, you can use either of these methods:

- **File > Open**, then set **Files of type** to **Reflection for the Web**
- **File > Import and Export > Import XML**

Reflection for the Web settings that can be converted are imported into your current session. To export supported settings to Reflection for the Web format, use **File > Save As**, then set **Files of type** to **Reflection for the Web (*.config)**.
Importing and Exporting Settings Using XML

Extensible Markup Language (XML) is an industry-standard markup language for identifying and displaying structured information retrieved from a wide variety of applications. Reflection settings can be exported into XML and, in turn, these Reflection settings can be opened in another Reflection session or displayed in a readable format. Exporting settings as XML allows you to take Reflection settings as a source, translate them using XSL stylesheets, and open them in Reflection as XML files (*.xml), or in Reflection for the Web as configuration files (*.config) to replicate the session. To do this, supply the basic information using options in the Reflection Export and Transform XML dialog box, where you can specify the source data for export, the output, the location to save the output file, and whether the resulting content should be automatically displayed.

Using Reflection data as the source, you can export:

- Current or changed settings: Your current Reflection settings.
- Screen data: Data from the Reflection terminal window and display memory.
- Other: A prior Reflection session saved in XML format, filtered output, or Reflection for the Web configuration file settings.

To transform your Reflection settings, use the Export and Transform XML dialog box (File > Import and Export > Export and Transform XML).

Note: This feature is not available in Reflection for Secure IT.

For more information about working with XML files, see XML in the Reflection Help index.
Configuring Your Host to Support WRQ/Reflection File Transfer Protocol

This chapter only applies to Reflection for HP, Reflection for UNIX and OpenVMS, and Reflection for ReGIS Graphics.

Before Reflection users can transfer files between their PCs and a host using the WRQ/Reflection protocol, a host version of the file transfer program must be available to work with Reflection. Typically, this file is uploaded by the system administrator. Reflection includes host programs for transferring files to MPE (HP 3000), OpenVMS, and UNIX systems.

Locating the Upload Scripts

There are three Reflection Basic scripts included with Reflection that upload host programs to HP, OpenVMS, and UNIX hosts. Choose an upload script according to both the host and language you require:

<table>
<thead>
<tr>
<th>Language</th>
<th>PCLINK2, HP 3000 host</th>
<th>VAXLINK2, OpenVMS host</th>
<th>UNXLINK2, UNIX host</th>
</tr>
</thead>
<tbody>
<tr>
<td>English</td>
<td>Uphpenu.rbs</td>
<td>Upvxenu.rbs</td>
<td>Upuxenu.rbs</td>
</tr>
<tr>
<td>French</td>
<td>Upphpfra.rbs</td>
<td>Upvxfra.rbs</td>
<td>Upuxfra.rbs</td>
</tr>
<tr>
<td>German</td>
<td>Uphpdeu.rbs</td>
<td>Upxdeu.rbs</td>
<td>Upxdeu.rbs</td>
</tr>
<tr>
<td>Japanese</td>
<td>Upphpjpn.rbs</td>
<td>Upxjpn.rbs</td>
<td>Upxjpn.rbs</td>
</tr>
</tbody>
</table>

These scripts are not copied by Setup when you perform a Typical installation. Before you continue with the procedures that follow, check to see if the upload scripts are available—they are installed to the Host subfolder located in your Reflection program folder. If they are not in this location, open Windows Control Panel and use Add/Remove Programs to install the Host Transfer Files feature. You will find this feature listed under the Reflection product feature when you run the Windows Installer.
Basic Steps for Uploading the Host Program

To upload a host program:

1. Start Reflection, and establish a host connection.

2. Press `c+s +S` to open the Run Script dialog box.

3. Change to the Reflection Host folder.

4. Select the upload script name that matches your environment, where `<lang>` is either enu, fra, deu, or jpn depending on the language:

5. Click the Run button. After a moment, you'll see the Upload Script dialog box. It is recommended that you first click the Default Upload button; this successfully uploads the host program in almost all situations.

6. When you see the Completed Successfully dialog box, this indicates that the host program has been uploaded. Now your users can transfer files using the WRQ/Reflection protocol.

If you had a problem or received an error when using the Default Upload button to upload the host program, use the Custom Upload button:

- For more information on uploading PCLINK2, see following section.
- For more information on uploading VAXLINK2, see page 104.
- For more information on uploading UNXLINK2, see page 106.
Specifcics on Uploading the HP Host Program

This section provides detailed instructions for uploading the HP 3000 host program. PCLINK2 is the host program that lets you transfer files to and from an HP 3000 system; it must be copied to the host before you can transfer files using the WRQ/Reflection protocol. All users of Reflection can share the same host copy of PCLINK2; as a system administrator, you can place a copy in a common group and account on the host.

Important: AttachmateWRQ does not supply a host program for the HP 1000. You must obtain a Kermit or Xmodem file transfer program for the HP 1000 and use those transfer methods in Reflection.

Two versions of PCLINK2 are distributed with Reflection:

- PCLINK2 for Classic HP 3000 machines. (This program can also run on an MPE/iX system in compatibility mode.)
- PCLINK2 for MPE/iX systems. This version of PCLINK2 runs in native mode on an MPE/iX machine and provides the best performance in this environment. POSIX support is only available in the native mode version of PCLINK2.

During the upload of the HP host file transfer program, the upload program detects what type of system you have, and automatically uploads the appropriate version of PCLINK2. Because the native mode version of PCLINK2 is almost 10 times larger than the classic mode version, it takes longer to upload. If you have a slow data line, you may prefer to upload the smaller classic version of PCLINK2 and run it in compatibility mode on an MPE/iX system. To do this, use the Custom Upload option and select the Compatibility Mode (MPE/V or Classic) option explained on page 102.

PCLINK2 needs to be uploaded only once for each HP 3000 but should be updated with a newer version when one is available.
To upload PCLINK2, you need the following files in the Reflection \Host folder:

- A script file automating the upload procedure, for example, Uphp<lang>.rbs.
- Pclink2.pub is the host program for classic HP 3000s and compatibility mode. Nmpcl2.pub is the native mode version of PCLINK2 for MPE/iX HP 3000s.
- WRQUPLOA is an auxiliary file required for the upload.
- VERIFYPH is a program that checks the target group for PH (Processing Handling) capabilities. This type of processing capability is required to perform wildcard transfers and to display host directory information. If the target group does not have this capability, a warning message is issued with options enabling you to cancel the upload or continue with the operation.
- VERIFYPM is a program that checks the target group for PM (Privileged Mode) capabilities. This type of capability is required to perform faster host directory displays in the File Transfer dialog box. If the target group does not have this capability, then the older method of obtaining host directory information will be used.

To upload PCLINK2 to an HP 3000 host:

1. Start Reflection for HP with NS/VT, and establish a connection to the HP 3000. You can upload PCLINK2 using a direct serial, modem, or network connection.

2. Log on as Manager.sys or to the account where PCLINK2 will reside. You must sign on with a term type equal to 10 (the normal value). You can force this by adding \TERM=10 to your logon string, as follows:
   ```
   HELLO <logon>;TERM=10
   ```

3. Press c+s+S to open the Run Script dialog box.

4. From the Reflection \Host folder, select the file Uphp<lang>.rbs, and click the Run button to open the Reflection HP 3000 Upload Script dialog box.

5. Click Default Upload.

6. When you see the Completed Successfully dialog box, this indicates that the host program has been uploaded. Now your users can transfer files using the WRQ/Reflection protocol.

If you encounter any problems, perform a custom upload (explained next).
HP Custom Upload Options

If you need to specify custom options, click Custom Upload in the Reflection HP 3000 Upload Script dialog box. The custom options are explained next.

Upload Method

These options determine what method, or methods, will be used to upload the host program:

- Leave the **Try WRQ/Reflection** Protocol check box selected so the PCLINK2 host program will be uploaded using the WRQ/Reflection proprietary protocol. Using this protocol results in the fastest upload procedure. If the WRQ/Reflection protocol is not found by the upload script, then the next two options are tried (as long as you leave the **Try Old-WRQ Protocol** and **Try Method Using Host FCOPY Utility** check boxes selected).

- Leave the **Try Old-WRQ Protocol** check box selected so the PCLINK2 host program will be uploaded using the Old-WRQ proprietary protocol. (This was the protocol used by Reflection in versions prior to version 4.0, the protocol has since been replaced with the WRQ/Reflection protocol.)

If the Old-WRQ protocol is not found by the upload script, then the remaining option is tried (as long as you leave the **Try Method Using Host FCOPY Utility** check box selected).

- Leave the **Try Method Using Host FCOPY Utility** check box selected so the PCLINK2 host program will be uploaded using the HP 3000’s FCOPY utility. Reflection uses the FCOPY utility to upload PCLINK2 by issuing the command RUN FCOPY.PUB.SYS. If for some reason the HP 3000 was not able to run FCOPY, the message “Could not invoke FCOPY utility” displays. Make sure that another program is not running by pressing $c+x$, and then typing `ABORT` at the colon prompt and pressing $n$.

If you see the message “Received unexpected data from FCOPY,” normally this is a result of having a term type other than 10. Log on to the host with `$TERM=10` at the end of your logon string (see page 100), and try the upload again. This error may also be related to noise on the line or to the existence of an intermediary device such as a data switch.

When FCOPY is used, no error checking is performed. Use the Serial Connection Statistics dialog box (Connection > Trace > Serial Connection Statistics) to determine the source of the problem.
PCLINK2 Mode
This option determines what program to upload based on the operating system:

- Leave the **Script Determines Best Mode** option set so the script automatically detects which MPE operating system you have and uploads the appropriate software for your environment. If you have an MPE/XL or MPE/iX host, then the script uploads the native mode version of PCLINK2. For MPE/V or Classic hosts, the compatibility mode of PCLINK2 is uploaded.

- If you want to transfer files using the faster native mode on your MPE/iX system, select the **Native Mode (MPE/XL and MPE/iX)** option. This results in the best system performance. If you do not need to run your MPE/iX system in compatibility mode, this is the recommended option.

- The **Compatibility Mode (MPE/V or Classic)** option is intended for use on the Classic HP 3000 machines. Select this option if you have this type of host.

If you select this option and your host is an MPE/XL system, or if you start a file transfer from Reflection and notice slow performance on your MPE/iX system, you can do one of two things:

- Your host may be running the compatibility mode of the PCLINK2 software (because you selected this option); to take advantage of optimum system performance, you need to upload the Reflection file transfer host software that runs in native mode by forcing that selection here.

- If you must run PCLINK2 in compatibility mode, you can change the system priority by reassigning PCLINK2’s *queue* priority level to either D or E. To do this, modify the **Startup command** on the WRQ tab in the File Transfer Setup dialog box. For example:

  ```
  RUN PCLINK2.PUB.SYS;PRI=DS
  ```
PCLINK2 Capabilities
Leave this option set to **Script Determines Capabilities** so that the script automatically detects what capabilities the host software will have. The script detects either Privileged Mode or Process Handling.

Select the **PCLINK2 Will Have the Following Capabilities** option if you want to force PCLINK2's capabilities: you can select PM or PH capabilities.

Host Program Will Be Called
If you want to call the host program something other than the default proposed name of PCLINK2.PUB.SYS, type the name here.

**Caution:** Don’t confuse the name that you enter here (which is the name you want the program called once it is uploaded to the host) with the host **Startup command** that you specify on the WRQ tab in the File Transfer Setup dialog box. In other words, do not enter the **Startup command** here.

Create a Troubleshooting Log
Select this check box if you’re running the upload script again because the first time you ran it, the upload was unsuccessful. If you request assistance, Technical Support will ask for a copy of the log created by selecting this check box. The log will be located in the Reflection \Host folder.

Canceling an Upload
If you want to cancel the upload, press c or click Cancel. You may also need to abort the program on the host:

1. Enter a break (by pressing c+x).
2. Press c, and then enter a colon (:) to turn the HP 3000 echo facility back on.
3. Type **ABORT** at the host prompt, and press n to abort the PCLINK2 program.
Configuring Your Host to Support WRQ/Reflection File Transfer Protocol

This section provides detailed instructions for uploading the OpenVMS host program. Vaxlink2.exe is the host program that lets you transfer files to and from OpenVMS systems; it must be copied to the host before you can transfer files using the WRQ/Reflection protocol.

To upload VAXLINK2, you need the following files in the Reflection \\Host folder:

- Upvx<lang>.rbs is a script file that automates the upload procedure.
- Vaxlink2.exe is the VAX/OpenVMS host file transfer program.
- Alphalk2.exe is the AXP/OpenVMS host file transfer program.
- Wrquploa.mar is a receive-only Kermit program that assists in the upload.

Host programs are provided for both VAX and AXP machines running OpenVMS. Clicking the Default Upload button after running the upload script causes the upload procedure to automatically determine which program to upload to your host. If the AXP version is uploaded, it is renamed Vaxlink2.exe after the upload completes.

VAXLINK2 may already be defined as a logical name or foreign command (see the application Help). If so, you don’t need to upload another copy.

To upload VAXLINK2 to a OpenVMS host:

1. Start Reflection, and establish a connection to a VMS host. You can upload VAXLINK2 using a direct serial, modem, or network connection.
   
   **Note:** Connecting to one OpenVMS host and performing a SET HOST DCL command to another OpenVMS host may cause the upload script to fail. Be sure that you are connected to the host to which you want to upload VAXLINK2.

2. Log in to the host.

3. Press c+s +S to open the Run Script dialog box.

4. From the Reflection\\Host folder, select the file Upvx<lang>.rbs, and click Run to open the Reflection VMS Upload Script dialog box.

5. Click Default Upload.

6. When you see the Completed Successfully dialog box, this indicates that the host program has been uploaded. Now your users can transfer files using the WRQ/Reflection protocol.

If you encounter any problems, perform a custom upload (explained next).
OpenVMS Custom Upload Options
If you need to specify custom options, click Custom Upload in the Reflection VMS Upload Script dialog box. The custom options are explained next.

Upload Method
The check boxes under Upload Method enable you to specify up to three protocols the script should use when attempting to upload the host transfer program. By default, the script first tries to upload using the WRQ/Reflection protocol. If that is unsuccessful, the script tries the Old-WRQ protocol, then the Kermit public domain transfer protocol.

Upload VAXLINK2 to Which VMS System
By default, the upload script determines what OpenVMS system you are uploading to: either a VAX system or an AXP system. If you want to force a specific system type, select that option here.

Host Program Will Be Called
If you want to call the host program something other than the default proposed name of Vaxlink2.exe, type the name here.

Caution: Don’t confuse the name that you enter here (which is the name you want the program called once it is uploaded to the host) with the host Startup command that you specify on the WRQ tab in the File Transfer Setup dialog box. In other words, do not enter the Startup command here.

Create a Troubleshooting Log
Select this check box if you’re running the upload script again because the first time you ran it, the upload was unsuccessful. If you request assistance, Technical Support will ask for a copy of the log created by selecting this check box. The log will be located in the Reflection \Host folder.
Configuring Your Host to Support WRQ/Reflection File Transfer Protocol

Specifications on Uploading the UNIX Host Program

This section provides detailed instructions for uploading the UNIX host program. UNXLINK2 is the host program that lets you transfer files to and from a UNIX host, including Compaq’s Digital ULTRIX. It must be uploaded to the UNIX host before you can transfer files using the WRQ/Reflection transfer protocol.

To upload UNXLINK2, you need the following four files in the Reflection \Host folder:

- A script file that automates the upload procedure, for example “Upux<lang>.rbs.
- Unxlink2.c is part of the version 3.03 UNIX file transfer program.
- Unxfer2.c is part of the version 3.03 UNIX file transfer program.
- Wrqkerm.c is the receive-only Kermit program that assists in the upload of UNXLINK2.

To upload UNXLINK2 to a UNIX host:

1. Start Reflection and establish a connection to a UNIX host. You can upload UNXLINK2 using a direct serial, modem, or network connection.
2. Log in to the host.
3. Press c+s +S to open the Run Script dialog box.
4. From the Reflection \Host folder, select the file Upux<lang>.rbs, and click Run to open the Reflection UNIX Upload Script dialog box.
5. Click Default Upload.
6. When you see the Completed Successfully dialog box, this indicates that the host program has been uploaded. Now your users can transfer files using the WRQ/Reflection protocol.
UNIX Custom Upload Options
If you need to specify custom options, click Custom Upload in the Reflection UNIX Upload Script dialog box. The custom options are explained next.

Upload Method
The check boxes under Upload Method enable you to specify up to three protocols the script should use when attempting to upload the host transfer program. By default, the script first tries to upload using the WRQ/Reflection protocol. If that is unsuccessful, the script tries the Old-WRQ protocol, then the Kermit public domain transfer protocol.

Compile UNXLINK2 Using
You can customize the compiling of the UNIX host program by using “switches.” If you’re uploading to an AT&T UNIX System 5 system, leave the first check box selected. Also, by default, Berkeley Software Distribution (BSD) switches are used.

Other detected systems are shown in the box below after you select the Other System Switches check box. For example, if you select Berkeley Software Distribution 4.2 (BSD) from this box, this appends the following switch to the unxlink2 compiler:

-BSD42

You can append any additional switches to those that you see here.

To compile unxlink2 on an AIX host:
1. Select the Other System Switches check box.
2. Select AIX (IBM RS6000) from the Other System Switches list.
3. Clear these two check boxes:
   - AT&T and UNIX System V Switches
   - Berkeley Software Distribution (BSD) Switches
Host Program Will Be Called
If you want to call the host program something other than the default proposed name of ./unxlink2, type in the name here.

Caution: Don’t confuse the name that you enter here (which is the name you want the program called once it is uploaded to the host) with the host Startup command that you specify on the WRQ tab in the File Transfer Setup dialog box. In other words, do not enter the Startup command here.

Create a Troubleshooting Log
Select this check box if you’re running the upload script again because the first time you ran it, the upload was unsuccessful. If you request assistance, Technical Support will ask for a copy of the log created by selecting this check box. The log will be located in the Reflection \Host folder.
Administering Reflection for Secure IT
Files Used by Reflection for Secure IT

This chapter describes files used by the Reflection for Secure IT SSH client and the Reflection SFTP Client.

Before reading this chapter, you should be familiar with the Secure Shell information on pages 42-48.

Secure Shell Configuration Files

User-specific Reflection Secure Shell settings are stored in a configuration file named config. The config file is created the first time you change settings using the Reflection Secure Shell Settings dialog box.

The default location for this file is:

C:\Documents and Settings\<user>\My Documents\Attachmate\Reflection\.ssh\config

The config file is updated automatically by changes you make using the Reflection Secure Shell settings dialog box (shown on pages 44 and 45). You can also edit the config file manually in any text editor.

For detailed information about keywords used in the Secure Shell config file, see Secure Shell in the Reflection for Secure IT Help index. The configuration file (Secure Shell settings) topic lists keywords that affect all Reflection Secure Shell connections; the configuration file (terminal emulation settings) topic lists keywords for configuring terminal emulation for ssh command line sessions.
Saving Settings Host-by-Host vs. Using the Same Settings for Multiple Hosts

Within the Secure Shell configuration file, settings are saved in sections identified by the **Host** keyword. You can use these sections to save settings on a host-by-host basis, or you can create *SSH config schemes* to use the same settings for multiple hosts.

- If you change Secure Shell settings in Reflection without specifying an SSH config scheme, Reflection saves these changes under the host name and uses these settings whenever you connect to that host. In this case, the **Host** keyword in the config file specifies your host name.

- If you specify an SSH config scheme name, Reflection saves Secure Shell settings under the scheme name and uses these settings whenever you connect using that scheme. In this case the **Host** keyword in the config file specifies your SSH config scheme name.

Configuring Global Secure Shell Settings

The **config** file (which is located within each user's My Documents folder) configures Secure Shell settings for the current user. Reflection applications also support use of a system-wide configuration file, called **ssh_config**, which configures Secure Shell settings for all users of a computer. You can create this file manually, or use an existing **config** file, which you will need to rename and copy, or install to the correct location. The **ssh_config** file must be placed in the Reflection application data folder. The default location is:

C:\Documents and Settings\All Users\Application Data\Attachmate\Reflection

You can use the Reflection Customization Manager to add an **ssh_config** file to a Reflection installation to correctly configure end-user computers for Secure Shell connections the first time users launch Reflection.

For detailed information about deploying a global Secure Shell configuration file, see *Setup, deploying custom Secure Shell settings* in the Reflection for Secure IT Help index.
Understanding Secure Shell Configuration Files and Reflection Settings Files

The Reflection for Secure IT SSH client and SFTP client use settings stored in two distinct file types:

- Secure Shell configuration file (config or ssh_config).
- Application settings file (*.r3w for the SSH client, *.rfw for the SFTP client).

All Reflection applications share a common Secure Shell configuration file, and settings in this file are applied per host (or per SSH config scheme). For example, when you configure settings for a connection to Acme.com using the Reflection SSH client (and you don’t specify an SSH config scheme), these settings are saved in the Secure Shell config file in a section identified with the heading “Host Acme.com”. If you also configure the Reflection SFTP Client to connect to Acme.com (and you don’t specify an SSH config scheme), the SFTP client uses the existing settings in the “Host Acme.com” section of the config file. (Settings are shared in the same way if you specify the same SSH config scheme in both applications.)

Additional Reflection settings are saved in application-specific settings files. Reflection saves your host name and SSH config scheme name to the current settings file, along with other preferences that you have configured. For example, using the Reflection SSH Client, you could create a settings file called AcmeSettings.r3w that connects to the host Acme.com, and also configures display preferences and keyboard mappings that are appropriate for that host. These settings take effect when you open the AcmeSettings.r3w file. Before connecting to the host, Reflection looks for a “Host Acme.com” section in the Secure Shell configuration file and, if this section is found, uses the specified Secure Shell settings when it makes the connection.

Settings changes are saved per the following:

<table>
<thead>
<tr>
<th>Changes you make using</th>
<th>Are saved to</th>
</tr>
</thead>
<tbody>
<tr>
<td>The Secure Shell Settings</td>
<td>The Secure Shell config file when you close this</td>
</tr>
<tr>
<td>dialog box</td>
<td>dialog box.</td>
</tr>
<tr>
<td>Other Reflection dialog</td>
<td>The Reflection settings file when you use the</td>
</tr>
<tr>
<td>boxes</td>
<td>File &gt; Save command.</td>
</tr>
</tbody>
</table>
Files Used by Reflection for Secure IT

SSH Client Settings Files
Reflection for Secure IT SSH Client settings files include the host name, SSH config scheme name (when applicable), and any other information you configure in the Connection Setup dialog box. These files can also include any customizations you’ve made to the display, keyboard, or mouse setup.

Reflection for Secure IT settings files use an *.r3w file extension. When you double-click an .r3w file, Reflection launches with the configurations specified in that file.

Settings Update Files
With Reflection settings update files, you can share one or more settings with other Reflection users without modifying any of the other settings of those users. A settings update file contains information about specific settings—when a user opens a settings update file, only the settings particular to that file are changed. To create a settings update file, use File > Save As, and change Save as type to Settings Update.

Reflection for Secure IT settings update files use an *.r3u file extension.

For additional information about working with settings update files, refer to pages 91-92 in this manual. For complete information about working with settings update files, including step-by-step procedures, see Settings update files, using in the Reflection for Secure IT Help index.

SFTP Client Settings Files
SFTP Client settings files include the following information:

- All of the sites you have configured, including host name and other site properties, but excluding settings configured in the Secure Shell settings dialog box.
- Your settings for Transfer Method and If File Exists.
- Settings that you have configured using the Options dialog box.

When you start up, by default, the client automatically opens a settings file called “Settings”. Any changes you make to your configuration are saved to this settings file when you use File > Save. (To save your settings to a different file, use File > Save As.)

You can create shortcuts to launch the client and automatically open any settings file. The SFTP Client title bar displays the name of the settings file that is currently open.
Note: You can use the **Import Settings** command to modify your SFTP Client settings. Imported settings for new sites are appended to any currently configured settings; imported settings for existing sites update those sites. The title of your session remains unchanged.

**SFTP Client Script Files**

You can use commands from the SFTP Client **Script** menu to record, edit, and play back SFTP command scripts. Scripts allow you to automate SFTP connection and file transfer operations: either play back a script from within the SFTP Client application, or start the SFTP Client with a command-line parameter that executes the script automatically. For example, you can automate file transfers to and from an SFTP server. Such transfers are carried out without the need to interact directly with the SFTP Client.

Reflection SFTP Client script files use an *.rfs* file extension.

**Note:** The SFTP command set is not the same as the FTP command set—there are many FTP commands that are not available when you make an SFTP connection. The SFTP Client application Help includes detailed information about both FTP and SFTP commands (FTP commands are available from the SFTP client if you configure the client to forward an FTP connection through an SSH tunnel.) For detailed information about SFTP commands, see *SFTP commands, index* in the SFTP Client Help.
Layouts

If you frequently run two or more Reflection sessions simultaneously, you can use layout files to streamline your work. Layout files save your Reflection window arrangement, including all of the saved Reflection sessions that are running when you create the layout. For example, if you regularly work with both an SSH client session and an SFTP session, you can create a layout that launches both sessions using your preferred arrangement. Layouts can include any combination of the following applications:

- Reflection for Secure IT
- Reflection SFTP Client
- Reflection for IBM
- Reflection for HP
- Reflection for UNIX and OpenVMS
- Reflection for ReGIS Graphics
- Reflection FTP Client

To create a layout in Reflection for Secure IT, use File > Layout > Save Layout As. To create a shortcut to open your layout, click the Shortcut button. You can open a layout from a Reflection session using File > Layout > Open Layout, or using a shortcut.

Layout files use an *.rlo file extension.
Secure Shell File Reference

This file reference includes the Secure Shell configuration files described on page 111 and page 112 as well as additional files that may also be present on your computer, depending on how you have configured Reflection Secure Shell connections.

All files described in this section are shared among all Reflection applications and command-line utilities that support Secure Shell connections. The Reflection applications that support Secure Shell are Reflection for Secure IT SSH Client, Reflection for Secure IT SFTP Client, Reflection for HP, Reflection for UNIX and OpenVMS, Reflection for ReGIS Graphics, Reflection X, and Reflection FTP Client. The command-line utilities are ssh, ssh2, sftp, sftp2, scp, and scp2.

User-specific Secure Shell Files

User-specific Secure Shell files affect Secure Shell connections for the user currently logged into Windows. They are located in the user .ssh folder:

config
The user configuration file, which contains Secure Shell settings organized by SSH config schemes. The contents of this file is updated each time you change settings using the Reflection Secure Shell Client Settings dialog box. (You can also edit this file manually using a text editor.) The Configuration file keyword reference topics, available in the Reflection application Help, list the keywords supported by the Reflection Secure Shell Client.

known_hosts
This file is automatically updated by Reflection when you update the Trusted Host Keys list from the Host Keys page of the Secure Shell settings dialog box, or when you connect to a previously unknown host and answer Always in response to the Host Key Authenticity prompt.
System-wide Secure Shell Files
System-wide Secure Shell files affect Secure Shell connections for all users of the computer. They must be manually created and placed in the Reflection application data folder.

**ssh_config**
A system-wide configuration file, which provides defaults on the machine for values that are not specified in the user configuration file.

**ssh_known_hosts**
A system-wide list of known host keys, which should contain the public host keys of all computers in the organization. The public keys, one per line, are included in the following format (fields separated by spaces): system name, public key, and optional comment field. When different names are used for the same computer, all such names should be listed, separated by commas.

A canonical system name (as returned by name servers) is used to verify the client host when a user logs in. Other names are needed because Secure Shell does not convert the user-supplied name to a canonical name before verifying the key. This prevents individuals with access to the name servers from fooling host authentication.

Keys in this list can be viewed, but not edited, in the Global Host Keys list from the Host Keys page of the Secure Shell settings dialog box.

**Note:** You can configure an alternate location for the host key database by configuring the `GlobalKnownHostsFile` keyword in the configuration file.
**Files used by Reflection for PKI Support**

These files are used when you have configured Reflection to authenticate using the Reflection Certificate Manager described on page 50.

The default location for this folder is:

C:\Documents and Settings\<user>\My Documents\Attachmate\Reflection\.pki

**pki_config**

This file stores settings you configure, using the Reflection Certificate Manager, which are used by all Reflection sessions.

**trust_store.p12**

A file in PKCS#12 format that contains Trusted Root certificates added to the Reflection Certificate Manager.

**identity_store.p12**

A file in PKCS#12 format that contains private keys and certificates added to the Reflection Certificate Manager.

**cert_cache**

The intermediate root certificates cache. You can clear the cache by deleting this file.

**crl_cache**

The CRL (Certificate Revocation List) cache. You can clear the cache by deleting this file.
Secure Shell Authentication Overview

Authentication is the process of reliably determining the identity of a communicating party. Secure Shell connections require both host (server) and user (client) authentication. Identity can be proven by something you know (such as a password), or something you have (such as a private key or token).

By default, when a Secure Shell connection is made, the host authenticates to the user using a private cryptographic key, then the user authenticates to the host using a password. Additional options are available for both host and user authentication. This chapter provides an overview of Secure Shell authentication options.

These Reflection for Secure IT applications must be correctly configured for Secure Shell authentication before any connection can be made:

- Reflection for Secure IT
- Reflection SFTP Client

The following Reflection applications support a variety of connection methods, including the Secure Shell protocol. The authentication information in this chapter applies to these applications when they are configured to make Secure Shell connections.

- Reflection HP
- Reflection for UNIX and OpenVMS
- Reflection for ReGIS Graphics
- Reflection X
- Reflection FTP Client
Secure Shell Host Authentication

Reflection supports two types of host authentication: public key and certificate (a special form of public key authentication.)

Public key host authentication

Server public key authentication uses this sequence of events:

1. The Reflection client initiates a connection.
2. The host sends its public key to the Reflection client.
3. The Reflection client compares the public key sent by the host to a local copy of the host's public key. Host keys are kept in the known hosts file.
4. If the client copy of the host key matches the key sent by the server, the Reflection client sends a challenge to the server to confirm that the host holds the private key that corresponds to the public key in the known hosts file.
5. The server signs the client challenge using its private key and returns that to the client.
6. The client confirms that the hash for the signed challenge matches its own computed hash before accepting the host and beginning the user authentication.

If an administrator has already configured the local computer with the necessary public keys, host authentication proceeds without requiring any user response. However, if the Reflection client does not find a local copy of the public key, a prompt appears asking if the user wants to trust this new host key and continue connecting. This message includes two fingerprints identifying the host. Users should contact the host system administrator to confirm that they have connected to the actual host. When the user selects Always in response to the prompt, Reflection adds the host and its public key to your known hosts file, the prompt does not appear on subsequent connections.
Certificate host authentication

Digital certificates provide an alternate method for server authentication. In the public key authentication system just described, the system administrator must either place a copy of the host's public key on the client or count on client users to confirm the host identity correctly the first time a connection is made. Digital certificates avoid this problem by using a certification authority (CA) to verify the validity of the information coming from the host.

Server certificate authentication uses this sequence of events:

1. The Reflection client initiates a connection.
2. The host sends its certificate to the client.
3. The Reflection client uses the CA root certificate to verify the validity of the server certificate. To do this, the client must already have a copy of the CA certificate in either the Windows or Reflection trusted root store. (A single CA certificate can be used to authenticate multiple servers.)
4. The Reflection client checks that the server information in the certificate matches the host being contacted.
5. The Reflection client sends a challenge to the server to confirm that the host holds the private key that corresponds to the public key in the certificate.
6. The server signs the client challenge using its private key and returns that to the client.
7. The client confirms that the hash for the signed challenge matches its own computed hash before accepting the host and beginning the user authentication.

Digital certificates are maintained on your computer in certificate stores. Reflection can be configured to use digital certificates loaded in either the Reflection certificate store or the Windows certificate store. (These certificate stores are described on page 49.)

For more information about working with certificates, see Certificate management in the Reflection Help index.
Secure Shell User Authentication

The Reflection Secure Shell Client supports four methods of user authentication: Kerberos (GSSAPI), Public Key, Keyboard Interactive, and Password. Use the Reflection Secure Shell Settings General tab (see page 44) and User tab (page 45) to configure user authentication preferences. By default, Reflection attempts Public Key authentication first, followed by Keyboard Interactive, then Password.

Authentication settings are saved to the Secure Shell configuration file under either a host name or SSH config scheme. (For more information about this file, see page 112.)

GSSAPI/Kerberos

Kerberos key exchange uses shared secret keys to produce tickets which are used for the authentication of users to servers. Selecting GSSAPI/Kerberos in the User Authentication list enables Kerberos authentication for Secure Shell sessions. (The GSSAPI application programming interface is used to obtain Kerberos tickets for ssh2 connections.) When GSSAPI/Kerberos is enabled, Reflection attempts Kerberos authentication first unless you modify the authentication order. You can use either the Reflection Kerberos Client or the Microsoft Security Support Provider Interface (SSPI) for Kerberos authentication. Use the GSSAPI tab of the Secure Shell settings dialog box to configure this and other GSSAPI authentication options.

Public Key

Public key authentication relies on a public/private key pair. To configure public key authentication you create (or import) a key pair for your computer, then upload the public key to your host(s). You can create and manage Public key authentication using either the User Keys tab in the Reflection Secure Shell Settings dialog box, or the Reflection Key Agent (page 47). Depending on how you have configured your keys or certificates, you may be prompted to enter a passphrase in order to complete the connection.

One form of public key authentication is accomplished using X.509 certificates. Reflection can be configured to authenticate using certificates managed by the Reflection Certificate Manager (page 50) and/or the Windows Certificate Manager. Public Key authentication must be enabled if you use certificates for authentication.
Keyboard Interactive

This is a general-purpose method that supports any authentication procedure in which the authentication data is entered using the keyboard. Keyboard interactive authentication allows the Secure Shell client to support a range of authentication mechanisms without needing to know the underlying authentication mechanism used by the server. Challenge-response and one-time password mechanisms are examples of supported authentication methods. The keyboard data is sent to the host through the encrypted channel. Keyboard interactive authentication can also be used with passwords, and in many cases handles new or expired passwords better than standard password authentication.

Password

With password authentication you are prompted for your password after a host connection is made. The password is sent to the host through the encrypted channel. By default, you can expect new Secure Shell connections to display a password prompt unless one of the alternatives described above has already been configured for your host.
Chapter 15

Files Used by Reflection X

This chapter describes client (*.rxc) files used by Reflection X. These files store information that enables you to establish one or more connections in order to run one or more clients on the desktop. You can also run multiple X server instances using X server (*.rxs) files installed with the Reflection product.

Working with Client and Server Files in the X Manager

When you first start Reflection X, four panes appear. The two to the left are a tree view of available client and server files; the two panes to the right feature configurable connection options for the selected client or server file. Both client and X server instance files can be viewed by expanding each tree in the set of left panes in the X Manager. Right-click a file to view a context menu that includes options such as connecting using the this file, or creating a desktop shortcut to launch the connection. If the file should be loaded on startup, click the Use At Startup command, also available in the context menu.

Expand each tree listed below to view these files:

- **Client Files**: Files you create for each X client.
- **Client Templates**: Reflection X read-only factory client template files that can be used as the basis for files you create and save under Client Files. Right-click Client Templates to access information about client template files you can download via the web.
- **X Server Instances**: X server instance files you create are stored here.
- **X Server Templates**: Reflection X read-only factory template files that can start an X server instance or be used as the basis for files you create and save under X Server Instances. Additional template files are available on Attachmate WRQ's web site (right-click X Server Templates for more information) and by performing a Custom installation (see page 133).
Client Files

Client files contain information needed to establish a connection with the host and start a client on the X Manager. In general, there are two types of client files, a standard client file for an OpenVMS or UNIX host, and the XDMCP client file used to start an X display manager (XDM) client on a host (such as Sun's OpenLook or HP's VUE).

In both cases, the client files installed by Reflection X are read-only template files that provide the basic information required for connecting to the host. These files can be used as is, or the connection and client information can be customized for the host and client of your choice. When you change the information in a client file, use File > Save As to save the changed information in a new client file using the file name you choose. Once saved, these files are then listed under Client Files.

Client Files for UNIX and OpenVMS Hosts

The standard client file starts a host session over a network transport (either TCP/IP or DECnet) and starts one or more clients with a UNIX or OpenVMS command. Each client file includes a host name or IP address, a user name and password, and a valid command to be issued to the host once the connection is established.

These client files are installed by default:

<table>
<thead>
<tr>
<th>Client File Name</th>
<th>Host Type</th>
<th>Client Command</th>
</tr>
</thead>
<tbody>
<tr>
<td>aix.rxc</td>
<td>RISCSystem/6000 host</td>
<td>/usr/bin/X11/aixterm</td>
</tr>
<tr>
<td>dxterm.rxc</td>
<td>OpenVMS UNIX host</td>
<td>/usr/bin/X11/dxterm</td>
</tr>
<tr>
<td>hpux.rxc</td>
<td>HP UNIX host</td>
<td>/usr/bin/X11/hperm</td>
</tr>
<tr>
<td>linux.rxc</td>
<td>Linux host</td>
<td>/usr/X11R6/bin/xterm</td>
</tr>
<tr>
<td>sco.rxc</td>
<td>SCO UNIX host</td>
<td>/usr/bin/X11/scoterm</td>
</tr>
<tr>
<td>sgi.rxc</td>
<td>sgi host</td>
<td>/usr/bin/xwsh</td>
</tr>
<tr>
<td>solaris-gnome.rxc</td>
<td>Solaris host with GNOME desktop</td>
<td>/usr/bin/gnome-terminal</td>
</tr>
<tr>
<td>sun.rxc</td>
<td>Sun host</td>
<td>/usr/openwin/bin/xterm</td>
</tr>
<tr>
<td>unix.rxc</td>
<td>UNIX host with older X11</td>
<td>/usr/bin/X11/xterm</td>
</tr>
<tr>
<td>vms.rxc</td>
<td>VMS DECterm</td>
<td>.@startapp %IP% term</td>
</tr>
<tr>
<td>x11r6.rxc</td>
<td>UNIX host with X11R6</td>
<td>/usr/X11R6/bin/xterm</td>
</tr>
</tbody>
</table>
XDMCP Client Files for Indirect, Direct, and Broadcast

The XDMCP settings provided in these files are used to communicate with an X display manager running on a specific (direct) or available (indirect or broadcast) host machine. The host controls how the X environment is configured and which clients are run. (XDMCP is only available if you are using TCP/IP as a transport.)

When you use one of these XDMCP template files, you can change the connection information for the Description, Method, and Host name using options listed under Connection settings. You can also use the Advanced button to show a dialog box with options that let you further configure the connection.

These client files are installed by default:

<table>
<thead>
<tr>
<th>Client File Name</th>
<th>Connection Method</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>xdmcpbrd.rxc</td>
<td>Broadcast</td>
<td>The X server does a reset and then sends a request to all hosts on the network. Any display manager that is willing to service the request responds.</td>
</tr>
<tr>
<td>xdmcpdir.rxc</td>
<td>Direct</td>
<td>The X server does a reset and then sends a request to the X display manager program running on a specific host. You must enter the host name or IP address in the Host name text box.</td>
</tr>
<tr>
<td>xdmcpind.rxc</td>
<td>Indirect</td>
<td>The X server does a reset and then sends a request to a single host. Depending on its configuration, the host provides a dialog box to choose another host, automatically requests another host, or handles the XDM request itself.</td>
</tr>
</tbody>
</table>
The Reflection X Client Wizard

Use the X Client Wizard to create a new client file. To open the X Client Wizard, click Start > Programs > Attachmate Reflection > Wizards > X Client Wizard. Click Next in the wizard to open the panel shown below:

Fill out each option and click Next. When you close the X Client Wizard, the client file is saved.

For more information about the X Client Wizard consult the wizard Help or search the index of the Reflection X Manager application Help.
Files Used by Reflection X

X Server Instance Files

X server instance (*.rxs) files contain all of the connection information and settings required to start an X display. This means that users who wish to use XDM to initiate simultaneous X sessions (clients) from one or more hosts can do so by starting several X server instances using any combination of template or user-created files stored under X Server Instances and X Server Templates.

<table>
<thead>
<tr>
<th>Client File Name</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>Exceed.rxs</td>
<td>Emulates settings for the Exceed product.</td>
</tr>
<tr>
<td>SECURESHELL_Only.rxs</td>
<td>Uses the Secure Shell protocol.</td>
</tr>
<tr>
<td>XDMCP_Broadcast.rxs</td>
<td>Requests display managers via networked hosts.</td>
</tr>
</tbody>
</table>

Managing X Server Instances

An X server instance is managed using commands on the File and Action menus, the buttons in the X server management pane, or by right-clicking the currently managed file to view a list of context menu commands. For example, to start or select an X server instance click Action > Select/Start X Instances and choose the server instance to manage. Then use the buttons under X server management to manage the server instance. For more information see Chapter 14, “Managing Multiple Displays.”

Deploying Server Settings to Reflection Users

Each of the X server instance files can be exported by right-clicking a file and using the Export command. The *.rxs file that is created can then be deployed and the settings imported to the end users’ Windows registries for use on their machines.

For more information about deploying server settings see “Creating, Exporting, and Distributing X Server Instances” in the Reflection X User Help (Rxuser.hlp).
Keyboard Mapping Files

In the X Window System, pressing a key generates a key press/key release event that indicates the keycode and shift state of the key. The keycodes generated by a keyboard vary, depending on the keyboard manufacturer, the country, and the X server being used. This means that the same key on two keyboards can produce two different keycodes. The X protocol uses key symbols (called “keysyms” in the X Window System) to handle this problem. A keysym is an identifier for a particular character that is independent of keyboard-specific keycodes.

The Reflection X Manager uses a keyboard map maintained by the X server to determine the keysym from a keycode and shift state. In turn, Reflection X Manager uses a keymap file (*.kmp) to initialize the keyboard map when you start up or reset the server.

Keymap files are installed to the
C:\Documents and Settings\<all or per user>\Templates\Attachmate\Reflection\X
folder by default. Those you create and customize are saved to C:\Documents and Settings\<user>\My Documents\Attachmate\Reflection.

Reflection X detects your Windows keyboard driver and uses the appropriate keymap file. If you switch to a different keymap file, it is saved in your configuration and remains the same unless you specifically change it.

Toolbar Files

Reflection X toolbar (*.tbr) files contain information to display a set of buttons at the top of the Reflection X Manager.

By default, Reflection X creates the file Rx11enu.tbr to track the state of the toolbar on initial startup. Customize the toolbar to work with various host sessions by adding, removing, or rearranging toolbar buttons. The customized toolbar file is saved to the
C:\Documents and Settings\<user>\My Documents\Attachmate\Reflection folder. This customized file overwrites the default toolbar.
Additional Help

More information about Reflection X files can be found in the application Help. Open Help using any Help button in the X Manager or by clicking the file “Rxuser.hlp” in Windows Explorer.
Managing Fonts in Reflection X

Standard font sets are installed with Reflection X Manager. If a unique font is required, Reflection X will alias the requested font to an installed font set or from those on a font server. It is also possible to use Reflection FTP to download fonts from a server.

This chapter describes how fonts are managed by Reflection X Manager and where you can find more information on installing, downloading, and viewing fonts for X clients.

Overview of Fonts in Reflection X Manager

Reflection X Manager uses fonts in X Windows font format and any Windows font, such as TrueType, ClearType, or Microsoft ClearType. A full set of X11R5 and X11R6 fonts is installed by Reflection X. You can use the fonts installed on your local hard disk and the fonts supplied by one or more font servers. Reflection X fonts are separated into these sets: 75-dpi and 100-dpi in both standard and UTF (Unicode) format; English Host Fonts (HP, DEC, Sun, IBM); Japanese; Chinese; and Korean.
Fonts Installed in a Typical Installation

Reflection X installs the following fonts by default:

<table>
<thead>
<tr>
<th>Font</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Miscellaneous fonts</strong></td>
<td>The misc folder contains fonts for simple X clients, such as xterm. The font called cursor is frequently used for different cursors needed by X clients. A path to this folder is automatically created in your font path during installation.</td>
</tr>
<tr>
<td><strong>Unicode (UTF) miscellaneous fonts</strong></td>
<td>Unicode fonts for xterm and other simple applications. Copied to <code>&lt;Reflection X&gt;\X\fonts\utfmisc</code>.</td>
</tr>
<tr>
<td><strong>75-dpi fonts</strong></td>
<td>Recommended for VGA resolution displays: 640x480 13” and 14” 800x600 16” and 17” 1024x768 19” 1152x900 21” 1280x1024 21”</td>
</tr>
<tr>
<td><strong>100-dpi fonts</strong></td>
<td>Recommended for high resolution displays: 800x600 13” and 14” 1024x768 13” and 14” 1024x768 16” and 17” 1152x900 19” 1280x1024 19” 1600x1200 21”</td>
</tr>
<tr>
<td><strong>English HP fonts</strong></td>
<td>75-dpi fonts required by HP VUE and other X clients running on Hewlett-Packard hosts. Copied to <code>&lt;Reflection X&gt;\X\fonts\hp</code>.</td>
</tr>
<tr>
<td><strong>English DEC fonts</strong></td>
<td>75-dpi fonts required by X clients running on Digital Equipment Corporation hosts. Copied to <code>&lt;Reflection X&gt;\X\fonts\dec</code>.</td>
</tr>
<tr>
<td><strong>English IBM fonts</strong></td>
<td>75-dpi fonts required by AIXwindows and by X clients running on IBM RISCsystem/6000 (AIX) hosts. Copied to <code>&lt;Reflection X&gt;\X\fonts\ibm</code>.</td>
</tr>
<tr>
<td><strong>English Sun fonts</strong></td>
<td>75-dpi fonts required by X clients running on Sun Microsystems hosts. Copied to <code>&lt;Reflection X&gt;\X\fonts\sun</code>.</td>
</tr>
</tbody>
</table>
Other Fonts Installed Using a Custom Installation

When you install Reflection X using a Custom installation type, you can choose to install additional fonts. To add more fonts, run the Installer program again and use the Reflection X fonts feature in the Select Features dialog box. Or, copy the directories that contain the fonts you want from the Reflection X product CD.

These fonts are available with a Custom installation:

<table>
<thead>
<tr>
<th>Font</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>Unicode (UTF) 75-dpi fonts</td>
<td>75-dpi Unicode fonts. Copied to <code>&lt;Reflection X&gt;</code>\fonts\utf75dpi.</td>
</tr>
<tr>
<td>Unicode 100-dpi fonts</td>
<td>Unicode fonts recommended for high resolution displays. Copied to <code>&lt;Reflection X&gt;</code>\fonts\utf100dpi.</td>
</tr>
<tr>
<td>Japanese common fonts</td>
<td>75-dpi fonts for generic Japanese hosts. TrueType fonts equivalent to these Japanese common fonts are also included. Copied to <code>&lt;Reflection X&gt;</code>\fonts\jpnxcom.</td>
</tr>
<tr>
<td>Chinese host fonts</td>
<td>75-dpi fonts for Chinese hosts. Copied to <code>&lt;Reflection X&gt;</code>\fonts\chicom.</td>
</tr>
<tr>
<td>Korean host fonts</td>
<td>75-dpi fonts for Korean hosts. Copied to <code>&lt;Reflection X&gt;</code>\fonts\korcom.</td>
</tr>
</tbody>
</table>

How Font Requests Work

Clients request font information from the X server. The server selects font files either from its list of font directories or from internal tables of information used to build fonts. Font requests are recorded in the Reflection X Manager log file if Log font activity is selected in the Fonts Settings dialog box. When a client requests a font, Reflection X searches for the the Fonts.dir and Fonts.ali files in each font directory in the order that they are specified in the Font path box.
Font Aliasing (Substitution)

If a particular font set is not found, or cannot be correctly scaled for use by Reflection X, then a folder with two ASCII files (Fonts.ali and Fonts.dir) will cross-reference aliases for these missing font sets. The X Manager uses the miscellaneous and 75- or 100-dpi fonts to do this.

The Font Settings Panel: Overview of Options

The Font Settings panel provides options to fine tune use of your fonts. Click Settings > Fonts to view this panel:
When managing fonts you may need to customize your settings to make a font set display properly:

- If the font appears unreadable, clear the **Allow Font Scaling** option to force a different font substitution.

- Download and store recently used fonts using the **Font server fonts storage settings** button.

- Force a font specified by the keyword DefaultFont using the **If font not found - Allow font substitution** or **Try font server on client host** option.

- Click **Retrieve fonts** to download fonts from a server via FTP.

More information about the Font Settings panel can be found in the Help. Click the Help button in this panel or search for **Fonts: Settings** using the Index tab.

### Font Formats

Reflection X supports the following font formats:

- **Unicode**: For applications that support Unicode display.

- **BDF**: Bitmap Distribution Format stores only bitmap fonts and is the standard format for distribution of fonts. It is an ASCII format that is edited using any standard editor. Most font format converters convert to or from this format. For example, if you want to go from format A to format B you would convert A to BDF and then BDF to B.

- **PCF**: Portable Compiled Format is a format used by the X Window System. The files are binary and independent of any server-specific byte order. Reflection X can read the font directly in its original PCF format, meaning that Reflection X Manager can display very large double-byte fonts.

- **Other**: Fonts in formats other than *.pcf can be used by Reflection X via a font server. In some cases, UNIX vendors provide utilities to convert fonts in a proprietary format to *.pcf format.

- **FON**: Microsoft Windows font (FON) format files are Windows fonts designed for on-screen display. These are not TrueType or Adobe scalable printer fonts.

- **TTF**: These are TrueType fonts equivalent to the Japanese FON files shipped with Reflection X. These fonts are provided to help solve problems associated with low resources.
If you cannot find a format to suit your needs, you can use an X11R5 or X11R6 font server, which transparently converts Speedo, PCF, and Type1 fonts to X server-compatible format. Using a font server has the advantage of giving many users access to the same set of fonts without requiring them to use the disk space on their local computers for font storage. One or more font servers can be specified in the Font path box (explained on page 140).

**Retrieving Fonts from a Server**

You can download the fonts you need directly from a server for local use and storage. Click **Settings > Fonts > Retrieve fonts** to open the Reflection Font Retrieval dialog box:
After logging in to the host, browse to the server directory containing the fonts you need to download. Several commonly used host directories are provided in the Remote UNIX/Linux parent directory drop down list. Select the directory, specify the local folder to which the fonts should be directed, and click Retrieve fonts to save the fonts.

Additional Help

More information about using fonts in Reflection X can be found in the application Help. Click any Help button in a dialog box or Settings panel, or double-click the file Rxuser.hlp in Windows Explorer.

AttachmateWRQ Technical Note Library

The Technical Note Library provides easy-to-use documents about common technical issues or topics. Information about using fonts in Reflection X can be found by clicking “Fonts” on the following web page: http://support.wrq.com/techdocs/9992.html.
Managing Multiple Displays in Reflection X

The Reflection X Manager can initiate and display one or more X Display Manager (XDM) sessions on a single machine. Each session can have up to nine X screens associated with it. These capabilities are intended for users who maintain several XDM desktop sessions from one or more hosts. Each simultaneous session is directed to a separate X server instance running on the machine. Devices like the keyboard and mouse are shared for all server instances, but the input from the devices is directed only to the server instance currently being managed.

This chapter explains how to use the X Manager to view and manage your server instances.

**What is “Managing” One or More X Server Instances?**

Managing an X server instance is defined as selecting any currently-running instance and then changing its status (stop, reset) or settings. Use the Settings panels to define the behavior of the instance for display, windows management, number of X screens, security, fonts, or panning.
The X Manager uses the two lower panes of its four pane interface for X server instance management along with commands available from the menu bar and from a right-click context menu. When you first start the X Manager, both lower panes appear:

The left pane contains two trees, **X Server Instances** and **X Server Templates** under which are stored user-created and factory template X server instances. To the right is the **server management** list under which is listed the default server instance “config” and all server instances currently running on the machine. Below these are buttons to stop, reset, and view settings for the selected server instance.

**Closing and Opening the X Server Panes**

You can “fold up” the two panes that display your X server instances by clicking **View > X Server Management**. This toggle command causes the panes to appear and disappear, a check mark appearing next to the command indicates the panes are displayed by the X Manager. You can also use the Action menu's commands to manage your X server instances.
Installing Additional Factory X Server Instance Templates

Factory template files are X server instances preconfigured for certain environments. To add a factory template, run the Reflection installation program and choose a Custom installation type, choosing to install all of the features under Attachmate Reflection > X Window Server > Templates > X Server Templates.

Additional X server (and client) templates are also available on AttachmateWRQ’s web site. To access a Technical Note that describes how to download them, right-click X Server Templates in the lower left pane and select Add templates from AttachmateWRQ.com. To access a Technical Note that describes how to make X server (or client) templates available to your end-users from your own web site, right-click X Server Templates and select Add templates from my site.

Creating an X Server Instance

The Reflection X Manager comes with a default X server instance containing settings that are the basis for the very first server instance you create. This instance, called “config” can be seen by expanding the X Server Instances tree. Note that this default server instance cannot be deleted or renamed; however the instance can be stopped or reset.

To create a server instance, click File > New X Instance Settings and type a name for the server instance under Enter settings name. Or, right-click X Server Instances in the X server instance left pane and then click New on the context menu. A new key name representing the server instance is created that you can now rename:

Start this server instance and configure the settings using the Settings button to open the Settings panels, or click any command in the Settings menu to open a specific panel. This X server instance is saved in Windows registry and its settings can be exported to an *.rxs file for use at another user’s machine.
How Settings are Inherited When an X Server Instance is Created
The first X server instance you create inherits all of its settings from the default config server instance. However, other X server instances you create can be based on any server instance you choose. To use an X server instance for default settings, start it under X server management.
Using the X Manager to Manage X Server Instances

Reflection X Manager provides menu commands, a right-click context menu, and buttons in the X server management box to manage your X server instances:

- **Click a menu command:** The Action menu has commands to start, stop, or reset a server instance. Use the **Select/Start X Instances** command to select an X server instance and automatically start it. Use this same command to switch to a running instance so that it can be managed. The **Stop Current X Server** command stops the instance and removes it from the lower pane under **X server management**. The **Reset Current X Server** resets the server instance you are currently managing.

- **Right-click the file directly:** In the left pane right-click an X server instance file to display a context menu. Use the commands on this menu to start, stop, or export the settings.

- **Click a button:** When you have one or more X server instances running under **X server management**, you can select a server instance and then click the **Stop**, **Reset**, or **Settings** buttons to manage the selected instance.

It is important to remember that changes you make using these options affect only the server instance you have selected.
Exporting X Server Instances for Deployment to Users

Using Export commands in the X manager, any X server instance settings can be exported to create an X server instance (*.rxs) file. This file can, in turn, be used to import the settings at another machine. An administrator can create X server instances on their machine for deployment to a group of Reflection users; this enables the administrator to configure all aspects of the X server instance, including enforcing secure connections to a host of their choice.

For more information about deploying X server settings see “Creating, Exporting, and Distributing X Server Instances” in the Reflection X User Help (Rxuser.hlp).

Additional Help

More information about X server instances can be found in the application Help. Open Help using any Help button in an X Manager dialog box or Settings panel or directly, by clicking the file “Rxuser.hlp” in Windows Explorer.

The Deployment Guide

To assist you in deploying Reflection, review the guide available on AttachmateWRQ’s web site at http://support.wrq.com/tutorials/. Click Preparing to Deploy Reflection 14.0 Guide to open a PDF file that you can print for reference purposes.

AttachmateWRQ Technical Note Library

The Technical Note Library provides easy-to-use documents about common technical issues or topics. The library is available online at http://support.wrq.com/techdocs/.
Reflection X Utilities

Reflection X Manager includes several utilities you can access through the menu bar. This chapter describes these utilities that enable you to view settings, tune performance, run commands from the utility line, retrieve fonts from servers, make connection files, and create trace files.

View Settings

The Reflection X View Settings utility lists Reflection X settings and enables you to control the state and values for these settings from a single, central location. Click **Settings > View Settings** to open the dialog box:

Use the View Settings dialog box to look at any of the following:

- Status of any setting using the Search box.
- Current state of individual Reflection settings.
• Settings that you have changed during your Reflection session.
• Settings that have been profiled.
• Settings that are different from your profiled settings file.

You can view the settings in one of two formats: descriptive text format or Windows registry keyname.

You can also use this dialog box to check the current setting, change the setting, and find out what settings can be used. When you change a setting here, the corresponding setting in a dialog box changes, too (if there is one). For example, if you change the Allow font scaling setting from No to Yes, the Allow font scaling check box (Settings > Fonts panel > Options box) is selected.

To find more information, see “View Settings dialog box” in the Reflection X Help index.

**The Performance Tuner Utility**

The Reflection X Performance Tuner optimizes the performance of Reflection X for your hardware and software configuration (in particular your CPU, video driver, and operating system). When you first start the X Manager, you are asked if you would like to use the Performance Tuner in the dialog box that opens:
You only need to run the Performance Tuner again if the machine configuration changes. Click **Tools > Performance Tuner** to open the Reflection X Performance Tuner dialog box.

Choose to optimize certain aspects of your system by selecting or clearing options under **Test categories** (all are selected by default). When you run the Performance Tuner, a series of keywords (PerfTune=<n>) are added to the registry, based on the results of the performance tuning. These can be customized using information in the application Help.

You can find more information about the PerfTune keyword in the System Administrator's application Help file "Rxsys.hlp." For more information about the Performance Tuner click a Help button and search the Index tab for "Performance Tuner."
The RunRX Command Line Utility

The RunRX utility is an executable file establishes an X client connection from a command line. This utility is designed to let a user combine startup of the X Manager with a script or macro or to start the program with parameters that can customize the behavior of the X Manager.

The following example will establish an RLOGIN connection to the server “unixhost.domain.org” and log in using a user name of “huckle” and a password of “shipshape.” Once logged, the command “(usr/X11R6/bin/xterm -display 172.16.0.1 &)” will be executed on the host.

runrx -m RLOGIN -h unixhost.domain.org -u huckle -p shipshape -c "(usr/X11R6/bin/xterm -display 172.16.0.1 &)"

You can find more information about the RunRX utility in the application Help file "Rxuser.hlp." Here you will find all of the supported command line parameters that can be used to start the X Manager.

The Font Retrieval Utility

The Font Retrieval utility enables a user to download and save to a folder a set of fonts from the host. The user can then maintain a font set that supplements the font sets installed by the Reflection Setup program. Open the Reflection Font Retrieval dialog box by clicking Settings > Fonts > Retrieve fonts.

For complete information about the Font Retrieval utility, see Chapter 13, “Managing Fonts in Reflection X,” page 137.
The Reflection X Client Wizard

The Reflection X Client Wizard enables you to create a connection that you can save as a client (*.rxc) file. By displaying a series of panels and asking questions to gather site information, the wizard establishes the desired connection and asks if you would like to save the connection information in a file. The Client Wizard opens when you click Tools > Client Wizard.

For more information about the Client Wizard, see Chapter 12, “Files Used by Reflection X,” page 132.

The Reflection X Resource Database (XRDB) Utility

Use the Reflection X Manager’s XRDB dialog box to define properties and to specify how Reflection X’s resource database interprets and handles them. The functionality of XRDB is incorporated into Reflection X. This local resource database enables you to set client properties on your local machine, without having to configure resources on the host. Use XRDB if you want X clients to always have a particular set of properties. As an example, you might want each instance of Xterm to have a customized foreground color. After specifying this color in the file listed under Local X Resource File and clicking Load, each instance of Xterm you run will show this color in the foreground.
Click **Tools > XRDB** to open the Reflection X XRDB dialog box:

Click **Load** to load the file “**Xrdb.txt**” and **Edit** to open this file in your specified text file editor. Editing the file directly enables you to specify the attributes you wish the client to adopt. To return to host properties for the client, click **Unload**. You will need to restart the client to see the changes.

**Configuring Client Properties**

X clients usually have a number of user-configurable properties, such as colors and default fonts. XRDB loads a list of client properties into a **RESOURCE_MANAGER** property in the root window. Properties that are present in **RESOURCE_MANAGER** are used as defaults by any X clients that are started after XRDB is run.

**Note:** There are some alternate ways to specify client properties. For example, you can include command line switches when you start a client, or set up a resource file on the host with defaults for a specific client or for all clients.

For detailed information about managing resources in the X Window System, see the X Window System User's Guide or the XRDB man page. You can also find additional information in Reflection X Manager's application Help file “**Rxuser.hlp**.”
The Reflection X Trace Utility

Use the X Manager’s Trace utility to capture events for diagnostic purposes. Typically the trace (*.trc) file is sent to Technical Support for replay and analysis of a problem with the Reflection program.

To open the Reflection X Trace dialog box, click **Tools > Client Trace**.

The Trace utility generates files in binary format. Once you have captured a trace, you can filter (see below) and process the file (the output will be in ASCII text), replay its contents, or both.

**Note:** If you are sending the trace file to Technical Support staff, do not process it.

Filtering Trace Output

Filter (*.flt) files let you mask all aspects of the trace except those related to the filter. You can, as an example, specify the file *Mouse.flt* and view only the information in the trace related to (as examples) scrolling or mapping via the mouse.

For detailed information about troubleshooting the Reflection X program using the Trace utility, search the index of the application Help for “Trace, using” or “Trace, default filters” in the X Manager's application Help file "Rxuser.hlp.”
Administering Reflection FTP Client
Files Used by Reflection FTP Client

This chapter describes files used to store information for the Reflection FTP Client.

Settings Files

FTP Client settings are saved in settings files. Settings files include the following information:

- All the sites you have configured, including all site properties. If you have elected to save passwords, these are saved in encrypted form in the settings file.
- Your settings for **Transfer Method** and **If File Exists**.
- Settings that you have configured using the Options dialog box.

By default the client automatically opens a settings file called “Settings” when you start up. Any changes you make to your configuration are saved to this settings file when you use File > Save. (Use File > Save As to save your settings to a different file.) You can create shortcuts to launch the client and automatically open any settings file. The FTP Client’s title bar displays the name of the currently open settings file.

Prior to version 13.0, settings were saved in the Windows registry. If you have upgraded from an older version your settings are migrated automatically to a settings file the first time you run the client.

**Note:** You can use the Import Settings command to modify your FTP Client settings. When you do, imported settings for new sites are appended to any currently configured settings. Imported settings for existing sites update those sites. The title of your session remains unchanged.
Script Files

You can use options on the FTP Client Script menu to record, edit, and play back FTP command scripts. Scripts allow you to automate FTP connection and file transfer operations: either play back a script from within the FTP Client application, or start the FTP Client with a command line parameter that executes the script automatically. For example, you can automate file transfers to and from an FTP server. Such transfers are carried out without the need to interact directly with the FTP Client.

Reflection FTP Client script files use an *.rfs file extension.

Note: The Reflection FTP Client can also be controlled programmatically using its OLE Automation Application Programming Interface. The FTP Client Help includes a complete reference to the methods and properties that you can use to access Reflection FTP Client features through this API. To view this reference, see Help for the Automation API on the Contents tab of the FTP Client Help.

Layouts

If you frequently run two or more Reflection sessions simultaneously, you can use layout files to streamline your work. Layout files save your Reflection window arrangement. For example, if you regularly work with an emulator session and an FTP Client session, you can create a layout to launch both sessions using your preferred arrangement. Layouts include all the saved Reflection sessions that are running when you create the layout. Layouts can include any combination of the following applications:

- Reflection FTP Client
- Reflection SFTP Client
- Reflection for IBM
- Reflection for HP
- Reflection for UNIX and OpenVMS
- Reflection for Secure IT
- Reflection for ReGIS Graphics

To create a layout, use File > Layout > Save Layout As. Click save Shortcut on desktop if you want to create a shortcut to open your layout. You can open layouts using shortcuts, or from a Reflection session using File > Layout > Open Layout.

Layout files use an *.rlo file extension.
Deploying FTP Client Settings to Other Users

You can distribute settings files to share FTP Client settings with other users. Administrators can also use the Reflection Customization Manager (described in Chapter 3) to create a customized Reflection installer that includes site-specific FTP settings. To do this:

1. Run the Reflection FTP Client on your PC and configure the settings you want to export.
2. Launch the Reflection Customization Manager and create an administrative installation (or use an existing one).
3. Click Customize, open the installation, then click Define Profiles and Default Settings.
4. Select Reflection FTP in the list of Reflection products, then click Define. This opens the Export FTP Settings dialog box, which you can use to specify the sites and the kinds of settings you want included.
5. Close the open dialog boxes to return to the Customization Manager. Click Deployment Utilities and use the Create Deployment Shortcuts utility to create a shortcut for installing your custom installation.

When users install from the shortcut you create in step 5, the custom FTP site settings are saved to the default Settings.rfw file the first time they run the Reflection FTP Client.

Note: This procedure installs an XML file called Rftp.xml to a Reflection folder in the common application data folder. (The default location for this folder is C:\Documents and Settings\All Users\Application Data\Reflection.) This file is in the same XML format as files you create using the Export Settings command. Settings in this file are migrated to Settings.rfw for each Windows user the first time the user runs the FTP Client.
Administering Reflection NFS Client
Files Used by Reflection NFS Client

Reflection NFS Client settings are saved to the Windows registry. You can use the NFS Utility (described in Chapter 21) to export your NFS settings to an XML settings file called Wrqnfs.xml.

To create an XML settings file:

- Launch the NFS Utility and click **File > Export Settings to XML**. The settings file is saved to your personal documents folder (typically C:\Documents and Settings\<username>\My Documents\wrqnfs.xml).

To import NFS settings from an XML settings file:

1. Copy Wrqnfs.xml to the Reflection folder located in the Windows Common Application data folder (typically C:\Documents and Settings\All Users\Application Data\Reflection).
2. Reboot the computer.
Deploying NFS Settings to Other Users

Administrators can use the Reflection Customization Manager (described in Chapter 3) to create a customized Reflection installer that includes NFS settings. To do this:

1. Install Reflection NFS Client and the Reflection Administrator’s Toolkit on your workstation.

2. Configure and test the NFS Client settings that you want to deploy to users.

3. Use the NFS Utility (Start > Programs > Attachmate Reflection > Utilities) to export your settings to an XML settings file (File > Export Settings to XML). Note the location of the saved settings file (called Wrqnfs.xml) when this information is displayed.

   Note: The NFS settings file is an XML file that you can view and edit using any text editor.

4. Create an Administrative install of the Reflection NFS Client.

5. Launch the Reflection Customization Manager (Start > Programs > Attachmate Reflection > Administrative Tools). Click Customize in the left panel, then click Open Installation. Locate the Reflection NFS Client installer file (*.msi) at the administrative installation point you created in step 4. Enter a transform file name when you are prompted to do so. The transform file contains your customization information.

6. Use the Customization Manager’s Set Installation Options button to customize options such as the Reflection installation folder; and to select which features you want installed.

7. Use the Customization Manager’s Add Files button to add your XML settings file (Wrqnfs.xml) to the installation. Select Install file to end machine without shortcut. The settings file must be added to a subfolder called Reflection in the PC’s shared application data folder. (The default location is C:\Documents and Settings\All Users\Application Data\Reflection.) If it is not installed to this location, the settings will not be successfully imported. To specify this location, choose Shared Application Data under Install file to, and type Reflection in the box directly next to it.

8. You can use the Customization Manager’s Deployment Utilities to create a shortcut that end-users can click to launch your customized installation.

Users can install the NFS Client using the shortcut. The custom settings will be configured automatically when they reboot.
NFS Client Utilities

This chapter describes two utilities for use with the Reflection NFS Client:

- The NFS Utility
- The Windows Event Viewer

NFS Utility

The NFS Utility displays information about the current local drives and files, NFS remote drives and file systems, print queues, and NFS server daemons. You can also use this utility to manage your NFS Client settings.

To open the NFS Utility:

- On the Windows Start menu, select Programs > Attachmate Reflection > Utilities > NFS Utility.

Refer to the NFS Utility Help for information about how to use this utility.
Windows Event Viewer

You can configure Reflection NFS Client to log information to the Windows Event Viewer. Logging is disabled by default.

To enable NFS logging:

1. Open the NFS Utility, then click **View > Settings** to display the Reflection NFS Client Properties dialog box.
2. On the **NFS Other** tab, select **Enable logging**.
3. Restart your computer for the change to take effect.

To open the Windows Event Viewer:

1. Right-click the **My Computer** icon, and select **Manage**.
2. Select **System Tools > Event Viewer**.

   The NFS Client sends information to both the System log (look for **Reflection NFSRDR**) and the Application log (look for **NFS Client**). To view detailed information about a line of information, double-click that line.

If you are asked to send event log information to Technical Support, do the following:

1. Open the Windows Event Viewer.
2. If you want to preserve existing information in the viewer, save this information to a file before you clear the event logs.
   
   Right-click both **Application** and **System** and select **Clear all Events** to clear these event logs.
3. Restart your computer.
4. Perform the sequence of steps that produces the problem.
5. Return to the Event Viewer and save the Application and System logs as *.evt files. (Right-click and select **Save Log As**.)
6. Send the files to support@attachmatewrq.com, referencing your Service Request number in the subject field.
Some NFS Client messages are displayed as numbers in the event log:

<table>
<thead>
<tr>
<th>Code</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>Successful NFS browsing</td>
</tr>
<tr>
<td>8</td>
<td>Not enough NFS Client buffer space when browsing</td>
</tr>
<tr>
<td>234</td>
<td>Not enough Windows buffer space. (Normally not fatal.)</td>
</tr>
<tr>
<td>259</td>
<td>No additional entries present for browsing</td>
</tr>
<tr>
<td>1000</td>
<td>No error</td>
</tr>
<tr>
<td>1003</td>
<td>Out of internal memory</td>
</tr>
<tr>
<td>1004</td>
<td>User has not logged in yet</td>
</tr>
<tr>
<td>100b</td>
<td>Device name not found</td>
</tr>
<tr>
<td>100c</td>
<td>IP address for host cannot be obtained</td>
</tr>
<tr>
<td>100d</td>
<td>Access is denied to file/directory</td>
</tr>
<tr>
<td>100e</td>
<td>Tried to open a directory as a file</td>
</tr>
<tr>
<td>1010</td>
<td>Unable to follow path name</td>
</tr>
<tr>
<td>1011</td>
<td>Name conflict detected</td>
</tr>
<tr>
<td>1013</td>
<td>Path is longer than 128 characters</td>
</tr>
<tr>
<td>1014</td>
<td>File cannot be located</td>
</tr>
<tr>
<td>1015</td>
<td>Cannot create a file: file by this name already exists</td>
</tr>
<tr>
<td>101d</td>
<td>Network startup error</td>
</tr>
<tr>
<td>101e</td>
<td>No NFSD or MOUNTD present</td>
</tr>
<tr>
<td>101f</td>
<td>TCP/UDP was not initialized</td>
</tr>
<tr>
<td>1024</td>
<td>Lock Manager not running on host</td>
</tr>
<tr>
<td>1027</td>
<td>Sharing error</td>
</tr>
<tr>
<td>1028</td>
<td>No Read privileges</td>
</tr>
<tr>
<td>1029</td>
<td>No Write privileges</td>
</tr>
<tr>
<td>102a</td>
<td>No Execute privileges</td>
</tr>
<tr>
<td>Code</td>
<td>Meaning</td>
</tr>
<tr>
<td>------</td>
<td>------------------------------------------------------------------------</td>
</tr>
<tr>
<td>102b</td>
<td>Access to this directory is restricted</td>
</tr>
<tr>
<td>102e</td>
<td>Version 2 of PCNFSD not available; cannot browse</td>
</tr>
<tr>
<td>102f</td>
<td>TCP stack not present</td>
</tr>
<tr>
<td>1030</td>
<td>No home directory for user</td>
</tr>
<tr>
<td>1031</td>
<td>Argument list is improper</td>
</tr>
<tr>
<td>1222</td>
<td>NFS Client or the TCP/IP software is not available for browsing request.</td>
</tr>
<tr>
<td>1250</td>
<td>Browsing request for item that does not contain NFS resources.</td>
</tr>
<tr>
<td>1311</td>
<td>PCNFSD not available on host, or user needs to be added to /etc/hosts file (RS6000/OpenVMS).</td>
</tr>
</tbody>
</table>
SECTION 8

Other Tools
Additional Reflection Utilities

This chapter describes additional utilities that are included with Reflection.

Reflection Line Printer Daemon (LPD)

Reflection LPD is a line printer daemon, or server, that you can use to make your locally attached printer available to other users on the network. Use Reflection LPD to:

- Add, change, or remove LPD printers
- Monitor print queue status
- Automatically enable LPD when you start Windows
- View an activity log containing a complete record of LPD activity

Reflection LPD is not included as part of a Typical installation. To install it, use a custom installation or modify your existing installation and install the following item from the Reflection features list: Attachmate Reflection > Utilities > LPD Server.

To launch Reflection LPD, open the Windows Start menu and go to Attachmate Reflection > Utilities > LPD. See the LPD application Help for information about configuring and using Reflection LPD.

Reflection Ping

Ping is a troubleshooting utility that helps you to confirm that a host can be reached. It is installed with all Reflection products as part of a Typical installation.

Use Ping to determine whether other hosts on your network are functioning. When other elements of the network seem to be working but you can’t reach a particular host on the network, sending a Ping request can help you determine whether that host is responding even if you are not able to run an application or establish a session.

To launch the Ping utility, open the Windows Start menu and go to Attachmate Reflection > Utilities > Ping. See the Ping application Help for information about configuring and using Ping.
Reflection Virtual Desktop

Most Windows users run several programs at a time and unless you have a very large display, your PC screen can begin to look very cluttered. The Reflection Virtual Desktop is a way to spread out your work and organize it. Your computer screen is like a viewing window (or "viewport") for a much larger area.

Reflection Virtual Desktop is installed as part of a Typical installation. Reflection Virtual Desktop is not available for Windows XP and will not install on computers running this operating system. If you are using Windows XP, you can use the Virtual Desktop Manager, which is available with Microsoft’s PowerToys.

To view the Virtual Desktop, open the Windows Start menu and go to Attachmate Reflection > Utilities > Reflection Virtual Desktop. For information about working with the desktop, right-click anywhere on the virtual desktop and select Help.

Reflection TimeSync

Reflection TimeSync synchronizes Windows desktop clocks with network time servers. The network time servers you use for calibration can be on your local area network or anywhere on the Internet. TimeSync supports both NTP and the Time protocol.

TimeSync is installed as part of a Typical installation. Reflection TimeSync is not available for Windows XP. If you are running Windows XP, use the Service called Windows Time, which is available as part of the Windows XP operating system.

To launch Reflection TimeSync, open the Windows Start menu and go to Attachmate Reflection > Utilities > Reflection TimeSync. See the Reflection TimeSync application Help for information about configuring and using Reflection TimeSync.
Reflection File Reference

Installer Package Files

For standard installations, you should run the Reflection installation using Install.exe, which launches automatically on most systems when you load the Reflection CD. If you are customizing a Reflection installation using Reflection Customization Manager, you’ll need to specify one of the following Reflection installer package files:

<table>
<thead>
<tr>
<th>Product/Feature Name</th>
<th>Installer File</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reflection for the Multi-Host Enterprise, Professional Edition</td>
<td>MP140ilc.msi</td>
</tr>
<tr>
<td>Reflection for the Multi-Host Enterprise, Standard Edition</td>
<td>ME140ilc.msi</td>
</tr>
<tr>
<td>Reflection Suite for X</td>
<td>SX140ilc.msi</td>
</tr>
<tr>
<td>Reflection for IBM</td>
<td>RI140ilc.msi</td>
</tr>
<tr>
<td>Reflection for HP, with NS/VT</td>
<td>HP140ilc.msi</td>
</tr>
<tr>
<td>Reflection for UNIX and OpenVMS</td>
<td>UD140ilc.msi</td>
</tr>
<tr>
<td>Reflection for Secure IT</td>
<td>RS140ilc.msi</td>
</tr>
<tr>
<td>Reflection X</td>
<td>RX140ilc.msi</td>
</tr>
<tr>
<td>NFS Client (full product)</td>
<td>NB140ilc.msi</td>
</tr>
<tr>
<td>NFS Client (on Reflection CD)</td>
<td>NL140ilc.msi</td>
</tr>
<tr>
<td>Reflection Administrator's Toolkit</td>
<td>RT140ilc.msi</td>
</tr>
</tbody>
</table>
Shared Files

Files listed below can be used by more than one Reflection application.

**Application abbreviation key:**
- RIBM  Reflection for IBM
- RUO  Reflection for UNIX and OpenVMS
- RSIT  Reflection for Secure IT
- RRG  Reflection for REGIS Graphics
- RHP  Reflection for HP
- RX  Reflection X
- RFTP  Reflection FTP and Reflection SFTP

<table>
<thead>
<tr>
<th>File Description</th>
<th>File Name or Extension</th>
<th>RIBM</th>
<th>RUO</th>
<th>RSIT</th>
<th>RRG</th>
<th>RHP</th>
<th>RX</th>
<th>RFTP</th>
<th>See Pages</th>
</tr>
</thead>
<tbody>
<tr>
<td>Layout</td>
<td>.rlo</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>80, 94, 116, 162</td>
</tr>
<tr>
<td>Key/Mouse map partial settings</td>
<td>.rkm</td>
<td>⬤</td>
<td></td>
<td>⬤</td>
<td></td>
<td></td>
<td>⬤</td>
<td></td>
<td>90</td>
</tr>
<tr>
<td>Toolbar partial settings</td>
<td>.rtb</td>
<td>⬤</td>
<td></td>
<td>⬤</td>
<td></td>
<td></td>
<td>⬤</td>
<td></td>
<td>90</td>
</tr>
<tr>
<td>Colors partial settings</td>
<td>.rcr</td>
<td>⬤</td>
<td></td>
<td>⬤</td>
<td></td>
<td></td>
<td>⬤</td>
<td></td>
<td>90</td>
</tr>
<tr>
<td>Menus partial settings</td>
<td>.rmu</td>
<td>⬤</td>
<td></td>
<td>⬤</td>
<td></td>
<td></td>
<td>⬤</td>
<td></td>
<td>90</td>
</tr>
<tr>
<td>Hotspots partial settings</td>
<td>.rhs</td>
<td>⬤</td>
<td></td>
<td>⬤</td>
<td></td>
<td></td>
<td>⬤</td>
<td></td>
<td>90</td>
</tr>
<tr>
<td>Connection partial settings</td>
<td>.rco</td>
<td>⬤</td>
<td></td>
<td>⬤</td>
<td></td>
<td></td>
<td>⬤</td>
<td></td>
<td>90</td>
</tr>
<tr>
<td>Kerberos settings</td>
<td>Rsckrb5.xml</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>55</td>
</tr>
<tr>
<td>Secure Shell configuration</td>
<td>config</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>111</td>
</tr>
<tr>
<td>Secure Shell configuration (all users)</td>
<td>ssh_config</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>111</td>
</tr>
<tr>
<td>Secure Shell known hosts (per user)</td>
<td>known_hosts</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>117</td>
</tr>
<tr>
<td>Secure Shell known hosts (all users)</td>
<td>ssh_known_hosts</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>118</td>
</tr>
<tr>
<td>Reflection Certificate Manager settings</td>
<td>pki_config</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>119</td>
</tr>
<tr>
<td>Reflection Certificate Manager store</td>
<td>trust_store.p12</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>119</td>
</tr>
<tr>
<td>Reflection Certificate Manager cache</td>
<td>cert_cache</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>119</td>
</tr>
<tr>
<td>Reflection Certificate Manager cache</td>
<td>cert_cache</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>119</td>
</tr>
</tbody>
</table>
## Reflection for IBM Files

<table>
<thead>
<tr>
<th>File Description</th>
<th>File Name/Extension</th>
<th>See Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reflection for IBM settings</td>
<td>.rsf</td>
<td>77</td>
</tr>
<tr>
<td>Key/Mouse map partial settings</td>
<td>.map</td>
<td>78</td>
</tr>
<tr>
<td>Toolbar partial settings</td>
<td>.btp</td>
<td>78</td>
</tr>
<tr>
<td>Colors partial settings</td>
<td>.clr</td>
<td>78</td>
</tr>
<tr>
<td>Hotspot/Hotlist partial settings</td>
<td>.hsp</td>
<td>78</td>
</tr>
<tr>
<td>Menus partial settings</td>
<td>.mnu</td>
<td>78</td>
</tr>
<tr>
<td>Settings update</td>
<td>.rsu</td>
<td>78</td>
</tr>
<tr>
<td>Layout</td>
<td>.rlo</td>
<td>80</td>
</tr>
<tr>
<td>5250 transfer request/batch transfer</td>
<td>.xto</td>
<td>82</td>
</tr>
<tr>
<td>3270 transfer request/batch transfer</td>
<td>.mto</td>
<td>82</td>
</tr>
<tr>
<td>SNA Engine configuration</td>
<td>Wrqsna.rlf</td>
<td>83</td>
</tr>
<tr>
<td>Reflection for IBM profile</td>
<td>Profile8.rpf</td>
<td>27</td>
</tr>
<tr>
<td>SNA Engine profile</td>
<td>Snassc.dll</td>
<td>27</td>
</tr>
</tbody>
</table>
## Reflection for HP Files

<table>
<thead>
<tr>
<th>File Description</th>
<th>File Name/Extension</th>
<th>See Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reflection for HP settings</td>
<td>.r1w</td>
<td>90</td>
</tr>
<tr>
<td>Key/Mouse map partial settings</td>
<td>.rkm</td>
<td>90</td>
</tr>
<tr>
<td>Toolbar partial settings</td>
<td>.rtb</td>
<td>90</td>
</tr>
<tr>
<td>Colors partial settings</td>
<td>.rcr</td>
<td>90</td>
</tr>
<tr>
<td>Menus partial settings</td>
<td>.rmu</td>
<td>90</td>
</tr>
<tr>
<td>Hotspots partial settings</td>
<td>.rhs</td>
<td>90</td>
</tr>
<tr>
<td>Connection partial settings</td>
<td>.rco</td>
<td>90</td>
</tr>
<tr>
<td>Settings update</td>
<td>.r1u</td>
<td>91</td>
</tr>
<tr>
<td>Layout</td>
<td>.rlo</td>
<td>94</td>
</tr>
<tr>
<td>Reflection for HP profile</td>
<td>Profile1.rpf</td>
<td>28</td>
</tr>
<tr>
<td>Reflection for HP trace</td>
<td>.rev</td>
<td>See application Help</td>
</tr>
</tbody>
</table>
Reflection for UNIX and OpenVMS Files

<table>
<thead>
<tr>
<th>File Description</th>
<th>File Name/Extension</th>
<th>See Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reflection for UNIX and OpenVMS settings</td>
<td>.r2w</td>
<td>90</td>
</tr>
<tr>
<td>Key/Mouse map partial settings</td>
<td>.rkm</td>
<td>90</td>
</tr>
<tr>
<td>Toolbar partial settings</td>
<td>.rtb</td>
<td>90</td>
</tr>
<tr>
<td>Colors partial settings</td>
<td>.rcr</td>
<td>90</td>
</tr>
<tr>
<td>Menus partial settings</td>
<td>.rmu</td>
<td>90</td>
</tr>
<tr>
<td>Hotspots partial settings</td>
<td>.rhs</td>
<td>90</td>
</tr>
<tr>
<td>Connection partial settings</td>
<td>.rco</td>
<td>90</td>
</tr>
<tr>
<td>Settings update</td>
<td>.r2u</td>
<td>91</td>
</tr>
<tr>
<td>Layouts</td>
<td>.rlo</td>
<td>94</td>
</tr>
<tr>
<td>Reflection for UNIX and OpenVMS profile</td>
<td>Profile2.rpf</td>
<td>28</td>
</tr>
<tr>
<td>Reflection for UNIX and OpenVMS trace</td>
<td>.rev</td>
<td>See application Help</td>
</tr>
</tbody>
</table>

Reflection for Secure IT Files

<table>
<thead>
<tr>
<th>File Description</th>
<th>File Name/Extension</th>
<th>See Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reflection for Secure IT settings</td>
<td>.r3w</td>
<td>90</td>
</tr>
<tr>
<td>Settings update</td>
<td>.r3u</td>
<td>91</td>
</tr>
<tr>
<td>Layouts</td>
<td>.rlo</td>
<td>94</td>
</tr>
<tr>
<td>Reflection for Secure IT trace</td>
<td>.rev</td>
<td>See application Help</td>
</tr>
</tbody>
</table>
# Reflection for ReGIS Graphics Files

<table>
<thead>
<tr>
<th>File Description</th>
<th>File Name/Extension</th>
<th>See Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reflection for ReGIS Graphics settings</td>
<td>.r4w</td>
<td>90</td>
</tr>
<tr>
<td>Key/Mouse map partial settings</td>
<td>.rkm</td>
<td>90</td>
</tr>
<tr>
<td>Toolbar partial settings</td>
<td>.rtb</td>
<td>90</td>
</tr>
<tr>
<td>Colors partial settings</td>
<td>.rcr</td>
<td>90</td>
</tr>
<tr>
<td>Menus partial settings</td>
<td>.rmu</td>
<td>90</td>
</tr>
<tr>
<td>Hotspots partial settings</td>
<td>.rhs</td>
<td>90</td>
</tr>
<tr>
<td>Connection partial settings</td>
<td>.rco</td>
<td>90</td>
</tr>
<tr>
<td>Settings update</td>
<td>.r4u</td>
<td>91</td>
</tr>
<tr>
<td>Layout</td>
<td>.rlo</td>
<td>94</td>
</tr>
<tr>
<td>Reflection for ReGIS Graphics profile</td>
<td>Profile4.rpf</td>
<td>28</td>
</tr>
<tr>
<td>Reflection for ReGIS Graphics trace</td>
<td>.rev</td>
<td>See application Help</td>
</tr>
</tbody>
</table>
Reflection X Files

<table>
<thead>
<tr>
<th>File Description</th>
<th>File Name/Extension</th>
<th>See Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Client file</td>
<td>.rxc</td>
<td>130</td>
</tr>
<tr>
<td>X server instance file</td>
<td>.rxs</td>
<td>133</td>
</tr>
<tr>
<td>Keyboard mapping file</td>
<td>.kmp</td>
<td>134</td>
</tr>
<tr>
<td>Toolbar file</td>
<td>.tbr</td>
<td>134</td>
</tr>
<tr>
<td>Trace file</td>
<td>.trc</td>
<td>157</td>
</tr>
<tr>
<td>Filter file</td>
<td>.flt</td>
<td>157</td>
</tr>
<tr>
<td>Reflection X profile</td>
<td>Rx.ini</td>
<td>29</td>
</tr>
</tbody>
</table>
# Reflection FTP and SFTP Client Files

<table>
<thead>
<tr>
<th>File Description</th>
<th>File Name/Extension</th>
<th>See Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reflection FTP Client settings</td>
<td>.rfw</td>
<td>114, 161</td>
</tr>
<tr>
<td>Layout</td>
<td>.rlo</td>
<td>116, 162</td>
</tr>
<tr>
<td>Reflection FTP Client script</td>
<td>.rfs</td>
<td>162</td>
</tr>
<tr>
<td>Reflection FTP exported settings</td>
<td>Rftp.xml</td>
<td>163</td>
</tr>
</tbody>
</table>

# Reflection NFS Client Files

<table>
<thead>
<tr>
<th>File Description</th>
<th>File Name</th>
<th>See Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reflection NFS Client settings</td>
<td>Wrqnsfs.xml</td>
<td>167</td>
</tr>
</tbody>
</table>
TCP and UDP Port Values Used for Reflection Connections

The table below details the port values for service protocols supported by Reflection applications. The values used by Reflection applications are IANA and other standard values. You may need to configure other port values to match specific requirements of your environment.

**Application abbreviation key:**
- RIBM  Reflection for IBM
- RUO  Reflection for UNIX and OpenVMS
- RSIT  Reflection for Secure IT
- RRG  Reflection for ReGIS Graphics
- RHP  Reflection for HP
- RX  Reflection X
- RFTP  Reflection FTP
- NFS  Reflection NFS Client
- LPD  Reflection Line Printer Daemon

<table>
<thead>
<tr>
<th>Port / IP Protocol</th>
<th>Service Protocol</th>
<th>Comment</th>
<th>RIBM</th>
<th>RUO</th>
<th>RSIT</th>
<th>RRG</th>
<th>RHP</th>
<th>RX</th>
<th>RFTP</th>
<th>NFS</th>
<th>Time/Sync</th>
<th>LPD</th>
<th>Ping</th>
</tr>
</thead>
<tbody>
<tr>
<td>7/icmp</td>
<td>Echo</td>
<td>Data echo</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>20/tcp</td>
<td>FTP-data</td>
<td>Data channel</td>
<td>●</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>21/tcp</td>
<td>FTP</td>
<td>Command channel</td>
<td>●</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>22/tcp</td>
<td>SSH</td>
<td>Secure Shell, sftp, scp</td>
<td>●</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>23/tcp</td>
<td>Telnet</td>
<td>Telnet; TN3270E; TN3270; TN5250</td>
<td>●</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>37/udp/tcp</td>
<td>Time</td>
<td>Timeserver</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>●</td>
</tr>
<tr>
<td>42/tcp</td>
<td>Nameserver</td>
<td>Hostname to IP address</td>
<td>●</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>53/udp/tcp</td>
<td>DNS</td>
<td>Domain Name Services</td>
<td>●</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Port / IP Protocol</td>
<td>Service Protocol</td>
<td>Comment</td>
<td>RIBM</td>
<td>RUO</td>
<td>RST</td>
<td>RRG</td>
<td>RHP</td>
<td>RX</td>
<td>RFTP</td>
<td>NFS</td>
<td>TimeSync</td>
<td>UDP</td>
<td>Ping</td>
</tr>
<tr>
<td>-------------------</td>
<td>------------------</td>
<td>---------</td>
<td>------</td>
<td>-----</td>
<td>-----</td>
<td>-----</td>
<td>-----</td>
<td>-----</td>
<td>------</td>
<td>-----</td>
<td>-----------</td>
<td>-----</td>
<td>------</td>
</tr>
<tr>
<td>80/tcp</td>
<td>HTTP</td>
<td>Unsecure HTTP via Reflection Administrator</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td></td>
</tr>
<tr>
<td>88/udp/tcp</td>
<td>Kerberos</td>
<td>Kerberos authentication</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td></td>
<td></td>
</tr>
<tr>
<td>111</td>
<td>Sunrpc</td>
<td>Portmapper</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td></td>
<td></td>
</tr>
<tr>
<td>123/udp</td>
<td>NTP</td>
<td>Network Time Protocol</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td></td>
<td></td>
</tr>
<tr>
<td>177/udp/tcp</td>
<td>XDMCP Broadcast</td>
<td>X Display Manager</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td></td>
<td></td>
</tr>
<tr>
<td>443/udp/tcp</td>
<td>https</td>
<td>Secure http via Reflection Administrator</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td></td>
<td></td>
</tr>
<tr>
<td>464/udp/tcp</td>
<td>kpasswd</td>
<td>Kerberos password changing (kpasswd daemon)</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td></td>
<td></td>
</tr>
<tr>
<td>512/tcp</td>
<td>exec</td>
<td>rexec</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td></td>
<td></td>
</tr>
<tr>
<td>513/tcp</td>
<td>login</td>
<td>rlogin</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td></td>
<td></td>
</tr>
<tr>
<td>514/tcp</td>
<td>shell</td>
<td>rsh</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td></td>
<td></td>
</tr>
<tr>
<td>515/tcp</td>
<td>printer</td>
<td>spooler</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td></td>
<td></td>
</tr>
<tr>
<td>520/udp</td>
<td>route</td>
<td>routed</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td></td>
<td></td>
</tr>
<tr>
<td>635/udp</td>
<td>mount</td>
<td>NFS mount service</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td></td>
<td></td>
</tr>
<tr>
<td>640/udp</td>
<td>pcnfs</td>
<td>PC-NFS DOS authentication</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td></td>
<td></td>
</tr>
<tr>
<td>731/udp 733/udp</td>
<td>ypserv</td>
<td>NIS server and binder processes</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td></td>
<td></td>
</tr>
<tr>
<td>732/tcp</td>
<td>ypserv</td>
<td>NIS server and binder processes</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td>⬤</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Port / IP Protocol</td>
<td>Service Protocol</td>
<td>Comment</td>
<td>RIBM</td>
<td>RUO</td>
<td>RSIT</td>
<td>RRG</td>
<td>RHP</td>
<td>RX</td>
<td>RFTP</td>
<td>NFS</td>
<td>TimeSync</td>
<td>LPD</td>
<td>PING</td>
</tr>
<tr>
<td>-------------------</td>
<td>------------------</td>
<td>---------</td>
<td>------</td>
<td>-----</td>
<td>------</td>
<td>-----</td>
<td>-----</td>
<td>----</td>
<td>------</td>
<td>-----</td>
<td>-----------</td>
<td>-----</td>
<td>-------</td>
</tr>
<tr>
<td>749/udp/tcp</td>
<td>kerberos-adm</td>
<td>Kerberos password changing (v5passwdd daemon)</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td></td>
<td></td>
</tr>
<tr>
<td>992/tcp</td>
<td>telnets</td>
<td>SSL-secured Telnet</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>1080/udp/tcp</td>
<td>socks</td>
<td>SOCKS</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td></td>
<td></td>
</tr>
<tr>
<td>1024-5000</td>
<td>VAXLINK2 FFT</td>
<td>Fast file transfer</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>1530</td>
<td>NS/VT</td>
<td>Network Services, Virtual Terminal</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>1649/udp/tcp</td>
<td>kermit</td>
<td>Kermit file transfer</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2049/udp/tcp</td>
<td>nfsd</td>
<td>NFS file service</td>
<td>●</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>6000 and up/tcp</td>
<td>X Protocol</td>
<td>Incoming ports for RX clients</td>
<td>●</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>7000/tcp</td>
<td>xfs</td>
<td>X font server (default)</td>
<td>●</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>7100/tcp</td>
<td>xfs</td>
<td>X font server</td>
<td>●</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>8471/tcp</td>
<td>lipi</td>
<td>AS/400 LIP1 file transfer</td>
<td>●</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>8476/tcp</td>
<td>lipi</td>
<td>AS/400 signon server port</td>
<td>●</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>8478/tcp</td>
<td>ehntfw</td>
<td>AS/400 EHNTFW file transfer</td>
<td>●</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>30000-40000</td>
<td>PCLINK FFT</td>
<td>Fast file transfer</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
INDEX

A
Active Directory 18
and Reflection Group Policies 22
Administrative WebStation 57, 59–60
Administrator Tools 9, 11
Authentication 35–56
available protocols 36
defined 35
SSL/TLS sessions 38
Auto Update File setting 79
Auto Update file setting
configuring via Group Policy 32

B
Batch file transfer (Reflection for IBM) 82

C
Certificate management
Reflection Certificate Manager 50
SSL/TLS sessions 38
Citrix MetaFrame, support for 71
Client files 130–132
default files 130
distributing 18, 57
installed by default 131
installed under Custom installation 133
XDMCP template files 131
Client wizard 132
Converting
EXTRA files 85
Reflection for the Web files 81, 95
Rumba files 85
settings to XML 81, 96
ViewNow files 85
Custom upload
HP options 101
OpenVMS options 105

D
Deploying
FTP Client settings 163, 168
Guide in PDF format 10
Kerberos settings 55
Reflection 13–18
Secure Shell settings 46
settings files 77, 89
settings updates 79, 92
SSL/TLS settings 39
using Customization Manager 13
X server settings 133

E
Electronic manuals 8
Encryption 35–56
available protocols 36
defined 35
EXTRA! Personal Client files 85

F
Files
Reflection for HP 89–94, 111–119, 182
Reflection for IBM 77–83, 181
Reflection for ReGIS Graphics 89–94, 111–119, 184
Reflection for Secure IT 183
Reflection for UNIX and OpenVMS 89–94, 111–119, 183
Reflection FTP Client 161
Reflection installation package 179
Reflection NFS Client 167
Reflection SFTP Client 161
Reflection X 185
Secure Shell 180
shared 180
Fonts (Reflection X)
  downloading from server 142
  installed by default 138
  installed using a Custom installation 139–143
  managing 137

G
  Group Policies 21–23, 30–33
  configuring 31–32
  installing 31

H
  Host
    uploading file transfer host program 98

I
  Installation package files 179
  Installing Reflection 13–18
    customizing the installation 16
    from a web page 57–58
    under Windows Terminal Server 71

K
  Kerberos 36, 52–55
    configuring 53
    deploying settings 55
    Kerberos Manager 54
    supporting Reflection applications 36
  Keyboard mapping files 90, 134
  Keysyms 134

L
  Layouts 80, 94, 116, 162
  LDAP integration 57
  LPD 175

M
  Macros in Reflection for IBM 80
  Manuals 8
  Metering 61–70
    configuring 61
    configuring Reflection workstations 64
    configuring using Group Policy 66
    configuring using the Customization Manager 64
    group policy settings 34

N
  NFS Utility 169

P
  Partial settings files 78, 90
  PCLINK2 98
  Ping 175
  PKI
    overview 49
    Reflection Certificate Manager 50
    SSL/TLS sessions 38
  Ports 187–189
  Product information 3–4
  Profile1.rpf file 28
  Profile2.rpf file 28
  Profile4.rpf file 28
  Profile8.rpf file 27
  Profilers 21–29
    Reflection for HP 28
    Reflection for IBM 27
    Reflection for ReGIS Graphics 28
    Reflection for UNIX and OpenVMS 28
    Reflection X 29
    running 25

R
  Reflection Administrative WebStation 57
Reflection Administrator 11
  Administrative WebStation 57
  metering server 61
  security proxy server 40
Reflection Administrator's Toolkit 9
Reflection Certificate Manager 50
Reflection Customization Manager 13–18
  Customize Reflection Installations panel 16
  customizing Reflection FTP Client 163, 168
  deploying profiles 26
  Deployment Utilities Panel 18
  distributing settings files 77, 89
  installing and starting 15
  Introduction panel 16
  Prepare Installation panel 16
Reflection for HP
  files 89–93, 182
  Group Policy support 32, 33, 34
  product information 4
  profiling 28
  security protocols 36
  uploading the host transfer program 98–108
Reflection for IBM
  batch file transfer 82
  conversion tool 85
  files 77–83, 181
  Group Policy support 32, 33, 34
  product information 4
  profiling 28
  transfer requests 82
Reflection for ReGIS Graphics
  files 89–93, 184
  Group Policy support 32, 33, 34
  profiling 28
  security protocols 36
  uploading the host transfer program 98–108
Reflection for Secure IT
  files 111–119, 183
  product information 4
  supported security protocol 36
Reflection for the Multi-Host Enterprise 4
Reflection for the Web
  migrating to and from 81, 95
Reflection for UNIX and OpenVMS
  files 89–93, 183
  Group Policy support 32, 33, 34
  product information 4
  profiling 28
  security protocols 36
  uploading the host transfer program 98–108
Reflection FTP Client
  Group Policy support 32, 33, 34
  importing and exporting settings 163
  security protocols 36
  settings files 161
Reflection Line Printer Daemon (LPD) 175
Reflection NFS Client
  importing and exporting settings 167
  logging 170
  NFS Utility 169
  product information 4
Reflection Security Components 37
Reflection SFTP Client
  script files 115, 162
  settings files 114
  supported security protocol 36
Reflection Suite for X 4
Reflection Virtual Desktop 176
Reflection X
  Client wizard 132
  files 185
  Font Retrieval utility 154
  Group Policy support 32, 33, 34
  Performance Tuner utility 152
  product information 4
  profiling 29
  resource database (XRDB) 155
  running from the command line 154
  security protocols 36
  Trace utility 157
  Rumba files 85
  RVX files 80
  Rx.ini file 29

S
  scp command line utility 48
  scp2 command line utility 48
Secure Shell 42–48
command line utilities 48
deploying settings 46
files 180
SSH config schemes 46
supporting Reflection applications 36
Security 35–56
configuring via Group Policy 32
Settings Files
FTP Client 161
SFTP Client 114
Settings files
distributing 18, 57, 77, 89
linking 93
partial 78, 90
Reflection for HP 89–95
Reflection for IBM 77–80
Reflection for ReGIS Graphics 89–95
Reflection for UNIX and OpenVMS 89–95
Settings update files 78
sftp command line utility 48
sftp2 command line utility 48
SMS 18
Snassc.dll file 27
SSH 42–48
command line utilities 48
deploying settings 46
files 180
SSH config schemes 46
ssh command line utility 48
SSH config schemes 46
ssh2 command line utility 48
ssh-keygen command line utility 48
SSL/TLS security 37–41
authentication 38
deploying settings 39
overview 37
proxy server 40
supporting Reflection applications 36
using the Administrative WebStation 60

T
TCP ports 187–189
Technical note library 8
Template files, X server instance 133

Terminal Server
installing Reflection under 73
requirements for using with Reflection 71
TLS security 37–41
Toolbar files 78, 90, 134
Transfer
host support for WRQ transfer protocol 97
Transform files 18
defined 16
Translation table editors 86

U
UNXLINK2 98
UPD ports 187–189
Uploading the host program 98–108

V
VAXLINK2 98
ViewNow files 85

W
Web pages
Administrative WebStation 59
installing Reflection software 57–58
Windows Event Viewer 170
Reflection NFS messages 171

X
X server
deploying server settings 133
list of server template files 133
managing multiple 133
managing multiple servers 133
XDM Authorization 56
XDMCP client file templates 131
XDMCP client files 131
XML
saving settings in XML format 81, 96